693 Rate this article:
No rating

ENVI SARscape 5.4 Platform Support

ENVI SARscape 5.4 Platform Support

Platform Hardware Operating System Supported Versions

Windows


Intel/AMD 64-bit

Windows

7 SP1, 8, 10

Linux

Intel/AMD 64-bit 

Linux 

Kernel 2.6.32, glibc 2.14, glibcxx 3.4.16, xterm(1)


(1) We use the “xterm” application to spawn some command-line applications (e.g., Sentinel data downloader, diagnostics tests, etc.) directly from within the ENVI graphical interface. The xterm tool is usually available by default on most of the available Linux distributions or can be easily installed through the various distribution repositories (e.g., under RHEL/CentOS, simply run “yum install xterm” as administrator to install it).

Note: the ENVI SARscape module requires ENVI 5.4.

Additional Requirements and Recommendations:

Minimal system requirements:
  • ENVI 5.4
  • 4 GB of RAM
  • A CPU with at least 2 cores and SSE2 support
  • OpenCL 1.2-compatible runtime with 1 GB of memory and FP64 support
  • 2 GB of disk space

(Please see Section 5 of the SARscape Installation Notes for an introduction and additional information on OpenCL.)

These requirements are provided as the bare minimum to launch the software. Please keep in mind that SAR processing can be extremely resource-demanding and, depending on the kind of datasets and operations performed through SARscape, a significantly better hardware configuration should be used. This also applies to the size of the hard-drives that will be used to store input data, results, and temporary/intermediate by products.

Minimum recommended configuration:
  • 8 GB of RAM
  • A CPU with at least 4 cores and AVX support
  • OpenCL 1.2-compatible GPU with 2 GB of memory and FP64 support
Ideal configuration:
  • 16/32 GB of RAM
  • A CPU with 6+ cores and AVX2 support
  • OpenCL 1.2-compatible GPU with 4 GB of memory and FP64 support
  • Fast 512/1024 GB of SSD disk as working directory

 

created 3/22/2017 kk

Please login or register to post comments.