Welcome to the Harris Geospatial product documentation center. Here you will find reference guides, help documents, and product libraries.


  >  Docs Center  >  Using ENVI  >  Collect Endmember Spectra

ENVI

Collect Endmember Spectra

Collect Endmember Spectra

Use Endmember Collection to select endmember spectra from many sources for use in classification and advanced spectral analysis techniques. See Import Spectra for instructions on importing from various sources.

See the following sections to continue:

Endmember Collection Dialog Components


The following input file information is provided in the text at the top of the Endmember Collection dialog:

  • File: The name of the input file and its selected spatial subset range. If the image is not spatially subset, the phrase Full Scene displays.
  • Mask: The name of the mask associated with the input file.
  • Wavelength: The wavelength range of the image data. The units of these wavelengths are derived from the header file of the input file. If the units cannot be derived from the header file, the phrase <unknown units> displays.
  • Number and range of the bands in the spectral subset: The number of bands spectrally subsetted from the input file and the range of the subset. If the input file is not spectrally subsetted, the total number of bands in the input file and the entire range displays.

The Endmember Collection dialog also contains the Endmember Spectra table. This table enables you to view and edit properties associated with any of the spectra listed in the table. The table contains the following columns:

  • Row Number: Contains the row number of each spectrum. You can select one or more spectra. Use the Select All button to select all of the spectra in the table. Click Plot or Delete to plot or delete the selected spectra.
  • Spectrum Name: Contains the name of each spectrum. You can edit the name of a spectrum by selecting its cell in this column. You can also specify the spectrum names for all the spectra from an ASCII file by right-clicking the Spectrum Name column title and selecting the Import names from ASCII. This menu also contains a Reset names option to reset all the spectra to their original names. All of the options in this menu are also available in the Options menu.
  • Color: Contains the color of each spectrum. You can use any of the following methods to change the color of a spectrum.
  • Right-click in the cell to display the color menu.
  • Left-click in the cell to enter a valid ENVI graphics color name. If a valid color is not provided, ENVI sets the color value to <none> by default.
  • Left-click in the cell to enter an RGB triplet (such as 255, 0, 0 for red). If you provide an RGB triplet, ENVI uses the closest valid ENVI graphics color.

You can also set the default ENVI colors for all the spectra by right-clicking in the Color column title and selecting Assign default colors to all. You can set all the spectra colors to <none> with Assign default colors to undefined, and you can select Reset Colors to reset all the spectra to their original colors. All of the right-click menu options are also available in the Endmember Collection dialog Options menu.

  • Source: Displays the source of each spectrum. The values in this column cannot be edited. The following list shows the possible sources for the spectra in the table.

    ASD file: Spectrum imported from ASD formatted file (which is output from the Analytical Spectral Devices spectrometers).

    Spec Lib: Spectrum imported from ENVI spectral library (.sli) file.

    ROI mean: Mean spectrum from either an ROI or a vector.

    Stats file: Spectrum imported from ENVI statistics (.sta) file.

    Plot: Spectrum imported from a plot window.

    Unknown: Spectrum retrieved from any other source.

  • ASCII file: Spectrum imported from ASCII column data file.
  • Bands: Displays the number of spectral bands contained in each spectrum. You cannot edit the values in this column.
  • Wavelength: Contains the wavelength range of each spectrum. ENVI converts the wavelengths of the spectra to the wavelengths of the image data when you click either Plot or Apply in the dialog. This conversion does not occur if the wavelength units of the spectra are unknown. You can change the wavelength units by right-clicking in the cell of the Wavelength column.

To change an input file with unknown wavelength units to a file containing known wavelength units, select File > Change input File option from the Endmember Collection dialog menu bar.

  • Status: Displays the status of each spectrum related to the input file. You cannot edit the values in this column. The following list shows the possible status values for the spectra in the table:
  • Match: The wavelengths of the input file and the spectrum match exactly and no resampling is necessary when you click either Plot or Apply.
  • Resample: The wavelengths of the input file and the spectrum are different, but ENVI is able to resample the spectrum to the wavelength space of the input file when you click either Plot or Apply.
  • Invalid: The wavelengths of the input file and the spectrum are different, but ENVI is not able to resample because the wavelength units of either the spectrum or the input file are unknown. If a spectrum is invalid, it cannot be plotted and is not used when you click Apply.

Manage Endmember Spectra


Use the File menu in the Endmember Collection dialog to save endmember spectra to an ASCII file, as a spectral library, or as an Endmember Collection file. You can also use the File menu to change the input file or exit the dialog.

  • To save spectra to an ASCII file, select File > Save Spectra As > ASCII file.
  • To save spectra to spectral libraries, select File > Save Spectra As > Spectral Library file.
  • To save the current state of the Endmember Collection dialog to a text file, select File > Save Spectra As > Endmember Collection file. The Endmember Collection file contains all the current information that is provided for each spectrum in the Endmember Spectra table.
  • To change the input file while the selected endmembers, select File > Change Input File. You can change the spectral or spatial subset of your input file by selecting File > Change Input File again, selecting the same filename, and changing the subset.

Plot Spectra


  • To plot a spectrum from the Endmember Spectra table, select the row number column of the spectrum to plot, then click Plot.
  • To plot multiple spectra, use the Shift or Ctrl key as you select the row number columns, then click Plot.
  • To plot all the spectra in the table, click Select All, then click Plot.

Delete Spectra


  • To delete a spectrum from the Endmember Spectra table, select the row number column of the spectrum to delete, then click Delete.
  • To delete multiple spectra, use the Shift or Ctrl key as you select the row number columns, then click Delete.
  • To delete all the spectra in the table, click Select All, then click Delete.

Endmember Options


Use the Options menu in the Endmember Collection dialog to edit the endmember names, edit the endmember colors, or suppress backgrounds (using BandMax).

  • To edit endmember names, select Options > Import spectrum names from ASCII. Select and open the ASCII file that contains the spectrum names. The names of the spectra collected in the dialog are changed to the names from the ASCII file.
  • To reset the spectra to their initial names, select Options > Reset spectrum names.
  • To assign default colors to all of the endmember spectra, select Options > Assign default colors to all.
  • To assign default colors to all of the undefined spectra colors (indicated by <none>), select Options > Assign default colors to undefined.
  • To reset the spectra to their initial colors, select Options > Reset colors.

Suppress Backgrounds with BandMax

You can select an optimal subset of input bands to differentiate one or more related target spectra from the spectra of other similar materials (backgrounds). The BandMax process isolates the bands that best distinguish selected targets from selected backgrounds. This optimal spectral subset generated with BandMax may increase the accuracy of the classification selected in the Endmember Collection dialog and speed processing.

You can also access BandMax in the SAM Target Finder with BandMax Wizard.

  1. Select at least one spectrum (to represent a target) in the Endmember Spectra table of the Endmember Collection dialog.
  2. From the Endmember Collection dialog menu bar, select Options > BandMax Background Suppression in the Endmember Collection dialog. The BandMax Background Suppression dialog appears.
  3. Use the Select Background section of the dialog to collect any spectra you want to use as backgrounds. This section contains an embedded version of the Endmember Collection dialog. All the items in this section are the same as the items provided in the Endmember Collection dialog.

    The BandMax significance values are calculated whenever a spectrum is added or deleted in the Select Background section.

  4. Review the Significant Bands list, which shows the bands that BandMax automatically determined were significant.
  5. Modify theBand Significance Threshold value as needed. The threshold ranges from 0 to 1. ENVI uses only bands with a significance value greater than or equal to the significance threshold. Setting the Band Significance Threshold to a higher value results in fewer selected bands in the subset.

    The increase/decrease buttons change the threshold by increments of 0.01. An increase in the Band Significance Threshold value decreases the Number of Significant Bands value and updates the Significant Bands list. If a change of 0.01 is not enough to update the Number of Significant Bands, increase the increment until it does.

    You can also decrease the Number of Significant Bands value, which increases the Band Significance Threshold value and updates the Significant Bands list.

  6. The increase/decrease buttons change the number of bands by at least 1. If two or more bands have the same significance value, ENVI uses a greater increment to include all of these bands.

  7. Click Save Significant Bands to File if you want to save the band subset in the Significant Bands list to an ASCII file. When you have derived the subset of bands that effectively detects your targets, you may want to use this same band subset to perform a series of classifications on a set of images from the same sensor. You can use the output ASCII file as input when spectrally subsetting a file.
  8. Click OK. All the significant bands displayed in the Significant Bands section form the band subset that is used on the input data when you click Apply in the Endmember Collection dialog.

Select Processing Methods


Use the Algorithm menu in the Endmember Collection dialog to select a classification or advanced spectral processing method. The classification methods available are parallelepiped, minimum distance, Mahalanobis distance, maximum likelihood, Spectral Angle Mapper, and binary encoding. The advanced spectral processing methods available are linear spectral unmixing, matched filtering, mixture tuned matched filtering, and spectral feature fitting.

When using the Mahalanobis distance or maximum likelihood classifiers, you can only import the endmember spectra from ROIs or statistic files because these classifications use the endmember covariance statistics. You must also have at least two endmembers.

  1. From the Endmember Collection dialog menu bar, select Algorithm > classification_method.

    You can also start the classification methods from the Classification > Supervised menu and you can start the advanced spectral processing methods from the Spectral Tools menu.

  2. Click Apply. The Algorithm Parameters dialog appears.
  3. Enter the selected algorithm’s required parameters.



© 2018 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us