>  Docs Center  >  Using ENVI  >  ENVI LiDAR  >  The ENVI LiDAR User Interface

The ENVI LiDAR User Interface

The ENVI LiDAR User Interface

To start ENVI LiDAR, select LiDAR > Launch ENVI LiDAR in the ENVI Toolbox. The user interface opens showing the toolbar, Main window, Layer Manager, Navigate window, and Operations Log.

By default, the toolbar, Layer Manager, Navigate window, and Operations Log are docked in the Main window, but you can undock them or hide them.

  • To undock a window, double-click at the top of the window.
  • To dock the window or the toolbar in the Main window again, double-click its title bar.
  • To show or hide a window or the toolbar, select View > window name or View > Toolbar from the menu bar.
  • To reset the toolbar and all the windows to the default layout, including reset the location of the ENVI LiDAR interface to its default position on your monitor, select View > Reset Windows from the menu bar.

Main Window


The Main window shows the area you are working on. Cursor coordinates and height display in the status bar of the Main window.

Zoom and Pan

  • To zoom in and out, right-click and drag up or down across the view, or use the mouse wheel.
  • To pan, click both mouse buttons and drag in any direction across the image.

    Note: This option does not work with some laptop internal mouse devices.

Rotate

  • To rotate the image along the x and z axes, click and drag across the view.

Jump to Coordinates

  • To jump to specific coordinates, select View > Jump to Location from the menu bar. Select the Coordinate System you want to use from the drop-down list, and enter the coordinates in the fields provided.

Save the View

  • To save the current view so you can return to it later, select View > Save from the menu bar. Enter a Display Name in the Select Display Name dialog and click OK.
  • To display a saved view, select View > Display from the menu bar and select the view from the Saved Views dialog.
  • To delete saved views, select View > Display from the menu bar and select the views to delete. Click Delete. To delete all saved positions, click Delete All. By default ENVI LiDAR 3D Viewer removes all but the first saved view from the list.

Create a Screen Capture

  • If Microsoft PowerPoint is installed on your machine, you can create a screen capture of the current view and automatically open it in a new or existing PowerPoint session. Click the Screenshot to PowerPoint button on the toolbar, or select File > Screenshot to PowerPoint from the menu bar to capture the screen and launch PowerPoint. If a PowerPoint session already running, you will be prompted to open the image in a new session or the current one. The Operations Log displays the location and name of the saved bitmap.
  • To create a screen capture of the current view that you can open later in other applications, press Ctrl+C on the keyboard keys. The Operations Log displays the location and name of the screen capture.

Return to the Default Position

  • To return the display to the default position when you rotated from the Perspective View, click the Reset Perspective View button on the toolbar.
  • To return the display to the default position when you rotated from the Isometric View, click the Reset Isometric View button on the toolbar.

Layer Manager


When you initially create a project, two layers are available in the Layer Manager: All Points, which contains the standard view of the raw point cloud, and DSM, which contains the digital surface model. Additional layers will appear when you annotate the view, when you calculate viewshed analysis, and after you process the data and the display toggles to QA Mode. When you are in QA mode, the Layer Manager shows the classification layers that were created during processing.

  • To show or hide layers in the Main window, enable or disable the check box next to the layer name.
  • To toggle the display of the Terrain, Buildings, or Trees vector layers between wireframe (lines only) or solid (filled), right-click the layer and select Wireframe or Solid.
  • To view the filename and location of a vector layer, right-click the layer name and select File Information. Vector files are created when you specify them as output from the Project Properties dialog Outputs tab, or if you export them from the File > Export menu.
  • To view the directory location of point layer files, right-click the layer name and select File Information. Point layer files are created when you select Produce Classified Point Cloud as output from the Project Properties dialog Outputs tab, or if you select File > Export > Point Cloud from the menu bar.

Navigate Window


The Navigate window shows a color Digital Surface Model (DSM) of the entire area. A DSM is an elevation model that includes the tops of buildings, trees, power lines, and any other objects. The area you select in this window is the area that displays in the Main window for processing or review. After you process the data, the Navigate window shows a grid overlay on the DSM. Correct and Reprocess Data describes how to select areas when you are in QA Mode.

Zoom and Pan

  • To zoom in and out, right-click and drag up or down across the map, then release the right mouse button to zoom in or out. You can also zoom with the Zoom In and Zoom Out buttons, or, with Navigate window selected, use the mouse wheel.
  • To pan, click both mouse buttons and drag in any direction across the map.

    Note: This option does not work with some laptop internal mouse devices.

Select an Area

  • To select the area to display in the Main window, click and drag on the DSM. The selection is surrounded by a magenta rectangle. The smallest selection size is 30x30 meters; if you select an area smaller than that range, the size automatically increases to 30x30. The largest selection size is 2000x2000 meters for 64-bit installations and 1000x1000 meters for 32-bit installations.

Jump

  • Click the jump buttons to move in regular jumps across the DSM. The distance per jump is set in the Jump field.

Set the View Point Density

  • In the View Point Density field, enter a whole number for the required points per square meter. Click Set. ENVI LiDAR will limit the number of points displayed to achieve the requested density, but it will not match exactly due to variations in the point density of the source data. This option only changes the density of points rendered in the Main window, it does not affect the point density for processing. Use the Maximum Points Density setting under the Production Parameters tab in the Project Properties dialog to set the point density in processing results. The View Point Density setting persists with the current project settings.
  • Selecting a large area to view along with a high point density can result in the following behavior:
    • Low frame rates
    • Longer time to load the rendered points
    • Unresponsive application
    • Longer time to load the project

    If you see any of these behaviors, try reducing the View Point Density setting or the size of the view region.

Operations Log


The Operations Log shows information about the area, point density, ENVI LiDAR actions, warnings, errors, and processing status in black text. When LAS standards are referenced in the log, refer to the ASPRS web site for details. If you are running extensions from the Toolbox and you have a licensed copy of IDL with ENVI LiDAR, the Operations Log shows output from IDL in blue text. Errors for ENVI LiDAR and IDL appear in red text.

Also, in the Operations Log, you can:

Additional Windows


Other windows that can appear in the interface are the:

By default, these windows are not open when you start ENVI LiDAR. To show these windows, select View > window name from the menu bar.

Toolbox

IDL projects that were added as a custom extension using the legacy E3De API appear in the Toolbox. To show the Toolbox, select View > Legacy Toolbox from the menu bar.

Custom extensions that were added using the ENVI LiDAR API will appear in the ENVI Toolbox.

Cross Section Window

The Cross Section window shows the selected DEM cross section and point cloud points that are bounded in the volume defined in the Main window. This window does not appear when you open ENVI LiDAR; you must first create a cross section view.

The following additional controls apply to the Cross Section window:

  • Use keyboard arrows Up/Down and Left/Right to pan the displayed area while the mouse is occupied in generating a change contour.
  • The frame of the cross section in the Main window shows the volume that appears in the Cross Section window. The volume is selected when you create the cross section. See Create a Cross Section for details.

ENVI LiDAR 3D Viewer Window

A separate window appears when you invoke the ENVI LiDAR 3D Viewer. The ENVI LiDAR 3D Viewer is separate viewer, but the ENVI LiDAR Main window and the ENVI LiDAR 3D Viewer window are linked so you can use them together. See Quality Assurance with ENVI LiDAR 3D Viewer for details.



© 2019 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us