>  Docs Center  >  Using ENVI  >  Getting Started with the ENVI Modeler
ENVI

Getting Started with the ENVI Modeler

Getting Started with the ENVI Modeler

To help you become familiar with using the ENVI Modeler, the following steps use a sample model.

  1. Start ENVI.
  2. Click the Open button in the ENVI menu bar, navigate to the examples folder in your ENVI installation path, and select the file Modeler_Tutorial.model. The default installation path is as follows, where xx is the ENVI version number:
    • Windows: C:\Program Files\Harris\ENVIxx\examples\
    • Linux: /usr/local/harris/envixx/examples/
    • Macintosh: /Applications/harris/envixx/examples/
  3. The sample model opens in an ENVI Modeler window:

  4. Click the Run button in the ENVI Modeler window to run the model.
  5. The model stops at the Input Parameters node so that you can select an image. In the Input Parameters dialog, click the Browse button .
  6. In the Data Selection dialog, click the Open File button.
  7. Select a multispectral file; for example, qb_boulder_msi. This file is located in the data folder of the ENVI installation path. Click OK.
  8. Click OK in the Input Parameters dialog. The model runs and displays a smoothed classification image derived from the input multispectral image. The classification image is also added to the Data Manager and the view.
  9. Now adjust some task parameters: click the button in the ISODATA Classification node, and change the Number of Classes and the Iterations values. Click OK.
  10. Rerun the model, then compare that result with the earlier result by using a portal. See the Portals topic.

This is a simple example that shows how different ENVI tasks are combined to produce a new image. In the following sections, you will learn more about using the ENVI Modeler.

Basic Usage


Start the ENVI Modeler using one of these options:

  • Select Display > ENVI Modeler from the ENVI menu bar.
  • In the ENVI Toolbox, expand the Task Processing folder and double-click ENVI Modeler.
  • Drag and drop a .model file from a Windows file system to the ENVI application.

The following figure shows the main components of the ENVI Modeler user interface:

To create a new model, select File > New from the ENVI Modeler menu bar. Or, click the New button in the toolbar. A new "Untitled" tab appears with an empty layout window so that you can start adding new elements.

Use the scroll bars to view all of the elements of a model if it becomes too big to display at once. Click and drag a corner of the ENVI Modeler window to resize it. Use the mouse scroll wheel to zoom out of the model.

Once you have created a model, click the Center Model button to center it in the layout window. As the model grows, click the Automatic Layout button to create a more organized layout with better horizontal and vertical alignment of model elements.

To save the current model, select File > Save or File > Save As from the ENVI Modeler menu bar. Or, click the Save button in the toolbar.

To close the current model after saving it, select File > Close from the ENVI Modeler menu bar. Or, right-click in the layout window and select Close Model. This closes the tab containing the model.

To close all models that are currently open, select File > Close All from the ENVI Modeler menu bar. This closes all tabs.

Elements of a Model


A model consists of two primary elements: nodes and connectors. A node is a basic building block such as an input file, task, or other operation. A connector is a grey line that connects nodes to one another via their input and output parameters. The following figure shows an example model with nodes and connectors:

Nodes

Nodes consist of Basic Nodes and Tasks.

To add a node to your model, you can:

  • Double-click its name in the list of nodes on the left side of the ENVI Modeler, as shown in the figure below.
  • Click and drag it from the list into the layout window (Windows systems only).
  • Right-click its name in the list and select Add Node.

Task nodes are displayed as yellow-colored boxes, while Basic nodes are displayed as boxes of various colors.

If a node accepts input, it has an arrow on the left side. If it creates output, it has an arrow on the right side. A node can have arrows on both sides.

Click the button to rename a node:

Click the button to change the parameters of a node:

Connectors

To connect nodes with each other, move the cursor over an arrow in a node until a + icon appears. Click and drag to draw a line to the appropriate arrow on another node, then release the mouse button. The connector becomes a solid line.

If you attempt to make a connection that is not valid, no solid line will appear.

A line represents a connection between two nodes. A connection between two tasks typically links the output raster of the first task with the input parameter of the second task. In some cases, a connection represents multiple links between input and output parameters. If more than one connection is possible between two nodes, a Connect Parameters dialog appears so that you can specify the correct connection. See File and Dataset Nodes for details.

To verify or change a connection in the layout window, double-click the connector or right-click on it and select Edit Connection.

Select, Move, and Edit Elements

Click a node or connector to select it. A cyan-colored border surrounds the element to indicate it has been selected.

To select multiple elements, use the Ctrl key and click each element. Or, draw a box around the elements that you want to select; for example:

To select all elements in the model, right-click in the layout window and choose Select All or choose Edit > Select All from the ENVI Modeler menu bar.

To move a node, move the cursor over it until a Pan icon appears:

Then drag it to a different location. Windows users can also move a node by using the arrow keys on your keyboard. Use the Ctrl key in combination with an arrow key to move the node in smaller increments.

To cut, copy, and paste elements, click Edit in the ENVI Modeler menu bar and select the appropriate action. You can also right-click in the layout window and select an action.

To delete an element, select it and do one of the following:

  • Press the Delete key on your keyboard.
  • Select Edit > Delete from the ENVI Modeler menu bar.
  • Right-click in the layout window and select Delete.

To undo an action (for example, adding or moving elements), select Edit > Undo from the ENVI Modeler menu bar, or use the Ctrl+Z keyboard shortcut. To redo an action, select Edit > Redo from the ENVI Modeler menu bar, or use the Ctrl+Y keyboard shortcut.

See Also


ENVI Modeler Examples



© 2019 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us