Welcome to the Harris Geospatial product documentation center. Here you will find reference guides, help documents, and product libraries.


  >  Docs Center  >  Using ENVI  >  Placemarks

ENVI

Placemarks

Placemarks

Spatial Placemarks are geographic locations that you can define and access later. They provide a quick way to move the view in your Image window between a set of "places" that you need to revisit frequently. Placemarks are saved with the session information when you save and restore views and layers.

To create and use placemarks, you need a view that contains layers with map information.

Create a Placemark


A new placemark is defined by the area visible in your active view, including location, scale (zoom level) and rotation.

  1. Select Placemarks > Add Placemark from the menu bar. The New Placemark dialog appears.
  2. Enter a name for the placemark, or use the default name.
  3. Click OK. The placemark is added to the Placemarks menu, where you can select and go to it as needed.

Select an Existing a Placemark


To go to a saved placemark, select Placemarks > placemark name from the menu bar. The view moves to the defined location, including the zoom level and any rotation that was applied to the view before the placemark was saved.

Placemark Manager


Use the Placemark Manager to import, export, rename, or delete placemarks. Select Placemarks > Placemarks Manager from the menu bar to open the Placemark Manager dialog.

  • To export placemarks to a .json file, select File > Export Placemarks from the Placemarks Manager menu bar. Select an output file where ENVI will store the currently defined placemarks, then click Save.
  • To restore a saved placemark file, select File > Import Placemarks from the Placemarks Manager menu bar. Select the .json file that contains the ENVI placemarks, then click Open. The restored placemarks will be added to the Placemarks list in the main menu bar.
  • To rename a placemark, select Edit > Rename from the Placemarks Manager menu bar. Enter a new name and click the check mark icon to save the new name. You can also right-click on a placemark name and select Rename.
  • To delete a placemark, select Edit > Delete selected placemark(s) from the Placemarks Manager menu bar, or select Edit > Delete all placemarks. You can also right-click on a placemark name and select Delete.
  • To update the definition of a placemark, select the placemark name, update the definition in the view (change the location, scale, or rotation), and click on the Update placemark button .
  • To change the order in which placemarks are listed, drag and drop them in the Placemarks Manager list. The order will also be updated in the main menu.
  • To search for a placemark by name, enter a full or partial name in the Search box at the bottom of the dialog.



© 2018 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us