Welcome to the Harris Geospatial product documentation center. Here you will find reference guides, help documents, and product libraries.


  >  Docs Center  >  Using ENVI  >  Image to Map Registration

ENVI

Image to Map Registration

Image to Map Registration

Use Image to Map Registration to select ground control points (GCPs) for image-to-map registration. This tool requires you to open at least one image prior to running the tool.

See the following sections:

Open and Display Images


  1. Open a multispectral image.
  2. From the Toolbox, select Registration > Registration: Image to Map. The Select Image Display Bands dialog appears.
  3. Select a combination of RGB bands to display, then click OK. The Image to Map Registration dialog appears, along with a three-window display group.
  4. In the Select Registration Projection list, select the output projection or enter a custom projection type.
  5. Click OK. The Ground Control Points Selection dialog appears.

Select GCPs


In this section, you will interactively define ground control points (GCPs) using the Zoom window of the display group.

  1. Click the Change Proj button to choose a projection and datum for the GCPs.
  2. In the Image window (the window with the menu bar), position the Zoom box over the desired GCP area. If the Image window is not displayed, you may need to use the Scroll window.
  3. In the Zoom window, left-click on a specific pixel to position the cursor over that pixel or portion of that pixel. The coordinates of the selected location appear in the Ground Control Points Selection dialog in the Image X and Image Y fields. Subpixel coordinates are supplied to provide higher accuracy in selecting GCPs.

  4. Enter the known map coordinates for the GCP.
    • Enter the easting and northing of the selected GCP into E and N fields, respectively.
    • To enter the map GCP location in latitude and longitude, click the toggle button next to the map projection name and enter the values into the Lat and Long fields. Use negative (-) longitude for the western hemisphere and negative (-) latitude for the southern hemisphere.

    • To change the latitude and longitude values to degrees, minutes, and seconds, click DMS. To use decimal degrees, click DDEG.
    • To return to map projection coordinates, click the projection toggle button.

      The corresponding map projection coordinates are calculated automatically.

  5. Click Add Point in the Ground Control Points Selection dialog to add the point to the list of GCPs.

    To view the Image to Map GCP List, click Show List. The Image to Map GCP List appears with the GCPs listed in a table. See The Image to Map GCP List for a list of different options.

    When you add a GCP, a marker is placed in the image, which consists of an ID number next to an encircled crosshair. The marker indicates the selected pixel (or subpixel location). The center of the marker (located under the crosshair) indicates the actual GCP location.

  6. Add more GCPs using the same steps.

  7. To restore GCPs from an ASCII .pts file, select File > Restore GCPs from ASCII from the Ground Control Points Selection menu bar. For image-to-map registration, coordinates are listed as Map x, Map y, Image x, and Image y. An example of a typical image-to-map .pts file is shown here:
  8. ENVI Registration GCP File
            359459.810 4143531.300 288.000 496.000
            367681.530 4141772.000 232.000 23.000
            366343.470 4138660.500 458.000 35.000
            362337.840 4145969.500 71.000 388.000
            361339.910 4138479.300 569.000 301.000
            354457.530 4140550.300 591.000 714.000
            354352.590 4145685.000 261.000 819.000
            359918.310 4142412.000 351.000 448.000
            364900.910 4141752.300 290.000 172.000

    The Ground Control Points Selection dialog shows the number of GCPs you selected. When you select a sufficient number of GCPs to conduct a first-degree polynomial warp, the total RMS error is also displayed. At this point, you can click Predict to predict the map coordinates.

    Tip: For the best registration, try to minimize the RMS error by refining the positions of the pixels with the largest errors or by removing them. You can reduce errors by adding more points. If you only have a few points, place them near the image corners or widely scatter them throughout the image.

    For details about editing, predicting, and positioning GCPs, see GCP Options.

  9. To save the GCPs, select File > Save GCPs to ASCII from the Ground Control Points Selection dialog menu bar. Enter an output filename with a .pts extension.
  10. Choose one of the following options from the Ground Control Points Selection dialog menu bar to begin the warping process:
    • Options > Warp Displayed Band: The Registration Parameters dialog appears.
    • Options > Warp File: Select the input file. The Registration Parameters dialog appears.
  11. To change the output projection, click Change Proj.
    • You can change the easting and northing coordinate of the upper-left corner by entering their respective values in the E and N fields.
    • To change the output pixel size or output image dimensions, use the X Pixel Size, Y Pixel Size, Output X Size, and Output Y Size fields.
    • Click Options and select from the menu to manage the output projection and map extent settings.
  12. In the Warp Parameters area of the Registration Parameters dialog, select the warping and resampling methods.
  13. In the Background field, enter a digital number (DN) value to use to fill areas where no image data appear in the warped image.
  14. Select output to File or Memory.
  15. Click OK. ENVI adds the resulting output to the Layer Manager.

The Image to Map GCP List


Use the Image to Map GCP List to edit and update positions, to turn GCPs on and off, and to delete selected GCPs.

  • To center the Zoom window over any of the selected GCPs, select the desired GCP in the Image to Map GCP List and click Goto, or select the GCP number. The marker outlining the selected GCP is positioned at the center of the Zoom window.
  • To selectively ignore GCPs during registration, select the GCPs to ignore and click On/Off. The RMS error and the spatial transformation are recalculated without using the selected GCPs. The + next to the GCP number changes to a - in the Image to Map GCP List, and the color of the GCP marker changes. To turn the GCP on again, select it and click On/Off again.
  • To permanently remove any GCP from the list, select the GCP and click Delete.
  • To edit the location of a GCP, interactively move the GCP in the Zoom window or select the GCP in the Image to Map GCP List and double-click a Base X, Base Y, Warp X, or Warp Y value to edit it. Enter the new value and press the Enter key or click Update. The changes are reflected in the Image to Map GCP List and in the displayed image.

GCP Options


Use the Options menu in the Ground Control Points Selection dialog to control GCP labels, colors, and order; and to set other preferences.

  • For first-order polynomials, you can calculate errors using a rotation, scaling, and translation (RST) method. From the Ground Control Points Selection dialog menu bar, select Options > 1st Degree (RST Only). A check mark next to the menu option indicates it is enabled.
  • To automatically predict GCP locations, select Options > Auto Predict from the Group Control Points Selection dialog menu bar. A check mark next to the menu option indicates it is enabled. When you adjust the pixel location by entering easting and northing coordinate values, the Zoom box and crosshairs of the Zoom window move to the predicted pixel location. Click Add Point to enter the GCP.
  • To turn the GCP labels off or on, select Options > Label Points from the Group Control Points Selection dialog menu bar. A check mark next to the menu option indicates it is enabled.
  • To change GCP label colors, select Options > Set Point Colors from the Group Control Points Selection dialog menu bar. Click the Points which are “On” color box to select the color of the active GCP markers. Click the Points which are “Off” color box to select the color of the inactive GCP markers.
  • To select whether the GCP pairs display in the list by their GCP ID# or by RMS Error, select Options > Order Points By Error from the Group Control Points Selection dialog menu bar. A check mark next to the menu option indicates ordering by RMS error is enabled. No check mark indicates the list order is by GCP ID#. The GCP ID order is the order in which they were selected. RMS error order lists the GCP with the highest error first.
  • To delete all of the GCPs in the Image to Image GCP List, select Options > Clear All Points from the Group Control Points Selection dialog menu bar.



© 2018 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us