Welcome to the Harris Geospatial product documentation center. Here you will find reference guides, help documents, and product libraries.


  >  Docs Center  >  Using ENVI  >  Spectral Library Viewer

ENVI

Spectral Library Viewer

Spectral Library Viewer

Use the Spectral Library Viewer to visualize data from ENVI standard spectral library (SLI) files, THOR Metadata Rich Spectral Library (MRSL) output, and Analytical Spectral Devices (ASD) spectrometers output.

Included with your installation of ENVI are several groups of laboratory spectra from the NASA Jet Propulsion Laboratory (JPL), Johns Hopkins University (JHU), and the U.S. Geological Survey (USGS). Data provided courtesy of courtesy of the Jet Propulsion Laboratory, California Institute of Technology, Pasadena, California. Copyright © 1999, California Institute of Technology. All Rights Reserved.

The aster folder contains the ASTER Spectral Library (version 2), which includes thousands of laboratory spectra from natural and man-made materials covering 400 to 1540 nm (Baldridge et al., 2009). This folder contains the JPL and JHU spectra.

Reference: Baldridge, A. M., S. J. Hook, C. I. Grove, and G. Rivera, 2009. The ASTER Spectral Library Version 2.0. Remote Sensing of Environment, Vol. 113, pp. 711-715.

To open and plot a spectral library:

  1. Use one of the following:

    • Select Display > Spectral Library Viewer from the menu bar.
    • Select File > Open from the menu bar, then open a spectral library file.
    • In the Data Manager, click the Open button, then open a spectral library file.

    The Spectral Library Viewer appears. By default, the left panel of the viewer lists all the spectral libraries that are in the installed \speclib directory. When you plot a spectral library, the center panel will contain the plot, and the right panel will contain the plot key and plot properties. The right panel is hidden when the Spectral Library Viewer opens; click the Show arrow to open it.

  2. Click the Open Spectral Library button, then select an MRSL, ASD, or SLI file.
  3. Use the Search field to search for a particular signature.
  4. Click a spectrum in the Spectral Library Viewer tree to plot it. Click additional signatures in the tree to overplot them in the viewer. You can also import data from an ASCII file or spectral library using the Import drop-down list in the Spectral Library Viewer. See Import Plot Data for details.
  5. To import data from an ASCII file or spectral library, select the Import drop-down list in the profile window. See Import Plot Data for details.
  6. Use the plot window controls and plot properties to change the display and appearance of the plot.
  7. To export plot data, see Export Plot Data for details.

The following buttons at the top of the left panel control the Spectral Library Viewer tree:

  • Click the Open Spectral Library button to open a library that is not already open in the tree.
  • Click the Close Spectral Library button to remove a library from the tree.
  • Click the Close All Spectral Library button to remove all libraries from the tree.
  • Use the Expand All and Collapse All buttons to expand or collapse the tree display.

Plot Window Controls


Use the following to control and change the plot display:

General Plot Controls

  • To zoom in and out of the plot, click in the plot and roll the mouse wheel back and forth, or click and drag the middle mouse button to draw a box around the area to zoom into.
  • Click and hold on a curve in the plot to show the X-Y line crosshair. As you move the cursor over the curve, the crosshair snaps to the closest data point. The X and Y values of the point appear below the plot.
  • The X-axis (Wavelength) is determined by the first spectra that is plotted. By default, the plot automatically rescales the Y-axis (Data Value) to the data minimum and maximum when you add or update plots. To toggle off rescaling and keep the current Y-axis range, right-click the plot and select Auto Scale Y-Axis. If auto scaling is toggled off and a plot is added outside the current Y-axis range, that plot is not visible until the Y-axis is rescaled.
  • If the Z plot range header value is set in the ENVI header, then the X- and Y-axis is set to the Z plot value and the Y auto scale value is turned off.
  • To offset the plots in the window so that data does not overlap, toggle on the Stack Plots button .
  • To reset the plot range to the original view, click the Reset Plot Range button .
  • Click the Show arrow on the right side of the window to expand the panel and show the plot key and plot properties.
  • To hide data in the plot, disable the check box for the curve in the plot key.
  • To remove data from the plot, select a curve in the plot key and click the Remove Selected Curve button , or click the Remove All Curves button . You can also right-click a curve in the plot key and select a Remove option from the menu that appears.
  • To edit the plot X-values if a plot has anomalous points, click the Edit Data Values button to open the Edit Plot Values dialog.

Select Statistics Plot

If the plot is being shown in the Statistics View, the initial view of the plot window contains the minimum, maximum, and mean values for each band in the raster. Use the Select Plot drop-down list to change the display to the standard deviation, eigenvalues (if the covariance was generated), or histograms (if the histograms were generated) for each band, or for all bands. If the statistics are for a classification image, you can also change the display to a specific class.

Change Plot Functions

To change the data display in the plot, select from the X and Y drop-down lists as follows:

X:

Available for all profiles:

  • Index: Plots Y values of the curve against equally spaced integers ranging from 1 to number_of_elements in the curve. For example, the "wavelength" of an AVIRIS spectrum will range from 0.4 to 2.5 microns, and the "index" of an AVIRIS spectrum will range from 1 to 224 bands.

Available for the Spectral Profile, Statistics Profile, Spectral Library Viewer, and ENVI Plot window:

  • Wavelength: (default) Plots the data as wavelengths, if wavelengths are in the image header.
  • Wavenumber: Plots the data as the wavenumber (1/wavelength), if wavelengths are in the image header. For example, a spectrum that ranges from 0.4 to 2.5 microns will have wavenumbers that range from 25,000 down to 4,000. Because the wavenumber is an inverse relationship to wavelength, smaller wavelengths will have larger wavenumbers.

Available for the Horizontal Profile:

  • Column: (default) Plots values of the curve as the column width.

Available for the Vertical Profile:

  • Row: (default) Plots values of the curve as the row length.

Available for the Arbitrary Profile:

  • Transect: (default) Plots values of the curve as the transect length.

Y:

  • Data Value: (default) Plots the data in the original values.
  • Continuum Removed: Plots the data with its continuum removed. The continuum is the convex hull that fits over the top of a spectrum. It is divided into the original data values to produce the continuum removed values. The continuum is calculated using the first and last data points displayed in the plot, so for plots that have been zoomed, the continuum is calculated based on the displayed data range only.
  • Binary Encoding: Replots the data as a spectrum of 0s and 1s. It calculates the mean of the data and encodes each value as a 0 if it is less than or equal to the mean and as a 1 if it is greater than the mean.

Options Menu

Available for all profiles:

  • To keep the crosshair visible at all times, select Crosshair Always On.
  • To toggle on a legend for the plot, select Legend.
  • To toggle on a wavelength color along the X axis of the plot, select Wavelength Color. This applies only when the X axis has valid Wavelength or Wavenumber units.

  • To apply a boxcar average smoothing of plotted data, select Curve Smoothing. A slider control will display, allowing on-the-fly adjustment of smoothing levels.

Available for Spectral, Horizontal, and Vertical Profiles:

  • To open the data in a new ENVI Plot window, select New Window with Plots.

Available for Spectral Profiles:

  • To show a vegetation index for the selected pixel, select Vegetation Index.
  • To change the bands displayed in the plot, select RGB Bars to display RGB bars on the plot. Click and drag to move the RGB bars, then select Load New Band Combination from the Options drop-down list to display the new band combination in the plot.
  • To extract the spectrum for the selected pixel from an additional file, select Additional Profiles > Add Files, from the Options menu, then select the input file. The input file must be the same spatial size as the as the original input file. The curve is added to the Spectral Profile.

Available for Horizontal and Vertical Profiles:

  • By default, the Horizontal and Vertical Profiles show data for only the area of the band that is visible in the Image window. To show the profile for the entire band, select Use Full Band. You can change the default in the General properties for the plot.

Available for Series Profiles:

  • To display a specific series frame in the view, select the Series Index Bar. A gray vertical line will appear on the Y-axis, and can be dragged to the desired series index. The associated image will load once you release the mouse button.

Plot Properties


Plot properties are located in the expanded right panel of the plot window. The plot properties display by default. To hide them, toggle the Show/Hide Properties button .

General Properties

The General tab contains properties for the plot ranges and data.

  • X-Axis Min Range: The minimum data range to include in the plot for the x-axis.
  • X-Axis Max Range: The maximum data range to include in the plot for the x-axis.
  • Y-Axis Min Range: The minimum data range to include in the plot for the y-axis.
  • X-Axis Max Range: The maximum data range to include in the plot for the y-axis.
  • Font Name: The font type for plot text. The default for all plots is set in the system Plot Preferences; this value overrides the font name for the current plot. The system default is Calibri.
  • Font Size: The font size for plot text. The default for all plots is set in the system Plot Preferences; this value overrides the font size for the current plot. The system default is 12.
  • Plot Title: The title that appears above the plot. The default is dependent on the type of profile you have open.
  • X-Axis Title: The title for the X-axis of the plot. The default depends on the type of profile you have open.
  • Y-Axis Title: The title for the Y-axis of the plot. The default depends on the type of profile you have open.
  • X Major Ticks: The number of major tick marks to show on the X-axis of the plot. The default for all plots is set in the system Plot Preferences; this value overrides the X Major Ticks for the current plot. Set to -1 to auto-compute. Set to 0 to suppress. The system default is -1.
  • Y Major Ticks: The number of major tick marks to show on the Y-axis of the plot. The default for all plots is set in the system Plot Preferences; this value overrides the Y Major Ticks for the current plot. Set to -1 to auto-compute. Set to 0 to suppress. The system default is -1.
  • Axis Thickness: The line thickness for the plot border and tick marks. The default for all plots is 1.
  • Left Margin: The left margin to offset the plot display within the plot window. The default for all plots is set in the system Plot Preferences; this value overrides the margin for the current plot. The system default is 0.
  • Right Margin: The right margin to offset the plot display within the plot window. The default for all plots is set in the system Plot Preferences; this value overrides the margin for the current plot. The system default is 0.
  • Top Margin: The top margin to offset the plot display within the plot window. The default for all plots is set in the system Plot Preferences; this value overrides the margin for the current plot. The system default is 0.
  • Bottom Margin: The bottom margin to offset the plot display within the plot window. The default for all plots is set in the system Plot Preferences; this value overrides the margin for the current plot. The system default is 0.
  • Background Color: The plot background color. The default for all plots is set in the system Plot Preferences; this value overrides the Background Color for the current plot. The system default is 240,240,240, which is the same color as the ENVI widgets. If the background is 0,0,0 (black) and the foreground is 255,255,255 (white), the colors will be reversed for printing.
  • Foreground Color: The plot foreground color. The default is 0,0,0 (black). The default for all plots is set in the system Plot Preferences; this value overrides the Foreground Color for the current plot. If the background is 0,0,0 (black) and the foreground is 255,255,255 (white), the colors will be reversed for printing.
  • Stack Offset: The offset for the spectra stack. The default is 0.1 percent.

General properties exclusive to the Spectral Profile and Spectral Library Viewer:

  • Spectral Average: The profile cursor size to use when selecting pixels to plot. For example, a setting of 1 would be a 1x1 pixel, and a setting of 3 would be 3x3 pixels. The default is 1.
  • NDVI Orientation: The orientation of the vegetation index legend, if enabled. To enable a legend, select Options > Legend from the plot menu bar. The default is Horizontal.
  • NDVI Width: The width of the vegetation index legend. The default is 25 points.

General property exclusive to the Horizontal and Vertical Profiles:

  • Use Full Band: A setting of True shows data for only the area of the band that is visible in the Image window. False shows the profile for the entire band. The default is True.

General properties exclusive to Series Profiles:

  • Date Format: The format in which dates are displayed along the X-axis of the plot. The default is Mon DD.
  • Date Separator: The character used to separate date components. The default is /.

Curve Properties

The Curve tab contains properties for the plot display.

  • Name: The name of the curve selected in the list.
  • Color: The display color of the curve selected in the list.
  • Line Style: The style for plot lines, with choices ranging from a solid line, to different dashed or dotted lines. The default for all plots is set in the system Plot Preferences; this value overrides the line style for the current plot. The system default is a solid line.
  • Thickness: The line thickness for the plot lines. The default for all plots is set in the system Plot Preferences; this value overrides the thickness for the current plot. The system default is 1 point.
  • Symbol: Select a symbol style to display a symbol on the peaks and valleys of the plot. The default for all plots is set in the system Plot Preferences; this value overrides the symbol setting for the current plot. The system default is No symbol.
  • Symbol Color: The symbol color, if symbols are enabled. The default for all plots is set in the system Plot Preferences; this value overrides the symbol color for the current plot. The system default is 0,0,0 (black).
  • Symbol Size: The symbol size, if symbols are enabled. The default for all plots is set in the system Plot Preferences; this value overrides the symbol size for the current plot. The system default is 2 points.
  • Symbol Thickness: The symbol thickness, if symbols are enabled. The default is 1 point.
  • Symbol Fill: Enable this property to fill the symbol, if symbols are enabled. The default is False.
  • Symbol Fill Color: The symbol fill color, if symbols and symbol fill are enabled. The default is 255,255,255 (white).

Legend Properties

The Legend tab contains properties for the legend display. The tab is available only when you have a legend enabled for the plot. To enable a legend, select Options > Legend from the plot menu bar.

  • Legend Style: The style for the legend that precedes the spectrum name. Solid boxes show as a filled box style, Flat lines as a long dash, Spike lines as a line with two peaks, and Sparklines as reduced versions of the actual plots, where the shape of the lines mimics the actual plot data. The default for all plots is set in the system Plot Preferences; this value overrides the legend style for the current plot. The system default is Sparklines.
  • Font Name: The font type for plot text. The default for all plots is set in the system Plot Preferences; this value overrides the font name for the current plot. The system default is Calibri.
  • Font Size: The font size for legend text. The default is 12.
  • Show Frame: Enable this property to show a frame around the legend. The default is False.
  • Frame Color: The color to use for the frame, if it is enabled. The default is 0,0,0, (black).
  • Show Background: Enable this property to show a background color under the legend. The default is False.
  • Background Color: The defaut background color to use for the legend, if it is enabled. The default is 218,218,218 (gray).

Drag and Drop Curves to Other Profiles or Plots


You can drag and drop curves between any profile or ENVI Plot window and the Spectral Library Viewer for analysis:

  1. Open any profile window or ENVI Plot window with data.
  2. Click the arrow on the right side of the profile window and the Spectral Library Viewer to expand the panels and show the plot key.
  3. In the Spectral Library Viewer, select a curve. You can also use Ctrl+click to multi select.
  4. Drag the selected items to the profile window. The curves appear in the corresponding plot. If the incoming curve or the receiving plot (or both) are missing wavelength units and/or y-scale factor information, the Scale Incoming Curve Data dialog appears.



© 2018 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us