Welcome to the Harris Geospatial product documentation center. Here you will find reference guides, help documents, and product libraries.


  >  Docs Center  >  Using ENVI  >  Photogrammetry Module  >  The ENVI Orthorectification Wizard

The ENVI Orthorectification Wizard

The ENVI Orthorectification Wizard

The ENVI Orthorectification Wizard dialogs have two control buttons at the bottom: Previous and Next, which allow you to maneuver backward and forward, respectively, through the steps of the Wizard.

  • Next continues to the next step in the Wizard, but it is only enabled when the required information has been provided in the current step.
  • Previous allows you to go back to a previous step in the workflow. Note, however, that you will lose all data in the current step.

Selecting Help > Help on current step from the Wizard menu bar provides information describing the current Wizard step.

Common Wizard Tools


Following are some tools that are common to the GCP, tie point, and/or cutline steps:

Button

Description

Set the color for on/off GCPs, tie points, and cutlines.

Open a GCP or tie point file.

Save a GCP or tie point file

 

If a multiband image is intially displayed as a grayscale image in the display group, you can click the MB button in the ENVI Orthorectification Wizard to display a multispectral image of Bands 3, 2, and 1 as red, green, and blue, respectively. Click the MB button again to display a grayscale image. This button is only available for images with three or more bands. See Select Bands below.

Save and Restore Projects


At any point throughout the orthorectification workflow, you can save your project and restore it later if needed. Saving a project saves the complete state of the project including GCP and tie point on/off status and colors, cutline image coordinates and colors, and various parameter settings available in the workflow. The on/off status for GCPs and tie points is only preserved when restoring a project to the relavent GCP or tie point step.

When restoring a project, the images and DEMs must be in the same directory as when you saved the project.

Follow these steps to save your project:

  1. From the ENVI Orthorectification Wizard menu bar, select File > Save Project. The Select Project File dialog appears. You can save projects during Step 2 or later in the Wizard.
  2. Select an output location and filename, and click Save. ENVI saves the project state in XML format. A file named *_envidata.xml contains any cutline polygons you created (in original image space), and the state of the Layout Manager, including GCPs, tie points, cutline color, auto tie point parameters, and GCP/tie point on/off status. Do not modify this XML file or else the project will not restore correctly.

Follow these steps to restore a previously saved project. You can only restore a project during Step 1 of the Wizard.

  1. From the ENVI Orthorectification Wizard menu bar, select File > Restore Project. The Select Project File dialog appears.
  2. Select a project file (in XML format), and click Open. ENVI automatically opens all input images, DEMs, GCPs, and tie points.

Select Bands


From the ENVI Orthorectification Wizard menu bar, select Options > Band Selection. The Bands dialog appears. Use this dialog to change the default multi-band and single-band display options. Band 1 is the default setting for single-band images. To change this setting, enter a band number in the Single Band Number field. Bands 3, 2, and 1 are used by default for red, green, and blue, respectively, in multi-band images. To change this setting, enter band numbers in the Red, Green, and Blue fields.

Using this method ensures that band settings persist throughout the orthorectification workflow. You can also change bands through the Data Manager, but the band settings will not persist throughout the orthorectification workflow.

View the Project Summary


From the ENVI Orthorectification Wizard menu bar, select Options > View Project Summary. The Project Summary dialog appears. Use the Project Summary to review characteristics of the images, DEMs, GCPs, tie points, and cutlines currently used in the project.



© 2018 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us