Welcome to the Harris Geospatial product documentation center. Here you will find reference guides, help documents, and product libraries.


  >  Docs Center  >  Using ENVI  >  ENVI LiDAR  >  Quality Assurance with ENVI LiDAR 3D Viewer

Quality Assurance with ENVI LiDAR 3D Viewer

Quality Assurance with ENVI LiDAR 3D Viewer

Three-dimensional (3D) navigation provides a unique view that is useful during QA. You can use the ENVI LiDAR 3D Viewer along with ENVI LiDAR to perform QA in 3D mode.

Click the ENVI LiDAR 3D Viewer button on the toolbar to display a 3D rendering of the data. To display a list of available controls for ENVI LiDAR 3D Viewer in the window, press F1.

Note: Very old graphic cards may not support trees in ENVI LiDAR 3D Viewer.

Navigate in the 3D image as follows:

  • To rotate the image along the x and z axes, click and drag across the image.
  • To zoom in and out, right-click and drag across the image, or use the mouse wheel. To zoom in and out by smaller increments, press the q key on the keyboard before using a zoom control. Press the q key again to toggle the sensitivity off. You can also use the / and * keys on the keyboard number pad to zoom in and out in smaller increments.
  • To pan the image, click both mouse buttons and drag across the image.

    Note: This action does not work with some laptop internal mouse devices.

  • Double-click on a point in the ENVI LiDAR 3D Viewer window to bring the area to the center of the display in the ENVI LiDAR Main window, then perform editing in the ENVI LiDAR Main window, as described in Perform Quality Assurance.

Adjust the 3D Screen Mode


To optimize the display on monitors or projectors, you can change to full-screen mode by selecting ScreenMode > Full Screen from the menu bar to view in full-screen mode. To exit full-screen mode, select ScreenMode > Windowed, or press Esc.

3D Flying Mode


You can fly through the 3D image by using the following keys on the keyboard. To view the key controls on the screen, press the F1 key.

  • Press a to move forward in the display. Press a again to increase forward speed. To decrease the speed, press the z key.
  • Press z to move backward in the display. Press z again to increase backward speed.
  • Right-click to freeze forward or backward movement and return to non-flying mode.
  • Control the flight path as you fly by moving the mouse in the direction you want to go with respect to screen center.

You can toggle view information about the position marked on the center of the picture by pressing the r key on the keyboard.

You can record and save a flying route for later viewing:

  1. Select Navigate > Record Route from the ENVI LiDAR 3D Viewer menu.
  2. Fly the route.
  3. Select Navigate > Stop from the ENVI LiDAR 3D Viewer menu.

To play the route, select Navigate > Play Route from the ENVI LiDAR 3D Viewer menu.

Toggle Controls for the Display and Layers


You can enable or disable various display controls pressing the following keys on the keyboard:

  • r: Shows cursor ground location and camera position information for the position marked on the center of the display.
  • b: Toggles on/off bilinear filtering.
  • f: Toggles on/off haze.
  • m: Toggles on/off terrain noise.
  • [ and ]: Increases and decreases light time, respectively.
  • Ctrl+C: Captures the image in the ENVI LiDAR 3D Viewer window and saves it to a .bmp file in the project's \3DViewer directory.

You can hide or show various layers by the pressing the following keys on the keyboard:

  • 0: Terrain
  • 1: Buildings
  • 5: Trees (trees might not be visible, depending on the type of video card)
  • 9: Power lines and other vectors

Jump to and Save Positions


You can jump to a specific location when you select Navigate > Jump to Location from the menu bar and enter x/y coordinates in the Select Location dialog.

You can save camera positions so you can return to them later.

  • To save a position, select Navigate > Save Position from the ENVI LiDAR 3D Viewer menu. Enter a Display Name in the Select Display Name dialog and click OK.
  • To return to a saved position, select Navigate > Display Position from the ENVI LiDAR 3D Viewer menu and select the relevant position from the Saved Views dialog.
  • To delete saved positions, select the positions you want to delete in the Saved Views dialog and click Delete. To delete all saved positions, click Delete All in the Saved Views dialog. By default, the ENVI LiDAR 3D Viewer removes all but the first saved view from the list.

Overlay a Shapefile on the 3D Presentation


You can load shapefile information to overlay on the 3D presentation.

To overlay a shapefile:

  1. Select File > Load Shape File from the ENVI LiDAR 3D Viewer menu. The Load Shape File dialog appears.
  2. Navigate to and select the shapefile, then click Open. The selected shapefile overlays the 3D image.

Annotate the 3D Presentation


You can add text annotations to mark places of interest. Annotations appear in both the ENVI LiDAR 3D Viewer and the ENVI LiDAR Main window.

To add an annotation:

  1. Press and hold the Ctrl key and double-click the location to annotate. The Add Text Annotation dialog appears.
  2. Enter the text in the Text field.
  3. To change the background color of an annotation to make it more visible, click Color. Select a different color in the Color dialog that appears. The text color will be white or black, depending on which provides the best contrast from the background.
  4. Click OK.

To edit or delete an annotation, double-click the text. The Edit Text Annotation dialog appears.

  • Edit the text, then click Save.
  • To edit the annotation background color, click Color. Select a different color in the Color dialog that appears, then click Save.
  • Delete the annotation by clicking Delete.

Measure the Distance Between Two Points


The Measurement Tool measures the difference between two selected points and adds the result as an annotation. The annotation will also be visible in the ENVI LiDAR Main window.

To use the ENVI LiDAR 3D Viewer Measurement Tool:

  1. Select Edit > Measurement Tool from the ENVI LiDAR 3D Viewer menu bar.
  2. Click the first point.
  3. Click the second point.

    The ENVI LiDAR 3D Viewer dialog appears with the following information:

    • Horizontal range between points 1 and 2 (meters and feet)
    • Z difference
    • Slant range between points 1 and 2 (meters and feet)

    Click OK. A measurement annotation is added to the ENVI LiDAR 3D Viewer window.

    To delete a measurement annotation, double-click the annotation and select Delete. You can modify the measurement annotation color, described previously in the section on annotations.

Help Menu


  • To view help for the ENVI LiDAR 3D Viewer, select Help > Help Contents from the menu bar.
  • To toggle on and off the display of controls in the window, select Help > On Screen Viewer Controls from the menu bar.
  • To toggle on and off the cursor ground location and camera position information for the position marked on the center of the display, select Help > On Screen Camera Information from the menu bar.

Share ENVI LiDAR 3D Viewer Data


You can share exported 3D data with users who do not have an installation of ENVI LiDAR. ENVI LiDAR bundles the data with an installer for the standalone version of ENVI LiDAR 3D Viewer, which you can then copy to removable media, such as a flash drive or CD or, for large datasets, DVD.

To export the ENVI LiDAR 3D Viewer:

  1. In ENVI LiDAR, ensure that ENVI LiDAR 3D Viewer data is created by enabling Produce 3D Viewer Database in the Project Properties dialog Outputs tab.
  2. Process the data.
  3. From the main menu, select File > Export > Export 3D Viewer. ENVI LiDAR creates an output directory called Export3D, located under the project directory.
  4. Copy the contents of the Export3D directory to a CD or DVD.



© 2018 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us