Welcome to the Harris Geospatial product documentation center. Here you will find reference guides, help documents, and product libraries.


Harris Geospatial / Docs Center / Using IDL / Using The Export Bridge Assistant

IDL

Using The Export Bridge Assistant

Using The Export Bridge Assistant

You can use the Export Bridge Assistant to create COM or Java wrapper objects from native IDL objects. The Assistant is a system-wide dialog; for information on launching it, see Running the Assistant.

The image above shows the Assistant when it is first launched, without a project open.

Understanding the Assistant Interface


The Assistant consists of three panels, a menu bar, and a toolbar. The panels are a tree view of the current project (if any), a property view of the current selected item (if any), and a view of the three informational logs available in the Assistant.

The Menu Bar

The following menus appear on the Assistant menu bar:

  • File
  • Edit
  • Build
  • Help

The File menu contains tools for creating, importing, exporting, and saving projects.

Menu Selection

Function

New Project

For COM or Java (selected in a sub-menu), creates a new project by selecting an IDL source file (.pro) or SAVE file containing an object definition. See Working with a Project for details.

Open Project...

Opens an existing project. See Opening a Project for details.

Close Project

Closes the current project, prompting you to save any unsaved changes.

Save Project

Saves the current project to an IDL SAVE file. If the project has not been previously saved, the behavior matches that of Save Project As... (below). See Saving a Project for details.

Save Project As...

Prompts you to select a name for the project’s IDL SAVE file. See Saving a Project for details.

Revert To Saved

Prompts you to discard changes made to the current project and revert to its most recent saved version.

Update From Source...

Prompts you to select an IDL source file or SAVE file containing an object definition, which is compared to the source object in the current project. See Updating a Project for details.

Save Log...

Saves the contents of the current log (change, export, or build). The menu selection’s name changes to reflect that of the current log (e.g., Save Change Log...). See The Logs Panel for details.

Exit

Closes the Assistant, prompting you to save any unsaved project changes.

The Edit menu contains only one operation: Clear Log, which clears the contents of the current log (change, export, or build). The operation’s name changes to reflect that of the current log (e.g., Clear Change Log). See The Logs Panel for details.

The Build menu contains only one operation: Build Object, which builds the current object. See Building an Object for details.

The Help menu opens the online help for the following topics:

  • Using the Export Bridge Assistant
  • Configuring the Export Bridge Assistant
  • Exporting IDL objects to COM and Java
  • Using exported COM objects
  • Using exported Java objects
  • Help on IDL

The Toolbar

The following buttons appear on the Assistant toolbar:

  • Open Project
  • Save Project
  • Build Object

These buttons match the menu operations of the same name. See The Menu Bar for details.

The Project Tree View

The project tree displays a hierarchical view of the project and the contained IDL source object with its properties, methods, method parameters, and superclasses. (See Specifying Information for Exporting for more information.) Clicking on an item in the tree fills in the property sheet for that selected item.

Multiple selection is enabled. This can be very useful for setting object properties efficiently. A property is only applied to a selected item if it implements the property, allowing a selection to span disparate items.

The icons next to items in the project tree indicate their readiness for export to a wrapper object. For more information, see Exporting an Object.

The Property Sheet View

The property view displays the properties of items selected in the project tree view. You can change the properties using this view. Multiple selection is not enabled.

The Logs Panel

The logs panel has three tabs: Change Log, Export Log, and Build Log.

The Change Log

This text field initially contains welcome text that is cleared when a project is created or closed. When a project is open, the field displays a running log of property settings made by the user, including property changes and the following actions: Save Project, Update From Source, and Revert To Saved Project. The following shows an example of a change log in progress.

The text is saved with the project, and when an existing project is opened, it is re- displayed.

The Export Log

This text field contains a description of the items that are to be exported (those items that are both fully specified and marked for export). It is cleared when a project is created or closed. The following shows an example of an export log in progress.

The text is saved with the project, and when an existing project is opened, it is re- displayed.

The Build Log

This text field displays the results of the build operation. It is cleared when a project is created, opened or closed. The figure below shows an example of a build log in progress.

The text is saved with the project, and when an existing project is opened, it is re- displayed.

The ProgID identifies the exported IDL object, and is displayed on the Build Log tab. You may need this identifier if you handle the exported object directly in a custom application.



© 2017 Exelis Visual Information Solutions, Inc. |  Legal
My Account    |    Buy    |    Contact Us