>  Docs Center  >  Using ENVI  >  Classify from Rule Images

ENVI

Classify from Rule Images

Classify from Rule Images

Use Rule Classifier to create classification images from different thresholds, using previously saved rule images. See Rule Images in Supervised Classification for more information.

  1. From the Toolbox, select Classification > Post Classification > Rule Classifier. The Rule Image Classifier dialog appears.
  2. Select an input file and perform optional spatial subsetting, then click OK. The Rule Image Classifier Tool dialog appears.
  3. Click the Classify By toggle button to select whether the image will be classified by Minimum or Maximum values.
  4. Select one of the following options to set a threshold value:
    • To enter the same threshold value for all classes, enter a value in the Set All Thresholds field and click Set All Thresholds. The threshold value appears in the Thresh field for each class.
    • To enter a different threshold for each class, enter a value in the Thresh field for each class.
    • To enter a threshold value based on histogram percentage, enter the percent value (for example, 5%) in the Thresh field.

      Tip: You can plot a histogram of a rule band to help you determine threshold values, by clicking Hist for that class. A plot window displays with the histogram of the selected band.

      If using maximum likelihood rule images that were produced from ENVI 3.6 or later, enter the threshold using a percentage (for example, 95%), and the corresponding Chi Square value will automatically be computed using the histogram of the rule image.

  5. Click Quick Apply. A classification image based on the current settings displays in a new display group.

    To remove a class from the display, select the On check box for that class to deselect it. To display that class again, select the On check box again.

  6. Click Quick Apply to see how any of your changes affect the classification image.

Options in the Rule Image Classifier Tool Dialog


Use the Rule Image Classifier Tool Options menu to change class names and/or colors, and to reorder classes. Click Save to File to save the classification image to a file.

Change Class Names and Colors

  1. To change the class color or name select Options > Edit class colors/names. The Class Color Map Editing dialog appears.
  2. Select a class name in the Selected Classes list and select from the following options:
    • To change the class name, enter the new name in the Class Name field.
    • To change the class color, select a color system and/or color using the Color button. To further adjust the color, use the slider bars.

Reorder Classes

If two classes have the same rule value, the first one in the list will be used to make the output classification image.

  1. To reorder the classes, selecting Options > Reorder Classes. The Reorder Classes dialog appears with the class names displayed in a list.
  2. Click on a class name and drag it to the desired location in the list.
  3. Click OK.

Calculate Statistics

To calculate statistics for each On rule band, select Options > Stats for Selected Rule Bands. The band minimum, maximum, mean, and standard deviation display in the Statistics Results window.

To save the report as an ASCII file, select File > Save Text to ASCII in the report window.

Turn Rule Bands On/Off

To select all of the rule band check boxes without having to click on each one, select Options > Select All Rule Bands, or Options > Clear All Rule Bands.

Save the Classification Image

To save the displayed classification image to a file, click Save To File and enter or choose an output filename.



© 2019 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us