>  Docs Center  >  Using IDL  >  The IDL Development Environment - Overview
IDL

The IDL Development Environment - Overview

IDL Workbench Overview

The IDL Workbench provides IDL editing and debugging tools in a user interface (UI) format.

The Workbench UI is based on the Eclipse open-source framework (http://www.eclipse.org). For documentation about the underlying Eclipse Environment, see https://help.eclipse.org. Some of the Eclipse Development Environment has been customized for IDL; therefore, some menu items and functions may differ from those documented by Eclipse and are documented in these sections:

You can also install additional Eclipse plug-ins to the IDL Workbench. See Install the Marketplace Client and Plug-ins for instructions.

Change the Workbench Theme


The default IDL Workbench theme is a light background with dark text; however, you can change the IDL Workbench to use a dark theme with light text. After you change the theme, you will need to restart IDL.

To change the theme:

  1. From the main menu, select Window > Preferences > General > Appearance.
  2. In the Appearance dialog, select the Theme from the drop-down list.
  3. Click Apply and Close. You will need to restart IDL, which is described next.
  4. From the main menu, select File > Restart to restart IDL and apply the new theme to the Workbench.

If you select a theme and find that code syntax colors are difficult to see with the new theme, you can apply a different syntax color scheme as follows:

  1. From the main menu, select Windows > Preferences > IDL > Syntax Coloring.
  2. In the Syntax Coloring dialog, click Restore Defaults.
  3. Click Apply and Close. You do not need to restart IDL after you click Apply and Close.

You can find more themes to apply through the Marketplace Client. See Install the Marketplace Client and Plug-ins for steps to install the Eclipse client to the Workbench.

Set IDL Workbench Internationalization


When you start the IDL Workbench, Java automatically detects your location and uses it to set the language for the IDL Workbench UI.

You can also set the language in the idlde.ini file, under -vmargs, as follows:

-vmargs
-Duser.language=it

Example values for language can be found at https://www.oracle.com/java/technologies/javase/locales.html#translation.

IDL comes with language translations only for its plug-ins. You will need to download the language packs for the remainder of Eclipse. The Install New Software tool will install the required language support for the remaining plug-ins being used by the IDL Workbench. Note that installing multiple language packs will slow down the Workbench start-up process, so it is best to pick one.

To install a language:

  1. Select Help > Install New Software from the IDL Workbench main menu.
  2. From the Work with: drop-down list, select Babel Language Pack Metadata Repository.
  3. All the available language packs appear.
  4. Enable the check box for your language selection, then click Next.
  5. Follow the prompts to complete the installation wizard.
  6. Restart the IDL Workbench when prompted.

Java will detect the machine’s locale, and Eclipse will use the appropriate language pack.

Optionally, specify the language in the idlde.ini file, as detailed above.

Dock and Undock Views


The tabs for the Workspace Views can be moved and docked to different locations in the Workbench, and they can be undocked from the Workbench UI and placed elsewhere on your monitor or on a separate monitor. If you have moved Views around on the Workbench, or tore them off and moved them to another location on your monitor, return them to their starting positions by clicking Window > Perspective > Reset Perspective from the main menu.

If you have minimized a view, use one of the following to maximize the view:

Press Ctrl+M to maximize or restore it. Double-clicking on the View tab also restores the view. Or, you can minimize and maximize views from the Window > Appearance menu.



© 2020 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us