>  Docs Center  >  Using ENVI  >  Preferences
ENVI

Preferences

Preferences

You can set preferences to change the behavior of different properties in ENVI.

  1. To edit your preferences, select File > Preferences from the menu bar. The Preferences dialog appears.
  2. Select the preference you want to edit from the Settings tree. The right side of the dialog shows the settings available for the preference you select. Each preference category displays a Name and Description field, which are not editable.
  3. Edit the preferences as desired, then click OK to save the changes to the envi_preferences.json file in the preferences directory of the application user directory.

To edit Yes/No fields or other fields with drop-down lists, double-click in the field and select your preference. To revert to your previously saved changes, click Restore Defaults.

You can also write a script to edit your preferences, using the ENVIPreferences and ENVIPreferenceItem objects. The API Name column in the tables below refers to the preference name in ENVIPreferenceItem.

See the following sections for more information:

Application Preferences


Option

Description

API Name

application

Enable System Logging

Enable or disable system logging. The default is No. If this field is set to Yes, ENVI saves an ASCII log of error messages named systemlog.txt in your preferences directory. The default location on Windows operating systems is C:\Documents and Settings\user\.idl\envi\preferences_5_x.

The log file is overwritten with each new ENVI session.

enable system logging

Display Errors On Screen

Enable or disable display of error messages. The default is Yes, causing error messages to be displayed. Setting this preference to No suppresses the display of error messages received during operation.

If the Enable System Logging preference is set to Yes, the errors will be written to the application system log. If both the Display Errors on Screen and Enable System Logging preferences are set to No, then the errors will appear at the IDL console.

display errors on screen

Restore Messages

Some ENVI dialogs have a "Do not ask me again" option in cases where you repeatedly select the same button and do not want to be prompted each time. If you select this option for one or more dialogs but later decide that you need them, click in the Restore Messages preference.

do not show again dialogs

Icon Size

Use this preference to adjust the size of icons in the ENVI application. If it is set to Automatic (default), ENVI checks your system's default font size and resizes icons accordingly. Other choices are as follows:

  • Original - 100%: Icons display at their original size.
  • Medium - 140%: Icons display at 140% of their original size.

icon size

Processing Tile Size

When processing a raster, ENVI breaks it down into chunks or tiles. Use this preference to adjust the size of the tile in Megabytes. Changing this value may effect the speed of certain processes in ENVI.

processing tile size

Data Manager Preferences


These preferences immediately take effect on all subsequent actions without requiring you to restart ENVI.

Option

Description

API Name

data manager

Auto Display Files On Open

Enable or disable automatically loading the selected file in the current Image window view upon file open. The default is Yes.

No disables automatically loading the selected file. If you set the Launch Data Manager After File/Open preference to Always or If file not Auto-Displayed, the Data Manager appears and you can display the image from there.

auto display on open

Auto Display Method for Multispectral Files

The method for automatically displaying multispectral files. The choices are Yes Color (default) and CIR (color infrared). These settings only apply if the image file contains wavelength information.

multispectral auto display

Clear View when Loading New Image

Enable or disable clearing all layers from the active view and the tree for that view in the Layer Manager when you display a new image. The default is No, meaning ENVI continues to display all current layers when you display a new image. If this field is set to Yes, all layers are removed when a new layer is loaded, but the existing files remain open in the Data Manager.

clear display when loading new image

Launch Data Manager at Startup

Enable or disable opening the Data Manager when you start ENVI.

If this field is set to No, open the Data Manager as needed by selecting File > Data Manager from the menu bar or by clicking the Data Manager button.

launch when envi launches

Launch Data Manager after Opening File

The method for showing the Data Manager. The choices are as follows:

  • Never: Do not automatically open the Data Manager for any file-open instance.
  • If file not Auto-Displayed (default): Open the Data Manager when the Auto Display Files on Open value is No.
  • Always: Open the Data Manager every time a file is opened.

launch after open

Close Data Manager after Loading New Data

The default value is No. Set this preference to Yes if you want the Data Manager to close after loading a file to the Layer Manager. This preference only applies when you right-click a filename in the Data Manager and select a Load... option.

close after loading data

Load File after Chip or Save

Enable or disable whether chipped or saved output is automatically added to the Data Manager upon file save. The default is Yes.

If you set this preference to No, output is saved to disk but not added to the Data Manager.

load file after chip or save

Directories Preferences


Most of these preferences immediately take effect on all subsequent actions without requiring you to restart ENVI. The exceptions are Extensions Directory and Custom Code Directory; you must restart ENVI for these two preferences to take effect.

Option

Description

API Name

directories

Remember Input/Output Directories

If this preference is set to Yes (the default), ENVI will remember the last directory where you selected input files and will update the Input Directory preference accordingly. It will also remember the last directory where you saved any output files and will update the Output Directory preference. If you set this preference to No, the Input Directory and Output Directory preference values will be fixed.

remember directories

Input Directory

The directory for input images. ENVI uses this directory unless you specify another path when opening a file.

input directory

Output Directory

The directory for output files. ENVI writes output files to this directory unless you specify another path when entering an output filename.

output directory

Temporary Directory

The directory used to store ENVI temporary files.

temporary directory

Auxiliary File Directory

The directory for auxiliary files such as header files (.hdr), pyramid files (.enp), vector symbology files, and vector auxiliary files.

This directory contains auxiliary files associated with data from read-only devices such as a CDs or folders with no write permissions. ENVI typically stores auxiliary files in the same directory as the input image or shapefile; however, when that directory is read-only, ENVI writes to the auxiliary file directory. When opening a file, if ENVI is unable to locate a corresponding auxiliary file, it looks in the auxiliary file directory.

If the Store Pyramids Locally preference is set to Yes, those pyramids will be stored in the auxiliary file directory.

auxiliary file directory

Extensions Directory

This directory is searched on ENVI application launch to find extensions that should be added to the Toolbox. This folder should not contain any .pro or .sav files that are not Toolbox extensions.

See Write and Depoly Toolbox Extensions for a discussion of all the directories that are searched for ENVI Toolbox extensions.

You must restart ENVI for this preference to take effect.

extensions directory

Custom Code Directory

The directory is searched on ENVI application launch to find custom file readers and custom tasks.

You must restart ENVI for this preference to take effect with custom file readers.

custom code directory

Spectral Library User Directory

The directory for input and output spectral libraries. ENVI uses this directory unless you specify another path when opening or saving a spectral library. speclib user directory

Display General Preferences


These preferences immediately take effect on all subsequent actions without requiring you to restart ENVI.

Option

Description

API Name

display general

Default Stretch for 8-bit Imagery

The default stretch type to use when displaying byte data (pixel values of 0 to 255). By default, no stretching will be performed on this data type. If the default stretch field is defined in an accompanying ENVI file (.hdr), that value will take precedence over this preference setting.

default 8 bit stretch

Default Stretch for 16-bit UInt Imagery

The default stretch type to use when displaying 16-bit unsigned-integer data. The default value is Optimized Linear. If the default stretch field is defined in an accompanying ENVI file (.hdr), that value will take precedence over this preference setting.

default 16 bit stretch

Default Stretch for All Other Imagery

The default stretch type to use when displaying image data that are not byte or 16-bit unsigned integers. The default value is Linear 2%. If the default stretch field is defined in an accompanying ENVI file (.hdr), that value will take precedence over this preference setting.

default other stretch

Zoom Factor

The zoom factor to use when you zoom in or out of the image. The default is 1.25.

zoom factor

Default Selection Color

The default color to use to highlight the current selection. This color appears as a border when you select layers, as a border to an open Portal, and when you select vectors or annotations to edit. The default is (0,192,192).

selection color

Zoom Interpolation Method

The interpolation method to use when zooming on raster layers. This preference takes effect for any new layers that you create. Interpolation behavior may vary, depending on the method you choose, and whether the Use Graphics Card to Accelerate Enhancement Tools preference is enabled. Variations are noted in the following descriptions. The choices are as follows:

  • Nearest Neighbor: (default) Each pixel in the displayed image receives its value from the nearest pixel in the input (reference) image. If the Use Graphics Card to Accelerate Enhancement Tools preference is enabled, brightness, contrast, and sharpen filters are performed by the GPU,
  • Bilinear: Each estimated pixel value in the displayed image is based on a weighted average of the four nearest neighboring pixels in the input image. Not all GPUs support bilinear interpolation of floating point textures; therefore, if Use Graphics Card to Accelerate Enhancement Tools is enabled, the setting is ignored and brightness, contrast, and sharpen filters are performed by the CPU.
  • Bicubic: Each estimated pixel value in the displayed image is based on a weighted average of the sixteen nearest pixels in the input image. If Use Graphics Card to Accelerate Enhancement Tools is enabled, the setting is ignored and brightness, contrast, and sharpen filters are performed by the CPU. If your graphics processing unit (GPU) does not support OpenGL Shader Language (GLSL), the Nearest Neighbor interpolation method is used instead.
  • Optimized Bicubic: Each estimated pixel value in the displayed image is based on a weighted average of the sixteen nearest pixels in the input image. The weighting coefficients are improved over standard Bicubic. If Use Graphics Card to Accelerate Enhancement Tools is enabled, the setting is ignored and brightness, contrast, and sharpen filters are performed by the CPU. If your graphics processing unit (GPU) does not support OpenGL Shader Langauge (GLSL), the Nearest Neighbor interpolation method is used instead.

To use Bicubic and Optimized Bicubic:

  • Your graphics card must support OpenGL 2.0 or higher, and you must have the most recent drivers installed.
  • The displayed image must not be palettized.

Portals behave differently; they try to match the interpolation value of the target layer, regardless of the current preference setting.

zoom interpolation method

Use Low Resolution Tile Cache

For images with very high spatial resolution, ENVI displays low-resolution tiles in the Image window view while it retrieves the full-resolution data (if this preference is set to Yes, the default). If you have a slow processor, you may set this preference to No, which should improve display performance. If you set this preference to No, nothing is visible in the Image window view until ENVI loads each tile.

use low resolution tile cache

Use Graphics Card to Accelerate Enhancement Tools

The default setting of Yes accelerates raster operations, such as image stretching, sharpening, brightness, contrast, and so forth, using your computer’s graphics processing card (GPU) instead of your computer’s central processing unit (CPU). All of the following criteria must be met for this preference to be effective:

  • Your graphics card must support OpenGL 2.0 and must have the most recent drivers installed.
  • You must set the Zoom Interpolation Method preference to Nearest Neighbor.
  • The image data type must be byte, integer, unsigned integer, or floating-point.
  • Your platform must be Windows or Linux.

Some ENVI features take advantage of graphics hardware that supports the OpenGL 2.0 interface to improve rendering performance, if such hardware is present. Your video card should support OpenGL 2.0 or higher to take advantage of the graphics features ENVI. Be sure to update your video card drivers with the most recent version, and set the preference Use Graphics Card to Accelerate Enhancement Tools to Yes.

use graphics card accelerator

Report MGRS Location in Cursor Value

Set this preference to Yes (the default) to report Military Grid Reference System (MGRS) coordinates in the Cursor Value dialog.

report mgrs in cursor value

Data Precision in Cursor Value

The number of decimal places of precision to report floating-point pixel values. The default value is 1. The maximum value is 10.

data notation in cursor value

Data Notation in Cursor Value

Set this preference to Float (the default) to report pixel values in floating-point decimals. Set it to Scientific to report pixel values in scientific notation.

 

Status Bar Left/Center/Right Segment

The information to display in the first three segments of the Status bar. The file must have either map information and/or NITF metadata associated with it for the information to display in the Status bar. When you customize the Status bar contents using this method, the Status bar retains the information for subsequent ENVI sessions. You can temporarily set the information for each segment by right-clicking on the Status Bar segments. See Status Bar for details. The Status Bar displays information for the base layer in the Layer Manager.

The choices for all three Status bar segments are as follows:

  • Lat/Lon Degrees Minutes Seconds: Latitude and longitude coordinates relative to the cursor location, in degrees/minutes/seconds format. For example, Lat: 40°5'15.92"N, Lon: 105°21'32.83"W.
  • Lat/Lon Decimal Degrees: Latitude and longitude coordinates relative to the cursor location, in decimal degrees format. For example, Lat: 40.0866N, Lon: 105.3524W.
  • Current Projection: The current map projection type, zone, and datum. For example, UTM, Zone 13 North, NAD 27.
  • Map Coordinates: The map coordinates relative to the cursor location. For example, Map X: 471424.0000, Map Y: 4437999.0000.
  • NITF Security Banner: The NITF classification level of the image. The classification levels are Unclassified, Top Secret, Secret, Confidential, and Restricted.
  • NITF Acquisition time: The image date and time of acquisition, shown as MMM DD, YYYY hh:mm:ss format. For example, JAN 17, 2006 14:23:12.
  • Military Grid Reference System (MGRS): The number consists of the grid zone designator, (GZD), the 100,000-meter square identifier, and the numerical location.
  • Raster Data Values: The pixel values for the top-most raster layer in the Layer Manager.
  • Pixel Coordinates: The file (pixel) x,y coordinates relative to the cursor location.
  • Blank: No display.

status bar segment 1

status bar segment 2

status bar segment 3

Mensuration Distance Units

The default distance measurement units for the Mensuration and Region of Interest tools. The default is meters. If the tools are being used on a non-georeferenced image, the Cursor Value window reports the units in pixels.

mensuration distance units

Mensuration Area Units

The default area measurement units for the Region of Interest tool. The default is Units2. If the tool is being used on a non-georeferenced image, the Cursor Value window reports the units in pixels.

mensuration area units

Geographic Coordinate Format

The default format for geographic coordinate information in the Cursor Value window. The default is Degrees, Minutes, Seconds. Alternatively, you can choose to display the geographic location in Decimal Degrees.

geographic coordinate format

Base Projection for Non-Standard Rasters

The default standard base projection to use when two or more images with non-standard map information (RPC, Pseudo, etc.) will be displayed in a view. The values are Geographic (the default) or UTM.

base projection for non-standard

Middle Mouse Action

The tool to use when you click and drag the middle mouse button in the Image window view. The choices are the Pan tool or the Fly tool. The default is Pan.

middle mouse action

Mouse Wheel Behavior

The direction of the zoom (in or out) associated with a mouse wheel rotation (forward/backward). The default is Forward->Zoom In, Back->Zoom Out.

mouse wheel behavior

Maximum Time Series Frame Buffer Size

The maximum number of images that will be considered for loading into a frame buffer to achieve fast animation performance. If a data series contains more images than this value, then none of those images will be cached and animation performance will be constant from the start. Setting this value to 0 will turn off this limit.

max time series frame buffer size

North Arrow Preferences


These preferences immediately take effect on all subsequent actions without requiring you to restart ENVI.

Option

Description

API Name

north arrow

Show North Arrow

Set this preference to Yes (the default) to automatically display a north arrow on georeferenced images.

show north arrow

North Arrow Font

Select a font family or list of symbols. The default selection is ENVI Symbols. If you have ArcGIS® software installed, the ESRI North font offers a larger choice of symbols.

font

North Arrow Symbol

Select a symbol to represent the north arrow. The list of available symbols depends on the North Arrow Font selection.

symbol

North Arrow Size

Select a font size. The size of the north arrow will not change when you zoom in or out of the display.

size

North Arrow Location

Select the location of the north arrow in the display. The choices are Upper Left Corner, Upper Right Corner (default), Lower Left Corner, and Lower Right Corner.

location

North Arrow Foreground Color

Select a color for the font or symbol.

color

Fill North Arrow Background

Select Yes to fill the font/symbol background with a color, then use the North Arrow Background Color preference to select a color. Or, select No to make the font/symbol background transparent.

fill background

North Arrow Background Color

If you selected Yes for the Fill North Arrow Background preference, choose a background fill color.

background color

Overview Preferences


These preferences immediately take effect on all subsequent actions without requiring you to restart ENVI.

Option

Description

API Name

overview

Default Border Color

The default color of the Overview border. The default is magenta (255,0,255).

border color

Show Snail Trail

If this preference is set to Yes (default), the snail trail is shown in the Overview. The snail trail highlights, in yellow, areas you have viewed in the Image window.

show snail trail

Plots Preferences


Close and re-open any Profiles or Plots to enable the preference changes. These preferences do not require you to restart ENVI.

Option

Description

API Name

plots

X Size

The width of the plot window. The default is 400.

plot x size

Y Size

The height of the plot window. The default is 280.

plot y size

Left Margin

The left margin to offset the plot display within the plot window. The default is 0.

left margin

Right Margin

The right margin to offset the plot display within the plot window. The default is 0.

right margin

Top Margin

The top margin to offset the plot display within the plot window. The default is 0.

top margin

Bottom Margin

The bottom margin to offset the plot display within the plot window. The default is 0.

bottom margin

X Major Ticks

The number of major tick marks to show on the X-axis for plots, and the histograms for ROI Threshold and Raster Color Slice. Set to -1 to auto-compute. Set to 0 to suppress. The default is -1.

x major ticks

Y Major Ticks

The number of major tick marks to show on the Y-axis for plots, and the histograms for ROI Threshold and Raster Color Slice. Set to -1 to auto-compute. Set to 0 to suppress. The default is -1.

y major ticks

Font Name

The font type for plot text. The default is Calibri.

font

Font Size

The font size for plot text. The default is 12 point.

font size

Background Color

The background color for plots, and the histograms for ROI Threshold and Raster Color Slice. The default is 240,240,240, which is the same color as the ENVI widgets. If the background is 0,0,0 (black) and the foreground is 255,255,255 (white), the colors will be reversed for printing.

plot background color

Foreground Color

The plot foreground color for plots, and the histograms for ROI Threshold and Raster Color Slice. The default is 0,0,0 (black). If the background is 0,0,0 (black) and the foreground is 255,255,255 (white), the colors will be reversed for printing.

plot foreground color

Line Thickness

The thickness for the plot lines. The default is 1 point.

line thickness

Line Style

The style for plot lines, with choices ranging from a solid line, to different dashed or dotted lines. The default is a solid line.

line style

Symbol

Select a symbol style to display a symbol on the peaks and valleys of the plot. The default is No symbol.

symbol

Symbol Color

The symbol color, if symbols are enabled. The default is 0,0,0 (black).

symbol color

Symbol Size

The symbol size, if symbols are enabled. The default is 2 points.

symbol size

Legend Style

The style for the legend that precedes the spectrum name. Solid boxes show as a filled box style, Flat lines show as a long dash, Spike lines show as a line with two peaks, and Sparklines are reduced versions of the actual plots, where the shape of the lines mimics the actual plot data. The default is Sparklines.

legend style

Profile Cursor Color

When you click a pixel to add it to a profile, the cursor style changes to a box. Use this setting to change the profile cursor color. The default is 255,255,255 (white).

profile cursor color

Series Profile Maximum Index Size

The maximum number of data set indices sampled when creating a time series profile plot. The default is 100. Setting the value to 0 disables this limit.  

Pyramids Preferences


These preferences immediately take effect on all subsequent actions without requiring you to restart ENVI.

Option

Description

API Name

pyramids

Create Pyramid If None Exists

Create and use pyramid files to speed up the display of large images. Pyramid files are copies of the image at various reduced resolutions; they are displayed instead of the full-resolution image at different zoom levels. See Pyramids Background for more information.

Select an option from the drop-down list:

  • Always: Always create a pyramid file when opening a raster.
  • Never: Never create a pyramid file when opening a raster.
  • 10 bands or fewer: Create a pyramid file when opening a raster that has 10 bands or fewer.
  • 25 bands or fewer (default): Create a pyramid file when opening a raster that has 25 bands or fewer.
  • 50 bands or fewer: Create a pyramid file when opening a raster that has 50 bands or fewer.
  • 100 bands or fewer: Create a pyramid file when opening a raster that has 100 bands or fewer.

create pyramid if none exists

Optimize Display Performance (uses more disk space)

This preference is available for editing when the Create Pyramid If None Exists preference is set to Yes.

The default value is No, which means that you will save disk space when displaying ENVI, TIFF, and NITF images because you are not creating a full-resolution pyramid file; however, the display will be slower.

If you set this preference to Yes, a pyramid file will be created for the full-resolution zoom level that will improve display performance.

Full-resolution pyramids are always built for the following data formats, regardless of this preference setting:

  • Raster datasets in an ArcGIS® geodatabase
  • Custom file readers

Pyramids are never built for the following formats:

  • JPEG2000 files
  • MrSID
  • NITF 2.1 C8 compressed files
  • Remote datasets from OGC servers or Esri® image services

include full resolution

Copy Pyramids Locally

If this preference is set to Yes (default), pyramid files will be copied to your local hard drive if they already exist on a network server for a given image.

copy pyramids locally

Remote Connectivity Preferences


These preferences immediately take effect on all subsequent actions without requiring you to restart ENVI.

Option

Description

API Name

remote connectivity

OGC Proxy Server

A proxy server sits between your computer and remote servers to which you connect. If you consistently have trouble connecting to remote servers, you may have a proxy server installed. Contact your system administrator for details, then enter the server name in the OGC Proxy Server field. This field is blank by default. ENVI does not attempt to connect through a proxy server, unless you specify one. JPIP/IAS servers do not support proxy servers.

proxy server

OGC Proxy Port

The port number through which the proxy server connects to the Internet. The default is 80.

proxy port

Recent Datasets to Remember

The number of datasets to maintain in the Recent Dataset List in the File > Open Remote Dataset menu option. The default is 16.

number of recent datasets

WMS Pixels Per Side

The number of pixels to use as the default setting for the greater of the width or height within a WMS layer. The default is 10000.

wms pixel size

ArcGIS JavaScript API URL

 

arcgis script url

Default ArcGIS Basemap

 

default basemap

Reference Map Outline Color

 

reference map outline color

OpenStreetMap Overpass API URL

The URI for the Overpass API server, used to query OpenStreetMap vector data. The default value is lz4.overpass-api.de/api/interpreter.

osm overpass url

Esri License Type

This preference is for ENVI 32-bit only:

Set this preference to the type of Esri® license you currently have. The choices are Unknown (default), ArcInfo, ArcView, or ArcEditor. Setting this preference to a specific Esri license type speeds up performance because ENVI will skip the license check when you read or export to a geodatabase, or when you interact with ArcMap™ software. You can find the license type installed on your computer by selecting Help > About ArcMap from the ArcMap software menu bar.

esri license type

Printing Preferences


These preferences are for ENVI 32-bit only. The preferences immediately take effect on all subsequent actions without requiring you to restart ENVI.

Option

Description

API Name

printing

Default Map Template

Change the default template. By default, the Print Layout will be displayed in the ArcMap™ Normal template. (Normal.mxt). If the Preferences point to an invalid template, a warning message will be displayed the next time the Print Layout view is initialized.

default template

Map Template Directory

Change the default map template directory. The default template directory specifies the initial browse location of the dialog used to select a map template (see previous description). If the Preferences point to an invalid directory, a warning message will be displayed the next time the Print Layout view is initialized. See also Map Template.

template directory

Reference Scale

The scale unit at which symbols will appear in the data frame, specified in map units. The Reference Scale sizes text and symbols along with the display. Without a Reference Scale, symbols and text will remain the same at all map scales, even if the extent is changed. The default is 0 (no Reference Scale).

default

Annotations Preferences


You can set preferences for the different annotation types before adding them to the Image window view. These preferences immediately take effect on all subsequent actions without requiring you to restart ENVI.

Text Annotation Preferences 

Option

Description

API Name

annotations:text

Color

The annotation text color. The default is red (255,0,0).

color

Font

The font type to use for text annotations. The fonts that are installed on your system are available from the drop-down list. The default is Helvetica.

font

Font Style

The font style to apply to text annotations. The default is Normal.

font style

Font Size

The font size for text annotations. The default is 16 points.

font size

Horizontal Alignment

The horizontal alignment for text annotations. The default is Left.

horizontal alignment

Fill Background

Enable or disable using a background fill color for text annotations. The default is No.

fill background

Background Color

If the Background Fill setting is Yes, specify the color to use for the text annotation background. The default is black (0,0,0).

background color

Scale On Zoom

Enables or disables scaling the text annotation size according to the zoom level. If set to Yes (default), the item's size increases or decreases accordingly when the zoom level increases or decreases. If set to No, the item's size remains the same, regardless of the zoom level.

 

Symbol Annotation Preferences 

Option

Description

API Name

annotations:symbol

Color

The annotation symbol color. The default is red (255,0,0).

color

Font

The font type to use for symbols. The fonts that are installed on your system are available from the drop-down list. The default is Symbol.

font

Font Size

The font size for the symbols. The default is 24 points.

font size

Symbol Character

The symbol character to use. Click in this field and select Edit to open a dialog containing symbol choices. The default is ASCII 197.

symbol character

Fill Background

Enable or disable using a background fill color for the symbol. The default is No.

fill background

Background Color

If the Symbol Background Fill setting is Yes, specify the color to use for the symbol background. The default is black (0,0,0).

background color

Scale On Zoom

Enables or disables scaling the symbol annotation size according to the zoom level. If set to Yes (default), the item's size increases or decreases accordingly when the zoom level increases or decreases. If set to No, the item's size remains the same, regardless of the zoom level.

scale on zoom

Arrow Annotation Preferences 

Option

Description

API Name

annotations:arrow

Line Color

The line color for annotation arrows. The default is red (255,0,0).

line color

Line Style

The line style for annotation arrows. Style choices range from no line to solid, dashed, or dotted lines. The default is a solid line.

line style

Line Thickness

The line thickness for annotation arrows. The default is 3.

line thickness

Arrow Head size

The size of the annotation arrow heads, in points. The default is 25.

arrowhead size

Arrow Head Angle

The angle, in degrees, of the annotation arrow heads. The default is 30 degrees.

arrowhead angle

Arrow Head Fill Interior

The arrow head fill interior, either None or Solid. The default is Solid.

arrowhead fill

Polygon Annotation Preferences 

Option

Description

API Name

annotations:polygon

Show Outline

Enable or disable showing the outline of the polygon. The default is Yes.

show outline

Line Color

The line color for polygon annotations. The default is red (255,0,0).

line color

Line Style

The line style for polygon annotations. Style choices range from no line to solid, dashed, or dotted lines. The default is a solid line.

line style

Line Thickness

The line thickness for polygon annotations. The default is 3.

line thickness

Fill Interior

The polygon fill interior, either None or Solid. The default is None.

fill mode

Fill Color

If the Polygon Fill Interior setting is Yes, specify the color to use for the polygon background. The default is red (255,0,0).

fill color

Polyline Annotation Preferences 

Option

Description

API Name

annotations:polyline

Line Color

The line color for polyline annotations. The default is red (255,0,0).

line color

Line Style

The line style for polyline annotations. Style choices range from no line to solid, dashed, or dotted lines. The default is a solid line.

line style

Line Thickness

The line thickness for polyline annotations. The default is 3.

line thickness

Picture Annotation Preferences 

Option

Description

API Name

annotations:picture

Maximum Picture Dimension

The maximum dimension to allow for a picture annotation. The default is 512 pixels.

maximum image dimension

Legend Annotation Preferences

Option

Description

API Name

annotations:legend

Columns

The number of columns in the legend. The default value is 1.

columns

Color Bar Preferences

Option

Description

API Name

annotations:color bar

Number of Labels

The number of labels at the bottom of the color bar. The default value is 3.

labels

Label Precision

The numeric precision of the labels at the bottom of the color bar. The default value is 2 digits.

precision

Length

The length of the color bar. The default value is 256 pixels.

length

Width

The width of the color bar. The default value is 25 pixels.

width

Orientation

The orientation of the color bar. The default value is Horizontal (left to right).

orientation

Scale Bar Preferences

Option

Description

API Name

annotations:scale bar

Segments

The number of segments in the scale bar. The default value is 4.

segments

Height

The height of the scale bar. The default value is 15 pixels.

height

Grid Lines Annotation Preferences

Option

Description

API Name

annotations:grid lines

Text Orientation X-Axis

The orientation of coordinate labels along the x-axis. The default is Horizontal.

text orientation x-axis (0=horizontal, 1=vertical)

Text Orientation Y-Axis

The orientation of coordinate labels along the y-axis. The default is Vertical.

text orientation y-axis (0=horizontal, 1=vertical)

Text Offset

The distance (in pixels) between coordinate labels and their grid lines.

text offset

Geographic Format

The format for displaying coordinates when the grid represents a geographic coordinate system. The choices are Degrees, Minutes, Seconds (default), Degrees (in decimals), and Degrees, Minutes.

geographic format

Geographic Precision

The number of decimal places to display for any Geographic Format setting.

geographic precision

Grid Color

The color of the inner grid lines. The default is black (0,0,0).

grid color

Grid Thickness

The line thickness of the inner grid lines, in pixels. The default is 1 pixel.

grid thickness

Grid Linestyle

The line style of the inner grid lines. The default is a solid line.

grid linestyle

Intersection Symbol Size

The size of the crosshairs where grid lines intersect, in pixels. The default is 5 pixels.

intersection symbol size

Show Grid Lines

Choose whether to show inner grid lines. The default is Yes.

show grid lines

Show Intersections

Choose whether to show grid line intersections. The default is Yes.

show intersections

Show Bounding Box

Choose whether to show a bounding box on the outside edge of the grid. The default is Yes.

show bounding box

NITF Preferences


These preferences immediately take effect on all subsequent actions without requiring you to restart ENVI.

NITF General Preferences 

Option

Description

API Name

nitf:nitf general

NITF File Cache Size

The cache size for the NITF image. The default is 256 MB.

nitf cache size

Automatically View Metadata

Enable or disable automatically displaying the NITF Metadata Viewer dialog when you open a NITF file. The default is No.

autoview nitf metadata

Suppress Input Warning Messages

Enable or disable showing NITF input warning messages when opening a NITF file. The default is Yes.

suppress input warning messages

Originating Station ID

The station ID of the organization in which the image originated. If you enter your own value, that value will be used in the output file. If this preference field is initially empty, the software populates it with ENVI. Set this preference field to NO CHANGE (all uppercase) if you want the software to pass through the input value with no change.

originating station id

Originator’s Name

The name of the image’s originator. If this preference field is initially empty, it remains empty in the output file. If you enter your own value, that value will be used in the output file. Set this preference field to NO CHANGE (all uppercase) if you want the software to pass through the input value with no change.

originator name

Originator’s Phone Number

The telephone number of the image’s originator. If this preference field is initially empty, it remains empty in the output file. If you enter your own value, that value will be used in the output file. Set this preference field to NO CHANGE (all uppercase) if you want the software to pass through the input value with no change.

originator phone number

File Title Chip Prefix

The prefix to add to the File Title metadata if you save a spatial subset. The default is Chip_hhmmss_of_, where the hour (hh), minute (mm), and second (ss) reflect the time that you create the subset. If you remove this default value and enter your own text, the software appends your text to the filename.

file title chip prefix

IID2 Chip Suffix

The suffix to add to the IID2 field that indicates the output file contains chipped images (NITF 2.1 only). The default value is _CHIP. If the original IID2 field plus the IID2 Chip Suffix field is larger than 80 characters, the IID2 Chip Suffix field will be truncated.

iid2 chip suffix

HISTOA Processing Site

The name of the company who performed the processing event. Enter up to 10 characters of text. This preference fills in the PSITE field of the HISTOA Processing Site.

histoa processing site

Pass through NITF C8 ABPP

If set to Yes, ENVI will pass through the bits per pixel (ABPP) if you chip a NITF C8 image. Instead of creating new NITF C8 statistics (ABPP, NBPP, HISTOA:OBPP, and SOC::SIZ::Ssiz) from a chipped image, ENVI will pass them through from the original NITF file. The default setting is No.

pass through nitf c8 app

NITF File Settings Preferences

This section of NITF preferences contains NITF file metadata defaults. These preferences apply when you save a non-NITF file to NITF format using Save As. Descriptions of the NITF file metadata fields are available in the NITF specification documents MIL-STD-2500B or MIL-STD-2500A.

NITF 2.1 and NSIF 1.0 Files

Option

API Name

nitf:nitf file settings

NITF Version

nitf version

File Background Color

file fbkgc

Text ID

nitf text id

Text Title

nitf text itl

Security Classification

security classification

Security Classification System

security sclsy

Security Codewords

security scode

Security Control/Handling

security sctlh

Security Release Instructions

security srel

Security Declassification Type

security sdctp

Security Declassification Date

security sdcdt

Security Declassification Exemption

security sdcxm

Security Downgrade Level

security sdg0

Security Downgrade Date

security sdgdt

Security Downgrade Text

security scltx

Security Classification Authority Type

security scatp

Security Classification Authority

security scaut

Security Classification Reason

security scrsn

Security Source Date

security ssrdt

Security Control Number

security sctln

NITF 2.0 Files

Option

API Name

nitf:nitf file settings

NITF Version

nitf version

File Background Color

file fbkgc

Text ID

nitf text id

Text Title

nitf text itl

Security Classification

security classification

Security Codewords

security scode

Security Control/Handling

security sctlh

Security Release Instructions

security srel

Security Classification Authority

security scaut

Security Control Number

security sctln

Security Downgrade

security sdwng

Security Downgrade Event

security sdevt

NITF PIA TRE Metadata Preferences

This section of NITF preferences contains PIA TRE file metadata defaults. Descriptions of the PIA TRE metadata fields are in STDI-0002. These preferences only pertain to creating new PIA TREs.

Option

API Name

nitf:pia tre metadata

PIAIMC Sensor Name

piaimc sensor name

PIAIMC PIA Mission Number

piaimc piamsn num

PIAIMC Project ID Code

piaimc proj id

PIAPRD Access ID

piaprd access id

PIAPRD Access ID Unit

piaprd access unit

PIAPRD Access ID Initials

piaprd access initials

PIAPRD Product Short Name

piaprd prodsnme

PIAPRD Producer Code

piaprd producer cd

PIAPRD Keyword Repetitions

number of piaprd keywords

PIAPRD Keywords

piaprd keywords

PIATGB Target Identification

piatgb piatga id

PIATGB Target Country Code

piatgb piactry

PIATGB Target Geographic Coordinates

piatgb tgt geo

PIATGB Target Name

piatgb tgt name

Localization Preferences


You must restart ENVI for this preference setting to take effect.

Option

Description

API Name

localization

Language (ISO639-3)

Windows operating systems only:

Set this preference to an ISO 639-3 three-character language name to use for the user interface components such as menus, buttons, and messages. The default value is eng (for English).

If a localization package is available for your preferred language, then you can set this preference to that language. A localization package may include a language catalog file, translated help, and/or other related files.

You can also set an ENVI_LANGUAGE environment variable to an ISO 639-3 language name. Click the Environment Variables button under the Advanced tab of the System Properties dialog in your Windows operating system, to set its value.

If the LANGUAGE property to the ENVI object is set, the property's value will take precedence over the value of the environment variable. The environment variable value takes precedence over the Language (ISO639-3) preference setting. If the environment variable or LANGUAGE property are set to a different value than the preference, they override the preference but do not actually change the preference setting. In this case, the value listed in the Preferences dialog may not display the language that is used in the application.

language



© 2019 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us