ENVI Zoom User’s Guide
Legal
The IDL®, IDL Advanced Math and Stats™, ENVI®, ENVI Zoom™, and ENVI® EX software programs and the accompanying procedures, functions, and documentation described herein are sold under license agreement. Their use, duplication, and disclosure are subject to the restrictions stated in the license agreement. ITT Visual Information Solutions reserves the right to make changes to this document at any time and without notice.

Limitation of Warranty
ITT Visual Information Solutions makes no warranties, either express or implied, as to any matter not expressly set forth in the license agreement, including without limitation the condition of the software, merchantability, or fitness for any particular purpose. ITT Visual Information Solutions shall not be liable for any direct, consequential, or other damages suffered by the Licensee or any others resulting from use of the software packages or their documentation.

Permission to Reproduce this Manual
If you are a licensed user of these products, ITT Visual Information Solutions grants you a limited, nontransferable license to reproduce this particular document provided such copies are for your use only and are not sold or distributed to third parties. All such copies must contain the title page and this notice page in their entirety.

Export Control Information
The software and associated documentation are subject to U.S. export controls including the United States Export Administration Regulations. The recipient is responsible for ensuring compliance with all applicable U.S. export control laws and regulations. These laws include restrictions on destinations, end users, and end use.

Acknowledgments
ENVI® and IDL® are registered trademarks of ITT Corporation, registered in the United States Patent and Trademark Office. ION™, ION Script™, ION Java™, and ENVI Zoom™ are trademarks of ITT Visual Information Solutions.
ESRI®, ArcGIS®, ArcView®, and ArcInfo® are registered trademarks of ESRI.
Portions of this work are Copyright © 2009 ESRI. All rights reserved.
PowerPoint® and Windows® are registered trademarks of Microsoft Corporation in the United States and/or other countries.
Macintosh® is a registered trademark of Apple Inc., registered in the U.S. and other countries.
UNIX® is a registered trademark of The Open Group.
Adobe Illustrator® and Adobe PDF® Print Engine are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.
Numerical Recipes™ is a trademark of Numerical Recipes Software. Numerical Recipes routines are used by permission.
GRG2™ is a trademark of Windward Technologies, Inc. The GRG2 software for nonlinear optimization is used by permission.
NCSA Hierarchical Data Format (HDF) Software Library and Utilities. Copyright © 1988-2001, The Board of Trustees of the University of Illinois. All rights reserved.
NCSA HDF5 (Hierarchical Data Format 5) Software Library and Utilities. Copyright © 1998-2002, by the Board of Trustees of the University of Illinois. All rights reserved.
CDF Library. Copyright © 2002, National Space Science Data Center, NASA/Goddard Space Flight Center.
SMACC. Copyright © 2000-2004, Spectral Sciences, Inc. and ITT Visual Information Solutions. All rights reserved.
This software is based in part on the work of the Independent JPEG Group.
Portions of this software are copyrighted by DataDirect Technologies, © 1991-2003.
Portions of this computer program are copyright © 1995-2008 Celartem, Inc., doing business as LizardTech. All rights reserved. MrSID is protected by U.S. Patent No. 5,710,835. Foreign Patents Pending.
Portions of this software were developed using Unisearch’s Kakadu software, for which ITT has a commercial license. Kakadu Software. Copyright © 2001. The University of New South Wales, UNSW, Sydney NSW 2052, Australia, and Unisearch Ltd, Australia.
This product includes software developed by the Apache Software Foundation (www.apache.org/).
Portions of this software are copyrighted by Merge Technologies Incorporated.
Support Vector Machine (SVM) is based on the LIBSVM library written by Chih-Chung Chang and Chih-Jen Lin (www.csie.ntu.edu.tw/~cjlin/libsvm), adapted by ITT Visual Information Solutions for remote sensing image supervised classification purposes. IDL Wavelet ToolKit Copyright © 2002, Christopher Torrence.
IMSL is a trademark of Visual Numerics, Inc. Copyright © 1970-2006 by Visual Numerics, Inc. All Rights Reserved.
Other trademarks and registered trademarks are the property of the respective trademark holders.
## Contents

<table>
<thead>
<tr>
<th>Chapter 1: Introduction to ENVI Zoom</th>
<th>.................................................................</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td>About ENVI Zoom</td>
<td></td>
<td>6</td>
</tr>
<tr>
<td>ENVI Training</td>
<td></td>
<td>7</td>
</tr>
<tr>
<td>Custom Development Services</td>
<td></td>
<td>8</td>
</tr>
<tr>
<td>ENVI Zoom Documentation</td>
<td></td>
<td>9</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 2: The ENVI Zoom Interface</th>
<th>.................................................................</th>
<th>11</th>
</tr>
</thead>
<tbody>
<tr>
<td>The ENVI Zoom Interface</td>
<td></td>
<td>12</td>
</tr>
<tr>
<td>Image Window</td>
<td></td>
<td>13</td>
</tr>
<tr>
<td>Status Bar</td>
<td></td>
<td>14</td>
</tr>
<tr>
<td>Toolbars</td>
<td></td>
<td>15</td>
</tr>
<tr>
<td>Enhancement Tools</td>
<td></td>
<td>22</td>
</tr>
<tr>
<td>Category Bars</td>
<td></td>
<td>24</td>
</tr>
<tr>
<td>Working with Layers</td>
<td></td>
<td>31</td>
</tr>
<tr>
<td>Cursor Value Window</td>
<td></td>
<td>35</td>
</tr>
<tr>
<td>Setting Preferences</td>
<td></td>
<td>38</td>
</tr>
<tr>
<td>Annotation Preferences</td>
<td></td>
<td>46</td>
</tr>
<tr>
<td>Performance Tips and Tricks</td>
<td></td>
<td>50</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 3: Opening and Displaying Data</th>
<th>.................................................................</th>
<th>51</th>
</tr>
</thead>
<tbody>
<tr>
<td>Supported File Formats</td>
<td></td>
<td>52</td>
</tr>
<tr>
<td>Opening Files in ENVI Zoom</td>
<td></td>
<td>53</td>
</tr>
<tr>
<td>Opening Files from ENVI Zoom into ENVI</td>
<td></td>
<td>55</td>
</tr>
<tr>
<td>Displaying Large Images</td>
<td></td>
<td>56</td>
</tr>
<tr>
<td>Quad Display and Data Reduction for Vector Layers</td>
<td></td>
<td>58</td>
</tr>
<tr>
<td>The Data Manager</td>
<td></td>
<td>60</td>
</tr>
<tr>
<td>Opening Remote Datasets</td>
<td></td>
<td>66</td>
</tr>
<tr>
<td>Geo Link to ArcMap</td>
<td></td>
<td>77</td>
</tr>
</tbody>
</table>

| Chapter 4: Using Portals             | ......................................................................................................................... | 79 |
Chapter 1: Introduction to ENVI Zoom

In this chapter you will find:

About ENVI Zoom ................................................................. 6
ENVI Training ................................................................. 7
Custom Development Services .............................................. 8
ENVI Zoom Documentation .................................................. 9
About ENVI Zoom

ENVI Zoom is a powerful viewer with a dynamic display that allows for rapid viewing and manipulation of remotely sensed images, vectors, and annotations. The interface provides quick access to common display tools such as contrast, brightness, sharpening, and transparency. You can work with multiple layers of data at one time and in one window, use the Data Manager and Layer Manager to keep track of multiple datasets, and “punch through” layers to view and work with another layer or layers in the same window. In addition, ENVI Zoom will reproject and resample images and vectors on-the-fly. ENVI Zoom works seamlessly with ESRI layers and feature classes, and it allows you to create professional map presentations.

ENVI Zoom also contains the robust RX Anomaly Detection, Pan Sharpening, and Vegetation Suppression tools. The RX Anomaly Detection tool detects spectral or color differences between layers and extracts unknown targets that are spectrally distinct from the image background. Use Pan Sharpening to sharpen low spatial resolution multispectral data using high spatial resolution panchromatic data. The Vegetation Suppression tool allows you to remove the vegetation spectral signature from multispectral and hyperspectral imagery.

While anyone can take advantage of the display and enhancement tools, defense imagery analysts and other military personnel will find the optional NITF support to be a valuable addition to this software product. (Contact your ITT Visual Information Solutions sales representative to purchase a NITF/NSIF Module license.)

For a list of supported platforms, see the Installation and Licensing Guide.
ENVI Training

ITT Visual Information Solutions offers training courses designed to teach users about ENVI functions. We teach regularly scheduled ENVI courses at our training facility in Boulder, Colorado. In addition, ITT Visual Information Solutions offers regional training classes every year at various locations in the United States, Europe, and Australia. For the latest training schedule, a detailed course outline, contact the ITT Visual Information Services Training group as follows:

Phone: 303-786-9900 (ask for Training)
Fax: 303-786-9909

E-mail: training@ittvis.com
Visit the Training Web page: www.ittvis.com/EventsTraining.aspx
Custom Development Services

ITT Visual Information Solutions has a team of Professional Services Group (PSG) consultants who provide custom software development, consulting services, and training to commercial, research, and government markets. The PSG team can either help you define requirements and lead your development cycle from prototyping to final installation, or they can join your project mid-stream and provide expert assistance.

Each PSG team member offers expertise in areas such as image processing; data analysis; visualization; software development; a broad range of scientific application areas; and government, civilian, defense, and intelligence community requirements. If needed, ITT Visual Information Solutions has staff with the necessary security clearances to support classified projects.

The PSG team is experienced in extending ENVI’s robust suite of user functions and batch programming capabilities, and has up-to-date knowledge on recent product enhancements and future product direction. Contact the ITT Visual Information Services Professional Services Group as follows:

Professional Services Group
ITT Visual Information Solutions
4990 Pearl East Circle
Boulder, CO 80301 USA

Phone: 303-786-9900
Fax: 303-786-9909

E-mail: sales@ittvis.com
Visit the Professional Services Group Web page: www.ittvis.com/ProductServices/
ProfessionalServices.aspx
ENVI Zoom Documentation

ENVI Zoom includes a robust, searchable Help system. From the menu bar, select Help > Contents, or click the Help button on the toolbar. Help pertaining to the step you are working on is also available from many dialogs in the application.

The application Help launches in your default web browser and is supported on Mozilla Firefox 1.x and later, Internet Explorer 5.5 and later, and Safari 1.31 and later. See the Release Notes for detailed information related to the Help tool on other browsers.

In addition to Help, the Installation and Licensing Guide details how to install and license ITT Visual Information Solutions software on your machine.

ENVI Help is a separate application from ENVI Zoom Help that describes the basics of working with ENVI. Access ENVI Help by selecting Help > Contents from the ENVI main menu bar.
Chapter 2: The ENVI Zoom Interface

In this chapter you will find:

The ENVI Zoom Interface ................................................................. 12
Image Window .................................................................................. 13
Status Bar ......................................................................................... 14
Toolbars .......................................................................................... 15
Enhancement Tools .......................................................................... 22
Category Bars .................................................................................. 24
Working with Layers ....................................................................... 31
Cursor Value Window ...................................................................... 35
Setting Preferences ......................................................................... 38
Annotation Preferences ................................................................. 46
Performance Tips and Tricks ............................................................ 50
The ENVI Zoom Interface

Following is a summary of the main components of the interface.

Menu bar

Toolbars

Category Bars
Detach from the interface by clicking or expand or collapse by clicking

Image window

Portal

Status Bar
Right-click to select the contents to display in each of the Status bar segments.

Process Manager
View and cancel actively running processes.
Image Window

The Image window displays an image at full resolution when you first load it. If the first layer loaded is a vector layer, the vector layer is scaled to fit within the Image window.

When you have a layer selected in the Layer Manager, the boundary of the selected layer is shown with a red border. The Image window resizes when you resize ENVI Zoom.

If your layer is large, the Image window displays the subsection of the image defined by the View box in the Overview window. To navigate a large image, use the Pan or Fly tools, or move the View box in the Overview window.

If your layer is relatively small, the Image window shows the full extent of the image displayed on a white canvas.

ENVI Zoom applies a default 2% linear stretch to every image loaded in the Image window.
Status Bar

The Status bar is the horizontal bar at the bottom of the ENVI Zoom interface. By default, for non-georeferenced files, the Status bar is initially blank. For georeferenced files, the Status bar displays the following information about the base layer in the Layer Manager:

- Latitude and longitude of the current location of the cursor in Degrees/Minutes/Seconds (dynamically updating as the cursor moves)
- Projection and datum

The Status bar displays information as you hover the cursor over either the Overview window or the Image window.

**Note:** The Status bar always displays information about the base layer in the Layer Manager, not about all layers loaded into the Layer Manager. For information on all layers, see "Cursor Value Window" on page 35. For more information on working with base layers, see "Base Layers" on page 28.

You can customize the information displayed in each segment of the Status bar. To change the type of information displayed in a segment, right-click in a segment and choose an option from the menu.

When you customize the Status bar contents using this method, the Status bar only retains the information for the current ENVI Zoom session. You can permanently set defaults for each segment by setting the **Status Bar Segment 1, 2, 3** preference.

Process Manager

If you are running one or more processes (for example, **File > Save As**, building pyramids, or any of the Toolbox options, the right-most segment of the Status bar displays the process name and status for the oldest running process, along with an option to cancel the process (click the **Cancel Process** button \(\times\)). When all processes finish, this segment becomes blank.

As one or more processes are running, click the **Process Description** button \(\square\) to display a window that shows the name and status of each process, and the name of the input raster images. (See image above).
Toolbars

The toolbars allow you to perform common tasks in ENVI Zoom.

Note: If the toolbars are not fully visible, increase the size of the ENVI Zoom window.

Common Tools

The most common toolbar buttons include the following (in order from left to right):

<table>
<thead>
<tr>
<th>Button</th>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="open-icon" alt="Open" /></td>
<td>Open</td>
<td>Open a supported file type.</td>
</tr>
<tr>
<td><img src="data-manager-icon" alt="Data Manager" /></td>
<td>Data Manager</td>
<td>Open the Data Manager.</td>
</tr>
<tr>
<td><img src="cursor-value-icon" alt="Cursor Value" /></td>
<td>Cursor Value</td>
<td>Open the Cursor Value window.</td>
</tr>
<tr>
<td><img src="undo-icon" alt="Undo" /></td>
<td>Undo</td>
<td>Undo the last action. You can also undo the last action by selecting Edit &gt; Undo action from the menu bar.</td>
</tr>
<tr>
<td><img src="redo-icon" alt="Redo" /></td>
<td>Redo</td>
<td>Redo the last action. You can also redo the last action by selecting Edit &gt; Redo action from the menu bar.</td>
</tr>
<tr>
<td><img src="select-icon" alt="Select" /></td>
<td>Select</td>
<td>For images: click this button to exit the Zoom, Fly, Crosshairs, Vector Edit, Pan, and Rotate tools. For vectors: click this button, then click in the Image window to select vector records in the active layer. ENVI Zoom highlights the selected vector records in cyan. If the layer has an attribute table, information about the selected vector record appears in the Cursor Value window. Use the Ctrl or Shift keys as you click to select multiple vector records. You can also click and drag to draw a box around the vector records to select. To deselect vector records, right-click and select Clear Selections. To select vector records for editing, use the Vector Edit tool.</td>
</tr>
<tr>
<td><img src="help-icon" alt="Help" /></td>
<td>Help</td>
<td>Access ENVI Zoom Help.</td>
</tr>
</tbody>
</table>
Chipping

Use the Chip to File button to create a screen capture of the image and/or vector layers displayed in the Image window. See "Chipping the Display" on page 138 for details.

Panning

You can pan your display using the middle mouse button. Click and hold the button, then drag the display in any direction. You can also use the following toolbar buttons to pan:

<table>
<thead>
<tr>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
</table>
| Pan         | Pan the display in the Image window. Place the cursor in the Image window and do one of the following:  
- Click and drag the display in any direction.  
- If your Default Middle Mouse Action preference setting is Pan, click the middle mouse button and drag the display in any direction. Panning is active when you are using the Select, Fly, Crosshairs, Vector, Feature Counting, Annotations, Rotate, or Zoom tools; you do not need to select the Pan button to activate it.  
- Click in the Image window, then press any arrow key to move 10 display pixels in the direction of the arrow. To move continuously in the direction of the arrow, hold down the arrow key.  
- Click in the Image window, press and hold the Ctrl key, then press any arrow key to move 2 display pixels in the direction of the arrow. To move continuously in the direction of the arrow, hold down the arrow key.  
- Click in the Image window, press and hold the Shift key, then press any arrow key to move 40 display pixels in the direction of the arrow. To move continuously in the direction of the arrow, hold down the arrow key.  
To exit this tool, click the Select button. |
| Fly         | Pan the display in the Image window in any direction. Place the cursor in the Image window and do one of the following:  
- Click and drag the display in the direction of the cursor arrow. To interactively change the panning direction, move the cursor around on the display.  
- If your Default Middle Mouse Action preference setting is Fly, click and hold the middle mouse button and drag the display in the direction of the cursor arrow. Flying is active when you are using the Select, Pan, Crosshairs, Vector, Feature Counting, Annotations, Rotate, or Zoom tools; you do not need to select the Fly button to activate it.  
To exit this tool, click the Select button. |

Crosshairs
Use the **Crosshairs** button to overlay crosshairs on the Image window. The Cursor Value window automatically opens when you enable Crosshairs. As you move the cursor around the Image window, the Cursor Value window displays information about the data under the crosshairs. If using crosshairs on a vector layer, be sure that any layer modifications are saved, to provide the most accurate data. You can do the following with crosshairs:

- Click anywhere in the Image window to move the crosshairs over the clicked pixel (for images), or over the nearest vertex (for vectors).
- Double-click anywhere in the Image window to center the crosshairs in the Image window over the clicked pixel (for images), or over the nearest vertex (for vectors).
- For images: Click and drag the crosshairs to a pixel. Release the mouse button to center the crosshairs on the pixel under the cursor.
- For images: Click any arrow key to move 1 screen pixel in the direction of the arrow. Use **Ctrl** + arrow keys to move 10 screen pixels and **Shift** + arrow keys to move 20 screen pixels.
- For vectors: Click and drag the crosshairs to snap to the nearest vertex in the active layer (if the nearest vertex is close to the cursor). Release the mouse button to center the crosshairs over the vertex. If no vertices are near the cursor, the crosshairs center on the canvas area under the cursor.
- For images: If using the **Go To** tool and **Crosshairs** together, the crosshairs intersection is positioned over the location you specify.

**Vectors**

Use the following tools for vector record creation and manipulation in your display. To exit any of these tools, click the **Select** button.

<table>
<thead>
<tr>
<th>Button</th>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![vector_create]</td>
<td>Vector Create</td>
<td>Create new vector records in a vector layer. See &quot;Creating Vector Layers&quot; on page 97 for details.</td>
</tr>
<tr>
<td>![vector_edit]</td>
<td>Vector Edit</td>
<td>Edit vector records. See &quot;Editing Vector Records and Vertices&quot; on page 100 for details.</td>
</tr>
<tr>
<td>![vertex_edit]</td>
<td>Vertex Edit</td>
<td>Edit vector vertices or move points. See &quot;Editing Vector Records and Vertices&quot; on page 100 for details.</td>
</tr>
</tbody>
</table>

You can undo actions until you save the vector layer, or until you revert to the layer that was last saved.

**Feature Counting**

Use the **Feature Counting** button to mark features displayed in the Image window. See "About Feature Counting" on page 112 for details.

**Annotations**
Use the following tools for annotation item creation and manipulation in your display.

<table>
<thead>
<tr>
<th>Button</th>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Text Annotation</td>
<td>Add a text annotation to an annotation layer. See &quot;Creating Text Annotations&quot; on page 122 for details.</td>
</tr>
<tr>
<td></td>
<td>Symbol Annotation</td>
<td>Add a symbol annotation to an annotation layer. See &quot;Creating Symbol Annotations&quot; on page 122 for details.</td>
</tr>
<tr>
<td></td>
<td>Polygon Annotation</td>
<td>Add a polygon annotation to an annotation layer. See &quot;Creating Polygon Annotations&quot; on page 123 for details.</td>
</tr>
<tr>
<td></td>
<td>Polyline Annotation</td>
<td>Add a polyline annotation to an annotation layer. See &quot;Creating Polyline Annotations&quot; on page 123 for details.</td>
</tr>
<tr>
<td></td>
<td>Rectangle Annotation</td>
<td>Add a rectangle or square annotation to an annotation layer. See &quot;Creating Rectangle Annotations&quot; on page 124 for details.</td>
</tr>
<tr>
<td></td>
<td>Ellipse Annotation</td>
<td>Add an ellipse or circle annotation to an annotation layer. See &quot;Creating Ellipse Annotations&quot; on page 124 for details.</td>
</tr>
<tr>
<td></td>
<td>Arrow Annotation</td>
<td>Add an arrow annotation to an annotation layer. See &quot;Creating Arrow Annotations&quot; on page 125 for details.</td>
</tr>
<tr>
<td></td>
<td>Picture Annotation</td>
<td>Add a picture annotation to an annotation layer. See &quot;Creating Picture Annotations&quot; on page 125 for details.</td>
</tr>
</tbody>
</table>

Rotating

Use the following tools to rotate your display:

<table>
<thead>
<tr>
<th>Button</th>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Rotate</td>
<td>Rotate the display in the Image window. If the display includes annotation layers, most annotation items rotate with the associated image (you can change the default for an item in the Rotate with View property). By default, text, symbol, and picture annotations do not rotate; they retain their original orientation. Place the cursor in the Image window and do one of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Click and drag the cursor to rotate clockwise or counter clockwise.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Press an arrow key to rotate 5 degrees clockwise (down/right arrows) or counter clockwise (up/left arrows).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Press and hold the Ctrl key, then press an arrow key to rotate 1 degree clockwise (down/right arrows) or counter clockwise (up/left arrows).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Press and hold the Shift key, then press an arrow key to rotate 45 degrees clockwise (down/right arrows) or counter clockwise (up/left arrows).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To exit this tool, click the Select button.</td>
</tr>
</tbody>
</table>
Use the **Rotate To** drop-down list to select a fixed rotation angle (expressed in degrees) for the display in the Image window. Or, type your own degree of rotation and press **Enter** on your keyboard. This drop-down list interactively reports the current degree of rotation of the display when you use any rotation tool.

The following options are available from the **Rotate To** drop-down list (in degrees): 0, 90, 180, and -90.

### Zooming

You can zoom in and out on the display using the mouse wheel. Wheel up to zoom in and wheel down to zoom out. You can also use the following tools to zoom in or out:

Use the **Zoom To** drop-down list to select a fixed zoom extent (expressed as a percentage, followed by a ratio) for the display in the Image window. Or, type your own zoom percentage and press **Enter** on your keyboard. The default value is 100%. This drop-down list interactively reports the current zoom factor of the display when you use any zoom tool. The following options are available:

<table>
<thead>
<tr>
<th>Percentage</th>
<th>Ratio</th>
</tr>
</thead>
<tbody>
<tr>
<td>800% (8:1)</td>
<td>50% (1:2)</td>
</tr>
<tr>
<td>400% (4:1)</td>
<td>25% (1:4)</td>
</tr>
<tr>
<td>200% (2:1)</td>
<td>12.5% (1:8)</td>
</tr>
<tr>
<td>100% (1:1)</td>
<td>6.25% (1:16)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Button</th>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Top Up]</td>
<td>Top Up</td>
<td>Rotate the display in the Image window so that objects (especially buildings) are oriented vertically with your monitor. If the image contains rational polynomial coefficient (RPC) information, ENVI Zoom uses that to compute the rotation angle. If the image does not contain RPC information, or if it uses a standard projection, ENVI Zoom rotates the display to 0 degrees.</td>
</tr>
<tr>
<td>![North Up]</td>
<td>North Up</td>
<td>Rotate the display in the Image window so that North is at the top of the Image window. This option is only available for georeferenced images.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Button</th>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Zoom] | Zoom | Zoom in on the display in the Image window. Do one of the following:  
  - Roll the mouse wheel to zoom in and out by a fixed percentage.  
    This function is also active when using the **Select**, **Pan**, **Fly**, **Crosshairs**, **Vector Edit**, or **Rotate** tools.  
  - Click and drag over an area to draw a rubber-band box and zoom in on that area.  
  - Click once on the display to center the display on that location and zoom in by a fixed percentage.  
  To exit this tool, click the **Select** button. |
| ![Fixed Zoom In] | Fixed Zoom In | Click button to zoom into the center of the display in the Image window by a fixed percentage (the default is 1.25x, which can be set using the "Display General Preferences" on page 41). |
| ![Fixed Zoom Out] | Fixed Zoom Out | Click button to zoom out from the center of the display in the Image window by a fixed percentage (the default is 1.25x, which can be set using the Display General Preferences). |
Pyramids must be built before zooming out will work efficiently. See "Pyramid Preferences" on page 44 for pyramid preference settings.

Go To

Use the Go To tool to jump to a specific location in an image and center the Image window over that location. If Crosshairs are enabled, the crosshairs intersection is positioned over the location you specify.

1. Enter the coordinates in the Go To field, using one of the entry formats in the table below. You can also copy a location from the Cursor Value window and paste it in the Go To field.

2. Press Enter.

ENVI Zoom stores the locations you enter during your session in the Go To drop-down list. To jump to a stored location, select the desired location from the drop-down list.

Note: If you use the Go To tool and the layer is not selected (that is, you clicked outside of any valid data region, but are still in the canvas), then ENVI Zoom uses the bottom layer for the geographic jump.

<table>
<thead>
<tr>
<th>Entry Type</th>
<th>Valid Entry Formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lat, Lon</td>
<td>Enter the values in decimal degrees format or in degrees, minutes, seconds format. If the values fall within -180 to 180 for x and -90 to 90 for y, ENVI Zoom assumes the coordinates are lat/lon (for example, 179.9, 89.9). One exception to the range provided above is 1.0, 1.0, which goes to file coordinates. Decimal degrees format examples: 40.004036, 105.219047 40.004036N, 105.219047W 40.0481N, 105.3420W Degrees, minutes, seconds examples: 40 0 14.53, 105 13 8.57 40 0 14.53N, 105 13 8.57W 40 0'34.34&quot;N, 105 13’46.20&quot;W</td>
</tr>
<tr>
<td>FileX, FileY</td>
<td>Enter the value as x,y points. If both values are integers, or are outside the range used for lat/lon, ENVI Zoom assumes they are file coordinates. File x,y format examples: 181.1, 91.1 169, 79 29, 45</td>
</tr>
<tr>
<td>MapX, MapY</td>
<td>Enter the value as x,y points. If the x and y values are greater than 30,000, ENVI Zoom assumes it is a map coordinate. Map x,y format examples: 481168, 4426792 481872.8250, 4427702.4750 482970.42, 4427702.47</td>
</tr>
</tbody>
</table>
Mensuration

Use the **Mensuration** tool to measure distance and azimuthal direction on an image. Toggle the **Mensuration** tool on, select the Arrow or Polyline annotation tool and draw an annotation to calculate distance and direction (degrees relative to North). Multi-segment polylines will calculate and display distance for each segment as well as the total distance of the entire polyline. For Geographic Lat/Lon images, distance is calculated using the average latitude between the two endpoints of the line being measured. Distance and direction are displayed in the Cursor Value window. By default, georeferenced images will display distance in meters. Non-georeferenced images will display distance in pixels. Set the default measurement units using the Mensuration Units Preference.

Portals

Use the following tools to add and control a Portal in your display:

<table>
<thead>
<tr>
<th>Button</th>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>portal</td>
<td>Portal</td>
<td>Displays the bottom layer in a Portal. See &quot;Working with Portals&quot; on page 81 for details.</td>
</tr>
<tr>
<td>blend</td>
<td>Blend</td>
<td>Gradually transitions the display from one layer to another. See “Blending” on page 82 for details.</td>
</tr>
<tr>
<td>flicker</td>
<td>Flicker</td>
<td>Toggles between two layers at a desired speed. See &quot;Flickering&quot; on page 83 for details.</td>
</tr>
<tr>
<td>swipe</td>
<td>Swipe</td>
<td>Spatially transitions from one layer to another, using a vertical dividing line that moves between two overlapping layers. See &quot;Swiping&quot; on page 84 for details.</td>
</tr>
</tbody>
</table>

**Valid Entry Formats**

- **PixelX,PixelY**
  - Enter the value as x,y points, optionally following one of the values with a "p." If x and y values are greater than 30,000, append a "p" to one of the values to indicate it is a pixel coordinate, not a map coordinate.
  - Pixel x,y format examples:
    - 38p,45
    - 433.5, 469.5
    - -0.1039p, 0.749
Enhancement Tools

Enhancement tools let you interactively control the amount of brightness, contrast, stretching, and transparency for the selected image layer. For each tool, you can click and drag the slider or enter a value in the adjacent field. You can also use the following options to change slider values:

- Click on the slider bar to the right or left of the indicator or click the slider then use the Page Up or Page Down keys to move the slider value up or down incrementally by 10.
- Click on the icons to the right or left of the slider bar or click the slider then use the arrow keys on the keyboard to move the slider value up or down incrementally by one. The up/right arrow keys increase the enhancement; the left/down arrow keys decrease it.
- Click the slider then use the Home key to move the slider to 100 and the End key to move the slider to 0.
- Click the Reset button for the tool to return to the default value.
- Click the Undo or Redo buttons, or select Edit > Undo action or Edit > Redo action from the menu bar to undo and redo actions.

The value in the adjacent field interactively updates as you move the slider using any of the options listed, and the Image window immediately shows the results.

**Note:** If the enhancement tools are not fully visible, increase the size of the ENVI Zoom window.

**Brightness**

Click and drag the Brightness slider or type a number in the adjacent field to darken or brighten the display of the selected image. The valid range for this slider is 0 (dark) to 100 (bright). Click the Reset Brightness button to return to the default value of 50. The Brightness slider is disabled when viewing paletted images (for example, classification images) and vector layers.

**Contrast**

Click and drag the Contrast slider or type a number in the adjacent field to adjust the contrast of the selected image. The valid range for this slider is 0 (low contrast) to 100 (high contrast). Click the Reset Contrast button to return to the default value of 20. The Contrast slider is disabled when viewing paletted images (for example, classification images) and vector layers.

**Stretch Types**

A default 2% linear stretch is automatically applied to any image you open in ENVI Zoom. To specify a different contrast stretch for your image, select an option from the Stretch Types drop-down list:

- **No stretch:** Do not apply a contrast stretch to the image.
- **Linear:** This option is selected by default unless the data requires an optimized linear stretch (see Optimized Linear description). Apply a 2% linear stretch to the image. To enter a different percent stretch, type a new value in the Stretch Percent field in the interactive stretch dialog.
- **Equalization:** Apply a histogram equalization stretch to the image.
• **Gaussian:** Apply a Gaussian stretch to the image. The default standard deviation value is 0.3. To enter a different standard deviation, type a new value in the *Stretch Percent* field in the interactive stretch dialog.

• **Square Root:** Takes the square root of the input histogram then applies a linear stretch. The default value is 0.5. To enter a different square root value, type a new value in the *Stretch Percent* field in the interactive stretch dialog.

• **Logarithmic:** Apply a logarithmic stretch on the image.

• **Optimized Linear:** Apply an optimized linear stretch, also known as a dynamic range adjustment, to the image. By default, unsigned integer data (e.g. TIFF, NITF, JPIP, and ENVI) use the optimized linear stretch as the default for display, rather than the linear stretch. The optimized linear stretch has a dynamic range set that is optimal for integer data. This stretch provides the maximum amount of information from not only the midtones, but also from the shadow and highlight regions of this data type. Images stretched using this stretch type prohibit use of the Contrast enhancement.

Click the **Reset Stretch Type** button to return to the stretch type defined in the **Default Image Stretch** preference.

The stretch tool is not available for vector layers.

**Interactive Stretching**

The **Interactive Stretch** button is available when you select **Linear**, **Equalization**, **Gaussian**, **Square root**, or **Logarithmic** from the **Stretch Types** drop-down list.

Clicking this button opens an Interactive Stretch dialog that allows you to adjust the contrast of the selected image using a histogram. Click and drag the vertical dotted bars to interactively stretch the RGB colors, or type values in the adjacent fields and press **Enter** on your keyboard (or click outside of the field). You can change the default value used in **Linear**, **Gaussian**, or **Square Root** stretch types by typing a value into the *Stretch Percent* field in this dialog. The Image window updates automatically as you change the stretch.

Images with single-band lookup tables cannot be interactively stretched.

Click outside of the dialog or press **Esc** on your keyboard to close the Interactive Stretch dialog.

**Sharpen**

Click and drag the **Sharpen** slider or type a number in the adjacent field to blur or sharpen the display of the selected image. The valid range for this slider is 0 (blurry) to 100 (sharp). Click the **Reset Sharpen** button to return to the default value of 10. The **Sharpen** slider is disabled when viewing paletted images (for example, classification images) and vector layers.

**Transparency**

Click and drag the **Transparency** slider or type a number in the adjacent field to make your image or vector layer more opaque or transparent. The valid range for this slider is 0 (opaque) to 100 (transparent). Click the **Reset Transparency** button to return to the default value of 0.
Category Bars

ENVI Zoom includes three category bars: the Overview window, the Layer Manager, and the Toolbox. You can expand or collapse each of these categories by clicking the ▼ arrow next to the category name. You can also detach a category from the main window by clicking the Detach button on the category bar. A detached category displays as a separate dialog that you can move anywhere on your screen or drag to a second monitor. To re-attach a category, click the Close button (X) on the top right corner of the dialog. ENVI Zoom retains expand, collapse, attach, or detach category changes you make to from one session to the next.

The vertical bar that separates the categories from the Image window collapses and expands the entire category view. You can detach the categories you wish to see and then click on the vertical bar to collapse the category view and maximize your image display.

When you are working in the Image window, any detached windows go behind the Image window.

Overview Window

The Overview window provides a view of the full extent of the layers loaded into the Image window. Each time you display a new layer, the Overview window resizes to encompass the extents of all layers in the Image window. If you have an image selected in the Layer Manager, the selected image displays in the Overview window with a red border. The Overview window is not populated until ENVI Zoom builds supporting files (reduced resolution data sets or pyramids for images, rasterized file for vector layers); therefore, it may appear blank for several seconds while these files are being built. See "Displaying Large Images" on page 56 and "Quad Display and Data Reduction for Vector Layers" on page 58 for details.

By default, vector layers automatically display in the Overview window. However, you can choose to hide the display of all vector layers in the Overview window for the current ENVI Zoom session. To toggle vector layers on or off in the Overview window, right-click in the window and select Show Vectors. This option temporarily overrides the Show Vectors preference setting.

Note: ESRI layers do not display in the Overview Window.

In addition to detaching the Overview window (described in "Category Bars" on page 24), you can resize the detached window by clicking and dragging any of its sides or corners. When you resize the window, it maintains the aspect ratio of the contained canvas.

The Undo and Redo toolbar functions and Edit > Undo action and Edit > Redo action items from the menu bar are not available for actions performed in the Overview window.

View Box

The View box is a small, partially transparent window inside the Overview window that shows the extent of the imagery visible in the Image window:
• Click and drag any side or corner of the View box to resize it and therefore change the extent of the imagery in the Image window. If you click and drag a side, the View box adjusts shape to maintain the proper aspect ratio of the Image window.

• Increase or decrease the size of the View box (by clicking and dragging a corner), to zoom in or out on the image displayed in the Image window.

• Click inside of the View box and drag it to any location within the Overview window to dynamically update the Image window.

• Click outside of the View box in the Overview window to re-center the View box on the spot where you clicked.

• As you pan and zoom in the Image window, the View box changes location and size, respectively, in the Overview window.

By default, the Overview window shows the path history of the View box as you move it. The path history displays as a yellow highlight. To toggle the path history display on or off, right-click in the Overview window and select **Show Path History**. To clear the current path history display, right-click in the Overview window and select **Clear Path History**.

### Images with Different Extents

The View box behaves differently when you are viewing multiple images with different extents. Following is an example of two layers with different extents, shown in the Overview window:
If your View box is within the smaller of the two layers and you remove the larger layer (by right-clicking the larger layer name in the Layer Manager and selecting **Remove Selected Layer**), the View box stays where it is and the Overview window updates to show the full extent of the smaller layer.

If your View box is outside of the smaller layer and you remove the larger layer, the Overview window updates to show the extent of the smaller layer. However, the View box remains in its previous location and is therefore no longer visible. Click once in the Overview window to bring it back into view.
Layer Manager

You can display multiple image, vector, and annotation layers in one ENVI Zoom session. The Layer Manager lists these layers in a tree view and lets you manage how the layers are displayed in the Image window and Overview window. In addition to expanding or collapsing the Layer Manager, as described in "Category Bars" on page 24, you can also expand and collapse individual layers in the Layer Manager tree by clicking the + or - next to the layer name.

Displaying Layers

Layer names and information display as follows in the Layer Manager.

Image Layers

From image files, you can create new RGB or grayscale combinations using the same multispectral file and you can display each as a layer in the Layer Manager tree. This is helpful, for example, if you want to create separate true-color and color-infrared layers for the same file. For example, you can use Landsat TM Bands 1, 2, and 3 to render a true-color layer, and you can use Bands 2, 3, and 4 to render a color-infrared layer. Image layers are listed with an icon to the left of the layer name. The icon indicates the image type ( for grayscale, for RGB). Band names appear under the layer name, with wavelength information in parentheses. If you display additional layers with the same filename (for example, displaying different band combinations), sequential numbering appears in brackets to the left of the duplicate layer names (for example, [1] bldr_sp.img). The name of the original layer you displayed is not numbered.

Vector Layers

Vector layer names are listed with an icon to the left of the layer name. The icon indicates the vector type ( for points or multipoints, for polygons, for polylines) and is displayed in the same color as the loaded layer. As with image layers, if you display additional layers with the same name, sequential numbering appears in brackets to the left of the duplicate layer names, and the original layer is not numbered.
Annotation Layers

Annotation layers are listed with the icon to the left of the layer name. The annotation items are listed below the layer name as item types, with icons to the left of the type (Text, Symbol, Polygon, Rectangle, Ellipse, Polyline, Arrow Picture). The icon color matches the color of the actual annotation item.

NITF annotation layers are named as Annotation # and are listed with the icon to the left of the layer name. NITF annotation segments (objects) are listed under the layer name with colored icons to the left of the segment type (see above).

ESRI Layers

ESRI layer files are listed with an icon to the left of the layer name and legend patches showing examples of map symbols (points, lines, rectangles) below the layer name. The layer icon indicates the layer type (for raster, for points, for lines and polygons). Legend patches are described in ArcMap Help.

Portal Layers

Portal layers are listed as the name of the layer shown in the Portal. Names are not necessarily unique, as it is possible to create two or more Portals from the same layer. Because Portal names do not need to be unique, they are not sequentially numbered.

Feature Counting Layer

The feature counting layer is listed as a single layer with the icon next to it. This layer does not display individual feature counting items below the layer name.

Training Data Layers

The training data layer, used to create training areas for classification, is listed as a single layer with the icon to the left of the layer name Training Areas. The training data polygons are listed below the layer name as Polygon.

Base Layers

The first layer loaded into the Layer Manager that contains map information is the base layer. This layer defines the map projection and resolution. Subsequent layers loaded into the Layer Manager are reprojected on-the-fly to match the base layer projection. If the data being loaded into the layer has no associated map information, ENVI Zoom assumes it matches the projection and pixel size of the base layer, so no resampling or reprojection is done.

Because the base layer defines the projection and resolution, you should always load images with map information or with higher resolution into ENVI Zoom first. If you load an image with a higher resolution into ENVI Zoom after one with a lower resolution and map information, ENVI Zoom reprojects the higher resolution image to match the projection of the lower resolution image, without losing resolution.

Images that only contain rational polynomial coefficient (RPC) information or a pseudo projection cannot be used as a base layer when using other layers with projection information because they are not rectified standard projections.
If an image contains both RPC and traditional map projection information, ENVI Zoom will not save the
RPC information to the file header when you save the image to ENVI raster format.

In addition to setting the projection and resolution, the base layer defines the information that displays in
the Status bar and provides the information for the **Zoom To** drop-down list.

**GeoTIFF Map Information**

ENVI Zoom reads and writes ellipsoid semimajor and semiminor axes in GeoTIFF files, and it also saves
non-standard datum information. These values are stored in the following GeoTIFF structure fields:

```
GEOGSEMINORAXISGEOKEY
GEOSEMIMAJORAXISGEOKEY
```

For radial datums, the semimajor and semiminor axis values are the same; these are double-precision,
floating-point values.

A **GEOGCITATIONGEOKEY** structure field stores the string value of the datum name.

RPC information, affine map transformations (kx/ky or pseudo projections), and custom projections are not
retained when saving a file to TIFF or GeoTIFF format.

**Selected Layers**

Each time you open a new data file in ENVI Zoom, the layer appears at the top of the Layer Manager and
becomes the **selected** layer. To select a layer, click its name in the Layer Manager. The boundary of the
selected layer displays with a red border in the Image window and Overview window. The purpose of a
selected layer is to allow you to apply a display enhancement (brightness, contrast, transparency, etc.) to
that layer only, without affecting other layers.

**Active Layers**

Vector and annotation layers in ENVI Zoom can be the selected layer, but for editing purposes they also
need to be designated as the **active layer**. Specifying the active layer is necessary when you have multiple
layers of the same type open, as it indicates the layer you want to edit. Vector and annotation layers are
independent; if you have one or more of each layer type loaded, there will be one active vector layer **and**
one active annotation layer.

ENVI Zoom tools are applied differently to vector and annotation layers, depending on the tool. Vector,
Annotation, and Crosshairs tools work on the **active layer**, but the transparency and Go To tools work on
the **selected layer**, just as they do with imagery. The selected layer may or may not be the same layer as the
active layer at any given time. For example, you may add new vector records to the active layer, then click
to select a vector layer in the Layer Manager and apply transparency to that layer.

When working with active layers:

- When you create or load a new vector or annotation layer, it becomes the active layer for that layer
type.

- To change the active layer for a layer type, right-click on a layer name in the Layer Manager and
select **Set as Active Layer** or **Set As Active Annotation Layer**. The icon next to the active layer’s
name is highlighted by a red box for vectors or a cyan box for annotations, and the right-click menu option
**Set as Active Layer** or **Set As Active Annotation Layer** is disabled.
• When you have an active vector layer and an active annotation layer loaded and you are alternating between the two, select the appropriate tool button from the toolbar. For example, select a Vector tool if you want to edit the active vector layer.

• For vector layers, if you modified the active layer, ENVI Zoom prompts you to save the changes before you can set a new active layer. Save the changes if you want to keep them; otherwise, they are discarded.

• Reordering layers in the Layer Manager does not change which layer is the active layer. When you remove the active layer from the Layer Manager, another displayed layer automatically becomes the active layer.
Working with Layers

You can do the following with layers:

Ordering Layers

You can control the order of layers in the Image window and Overview window by dragging and dropping layers in the Layer Manager tree or by using menu options. To use the menu options, right-click on a layer name in the Layer Manager and select Order, or select Edit > Order Layer from the menu bar and select one of the following options:

- **Bring to Front**: Bring the layer to the front.
- **Send to Back**: Send the layer to the back.
- **Bring Forward**: Bring the layer one step closer to the front.
- **Send Backward**: Send the layer one step toward the back.

Removing Layers

You can remove a layer from the Layer Manager and close the display of that layer in the Image window. Though the layer no longer appears in the Layer Manager, its image, vector, or annotation file still remains open in the Data Manager.

To remove a single layer, perform one of the following steps:

- Right-click on a layer name in the Layer Manager, and select Remove.
- Select the layer name in the Layer Manager, then select Edit > Remove Selected Layer from the menu bar.

To remove all layers that are currently open, perform one of the following steps:

- Right-click on the Layers folder in the Layer Manager, and select Remove All.
- Select Edit > Remove All Layers from the menu bar.

**Note:** Removing annotation layers from NITF files is disabled in ENVI Zoom.

Hiding Layers

By default, all layers in the Layer Manager are displayed in the Overview window and the Image window. You can temporarily hide the display of a layer so that you can work with other layers in the Image window. To do this, right-click on a layer name in the Layer Manager, and disable the Show option to turn off the display of that layer in the Overview window and the Image window. Right-click on a hidden layer and enable the Show option to turn on the display of that layer. For vector layers, you can also set the default for a layer in the vector’s Properties dialog described in "Editing Vector Layer Properties" on page 108.

To toggle showing all vector layers in the Overview window on or off, right-click in the Overview window and select Show Vectors. You can change the system default setting for this via the Show Vectors preference.
**Working with Layers**

**Zoom Options**

For images, right-click on a layer name in the Layer Manager, select **Zoom To Layer**, and choose one of the following options:

- **Full Extent**: Zoom to the full extent of the layer. If you display two or more layers and you select this zoom option for one layer, the Image window updates to show the full extent of both layers, not just the selected layer.

- **Full Resolution**: Zoom to the full resolution (1:1) of the layer.

For vectors, right-click on a layer name in the Layer Manager and select **Full Extent**. If you display two or more layers and you select this zoom option for one layer, the Image window updates to show the full extent of both layers, not just the selected layer.

**Loading a Layer into a New Portal**

Right-click on a layer name in the Layer Manager, and select **Display In Portal** or click the **Portal** button. This button is only available when two or more layers are displayed in the Layer Manager. Portal layers are shown in a separate Portals directory within the Layer Manager. For more information on Portals, see "About Portals" on page 80.

**Sending Images to ArcMap from the Layer Manager**

Right-click on .shp and .evf files in the Layer Manager and select **Send to ArcMap** to open the files in ArcMap.

If ArcMap is not already running, ENVI Zoom will initiate it for you. The dataset will automatically display in ArcMap with the ArcMap default enhancements, and it will be added as a new layer to the ArcMap table of contents.

If you have one or more instances of ArcMap already running, an ArcMap Instances dialog appears. Select an instance to display your dataset, or start a new instance of ArcMap. Click **OK**.

**Toolbox**

The Toolbox is where you initiate and access image processing functions and, if you have ENVI EX, workflows. You can double-click a Toolbox function to initiate a process or a workflow. The Toolbox also contains ENVI Favorites, which provides access to extensive ENVI functionality.

If you have a Windows machine, you can use the Toolbox in these additional ways:

- Drag and drop an item from the Layer Manager onto the desired Toolbox function to initiate a process or a workflow.

- Drag and drop an item from the Data Manager onto the desired Toolbox function to initiate a process or a workflow.

- Drag and drop an item from ArcCatalog, ArcMap, or the Windows file manager onto the desired Toolbox function to initiate a process or a workflow.

**Starting a Process or Workflow Using Double-click**

When you double-click a Processing function or Feature Extraction, the Select an Input File dialog appears.

- If the data to use is already open, select it as described in "Selecting Previously Opened Files" on page 136.
• To open new data, see "Opening New Files from the Select Input File Dialog" on page 136.

When you double-click a Workflows item, the File Selection panel appears.

• If the workflow requires a single input and data in a supported format is already open, the filename is entered in the File Selection panel input file field. If multiple items are open and are in a supported format, the first supported item listed in the Data Manager is the one entered in the input field.

• If the data is already open and the workflow requires two input files, the File Selection panel input file fields are blank, Click Browse. The Input File dialog appears. See "Opening New Files from the Select Input File Dialog" on page 136 for details.

• If no data is open, or if you want to open new data, click Browse in the File Selection panel. The Input File dialog appears. See "Opening New Files from the Select Input File Dialog" on page 136 for details.

• If you know the location and name of the data to open, you can type the path and name in the File Selection panel input field.

Starting a Process or Workflow on Windows Using Drag and Drop

Note: The file you drag and drop onto a Toolbar item must be a file type supported by the process or workflow you wish to initiate.

• To initiate a process or a workflow with drag and drop, click the item, drag it to the Toolbox, and drop it on the name of the desired function. If the data is not supported by image processing or a workflow, the cursor looks as follows when you hover over the desired function:

  ![Cursor Image](image)

  • For Processing, the Select an Input File dialog appears, with the selected data highlighted. Click OK to proceed.

  • For Feature Extraction, the Select an Input File dialog appears, with the selected data highlighted. Click OK to proceed.

  • For all other workflows, the File Selection panel appears, with the name entered into the input field. If the workflow requires two inputs, the name is entered into the first input field.

ENVI Favorites

The ENVI Favorites Toolbox provides access to all ENVI functionality in ENVI Zoom. Double-click the Add Items option to customize the ENVI Favorites Toolbox with ENVI main menu and Display group menu items. Detailed information on each function can be found in the ENVI Help which is accessible from the ENVI main menu bar Help > Start ENVI Help option or by adding this function to the ENVI Favorites Toolbox. Windows users can also access ENVI Help by selecting Programs > ENVI x.x > ENVI Help from the Windows Start menu. UNIX users can access ENVI Help by typing either envihelp or envi man at the UNIX prompt (your environment variables must be appropriately set up).
Customizing the ENVI Favorites Toolbox

Double-click the Add Items option to customize the ENVI Favorites Toolbox. Click to select a menu function or folder from the ENVI Menus panel and either drag and drop it to the Toolbox panel or click the Add button to add the selected item to the Toolbox panel. Use the Ctrl or Shift keys as you click to select multiple menu functions or folders.

Expand or collapse all of the menu folders by right-clicking on any menu folder in the dialog and selecting the Expand All or Collapse All option. You can also remove, rename, and organize Toolbox items using the toolbar buttons at the bottom of the Toolbox panel or by right-clicking on an item in the Toolbox panel and selecting the appropriate option.

Type a keyword into the Find field at the bottom of the dialog to search for functions in the ENVI Menus panel.

Tips and Tricks

- You must have a raster image displayed in ENVI Zoom to use an ENVI Favorites Display group menu item. If you launch an ENVI Favorites Display group menu item and you have multiple images displayed, the raster image at the top of the Layer Manager will be used.
- Spectral Library files opened in ENVI will not open in ENVI Zoom.
- NITF "Composite" images opened in ENVI will not open in ENVI Zoom.

See also: "Toolbox" on page 32
Cursor Value Window

The Cursor Value window contains information about the displayed data at the current cursor location and data from the Mensuration tool when applicable.

You can access the Cursor Value window during any ENVI Zoom session by selecting Display > Cursor Value from the menu bar, or by clicking the Cursor Value toolbar button. The Cursor Value window opens automatically when you click the Crosshairs button.

When Blend, Flicker, or Swipe operations are active, the Cursor Value window does not update when you move your mouse.

If you move the cursor outside of the Image window or the Overview window, the Cursor Value window displays the coordinates of the last place the cursor was before leaving the Image window or Overview window. When you return the cursor to either window, the Cursor Value window resumes displaying the current cursor location.

Cursor Location Data from the Image Window

For all images, the Cursor Value window displays the layer name for each layer.

For non-georeferenced images, the following information displays along with the layer name:

- File x,y locations (in pixels) for the current location of the cursor.
- Data value(s) for the bands displayed at the current cursor location.
- Class names for classification images.

Example:

bldr_tm.img
File: 8,611
Data: [85, 33, 36]

For georeferenced images, the Cursor Value window displays the following along with the layer name:

- Map projection and datum, and whether the file contains rational polynomial coefficient (RPC) information.
- Map x,y coordinates for the current location of the cursor.
- Latitude and longitude values for the current location of the cursor.
- Data value(s) for the bands displayed at the current cursor location.
Example:

Geo: 40°4'11.53"N, 105°22'26.11"W
Map: 468114.0000, 4435369.0000
Proj: UTM, Zone 13N, NAD 27

bldr_sp.img
File: 8,611
Pixel: [0]

For all vector and ESRI feature class layers, the Cursor Value window displays the following for the selected vector record:

- Vector layer name
- Selected vector record number

If the vector or ESRI feature class layer has an associated attribute table, the attribute table data displays for the selected vector record.

Example:

Geo: 34°47'44.98"N, 90°53'34.49"W
Proj: Geographic Lat/Lon, NAD 83
lakes.shp
Selected Record: 11
AREA: 22228.402
NAME: Lake Michigan

If Crosshairs are enabled for an image, the Cursor Value window shows the following additional information:

- The location of the crosshairs, in file units relative to the visualization that established the base map.
- If a base map projection was established, the location of the crosshairs, in map units.

Example:

Crosshair
Loc: 398.000, 426.000
Geo: 40°0'0.18"N, 105°13'5.22"W
Map: 481381.600, 4427785.600

Click and hold the mouse button to view only the crosshair information in the Cursor Value window.

If Crosshairs are enabled and are centered over a vector vertex, or if the cursor is in Vector Edit mode, the Cursor Value window shows the following. Be sure that any layer modifications are saved, to provide the most accurate data.

- The layer name.
- The index of the current vector record (0 based) and the total number of records.
- If the file is multipart: the index of the current vector part (0 based) and the total number of parts in the vector record.
- The index of the vertex (0 based) within the vector part and the total number of vertices in the part.
- The location of the crosshairs in the native coordinates of the vector file.
- If the vector layer has an attribute table, the Cursor Value contains the attribute table data.
Cursor Location Data from the Overview Window

If the cursor is in the Overview window, the Cursor Value window shows the following information:

- For non-georeferenced images and vector layers: file x,y location (in pixels) for the current location of the cursor.

- For georeferenced images:
  - Map projection and datum, and whether the file contains rational polynomial coefficient (RPC) information.
  - Map x,y coordinates for the current location of the cursor.
  - Latitude and longitude values for the current location of the cursor.
Setting Preferences

You can set preferences to affect the behavior of visualizations, layer management, and data analysis. When you change a preference, it immediately takes effect without requiring you to restart the application.

To edit your preferences, select File > Preferences from the menu bar. The Preferences dialog appears.

Select the preference you want to edit from the Settings tree. The right side of the dialog shows the settings available for the preference you select. Each preference category displays a Name and Description field, which are not editable.

Edit the preferences as desired, then click OK to save the changes to your preferences file, `envizoom_prefs.sav` (ENVI Zoom) or `enviex_prefs.sav` (ENVI EX), which is in the following directory:

- **Windows:** `Documents and Settings\username\.idl\itt\components-37-x_x-osname-bits`
- **Unix and Linux:** `/home/username/.idl/itt/components-37-x_x-osname-bits/

Where `x_x` is the ENVI version number, `osname` is the operating system you are running, and `bits` is 32 or 64.

To edit True/False fields or other fields with drop-down lists, double-click in the field and select your preference. To revert to your previously saved changes, click Restore Defaults.
## Application Preferences

To edit application preferences, select **File > Preferences** from the menu bar, then select **Application** in the Preferences dialog tree.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Confirm on Exit</strong></td>
<td>Enable or disable displaying the message “Exit Application?” when you close the application. The default is <strong>True</strong>.</td>
</tr>
<tr>
<td><strong>Enable System Logging</strong></td>
<td>Enable or disable system logging. The default is <strong>False</strong>. If this field is set to <strong>True</strong>, ENVI Zoom saves an ASCII log of error messages named envizoomsystemlog.txt in your home directory:</td>
</tr>
<tr>
<td></td>
<td><strong>Windows:</strong> Documents and Settings\username\idl\itt\components-37-x_x-osname-bits\</td>
</tr>
<tr>
<td></td>
<td><strong>Unix and Linux:</strong> /home/username/.idl/itt/components-37-x_x-osname-bits/</td>
</tr>
<tr>
<td></td>
<td>Where x_x is the ENVI version number, osname is the operating system you are running, and bits is 32 or 64. The log file is overwritten with each new ENVI Zoom session.</td>
</tr>
<tr>
<td><strong>Display Errors on Screen</strong></td>
<td>Enable or disable display of error messages. The default is <strong>True</strong>, causing error messages to be displayed. Setting this preference to <strong>False</strong> suppresses the display of error messages received during operation.</td>
</tr>
<tr>
<td></td>
<td>If the <strong>Enable System Logging</strong> preference is set to <strong>True</strong>, the errors will be written to the application system log. If both the <strong>Display Errors on Screen</strong> and <strong>Enable System Logging</strong> preferences are set to <strong>False</strong>, then the errors will appear at the IDL console.</td>
</tr>
<tr>
<td><strong>OPS Pool Size</strong></td>
<td>The number of out-of-process servers (OPS) to start in the pooled resource service (PRS). This specifies the number of OPS instances to create for the tile server and asynchronous action resources. When clients request access, the requests are queued and run by priority.</td>
</tr>
<tr>
<td></td>
<td>The tile server manages accessing the data tiles for display. The asynchronous actions server manages certain data actions, such as long-running and high-latency operations, as a separate process.</td>
</tr>
<tr>
<td></td>
<td>When ENVI Zoom runs for the first time, it queries the hardware for the number of CPUs and sets this value accordingly. Setting this value to a large number on a machine with only one or two CPUs and loading multiple large datasets causes severe performance degradation.</td>
</tr>
</tbody>
</table>
Data Manager Preferences

To edit Data Manager preferences, select File > Preferences from the menu bar, then select Data Manager in the Preferences dialog tree.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto Display Files on Open</td>
<td>Enable or disable automatically loading the selected file in the Image window upon file open. The default is True. False disables automatically loading the selected file. If you set the Launch Data Manager After File/Open preference to Always or If file not Auto-Displayed, the Data Manager appears and you can display the image from there. For information on how files are automatically loaded, see &quot;Supported File Formats&quot; on page 52.</td>
</tr>
<tr>
<td>Auto Display Method for Multispectral Files</td>
<td>The method for automatically displaying multispectral files. The choices are True Color (default) and CIR (color infrared). These settings only apply if the image file contains wavelength information.</td>
</tr>
<tr>
<td>Clear Display When Loading New Data</td>
<td>Enable or disable clearing all layers from the Image window and the Layer Manager when you display a new image. The default is False, meaning ENVI Zoom continues to display all current layers when you display a new image. If this field is set to True, all layers are removed when a new layer is loaded, but the existing files remain open in the Data Manager.</td>
</tr>
<tr>
<td>Launch Data Manager at Startup</td>
<td>Enable or disable opening the Data Manager when you start ENVI Zoom. If this field is set to False, open the Data Manager as needed by selecting File &gt; Data Manager from the menu bar or by clicking the Data Manager button.</td>
</tr>
<tr>
<td>Launch Data Manager After File/Open</td>
<td>The method for showing the Data Manager. The choices are as follows:</td>
</tr>
<tr>
<td></td>
<td>• Never: Do not automatically open the Data Manager for any file-open instance.</td>
</tr>
<tr>
<td></td>
<td>• If file not Auto-Displayed (default): Open the Data Manager when the Auto Display Files on Open value is False.</td>
</tr>
<tr>
<td></td>
<td>• Always: Open the Data Manager every time a file is opened.</td>
</tr>
<tr>
<td>Close Data Manager After Loading New Data</td>
<td>Enable or disable automatically closing the Data Manager after you load new data. The default is False.</td>
</tr>
<tr>
<td>Load File After Chip or Save</td>
<td>Enable or disable whether output is automatically added to the Data Manager upon file save. This preference only applies to Chipping the Display and Save As. The default is True. If you set this preference to False, output is saved to disk but not added to the Data Manager. Note: Results that are output to memory are always added to the Data Manager.</td>
</tr>
</tbody>
</table>

The Data Manager will also appear if:

- You set Auto Display Files on Open to False, and you set Launch Data Manager After File/Open to If file not Auto-Displayed.
- You set Launch Data Manager After File/Open to Always.
Directories Preferences

To edit default directory preferences, select File > Preferences from the menu bar, then select Directories in the Preferences dialog tree.

To edit the directory fields, double-click in the field, then select Edit. The Browse For Folder dialog appears. Navigate to the directory, then click OK.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change Directory on Open</td>
<td>Enable or disable automatically changing the Default Input Directory value when you navigate to and open a file in a directory other than the current default. The default is True.</td>
</tr>
<tr>
<td>Default Input Directory</td>
<td>The directory for input images. ENVI Zoom uses this directory unless you specify another path when opening a file.</td>
</tr>
<tr>
<td>Temporary Directory</td>
<td>The directory used to store ENVI Zoom temporary files.</td>
</tr>
<tr>
<td>Output Directory</td>
<td>The directory for output files. ENVI Zoom writes output files to this directory unless you specify another path when entering an output filename.</td>
</tr>
<tr>
<td>Alternate Header Directory</td>
<td>The directory for header files associated with input images from read-only devices, such as a CD or folders with no write permissions. ENVI Zoom typically stores header files in the same directory as the input image; however, when that directory is read-only, ENVI Zoom writes to the alternate header directory. When opening a file, if ENVI Zoom is unable to locate a header file, it looks in the alternate header directory. This setting also affects pyramids. For more information, see Pyramids.</td>
</tr>
</tbody>
</table>

Overview Window Preferences

To edit Overview window preferences, select File > Preferences from the menu bar, then select Overview Window in the Preferences dialog tree.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Vectors</td>
<td>Enable or disable showing vector layers in the Overview window. The default is True. ESRI feature class layers (vector layers referenced in a file) are not visible in the Overview window. You can override this setting during a session by right-clicking in the Overview window and disabling the Show Vectors option.</td>
</tr>
</tbody>
</table>

Display General Preferences

To edit general display preferences, select File > Preferences from the menu bar, then select Display General in the Preferences dialog tree.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom Factor</td>
<td>The zoom factor to use when you zoom in or out of the image. The default is 1.25.</td>
</tr>
</tbody>
</table>
### Zoom Interpolation Method

The interpolation method to use when zooming on raster layers. This preference takes effect for any new layers that you create. Interpolation behavior may vary, depending on the method you choose, and whether the Use Graphics Card to Accelerate Enhancement Tools preference is enabled. Variations are noted in the following descriptions. The choices are as follows:

- **Nearest Neighbor**: (default) Each pixel in the displayed image receives its value from the nearest pixel in the input (reference) image. If the Use Graphics Card to Accelerate Enhancement Tools preference is enabled, brightness, contrast, and sharpen filters are performed by the GPU.

- **Bilinear**: Each estimated pixel value in the displayed image is based on a weighted average of the four nearest neighboring pixels in the input image. Not all GPUs support bilinear interpolation of floating point textures; therefore, if Use Graphics Card to Accelerate Enhancement Tools is enabled, the setting is ignored and brightness, contrast, and sharpen filters are performed by the CPU.

- **Bicubic**: Each estimated pixel value in the displayed image is based on a weighted average of the sixteen nearest pixels in the input image. If Use Graphics Card to Accelerate Enhancement Tools is enabled, the setting is ignored and brightness, contrast, and sharpen filters are performed by the CPU. If your graphics processing unit (GPU) does not support OpenGL Shader Language (GLSL), the Nearest Neighbor interpolation method is used instead.

- **Optimized Bicubic**: Each estimated pixel value in the displayed image is based on a weighted average of the sixteen nearest pixels in the input image. The weighting coefficients are improved over standard Bicubic. If Use Graphics Card to Accelerate Enhancement Tools is enabled, the setting is ignored and brightness, contrast, and sharpen filters are performed by the CPU. If your graphics processing unit (GPU) does not support OpenGL Shader Language (GLSL), the Nearest Neighbor interpolation method is used instead.

To use Bicubic and Optimized Bicubic:

- Your graphics card must support OpenGL 2.0 or higher, and you must have the most recent drivers installed.

- The displayed image must not be palettized.

Portals behave differently; they try to match the interpolation value of the target layer, regardless of the current preference setting.

### Mensuration Units

The default distance measurement units for the Mensuration tool. The default is meters. If the Mensuration tool is being used on a non-georeferenced image, the Cursor Value window will always report the mensuration units in pixels.

### Geographic Coordinate Format

The default format for geographic coordinate information in the Cursor Value window. The default is Degrees, Minutes, Seconds. Alternatively, you can choose to display the geographic location in Decimal Degrees.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Zoom Setting for JPIP Images</strong></td>
<td>The default load extent for JPIP images. The default is <strong>Full Extent</strong> which displays an entire JPIP image and results in JPIP images loading faster.</td>
</tr>
<tr>
<td><strong>Default Selection Color</strong></td>
<td>The default color to use to highlight the current selection. This color appears as a border when you select layers, as a border to an open Portal, and when you select vectors or annotations to edit. The default is <em>(0,192,192)</em>.</td>
</tr>
<tr>
<td><strong>Default Image Stretch</strong></td>
<td>The stretch to use for images when you load them. The options are as follows:</td>
</tr>
<tr>
<td></td>
<td>- <strong>None</strong>: Do not apply a contrast stretch to the image.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Linear 2%</strong> (default): Apply a 2% linear stretch to the image.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Histogram Equalization</strong>: Apply a histogram equalization stretch to the image.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Gaussian</strong>: Apply a 0.3 Gaussian stretch to the image.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Square Root</strong>: Take the square root of the input histograms then apply a 0.5 linear stretch to the image.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Logarithmic</strong>: Apply a logarithmic stretch to the image.</td>
</tr>
<tr>
<td></td>
<td>When you click the <strong>Reset Stretch Type</strong> toolbar button, ENVI Zoom reverts to the stretch type defined by this preference setting.</td>
</tr>
<tr>
<td><strong>Use Low Resolution Tile Cache</strong></td>
<td>For images with very high spatial resolution, ENVI Zoom displays low-resolution tiles in the Image window while it retrieves the full-resolution data (if this preference is set to <strong>Yes</strong>, the default). If you have a slow processor, you may set this preference to <strong>No</strong>, which should improve display performance. If you set this preference to <strong>No</strong>, nothing is visible in the Image window until ENVI Zoom loads each tile.</td>
</tr>
<tr>
<td><strong>Default Middle Mouse Action</strong></td>
<td>The tool to use when you click and drag the middle mouse button in the Image window. The choices are the <strong>Pan</strong> tool or the <strong>Fly</strong> tool. The default is <strong>Pan</strong>.</td>
</tr>
<tr>
<td><strong>Use Graphics Card to Accelerate Enhancement Tools</strong></td>
<td>The default setting of <strong>Yes</strong> accelerates raster operations, such as image stretching, sharpening, brightness, contrast, and so forth, using your computer’s graphics processing card (GPU) instead of your computer’s central processing unit (CPU). All of the following criteria must be met for this preference to be effective:</td>
</tr>
<tr>
<td></td>
<td>- Your graphics card must support OpenGL 2.0 and must have the most recent drivers installed.</td>
</tr>
<tr>
<td></td>
<td>- You must set the <strong>Zoom Interpolation Method</strong> preference to <strong>Nearest Neighbor</strong>.</td>
</tr>
<tr>
<td></td>
<td>- The image data type must be byte, integer, unsigned integer, or floating-point.</td>
</tr>
<tr>
<td></td>
<td>- Your platform must be Windows or Linux.</td>
</tr>
<tr>
<td><strong>Use Degree Symbol When Displaying DMS</strong></td>
<td>Set this preference to <strong>Yes</strong> (the default) to use the degree symbol when displaying Degrees, Minutes, Seconds in any Asian Language OS.</td>
</tr>
</tbody>
</table>
Settings Preferences

To edit data pyramid preferences, select File > Preferences from the menu bar, then select Pyramid in the Preferences dialog tree.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status Bar Segment 1, 2, 3</td>
<td>The information to display in the first three segments of the Status bar. The file must have either map information and/or NITF metadata associated with it for the information to display in the Status bar. When you customize the Status bar contents using this method, the Status bar retains the information for subsequent ENVI Zoom sessions. You can temporarily set the information for each segment by right-clicking on the Status Bar segments. See &quot;Status Bar&quot; on page 14 for details. The Status Bar displays information for the base layer in the Layer Manager (for more information, see &quot;Layer Manager&quot; on page 27). The choices for all three Status bar segments are as follows:</td>
</tr>
<tr>
<td></td>
<td>• Lat/lon degrees minutes seconds: Latitude and longitude coordinates relative to the cursor location, in degrees/minutes/seconds format. For example, Lat: 40°5’15.92”N, Lon: 105°21’32.83”W.</td>
</tr>
<tr>
<td></td>
<td>• Lat/lon decimal degrees: Latitude and longitude coordinates relative to the cursor location, in decimal degrees format. For example, Lat: 40.0866N, Lon: 105.3524W.</td>
</tr>
<tr>
<td></td>
<td>• Current projection: The current map projection type, zone, and datum. For example, UTM, Zone 13 North, NAD 27.</td>
</tr>
<tr>
<td></td>
<td>• Map coordinates: The map coordinates relative to the cursor location. For example, Map X: 471424.0000, Map Y: 4437999.0000.</td>
</tr>
<tr>
<td></td>
<td>• NITF classification level: The NITF classification level of the image. The classification levels are Unclassified, Top Secret, Secret, Confidential, and Restricted.</td>
</tr>
<tr>
<td></td>
<td>• NITF acquisition time: The image date and time of acquisition, shown as MMM DD, YYYY hh:mm:ss format. For example, JAN 17, 2006 14:23:12.</td>
</tr>
<tr>
<td></td>
<td>• Blank: No display.</td>
</tr>
</tbody>
</table>

Pyramid Preferences

To edit data pyramid preferences, select File > Preferences from the menu bar, then select Pyramid in the Preferences dialog tree.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatically Create Data Pyramids</td>
<td>Enable or disable creating copies of the data file at reduced resolutions (known as pyramids). The default is True, meaning ENVI Zoom builds the pyramids in the background when it opens an image file and before it displays the image in the Overview window. Using pyramids reduces the time required to display large portions of an image when panning, flying, zooming, etc. For more information, see &quot;Pyramids&quot; on page 56.</td>
</tr>
<tr>
<td>Minimum Data Dimensions to Create Pyramid</td>
<td>Set the minimum data dimensions that must be met for ENVI Zoom to create a data pyramid. The default is 1024 x 1024. ENVI Zoom does not build pyramid files for JPEG files (these are read into memory), JPEG 2000 files (which are able to return data at different resolutions), and files with spatial dimensions less than or equal to 512 x 512.</td>
</tr>
</tbody>
</table>
Print Layout Preferences

To edit Print Layout view preferences, select **File > Preferences** from the menu bar, then select **Printing** in the Preferences dialog tree.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Map Template</td>
<td>Change the default template. By default, the Print Layout will be displayed in the ArcMap Normal template (<strong>Normal.mxt</strong>). If the Preferences point to an invalid template, a warning message will be displayed the next time the Print Layout view is initialized.</td>
</tr>
<tr>
<td>Map Template Directory</td>
<td>Change the default map template directory. The default template directory specifies the initial browse location of the dialog used to pick a map template (see above). If the Preferences point to an invalid directory, a warning message will be displayed the next time the Print Layout view is initialized. See also &quot;Map Template&quot; on page 141</td>
</tr>
<tr>
<td>Reference Scale</td>
<td>Set the scale at which symbols will appear in the data frame, specified in map units. The Reference Scale sizes text and symbols along with the display. Without a Reference Scale, symbols and text will remain the same at all map scales, even if the extent is changed. The default is 0 (no Reference Scale).</td>
</tr>
</tbody>
</table>
Annotation Preferences

To edit annotation preferences, select File > Preferences from the menu bar, then select Annotation in the Preferences dialog tree.

You can set preferences for the different annotation types. You can override these settings as needed for each annotation through the individual annotation properties.

Text Annotation Preferences

The following are the text annotation preferences. You can temporarily override these settings when the Text Annotation tool is selected by right-clicking in the Image window (with no annotation items selected) and selecting Preferences.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>The annotation text color. The default is red (255,0,0).</td>
</tr>
<tr>
<td>Font Name</td>
<td>The font type to use for text annotations. The fonts that are installed on your system are available from the drop-down list. The default is Helvetica.</td>
</tr>
<tr>
<td>Font Style</td>
<td>The font style to apply to text annotations. The default is Normal.</td>
</tr>
<tr>
<td>Font Size</td>
<td>The font size for text annotations. The default is 16 points.</td>
</tr>
<tr>
<td>Horizontal Alignment</td>
<td>The horizontal alignment for text annotations. The default is Left.</td>
</tr>
<tr>
<td>Background Fill</td>
<td>Enable or disable using a background fill color for text annotations. The default is False.</td>
</tr>
<tr>
<td>Background Color</td>
<td>If the Background Fill setting is True, specify the color to use for the text annotation background. The default is black (0,0,0).</td>
</tr>
</tbody>
</table>

Symbol Annotation Preferences

The following are the symbol annotation preferences. You can temporarily override these settings when the Symbol Annotation tool is selected by right-clicking in the Image window (with no annotation items selected) and selecting Preferences.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>The annotation symbol color. The default is red (255,0,0).</td>
</tr>
<tr>
<td>Font Name</td>
<td>The font type to use for symbols. The fonts that are installed on your system are available from the drop-down list. The default is Symbol.</td>
</tr>
<tr>
<td>Font Size</td>
<td>The font size for the symbols. The default is 24 points.</td>
</tr>
<tr>
<td>Character</td>
<td>The symbol character to use. Click in this field and select Edit to open a dialog containing symbol choices. The default is ASCII 197.</td>
</tr>
<tr>
<td>Background Fill</td>
<td>Enable or disable using a background fill color for the symbol. The default is False.</td>
</tr>
<tr>
<td>Background Color</td>
<td>If the Symbol Background Fill setting is True, specify the color to use for the symbol background. The default is black (0,0,0).</td>
</tr>
</tbody>
</table>

Arrow Annotation Preferences
The following are the arrow annotation preferences. You can temporarily override these settings when the **Arrow Annotation** tool is selected by right-clicking in the Image window (with no annotation items selected) and selecting **Preferences**.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line Color</td>
<td>The line color for annotation arrows. The default is red (255,0,0).</td>
</tr>
<tr>
<td>Line Style</td>
<td>The line style for annotation arrows. Style choices range from no line to solid, dashed, or dotted lines. The default is a solid line.</td>
</tr>
<tr>
<td>Line Thickness</td>
<td>The line thickness for annotation arrows. The default is 1.</td>
</tr>
<tr>
<td>Arrow Head Size</td>
<td>The size of the annotation arrow heads, in points. The default is 25.</td>
</tr>
<tr>
<td>Arrow Head Angle</td>
<td>The angle, in degrees, of the annotation arrow heads. The default is 30 degrees.</td>
</tr>
<tr>
<td>Arrow Head Fill Interior</td>
<td>The arrow head fill interior, either None or Solid. The default is Solid.</td>
</tr>
</tbody>
</table>

**Polygon Annotation Preferences**

The following are the polygon, rectangle, and ellipse annotation preferences. You can temporarily override these settings when the **Polygon Annotation**, **Rectangle Annotation**, or **Ellipse Annotation** tool is selected by right-clicking in the Image window (with no annotation items selected) and selecting **Preferences**.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Outline</td>
<td>Enable or disable showing the outline of the polygon. The default is True.</td>
</tr>
<tr>
<td>Line Color</td>
<td>The line color for polygon annotations. The default is red (255,0,0).</td>
</tr>
<tr>
<td>Line Style</td>
<td>The line style for polygon annotations. Style choices range from no line to solid, dashed, or dotted lines. The default is a solid line.</td>
</tr>
<tr>
<td>Line Thickness</td>
<td>The line thickness for polygon annotations. The default is 1.</td>
</tr>
<tr>
<td>Fill Interior</td>
<td>The polygon fill interior, either None or Solid. The default is None.</td>
</tr>
<tr>
<td>Fill Color</td>
<td>If the Polygon Fill Interior setting is True, specify the color to use for the polygon background. The default is red (255,0,0).</td>
</tr>
</tbody>
</table>

**Polyline Annotation Preferences**

The following are the polyline annotation preferences. You can temporarily override these settings when the **Polyline Annotation** tool is selected by right-clicking in the Image window (with no annotation items selected) and selecting **Preferences**.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line Color</td>
<td>The line color for polyline annotations. The default is red (255,0,0).</td>
</tr>
<tr>
<td>Line Style</td>
<td>The line style for polyline annotations. Style choices range from no line to solid, dashed, or dotted lines. The default is a solid line.</td>
</tr>
<tr>
<td>Line Thickness</td>
<td>The line thickness for polyline annotations. The default is 1.</td>
</tr>
</tbody>
</table>

**Picture Annotation Preferences**

The following is the picture annotation preference.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum Picture Dimension</td>
<td>The maximum dimension to allow for a picture annotation. The default is 512 pixels.</td>
</tr>
</tbody>
</table>
## Vector Preferences

To edit vector preferences, select **File > Preferences** from the menu bar, then select **Vectors** in the Preferences dialog tree.

| Option                        | Description                                                                                                                                                                                                。
|-------------------------------|----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.
| Build Reduced Vertices File   | Enable or disable automatically building a reduced vertices file the first time a vector file is opened. ENVI Zoom creates a .qtr file in the same directory as the vector file to use for all subsequent file opens. A reduced vertices file (also known as a reduced resolution file) improves rendering performance when the ratio of vertex density to viewable area pixel resolution is very high. The default is True. For more information on reduced vertices files, see "Quad Display and Data Reduction for Vector Layers" on page 58. |
| Maximum Vertices Per Quad Node | The maximum number of vertices to allow in each quadtree node. When this number is exceeded, the node splits. The default is 75000.                                                                                                                                 |
| Maximum Vertices to Read in as Memory | The maximum number of vertices to read in as memory. This setting is used before building the reduced vertices file. ENVI Zoom checks how many vertices are stored in the file. If the number is smaller than or equal to this setting, all of the vector records are loaded into memory for efficient access. If the number is larger than this setting, no vector records are loaded into memory. In this case, records are read temporarily from the file each time a vector is accessed. The default is 100000. |
| Maximum Vertices to Display at Once | The maximum number of vertices to display in the viewable area at one time. When this number is exceeded, some data appear as bounding boxes in the viewable area. The default is 1000000. |

## Remote Connectivity Preferences

To edit remote connectivity preferences, select **File > Preferences** from the menu bar, then select **Remote Connectivity** in the Preferences dialog tree.

| Option                        | Description                                                                                                                                                                                                。
|-------------------------------|----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.
<p>| OGC Proxy Server             | A proxy server sits between your computer and remote servers to which you connect. If you consistently have trouble connecting to remote servers, you may have a proxy server installed. Contact your system administrator for details, then enter the server name in the OGC Proxy Server field. This field is blank by default. ENVI Zoom does not attempt to connect through a proxy server, unless you specify one. JPIP/IAS servers do not support proxy servers. |
| OGC Proxy Port               | The port number through which the proxy server connects to the Internet. The default is 80.                                                                                                                                                   |
| Recent Datasets to Remember  | The number of datasets to maintain in the Recent Dataset List in the <strong>File &gt; Open Remote Dataset</strong> menu option. The default is 16.                                                                                                         |
| Close Remote Connection Manager After Opening New Data | Enable or disable automatically closing the Remote Connection Manager dialog after you load new data. The default is False.                                                                                                      |
| WMS Pixels Per Side          | The number of pixels to use as the default setting for the greater of the width or height within a WMS layer. The default is 10000.                                                                                       |</p>
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ESRI License Type</td>
<td>Set this preference to the type of ESRI license you currently have. The choices are Unknown (default), ArcInfo, ArcView, or ArcEditor. Setting this preference to a specific ESRI license type speeds up performance because ENVI Zoom will skip the license check when you read or export to a geodatabase, or when you interact with ArcMap software. You can find the license type installed on your computer by selecting Help &gt; About ArcMap from the ArcMap software menu bar.</td>
</tr>
</tbody>
</table>
Performance Tips and Tricks

If tile rendering performance is slow or non-responsive, try setting the preference **Use Graphics Card to Accelerate Enhancement Tools** to **No**. Or, set this preference to the default value of **Yes** to accelerate raster operations, such as image stretching, sharpening, brightness, contrast, and so forth, using your computer’s graphics card instead of your computer’s central processing unit (CPU). All of the following criteria must be met for this preference to be effective:

- Your graphics card must support OpenGL 2.0 and must have the most recent drivers installed.
- You must set the **Zoom Interpolation Method** preference to **Nearest Neighbor**.
- The image data type must be byte, integer, unsigned integer, or floating-point.
- Your platform must be Windows or Linux.

If you experience problems using the Preview Portal or ENVI EX workflows:

- Update your graphic card with the most recent driver.
- Try setting the preference **Use Graphics Card to Accelerate Enhancement Tools** to **No**.

For images with very high spatial resolution, ENVI Zoom displays low-resolution tiles in the Image window while it retrieves the full-resolution data as long as the **Use Low Resolution Tile Cache** preference is set to the default value of **Yes**. If you have a slow processor, you may set this preference to **No**, which should improve display performance. If you set this preference to **No**, nothing is visible in the Image window until ENVI Zoom loads each tile.

In the case of very large vector files (those with over 50K records), it is recommended that you view individual attributes using the Cursor Value window rather than attempting to use the **View Attributes** option. Using this method will help in avoiding lengthy wait times as the Attribute table is populated and displayed. For more information on vectors, see "Displaying ESRI Layers and Feature Classes" on page 63 and "About Vectors" on page 94.
Chapter 3: Opening and Displaying Data

In this chapter you will find:

Supported File Formats ................................................................. 52
Opening Files in ENVI Zoom ......................................................... 53
Opening Files from ENVI Zoom into ENVI ..................................... 55
Displaying Large Images ............................................................... 56
Quad Display and Data Reduction for Vector Layers .................... 58
The Data Manager ........................................................................ 60
Opening Remote Datasets ............................................................. 66
Geo Link to ArcMap ....................................................................... 77
Supported File Formats

**ENVI Zoom -Supported Formats**

- Digital Terrain Elevation Database (DTED):
  - .dt0: Level-0 data with a spatial resolution of 30 arc seconds
  - .dt1: Level-1 data with a spatial resolution of 3 arc seconds
  - .dt2: Level-2 data with a spatial resolution of 1 arc second
- ENVI annotation (.ann)
- ENVI Zoom annotation (.anz)
- ENVI raster and classification images
- ENVI vector (.evf)
- ERDAS IMAGINE: ENVI Zoom reads and displays .img files, and it uses .ige spill files for large images if needed.
- GeoTIFF (.tif, .tiff)
  See "GeoTIFF Map Information" on page 29.
- GeoTIFF with metadata (.met, .txt)
  See "Opening Landsat GeoTIFF Files with Metadata" on page 53.
- JPEG (.jpg)
- JPEG 2000 (.jp2, .j2k)
- MrSID (.sid)
- NITF 1.1, 2.0, and 2.1 (.nitf, .ntf)
- NSIF 1.0 (.nsf)
- RapidEye (.xml)
  See "Opening Files in ENVI Zoom" on page 53 for instructions on reading RapidEye data.
- SPOT DIMAP (.dim)

ENVI Zoom reads and displays data from any sensor as long as the files are in one of the above formats. See "Opening Files in ENVI Zoom" on page 53 for more detailed instructions on reading Landsat, RapidEye, and GeoEye-1 data.

**GIS-Ready Formats**

- ESRI Geodatabase (.mdb, .gdb, .sde)
  - ESRI simple/standalone feature class
  - ESRI raster dataset
- ESRI Layer (.lyr)
- Shapefile (.shp)
- ESRI GRID (hdr.adf) with the exception of classification names and color tables
Opening Files in ENVI Zoom

1. Select File > Open from the menu bar, or click the Open button on the main toolbar or the Data Manager toolbar. Windows users can click and drag a file from ArcMap, ArcCatalog, or the Windows file manager into the Image window. The Open dialog appears.

2. Select a file to open. To filter the list of input files by data type, click the Files of type drop-down list and select a data type.

3. Click Open.

By default, ENVI Zoom automatically displays a true-color image, a grayscale image, an annotation layer, a vector layer, an ESRI feature class, or an ESRI layer based on your file type. You can change the Auto Display Files On Open default in the Data Manager preferences. If you choose not to automatically load the data, the Data Manager appears (see "The Data Manager" on page 60 for more information).

For images, ENVI Zoom uses information from the image metadata to determine how to automatically load the image. The following items assume the Auto Display Method For Multispectral Files preference is set to True Color.

- If the image has wavelength information and bands are available for visible red, green, and blue wavelengths, they will be assigned red, green, and blue.
- If the image has wavelengths, but they are not in the visible region, or the image does not have wavelength information, the following rules apply:
  - If the image has three bands, ENVI Zoom assumes that they are red, green, and blue (in that order), and assigns band 1 to red, band 2 to green, and band 3 to blue.
  - If the image has four bands, ENVI Zoom assumes that they are blue, green, red, and near infrared (in that order), and assigns band 3 to red, band 2 to green, and band 1 to blue.
  - If the image has more than four bands, ENVI Zoom loads band 1 into a grayscale display.

Note: If the image is in NITF format and has default bands set, this will take precedence.

ENVI Zoom supports the following annotation items from ENVI .ann files: text, square/rectangle, circle/ellipse, polygon, polyline, arrow, symbol, and picture.

ENVI Zoom does not support map scale bars, image color ramp, map key, declination arrow and plot annotation items from the .ann file, and therefore does not display them if they are present. If you open an .ann file that contains only unsupported types, an information dialog appears.

Opening Landsat GeoTIFF Files with Metadata

ENVI Zoom reads Landsat (MSS, TM and ETM+) metadata files from the Global Land Cover Facility (GLCF) or from the U.S. Geological Survey (USGS). The metadata files provide information needed to open the associated imagery. Select File > Open from the menu bar. In the Open dialog, select a .met file for GLCF Landsat data or a .txt file for USGS Landsat data. The Data Manager displays the band and wavelength information for the Landsat multispectral bands first, followed by the thermal band and the panchromatic band.

Opening RapidEye Files

ENVI Zoom reads and displays RapidEye Level-1B (Basic) and Level-3A (Ortho) data. A Level-1B scene consists of five co-registered NITF 2.0 files (one for each band) with associated rational polynomial coefficients (RPCs).
When you open the *metadata.xml file associated with a Level-1B image, ENVI Zoom opens all five bands at once. To view a single band of data, open the corresponding NITF file.

Level-3A images are distributed as GeoTIFF files with associated metadata. Each GeoTIFF file contains five bands of data. Opening the GeoTIFF or XML file distributed with the data will load all five bands into ENVI Zoom at once; however, opening the XML file will also load the associated metadata.

**Opening GeoEye-1 Files**

ENVI Zoom reads and displays GeoEye-1 data in NITF and GeoTIFF formats. An individual GeoTIFF file may only contain one band of data, while another may contain a combination of multispectral bands. In either case, you can either open the individual GeoTIFF file directly, or select the *metadata.txt file if it is available. The metadata file provides the information needed to open the appropriate GeoTIFF files.
Opening Files from ENVI Zoom into ENVI

You can open a file from the ENVI Zoom Data Manager into ENVI. The file must be a saved file; you cannot open in-memory files. Additionally, the file cannot be opened in ENVI Zoom via an OGC server.

1. Select **File > Data Manager** from the menu bar. The Data Manager opens.
2. Select the file(s) to open in ENVI.
3. Click the **Open Selected Files in ENVI** button. ENVI starts, and the selected files are added to ENVI’s Available Bands List (for images) or the Available Vectors List (for vector layers). See the *ENVI User’s Guide* for more information.
Displaying Large Images

Many modern remote sensing datasets from high-resolution sensors have a large file size; some images are several gigabytes. ENVI Zoom manages the display of large raster datasets using three primary methods, described below.

Reduced Resolution Data Sets

Some remote sensing images include reduced resolution data set (RRDS) files to speed the display of the imagery. RRDS files (also called RSETs) are versions of the original image at various reduced resolutions. ENVI Zoom uses the RRDS files to display imagery in the Image window when you zoom in or out of the display. RRDS files take precedence over any existing pyramid files when displaying large images in the Image window. If RRDS files are not available, ENVI Zoom creates and uses pyramids to display the images.

ENVI Zoom currently supports RRDS files generated by RemoteView, with file extensions of \texttt{.rv1} through \texttt{.rvn}. Each progressive number represents a spatial resampling twice that of the previous file. These files are in NITF 2.1 uncompressed format, so you must have a NITF/NSIF Module license installed before ENVI Zoom will use RRDS files to display these images.

Pyramids

For large data files, ENVI Zoom builds pyramids in the background while loading the image into the display and prior to displaying the image in the Overview window. ENVI Zoom does not build pyramid files for JPEG files (these are read into memory), JPEG 2000 files (which can return data at different resolutions), and files with spatial dimensions less than or equal to 512 x 512.

Pyramids are copies of the data file at various reduced resolutions. They are used to speed image display by reducing the resampling required when displaying large portions of an image at low resolution. The Process Manager in the Status bar shows the progress of building pyramids when you open a data file. ENVI Zoom only builds pyramids for a large data file the first time you open it. When you open the data file thereafter, it displays more quickly because it accesses the previously built pyramid file.

By default, pyramid files are created in the directory containing the original data file. If this directory is unavailable (due to write permission, for example), ENVI Zoom attempts to create the pyramid file in directory set in the \textbf{Alternate Header Directory} preference. If this is not available, ENVI Zoom uses the IDL temporary directory. Note that files on network drives may be slower to build pyramids due to network issues.

You can set preferences to disable pyramid creation or to specify the minimum data dimensions for creating pyramids. See "Pyramid Preferences" on page 44 for more information.

Tiles

Typical desktop and workstation computers running image processing software cannot feasibly load an image that is several gigabytes into memory at once and display it as a single unit. ENVI Zoom manages the display of large datasets by dividing them into discrete chunks called tiles.

ENVI Zoom initially creates an image without any data. It only loads image pixels when a tile section comes into view through panning or zooming. Depending on the file size and performance, you may see a grey tile until ENVI Zoom retrieves the proper tile to display. Tiling combined with the use of pyramids ensures the quickest display of large images.
If you set the **Use Low Resolution Tile Cache** preference to **Yes** on images with very high spatial resolution, ENVI Zoom displays low-resolution tiles in the Image window while it retrieves the full-resolution data.
Quad Display and Data Reduction for Vector Layers

When you open a vector file, ENVI Zoom automatically organizes the data into quadtrees. It partitions the geometrical entities into four spatial quadrants until each cell (or bucket) reaches its maximum capacity (set in the Maximum Vertices Per Quad Node preference). When a bucket reaches maximum capacity, it splits; this process continues until all of the data is subdivided. Quadtrees (`.qtr`) are located in the same directory as the original file; if that directory is read-only, the file is created in the directory set in the Temporary Directory preference.

If the Build Reduced Vertices File preference is set to Yes, ENVI Zoom performs data reduction on files with high-density vertex data to improve rendering performance. If data reduction is needed, ENVI Zoom builds the necessary files after the quadtree file is complete. Until ENVI Zoom finishes creating the reduced resolution shapefiles, the view in the Image window will show some of the quadtrees as bounding boxes with an X through them (see figure below). This means that data is present but could not be loaded into memory.

Once the reduced resolution shapefiles are available, the display is updated by replacing the bounding boxes with the vector data (see figure below). Reduced resolution filenames are the same as the original file, with `_reduced` appended to the name. The files are located in the same directory as the original file; if that directory is read-only, the files are created in the directory set in the Temporary Directory preference.

A third file type is created when a vector layer is drawn in the Overview window for the first time. ENVI Zoom creates a rasterization file (`.zrf`), which is used to display the vector layer in the Overview window. Rasterization files are located in the same directory as the original file; if that directory is read-only, the file is created in the directory set in the Temporary Directory preference.

The following example shows the Image window before the quadtree file completes, with quadtrees shown as bounding boxes.
The Data Manager

The Data Manager lists the files that you have opened and makes them accessible to load into your display. By default when you open a file, ENVI Zoom attempts to automatically display that file based on the file type and does not display the Data Manager. You can change this preference and other Data Manager preferences using the File > Preferences menu option described in "Data Manager Preferences" on page 40.

When you open a file, ENVI Zoom adds a new item to the bottom of the Data Manager tree. You can open multiple files in one ENVI Zoom session, and you can choose which of those files to display and how to display them using the Data Manager. You can expand and collapse files in the Data Manager tree by clicking the + or - next to the filename.

You can access the Data Manager during any ENVI Zoom session by selecting File > Data Manager from the menu bar, or by clicking the Data Manager button. You can enable the Display Data Manager when Launching ENVI Zoom preference to always automatically open the Data Manager at startup.

Data Manager Toolbar

<table>
<thead>
<tr>
<th>Button</th>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Open]</td>
<td>Open</td>
<td>Open a data file.</td>
</tr>
<tr>
<td>![Expand All]</td>
<td>Expand All</td>
<td>Expand all of the files in the Data Manager to show band names.</td>
</tr>
<tr>
<td>![Collapse All]</td>
<td>Collapse All</td>
<td>Collapse all of the files in the Data Manager so that only filenames are shown.</td>
</tr>
<tr>
<td>![Close File]</td>
<td>Close File</td>
<td>Select a file in the Data Manager, then click this button to close that file.</td>
</tr>
<tr>
<td>![Close All Files]</td>
<td>Close All Files</td>
<td>Close all files that are currently open. This option removes all files from the Layer Manager.</td>
</tr>
<tr>
<td>![Pin/Unpin]</td>
<td>Pin/Unpin</td>
<td>Toggle whether to have the Data Manager persist on the screen or automatically close when layers are loaded into the display. <strong>Unpin</strong> the Data Manager to have it automatically close when you load a file into the display.</td>
</tr>
<tr>
<td>![Open Selected Files in ENVI]</td>
<td>Open Selected Files in ENVI</td>
<td>Open the selected file(s) in ENVI. The file must be a saved file; you cannot open in-memory files. You cannot open ESRI layers in ENVI. The selected files are added to ENVI’s Available Bands List (for images) or the Available Vectors List (for vector layers). See the ENVI User’s Guide for details about using ENVI.</td>
</tr>
</tbody>
</table>
Displaying Multispectral Images

When you open a multispectral image file, a multispectral icon appears next to the filename in the Data Manager.

1. When you click on band names in the Data Manager, color gun assignments will automatically cycle through red, green, then blue (in that order). Click the band name you want to assign to red. A red box appears next to the band name.

2. Repeat for the green and blue bands. Colored boxes appear next to the bands to indicate which color is assigned to those bands. If one band is assigned multiple colors, a split box appears next to the band name showing the colors.

3. Click Load Data. ENVI Zoom loads an RGB image into a new layer and automatically displays the image in the Image window.

Open Selected Files in ArcMap
(Requires ArcMap license and runs on Windows 32-bit only)

Open the selected file(s) in ArcMap. When you click this button, the Process Manager updates to show export progress to ArcMap. The Process Manager displays the progress, but the coordination between ENVI or ENVI Zoom and ArcMap does not allow the process to be canceled once initiated.

If you have one or more instances of ArcMap already running, an ArcMap Instances dialog appears. Select an instance of ArcMap to display your dataset, or start a new instance of ArcMap. Click OK.

If ArcMap is not already running, ENVI Zoom will initiate it for you. The dataset will display in ArcMap with ArcMap’s default enhancements and will be added as a new layer to the ArcMap table of contents.

Raster datasets in GeoTIFF or NITF format, those stored in a geodatabase, and those referenced by an ESRI layer, can pass directly into ArcMap software without any conversion. For all other formats, ENVI Zoom temporarily converts the datasets to GeoTIFF format before passing them to ArcMap. These are stored in the location you specify as the Temporary Directory in the ENVI Zoom Directories preferences.

Vector datasets in shapefile format, feature classes in a geodatabase, and feature classes referenced by an ESRI layer can pass directly into ArcMap software without any conversion. ENVI Zoom temporarily converts any ENVI vector format (EVF) datasets to shapefile format before passing them to ArcMap. These are stored in the location you specify as the Temporary Directory. You cannot export vector data with unsaved edits to ArcMap. You must first commit your edits or revert to the original vectors before exporting them.

Datasets exported to ArcMap remain open in ENVI Zoom.
Displaying Different Bands from the Same Multispectral Image

To assign a new RGB combination, click a different band name you want to assign to red, then continue with the green and blue selections.

Automatically Loading True Color, Color Infrared, or Default Bands

Information for how an image will be automatically loaded into ENVI Zoom is taken from the image header file. If this information is not available, the options below will not be accessible.

- To load a true-color image into the display, right-click on a filename in the Data Manager and select Load True Color.
- To load a color-infrared (CIR) image into the display, right-click on a filename in the Data Manager and select Load CIR.
- Right-click on a filename in the Data Manager and select Load Default to display an image for which you have assigned default bands in the associated ENVI header. See “Setting Default Bands to Load” in ENVI Help for details. If you do not define default bands to load but the image file contains wavelength information, Load Default uses the Auto Display Method For Multispectral Files preference.

Selecting Bands to Display

The Band Selection category of the Data Manager is collapsed by default. You can expand or collapse this category by clicking the arrow next to the category name. Band Selection provides another way to assign bands to RGB color guns. This approach is especially useful for hyperspectral images with hundreds of bands.

1. Click the Red button, then click the band name you want to assign to red.
2. Click the Green button, then click the band name you want to assign to green.
3. Click the Blue button, then click the band name you want to assign to blue.
4. Click Load Data. ENVI Zoom loads an RGB image into a new layer and automatically displays the image in the Image window.

Displaying Grayscale or Classification Images

When you open a single-band image file in the Data Manager, a grayscale icon appears next to the filename. When you open a classification image, a classification icon appears next to the filename.

- For a single-band image, select the band and click Load Data. ENVI Zoom loads the image into a new layer and displays the classification or grayscale image in the Image window.
- Right-click on a filename and select Load Grayscale. ENVI Zoom loads a grayscale image into a new layer and displays the image in the Image window. For a multispectral image, this will result in the first band being displayed.
- For a multispectral image, right-click on a band name that you want to view as a grayscale image, and select Load Grayscale. ENVI Zoom loads a grayscale image from that band into a new layer and displays the image in the Image window.
Displaying ESRI Layers and Feature Classes

When you open an ESRI layer in the Data Manager, an icon appears next to the filename to indicate the layer type (▲ for raster, ◆ for points, ◆ for lines and polygons).

- Select the ESRI layer name(s) and click **Load Data**. ENVI Zoom loads the ESRI layer and displays it in the Image window. Layer files will be displayed in the Layer Manager and Data Manager with the layer name (not the filename).

- You can also expand the ESRI layer, select the data source, and load the source data (see "Displaying Grayscale or Classification Images" on page 62, "Displaying Multispectral Images" on page 61, or "Displaying Vector Layers" on page 63). ENVI Zoom loads the ESRI layer’s data source and displays it in the Image window.

  **Note:** Layer files in ArcGIS consist of a set of rules for displaying and working with datasets. Information in files can include symbols, classifications, labeling rules, and other information describing the appearance and actions of the layer. When visualizing an ESRI layer, ENVI Zoom inherits properties from ArcGIS. If you open the source data for an ESRI layer, you will be using ENVI Zoom properties (e.g. stretch) and the two may not display the same way.

- You can load multiple ESRI layers with the same filename into the Data Manager.

  **Note:** Layer files reference data sources, they do not include the actual data. If referenced data in a file is renamed or moved, the layer files must be updated in ArcMap or ArcCatalog to use the new path. For more information on files and data sources, see the ArcGIS Help.

When you open an ESRI simple/standalone feature class in a geodatabase in the Data Manager, an icon appears next to the filename to indicate the type (▲ for multispectral raster, ◆ for grayscale raster, ◆ for points, ◆ for polygons, ◆ for polylines). See "Using the Remote Connection Manager" on page 71 for more information on connecting to and opening feature classes from a geodatabase.

- Select the feature class name(s) and click **Load Data**. ENVI Zoom loads the feature class and displays it in the Image window.

  **Note:** You cannot edit a vector layer originating from a geodatabase or referenced by an ESRI layer. However, you can access and edit the source data for an ESRI layer. For more information on ESRI layers, see "Displaying ESRI Layers and Feature Classes" on page 63.

Displaying Vector Layers

When you open a vector layer in the Data Manager, an icon appears next to the filename to indicate the vector type (◆ for points, ◆ for polygons, ◆ for polylines). See also "Displaying ESRI Layers and Feature Classes" on page 63.

- Select the vector layer name(s) and click **Load Data**. ENVI Zoom loads the vector layer and displays it in the Image window.

- Right-click on a vector layer name and select **Load Vector**. ENVI Zoom loads the layer and displays it in the Image window.

- Use **Ctrl** or **Shift** keys and click to select multiple filenames, then right-click and select **Load Files**. ENVI Zoom loads the layers and displays them in the Image window.
Displaying Annotation Layers

When you open an annotation layer in the Data Manager, an icon appears next to the filename to indicate the layer type (A).

- Select the annotation layer name(s) and click **Load Data**. ENVI Zoom loads the annotation layer and displays it in the Image window.
- Right-click on an annotation layer name and select **Load Annotation**. ENVI Zoom loads the layer and displays it in the Image window.

Closing Files

If you attempt to close a file that is currently being displayed, a prompt appears to ensure you want to close that file and remove the layers containing those bands.

- To close a single file, right-click on a filename in the Data Manager and select **Close File**, or click the **Close File** button on the Data Manager toolbar.
- To close all files that are currently open, right-click on any filename in the Data Manager and select **Close All Files**, or click the **Close All Files** button on the Data Manager toolbar.
- To close selected files that are currently open, use **Ctrl** or **Shift** keys when you click to select multiple filenames in the Data Manager, then click the **Close File** button or right-click and select **Close Files**.

Accessing File Information

The File Information category of the Data Manager provides detailed information about the files listed in the Data Manager. This category is collapsed by default. You can expand or collapse this category by clicking the arrow next to the category name. When expanded, the File Information category lists information derived from the file header.

You cannot edit the File Information fields. To edit header information, open ENVI (see “Editing Header Files” in ENVI Help).

**Raster File Information**

- **File**: Filename, including the full path.
- **Dims**: File dimensions, including number of lines, samples, and bands; and interleave (BIL, BIP, or BSQ).
- **Data Type**: Data type (unsigned integer, byte, etc.)
- **Size**: File size in bytes. This information is available for all datasets except for WCS, WMS, and JPIP remote datasets.
- **File Type**: File format.
- **Wavelength**: Wavelength range, if wavelength information is available.
- **Projection**: Projection name (for georeferenced images), including datum and pixel size. If the file contains rational polynomial coefficient (RPC) information, the text *RPC* precedes the projection type.
- **Upper Left Corner**: Image coordinates for the upper-left pixel in the image for images with XSTART and YSTART values (extracted from the ENVI header). If your image is a spatial subset of a larger image, the image coordinate system references the parent (or larger) image.
Vector Layer Information

- **File**: Filename, including the full path.
- **Shape Type**: Type of vector record (Point, Polyline, Polygon).
- **Number of Records**: Number of vector records in the file.
- **Number of Vertices**: Number of vertices in the file.
- **Number of Quad-Tree Nodes**: Number of quadtree nodes created.
- **File Size**: File size, in bytes.
- **Attributes**: Indicates whether or not an attribute table exists for this layer.
- **Projection**: Projection name (for georeferenced data), including datum and measurement units.

Annotation Layer Information

- **File**: Filename, including the full path.
- **Number of Annotation Items**: Number of annotation items in the file.
- **Number of Quad-Tree Nodes**: Number of quadtree nodes created. Annotations currently use only one node.
- **Projection**: Projection measurement units.

ESRI Layer Information

- **File**: Filename, including the full path.
- **Data Name**: ESRI layer name (name displayed in the ArcMap Table of Contents).
- **Layer Type**: Feature Layer or Raster Layer
- **Shape Type** (for ESRI feature classes only): Type of vector record (Point, Polyline, Polygon).
- **Data Type** (for ESRI raster layers only): Data type (unsigned integer, byte, etc.)
- **Dims**: File dimensions, including number of lines, samples, and bands; and interleave (BIL, BIP, or BSQ).
- **Top/Bottom/Left/Right**: The left, top, right, bottom coordinates of the raster dataset.
- **Projection**: Projection name (for georeferenced data), including datum and measurement units.
Opening Remote Datasets

Use File > Open Remote Dataset or File > Remote Connection Manager to access data from the following types of Web servers:

- OGC: for Web Map Service (WMS) and Web Coverage Service (WCS)
- JPEG 2000: for JPEG 2000 Internet Protocol (JPIP) and Image Access Solutions (IAS)
- Geodatabases: (only accessible from File > Remote Connection Manager)

See "Using the Remote Connection Manager" on page 71 and "Using the Open Remote Dataset Dialog" on page 68 for steps.

Also see "Remote Connectivity Preferences" on page 48 for descriptions of the preferences associated with opening and viewing remote datasets.

Supported Platforms

Supported platforms vary by connection type:

<table>
<thead>
<tr>
<th>Connection Type</th>
<th>Windows 32-bit</th>
<th>Windows 64-bit</th>
<th>Mac OS X PPC 32-bit</th>
<th>Mac OS X 32-bit</th>
<th>Mac OS X 64-bit</th>
<th>Linux 32-bit</th>
<th>Linux 64-bit</th>
<th>Solaris 32-bit</th>
<th>Solaris 64-bit</th>
</tr>
</thead>
<tbody>
<tr>
<td>ArcGIS® geodatabase a,b</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Connect to and read from geodatabase</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save to file or personal geodatabase</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save to enterprise SDE geodatabase c</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>IAS and JPIP a</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>OGC WCS and WMS</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

a Windows users: these functions only run in 32-bit mode. If you have a 64-bit Windows PC and you want to use these functions, run ENVI or ENVI Zoom in 32-bit mode from the Windows Start menu.

b Supported on ArcGIS® Desktop 9.2 and later; tested on Windows XP 32-bit and Vista 32-bit with ArcGIS® Desktop 9.3.

c Requires an ArcInfo® or ArcEditor™ license (ArcView® software does not support this feature).

OGC Servers

The Open Geospatial Consortium (OGC) provides a variety of protocol specifications for transmitting geospatial data via the web. ENVI and ENVI Zoom will support two of these specifications: WMS and WCS.
See http://www.opengeospatial.org for more information.

OGC servers have several common features:

- Data are sent as image files. The supported formats are JPEG 2000, JPEG, and TIFF/GeoTIFF formats. If a dataset you are querying cannot be transmitted in one of these formats, you cannot open the dataset.

- You can customize data delivery by specifying a spatial extent, interpolation type, pixel size, and map projection, which saves you from reading unwanted data for regions you are not interested in. ENVI and ENVI Zoom can manage the details of server requests, such as downloading data tiles, deleting temporary files, and reading data.

- OGC servers provide a directory listing service called GetCapabilities to list OGC datasets available on any server, or you can directly connect to an OGC dataset.

**OGC WCS**

WCS is a protocol for serving raster data that represent properties of geographic locations. WCS servers provide coverages that you can manipulate. WCS servers list datasets at one level instead of in a folder hierarchy.

**OGC WMS**

WMS is a protocol for serving maps that are generated on-the-fly for display purposes only. A powerful feature of WMS servers is that you can identify multiple datasets that meet your criteria, and the server combines them into one displayable map layer. WMS servers do not specify a pixel size for a given dataset, so ENVI and ENVI Zoom will estimate a default pixel size. You can change this value by setting the **WMS Pixels Per Side** preference. WMS servers list datasets on the server in a folder hierarchy.

**JPEG 2000 Servers**

OGC and JPIP servers support delivery of image data at different resolutions that are automatically resampled by the servers. IAS and JPIP servers send compression parameters known as wavelets, while OGC servers send actual image files. This means that ENVI and ENVI Zoom can read any IAS server dataset.

**Note:** If you are working on a Windows 64-bit platform, you need to start ENVI or ENVI Zoom in 32-bit mode to access data from JPIP or IAS servers.

**Note:** To view datasets from IAS and JPIP servers, you need a server that uses the ISO/IEC 15444-9 JPEG 2000 standard (JPEG 2000 Internet Protocol). IAS 3.x and higher provides support for this version of the standard.

**JPIP**

JPIP is a client-server protocol used to serve JPEG 2000 compressed imagery (.jp2, .j2c, and .jpx). No directory listing service is available with JPIP servers; you must specify the full path to a dataset you want to view, for example:

```
jpip://exampleservername:1234/file.jp2
```

If a dataset from a JPIP server contains map information, it is stored in the file header using a GeoJP2 protocol. ENVI or ENVI Zoom will attempt to read and import map information and apply it to the input file whenever possible.

**IAS**
The IAS product, available from ITT Visual Information Solutions, provides a server that streams JPEG 2000 and NITF 2.1 C8 compressed imagery using the JPIP protocol, which you can display and analyze. IAS supports full JPIP streaming capabilities, plus it provides a directory listing service, NITF support, and a tool to convert any image file to JPEG 2000 or NITF 2.1 C8 formats. ENVI and ENVI Zoom will not support opening CMYK compressed JPEG 2000 files using an IAS server.

An IAS server lists datasets in a hierarchy similar to that of a file system. You can browse data from an IAS server in ENVI and ENVI Zoom.

An IAS server can list datasets that are not JPEG 2000 compressed, but it cannot serve them. An error message appears if you attempt to open this type of dataset from an IAS server. Once you select a JPEG 2000 compressed dataset through an IAS server, you can also access metadata.

IAS servers retain and serve metadata associated with NITF datasets. ENVI and ENVI Zoom can read and interpret NITF metadata, including map and wavelength information, as well as file and image metadata, text segments (if present), and most tagged record extensions (TREs). If map information is not present in NITF metadata, the dataset is read in from a GeoJP2UUID box, if present.

For more information about IAS functionality, refer to the ITT Visual Information Solutions website.

Geodatabases

The ArcGIS geodatabase is a data storage mechanism that allows for many types and sources of geographic data, both raster and vector, to be supported in a consistent manner. ENVI Zoom supports reading and writing to personal geodatabases (in Microsoft Access .mdb format), file geodatabases, and enterprise geodatabases.

See "Using the Remote Connection Manager" on page 71 for instructions on reading geodatabase files and "Selecting an Output Geodatabase" on page 134 for instructions on writing to a geodatabase.

Using the Open Remote Dataset Dialog

The File > Open Remote Dataset menu option is useful when you are already familiar with the connection details of the dataset you want to open. You cannot use the Open Remote Dataset dialog to access a server, only a specific dataset. The Open Remote Dataset dialog only connects to datasets on JPIP, IAS, and OGC servers.

For JPIP and IAS servers, the connection string consists of the IP address or server (host) name, port number, the path (relative to the server root), and filename. Preface the URL with http:// or jpip://. For example:

```
jpip://ias-server:80/data/jpg2000_file.jp2
```

The scheme is jpip://, the server name is ias-server, the port number is 80, the path is data/jpg2000_file.jp2, and the filename is jpg2000_file.jp2.

For OGC servers, the connection string consists of the server name, port number, CGI get request (followed by a question mark), and optional OGC keywords. Preface the URL with http://. See "OGC Connection Keywords" on page 69 for a list of keywords. For example:
Because no port number was specified in the example above, ENVI Zoom uses port 80 as the default.

You can also define a proxy server by setting the **OGC Proxy Server** preference.

Follow these steps to open a remote dataset:

1. Select **File > Open Remote Dataset** from the ENVI Zoom menu bar or **File > Open Remote File** from the ENVI main menu bar. The Open Remote Dataset dialog appears.

2. There are two ways to open a dataset from this dialog:
   - To open a new dataset, type (or paste) the connection string for the dataset in the **URL** field. Refer to the beginning of this section for examples and details about the format of the connection string.
   - If you have previously opened any datasets, an arrow appears next to the **URL** field. Click the arrow and select the dataset from the drop-down list.

3. Click **OK**.

4. If a username and password are required to log in to a server, the Connection Authentication dialog appears. See "Connection Authentication" on page 71 for details on logging in.

After you click **OK** and after authentication is complete (if required), the dataset is displayed and added to the Data Manager in ENVI Zoom or the Available Bands List in ENVI. If you opened an IAS dataset that contains metadata, you can view that metadata by right-clicking on the image in the Data Manager and selecting **View NITF Metadata**. The NITF Metadata Viewer dialog appears. If the NITF preference **Automatically View Metadata in ENVI Zoom** is set to **True**, the metadata are automatically displayed. See the NITF topics in this Help for more information.

**OGC Connection Keywords**

The OGC keywords specify details about what data to open on the server and how to open it. You specify the details by using standard keywords defined by OGC. Separate keywords from their values with an equal sign (=), and separate keyword/value pairs with an ampersand (&), for example: `width=500&height=500`. The following keywords are supported:

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WCS and WMS keywords</strong></td>
<td></td>
</tr>
</tbody>
</table>
Opening Remote Datasets

Using the Open Remote Dataset Dialog

The geographic extent (or bounding box) of the dataset. The keyword value enables you to subset the data to open from the server (for example, if the dataset contains data for the whole world and you need only data for Colorado). Enter values in the following order: minx, miny, maxx, maxy. The default is to open the entire dataset. Example:

```
bbox=23.73,37.97,23.752,37.984
```

The number of samples in the image when it is opened. The default for WCS is to use metadata from the image. The default for WMS is to use the base layer (if there is one) and use the pixel size of the base layer to calculate the width. If a base layer is not available, then width is determined by using the **WMS Pixels Per Side** preference. A square pixel size is selected, where the greater of the number of samples and lines are equal to the **WMS Pixels Per Side** value. Example: `width=500`

The number of lines in the image when it is opened. The default for WCS is to use metadata from the image. The default for WMS is to use the base layer (if there is one) and to use the pixel size of the base layer to calculate the height. If a base layer is not available, then height is determined by using the **WMS Pixels Per Side** preference. A square pixel size is selected, where the greater of the number of samples and lines are equal to the **WMS Pixels Per Side** value. Example: `height=500`

The format in which to transmit the data across the Internet. The format must be among the list of formats supported by the OGC server. The supported transmission formats are JPEG 2000, JPEG, and TIFF. The default is to first look for JPEG 2000 (lower transmission time). If the server does not support JPEG 2000, then it looks for any supported JPEG format, then any supported TIFF format. If the server does not support the specified format, it returns an error.

Example for WMS: `format=image/jpeg`
Example for WCS: `format=jpg`

**WCS-only keywords**

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>coverage</td>
<td>Required. The name of the dataset. Example: <code>coverage=srtmplus_raw</code></td>
</tr>
<tr>
<td>crs</td>
<td>The coordinate reference system of the image. This keyword value must be a string that comes from the list of reference systems supported by the server. Example: <code>crs=EPSG:4326</code></td>
</tr>
</tbody>
</table>

**WMS-only keywords**

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>layers</td>
<td>Required. The name of the layer. You can specify multiple, comma-delimited layers. ENVI and ENVI Zoom will allow the server to combine the WMS layers and display them as a single layer. Example: <code>layers=streets</code></td>
</tr>
<tr>
<td>srs</td>
<td>The spatial reference system of the image. This value must be a string that comes from the list of reference systems supported by the server. Example: <code>crs=EPSG:4326</code></td>
</tr>
<tr>
<td>style</td>
<td>The display style from the server-supported style list. This specifies how to display certain features, if used (for example, display a two-pixel yellow line for roads). Example: <code>style=visual</code></td>
</tr>
</tbody>
</table>
Connection Authentication

If a username and password are required to log in to a server or geodatabase, the Connection Authentication dialog appears. Perform the following steps:

1. Enter a **Username**.
2. Enter a **Password**. Passwords are displayed as a series of asterisks representing each character you type.
3. Click **OK** in the Connection Authentication dialog to attempt a connection using the specified login information. If the connection fails, an error message appears and the Connection Authentication dialog remains open so that you can reenter the login information.

**Note:** Your username and password are retained for as long as the server or dataset is open.

Using the Remote Connection Manager

Use the Remote Connection Manager dialog to connect to geodatabases and servers, to add a connection to a list of frequently visited servers, and to manage connection properties. If accessing datasets on a WMS server, you can also use this dialog to combine two or more datasets into one displayable map layer.

To open a remote dataset from the Remote Connection Manager dialog:

1. Select **File > Remote Connection Manager** from the ENVI Zoom menu bar or **Window > Remote Connection Manager** from the ENVI main menu bar. The Remote Connection Manager dialog appears.

You may also have accessed this dialog by clicking **Open Remote Dataset** in another dialog.

2. There are two ways to connect to a server or geodatabase from this dialog.
   - The dialog is initially empty. Click **Connection**, then select **New** and see the steps in “Managing Connection Properties” on page 74 to create a new connection.
If you have a commonly used connection that you have saved as a favorite, click **Favorites**, then select the server name from the menu. To add favorites to the Favorites list, see "Managing Favorites" on page 75. Connection may be slow.

The icons that appear in the Remote Connection Manager dialog differ depending on the connection type, to help you easily distinguish among the four types:

- WMS Server
- WCS Server
- IAS Server
- Geodatabase

3. Select the server or geodatabase from the Connection List. The list of available datasets appears in the Dataset List with icons that indicate the dataset type:

- IAS dataset
- WMS dataset
- WCS dataset
- Geodatabase: Raster
- Geodatabase: Point or multi-point feature class
- Geodatabase: Polygon feature class
- Geodatabase: Polyline feature class
- Geodatabase: Unsupported data type

Select the dataset to open from the Dataset List. The properties for the selected dataset appear in the Properties List. If needed, you can edit some of the properties before opening the dataset, as described in "Editing Properties" on page 73.

**Note:** For OGC datasets only: if ENVI Zoom does not support one of the formats under the **Supported Formats** drop-down list (in the Properties List), you cannot open the dataset. You can view all of the dataset properties, but the **Open** button is disabled.

Additionally, some IAS datasets cannot be opened. When you select an IAS dataset from the Dataset List that cannot be opened, the properties do not display in the Properties List, and the **Open** button is disabled.

4. If you want to combine multiple datasets on a WMS server and open them as one map layer, select additional datasets from the Dataset List. You can multi-select datasets by pressing the **Ctrl** or **Shift** key as you select files.

5. Click **Open**. In ENVI Zoom, the dataset may be automatically displayed and added to the Layer Manager, depending on your display preferences. (See "Display General Preferences" on page 41.) If you opened multiple WMS datasets as one displayable map layer, the layer name in ENVI Zoom is a combination of all selected dataset names. If you opened an IAS dataset that contains metadata, you can view that metadata as described in "Viewing NITF Metadata" in ENVI Zoom Help. You cannot use ENVI Zoom’s vector tools to edit a vector layer originating from a geodatabase.

If ENVI and ENVI Zoom are both running from the same IDL session, the dataset is opened in both applications. Refer to the following if you are only running one application:
**ENVI:**

Raster datasets are added to the Available Bands List. Vector datasets are added to the Available Vectors List. You cannot use the Edit Header dialog to change header values for datasets on a server or in a geodatabase, and you cannot use ENVI’s vector tools to edit a vector layer originating from a geodatabase. If you opened an IAS dataset that contains NITF metadata, you can view that metadata as described in "Viewing NITF Metadata from IAS Datasets" in ENVI Zoom Help.

6. If you have connected to a geodatabase and datasets are added to or removed from the geodatabase while you are working in ENVI Zoom, you can refresh the Remote Connection Manager to see the updates. In the Remote Connection Manager, click **Connection** and select **Refresh**, or right-click on a geodatabase name in the Connection List and select **Refresh**. The Dataset List updates to show the changes.

**Editing Properties**

Edits you make to dataset properties apply to the current dataset only. The properties you can edit depend on the server type. The following describes the properties you can edit:

<table>
<thead>
<tr>
<th>Geodatabases</th>
<th>You cannot edit properties in personal, file, or enterprise geodatabases.</th>
</tr>
</thead>
<tbody>
<tr>
<td>IAS</td>
<td>All properties from IAS servers are read-only. Raw JPIP servers cannot display properties. The JPEG 2000 compression properties that are always available for viewing are Number of Layers, Number of Components, Number of Discard Levels, Progression, Number of Tiles, Bit Depth, and flags to indicate if the data are reversibly compressed, YCC rotated, or signed.</td>
</tr>
<tr>
<td></td>
<td>• If XML boxes or UUID boxes are present in the dataset, you can select from their respective drop-down lists to view them in a separate window.</td>
</tr>
<tr>
<td></td>
<td>• If NITF metadata is present in one of the XML boxes, the NITF metadata is imported if the file is opened, but only the XML data are accessible in the Remote Connection Manager’s Properties List.</td>
</tr>
<tr>
<td></td>
<td>• If a GeoJP2 style UUID box is present, the map information is extracted and the following fields are added to the properties listing: Projection, Top Boundary, Left Boundary, X Pixel Size, and Y Pixel Size.</td>
</tr>
<tr>
<td>WCS</td>
<td>The WCS properties you can edit are Formats, Coordinate System, Boundary (Top, Bottom, Left, and Right), Interpolation Type, and Pixel Size (X and Y).</td>
</tr>
<tr>
<td></td>
<td>• Formats, Coordinate System, and Interpolation Type are drop-down lists containing the values provided by the server. Select the value from the drop-down list.</td>
</tr>
<tr>
<td></td>
<td>• Boundary and Pixel Size values are derived from the coverage data. You can manually edit these values to customize the geographic extent and resolution of the dataset to open.</td>
</tr>
</tbody>
</table>
Opening Remote Datasets

Using the Remote Connection Manager

Managing Connection Properties

The Connection Properties dialog lets you enter connection information for a new connection or edit the name of an existing connection.

1. Choose one of the following:
   - To enter properties for a new connection, click Connection and select New. The Connection Properties dialog appears. The fields are initially blank.
   - To edit the name of an existing connection, select the connection you want to edit, click Connection and select Properties. Or, right-click on a server name in the Connection List and select Properties. The Connection Properties dialog appears. The fields are populated with the properties of that connection. You can only edit the connection name.

2. The URL field is optional and provides a convenient place for you to specify a path or connection details in a single string.

   If you press Enter or move to another field in the dialog, the remaining fields are automatically populated from the information in the URL. You can edit the fields described in Steps 3-8 if necessary. Or, click OK after entering a URL to connect as described in Step 10.

   Following are examples of URLs:

   **IAS**
   
   jpip://exampleserver:1234/

   **OGC WCS**
   
   http://exampleserver:1234/cgi-bin/mappserv.exe?map=/ogc_data/wcs_test.map&service=wcs

   **OGC WMS**
   
   http://exampleserver:1234/cgi-bin/mappserv.exe?map=/ogc_data/wms_test.map&service=wms
Enterprise geodatabase
exampleserver:5151

3. In the Name field, enter a custom name for the connection to help you recognize it in the Connection List. The default value is the name of the connection.

4. From the Type drop-down list, select from the available list of data sources. If you are editing existing connection properties, you cannot modify the selection. The choices are File Based Geodatabase, Personal Geodatabase, Enterprise (SDE) Geodatabase, OGC Web Coverage Service (WCS), OGC Web Map Service (WMS), and IAS Service. The list of available choices depends on your platform. (See "Supported Platforms" on page 66.)

5. For File Based Geodatabase or Personal Geodatabase, enter the Path to connect to.

6. For all other connection types, enter the Server name and the Port number you want to connect to. For Enterprise (SDE) Geodatabase, the port value is the instance.

7. If the connection type is Enterprise (SDE) Database, enter a required Database and transactional Version for querying Enterprise Database connections.

8. If the connection type is OGC, enter a required CGI Path for querying OGC connections, and you can enter an optional Prefix for querying OGC connections. This is a configuration string that is required to access the correct datasets on the server.

9. To open a file or personal geodatabase, select File Based Geodatabase or Personal Geodatabase from the Type drop-down list. Click the Open button. The Browse for Folder dialog appears. Select a geodatabase from your computer, and click OK. The Path field in the Connection Properties dialog is populated with the path and filename of the geodatabase.

10. Click OK in the Connection Properties dialog. ENVI or ENVI Zoom confirms the information you entered is valid and returns you to the Remote Connection Manager dialog. You may be prompted for a username and password if they are required. See "Connection Authentication" on page 71 for details.

If the connection does not respond or any of the connection information is invalid, an error message appears and the Connection Properties dialog remains open so that you can reenter the properties.

If you are connecting to an enterprise server and your database version string is not set to sde.DEFAULT, the Connection Details dialog appears. Select a transactional version from the Version Name list, or specify the details for a historical version. See “Creating Spatial Database Connections” in ArcGIS Desktop Help for details.

The new or edited connection becomes the active connection in the Remote Connection Manager dialog, and ENVI or ENVI Zoom queries that connection for available datasets and displays them in the Dataset List.

Managing Favorites

You can add commonly used connections to a list of favorites, so that you can easily open those connections in the future.

Note: The Favorites option is disabled for connections that require a password.

1. In the Remote Connection Manager dialog, select the connection name from the Connection List.

2. Select one of the following:
   • Right-click on the connection name and select Add to Favorites.
• Click Favorites and select Add to Favorites.

The Add to Favorites dialog appears.

3. Do any of the following:

• In the Name field, enter a custom name for the connection to help you recognize it in the Favorites List.

• If one or more folders exist in the Favorites List, select the folder into which to add the new favorite.

4. Click OK. The name is added to the Favorites List, which appears in the Remote Connection Manager dialog Favorites menu.

You can manage your Favorites List by creating folders in which to group favorites, by reordering favorites, and by deleting or renaming favorites. To manage favorites, click Favorites and select Manage to open the Favorites Manager dialog. This dialog contains the Favorites List.

• To create a new folder, right-click and select New Folder. The Enter Name dialog appears. Type a Name for the new folder and click OK. The new folder appears in the Favorites List.

• To reorder the Favorites List, or to move favorites to a folder, select the name from the Favorites List, then drag and drop the name to a new location.

• To rename a favorite or folder, right-click on the name in the Favorites List and select Rename. The Enter Name dialog appears. Type a new Name and click OK. The new name appears in the Favorites List.

• To delete a favorite or folder, right-click on the name and select Delete. The name is removed from the Favorites List. Deleting a folder deletes all of the connections and subfolders associated with it.

When you are finished working with the Favorites Manager dialog, click OK to close the dialog. To access a favorite connection, click Favorites and select the connection name.
Geo Link to ArcMap

The **Display** menu **Geo Link to ArcMap** option allows you to geographically link the same georeferenced image, or two images that are georeferenced, between the ENVI Zoom Image window and the active data frame in the ArcMap data view. Once linked, panning the image in ENVI Zoom or ArcMap will pan the image in the other application so that the center geolocation in both the ENVI Zoom and the ArcMap displays are the same. You can also move the image by moving the View box in the Overview window or by using the **Go To** tool in ENVI Zoom. The **Geo Link to ArcMap** feature is not supported in the ENVI Zoom Print Layout view or in the ArcMap layout view.

Geo Link to ArcMap currently supports datasets with the following types of georeferencing:

- Geographic coordinate systems
- Projected coordinate systems

Images with any other types of geo-referencing (RPC, RSM, affine map transformations kx/ky, pseudo projections, x/y start) are not supported in **Geo Link to ArcMap**.

To use the **Geo Link to ArcMap** feature:

1. Open the same georeferenced image or two different georeferenced images in ENVI Zoom and ArcMap.
2. From the ENVI Zoom menu bar, select **Display**, then click to enable/disable the **Geo Link To ArcMap** option.

   If you have more than one instance of ArcMap running, you will be prompted to select an instance to link to the Image window.

   If you change the active data frame in ArcMap after establishing a geo link, you will need to disable and re-enable the **Geo Link to ArcMap** option in ENVI Zoom.

   **Note:** **Geo Link to ArcMap** enables dynamic display in ArcMap; the symbology in ArcMap may vary slightly.

   **Note:** When **Geo Link to ArcMap** is enabled, ArcMap uses bilinear interpolation while zooming.
Chapter 4: Using Portals

In this chapter you will find:

About Portals ................................................................................................................. 80
Working with Portals ........................................................................................................ 81
About Portals

A Portal is a window inside the Image window that allows you to view multiple layers in the Layer Manager simultaneously. A Portal works as a separate layer (inside the Portals folder) in the Layer Manager.

The following example shows a Portal consisting of a multispectral image over a panchromatic image.
Working with Portals

A Portal is a window inside the Image window that allows you to view multiple layers in the Layer Manager simultaneously. A Portal works as a separate layer (inside the Portals folder) in the Layer Manager.

The following example shows a Portal consisting of a multispectral image over a panchromatic image.

To display a layer in a Portal, select one of the following options:

- Right-click on a layer in the Layer Manager and select **Display in Portal** to display that layer in a Portal.

- If you have two or more layers open, select **Display > Portal** from the menu bar or click the **Portal** button. If you have two layers open, the bottom layer in the Layer Manager tree is displayed in the Portal. If you have three or more layers open, the second layer in the Layer Manager tree is displayed in the Portal.

- You can load any displayed layer into an existing Portal by right-clicking in the Portal, selecting **Load New Layer**, and selecting the displayed layer from the list provided. This allows you to quickly change the layers displayed in the Portal.

Each time you create a new Portal in ENVI Zoom, it moves to the top of the Portals folder in the Layer Manager and becomes the selected layer (see "Selected Layers" on page 29 for more information). Displaying a layer in a Portal does not remove the layer from the Layers folder in the Layer Manager or from the Image window. You can remove the original layer without removing the Portal, you can reorder layers so that the original layer (now being displayed in the Portal) is at the bottom of the Layer Manager, or you can hide the original layer in the display without losing the view of that layer inside the Portal.

You can control the order of Portals in the Image window by dragging and dropping them within the Portals folder in the Layer Manager tree or by using menu options. Right-click on a Portal name in the Layer Manager and select **Order**. For more information on reordering Portals, see "Ordering Layers" on page 31.

As with other layers in the Layer Manager, selecting a Portal allows you to apply a display enhancement (brightness, contrast, transparency, etc.) to the Portal only, without affecting the associated layer or other layers.

Portals are displayed in the Image window but do not appear in the Overview window.
By default, Portals are displayed with a cyan border. You can toggle the border display on or off by right-clicking in a Portal and selecting Show Border.

**Portal Toolbar**

The Portal toolbar is only visible when multiple layers are open, the Select button on the toolbar is enabled, the Portal is the selected layer, and your cursor is at the top of the Portal. You cannot see the Portal toolbar (or the frame for small Portals) while using the Select, Pan, Fly, Crosshairs, Vector Edit, or Rotate tools.

<table>
<thead>
<tr>
<th>Button</th>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Pin" /></td>
<td>Pin</td>
<td>Pin the Portal to the top layer. When you pin the portal, the button then changes to Unpin. Click again to unpin the Portal from the layer. By default, Portals can be moved around the Image window by clicking and dragging the Portal. However, you can also attach (or pin) the Portal so that the Portal moves with the layer. This way, when you pan the layer, the Portal stays fixed to its original position relative to the data.</td>
</tr>
<tr>
<td><img src="image" alt="Zoom Lock" /></td>
<td>Zoom Lock</td>
<td>Lock the Portal’s zoom factor so that it remains fixed when zooming in the selected layer. You can zoom independently in the Portal using the Fixed Zoom In or Fixed Zoom Out buttons on the Portal toolbar. Click Zoom Lock again to unlock the Portal’s zoom factor. The Portal’s zoom factor resets to the selected layer’s zoom factor after you click the Fixed Zoom In or Fixed Zoom Out button on the Portal toolbar, and all subsequent zooming applies to both the selected layer and the Portal simultaneously.</td>
</tr>
<tr>
<td><img src="image" alt="Fixed Zoom In" /></td>
<td>Fixed Zoom In</td>
<td>Zoom in to the center of the Portal by a fixed percentage (the default is 1.25x, which can be set using the Zoom Factor preference described in &quot;Zoom Factor&quot; on page 41).</td>
</tr>
<tr>
<td><img src="image" alt="Fixed Zoom Out" /></td>
<td>Fixed Zoom Out</td>
<td>Zoom out of the center of the Portal by a fixed percentage (the default is 1.25x, which can be set using the Zoom Factor).</td>
</tr>
<tr>
<td><img src="image" alt="Play/Pause" /></td>
<td>Play/Pause</td>
<td>Activate the Flicker tool or pause/restart the Blend, Flicker, or Swipe operations. If you blend, flicker, or swipe in a Portal (using the right-click menu options), the button automatically changes to Pause so that you can pause the action if necessary. Click the button again to resume play.</td>
</tr>
<tr>
<td><img src="image" alt="Faster" /></td>
<td>Faster</td>
<td>Use with Blend, Flicker, or Swipe tools only. Click this button repeatedly to increase the speed of the action.</td>
</tr>
<tr>
<td><img src="image" alt="Slower" /></td>
<td>Slower</td>
<td>Use with Blend, Flicker, or Swipe tools only. Click this button repeatedly to slow down the speed of the action.</td>
</tr>
<tr>
<td><img src="image" alt="Close" /></td>
<td>Close</td>
<td>Close the Portal.</td>
</tr>
</tbody>
</table>

The right side of the Portal toolbar lists the current zoom extent. It updates whenever you click the Fixed Zoom In or Fixed Zoom Out buttons.

**Blending**
Blending allows you to gradually transition from one layer to another, by increasing the transparency of top layer. Because blending works using transparency, it is recommended that you not use the transparency enhancement slider when working with this tool. You can perform a manual blending operation by using the transparency slider on a Portal that is not in blend, flicker, or swipe mode.

You must have two or more layers open in the Layer Manager, and at least one of the layers should be displayed in the Image window.

1. Select **Display > Blend** from the menu bar, or click the **Blend** button on the toolbar.

   Blending automatically begins between the top layer and the layer below it in the Layer Manager. ENVI Zoom creates a new Portal that covers the entire Image window. You can swap the layers displayed in the Portal by right-clicking in a Portal and selecting **Load New Layer**.

   The top layer is initially opaque. Its transparency gradually increases until it is fully transparent. Then, the blend reverses.

2. To control the blending speed or to pause it, select the Portal layer in the Layer Manager, then use the controls available on the Portal Toolbar.

   **Note:** The Cursor Value information does not update as you move your mouse during a blending operation.

3. You can enhance the top layer anytime during the blending. See "Enhancement Tools" on page 22 for more information.

To blend from an existing Portal:

If you already have a Portal open inside of your layer, you can perform blending just within the Portal using the following steps:

1. Right-click in the Portal and select **Blend**. Blending automatically begins between the top layer in the Layer Manager and the layer that is in the Portal.

   The Portal size and location do not change. The top layer is initially opaque. Its transparency gradually increases until it is fully transparent. Then, the blend reverses.

2. To control the blending speed or to pause it, select the Portal layer in the Layer Manager, then use the controls available on the Portal Toolbar.

3. You can enhance the top layer anytime during the blending.

**Flickering**

Flickering allows you to toggle between two layers at a desired speed.

To flicker an entire layer:

You must have two or more layers open in the Layer Manager, and at least one of the layers should be displayed in the Image window.

1. Select **Display > Flicker** from the menu bar, or click the **Flicker** button on the toolbar.

   Flickering automatically begins between the top layer and the layer below it in the Layer Manager. ENVI Zoom creates a new Portal that covers the entire Image window. You can swap the layers displayed in the Portal by right-clicking in a Portal and selecting **Load New Layer**.

2. To control the flickering speed or to pause it, select the Portal layer in the Layer Manager, then use the controls available on the Portal toolbar.

   **Note:** The Cursor Value information does not update as you move your mouse during a flickering operation.
3. You can enhance the top layer anytime during the flickering. See "Enhancement Tools" on page 22 for more information.

To flicker from an existing Portal:

If you already have a Portal open inside of your layer, you can perform flickering just within the Portal using the following steps:

1. Right-click in the Portal and select Flicker. Flickering automatically begins between the top layer in the Layer Manager and the layer that is in the Portal. The Portal size and location do not change.
2. To control the flickering speed or to pause it, select the Portal layer in the Layer Manager, then use the controls available on the Portal toolbar.
3. You can enhance the top layer anytime during the flickering.

**Swiping**

Swiping allows you to spatially transition from one layer to another, using a vertical dividing line that moves between two overlapping layers.

1. Select Display > Swipe from the menu bar, or click the Swipe button on the toolbar.
   
   Swiping automatically begins between the top layer (shown in the right half of the Image window) and the layer below it in the Layer Manager (shown in the left half of the Image window). ENVI Zoom creates a new Portal that changes size as the swipe progresses. You can swap the layers displayed in the Portal by right-clicking in a Portal and selecting Load New Layer.
   
   The swipe moves at a default speed from left to right until it reaches the edge of the layer, then it reverses direction.
2. To control the swiping speed or to pause it, select the Portal layer in the Layer Manager, then use the controls available on the Portal toolbar.
   
   **Note:** The Cursor Value information does not update as you move your mouse during a swiping operation.
3. You can enhance the top layer anytime during the swipe. See "Enhancement Tools" on page 22 for more information.

To swipe from an existing Portal

If you already have a Portal open inside of your layer, you can perform swiping just within the Portal using the following steps:

1. Right-click in the Portal and select Swipe. Swiping automatically begins between the top layer in the Layer Manager and the layer that is in the Portal.
2. To control the swiping speed or to pause it, select the Portal layer in the Layer Manager, then use the controls available on the Portal toolbar.
3. You can enhance the top layer anytime during the swiping.

**Panning**

Click inside of a selected Portal and drag it to move it to a new location. By default, Portals move with the top layer as you pan in the Image window. However, you can also attach (or pin) the Portal to the top layer so that the Portal moves with the layer. This way, when you pan the layer, the Portal stays fixed to its original position relative to the data. See Portal Toolbar, above for more information.
Zooming

Right-click on a Portal name in the Layer Manager, select **Zoom To Portal**, and choose one of the following options:

- **Full Extent**: Zoom to the full extent of the Portal layer.
- **1:1**: Zoom to a 1:1 extent of the Portal layer.

You can also use the **Fixed Zoom In** and **Fixed Zoom Out** buttons in the Portal toolbar.

Resizing

You can resize a Portal by dragging its corners or sides to a preferred size. To resize a Portal so that it fills a specific area of the Image window, right-click inside the Portal, select **Resize Portal**, and choose one of the following options:

CLOSING PORTALS

To close a Portal, choose one of the following options:

- Right-click inside a Portal and select **Close Portal**.
- Click the **Close** button on the Portal toolbar.
- Right-click on the Portal layer name in the Layer Manager and select **Remove**.
Chapter 5: Image Processing

In this chapter you will find:

RX Anomaly Detection ............................................................................................................... 88
Pan Sharpening ......................................................................................................................... 90
Vegetation Suppression ........................................................................................................... 92
RX Anomaly Detection

RX Anomaly Detection processing uses the Reed-Xiaoli Detector algorithm to detect the spectral or color differences between a region to test and its neighboring pixels or the entire dataset. This algorithm extracts targets that are spectrally distinct from the image background. RXD is effective when the anomalous targets are sufficiently small, relative to the background. Results from RXD analysis are unambiguous and have proven very effective in detecting subtle spectral features. ENVI Zoom implements the standard RXD algorithm:

$$\delta_{RXD}(r) = (r - \mu)^T K_{LxL}^{-1} (r - \mu)$$

Where \( r \) is the sample vector, \( \mu \) is the sample mean, and \( K_{LxL} \) is the sample covariance matrix.

RXD works with multispectral and hyperspectral images. Bad pixels or lines appear as anomalous, but they do not affect the detection of other, valid anomalies. As with any spectral algorithm, exclusion of bad bands increases the accuracy of results. Currently, this algorithm does not differentiate detected anomalies from one another.

References


1. Use the Toolbox to initiate RX Anomaly Detection. Input a multispectral image, and perform optional spatial or spectral subsetting.

2. In the RX Anomaly Detection Parameters dialog, select one of the following options from the Algorithm drop-down list:
   - RXD: Standard RXD algorithm.
   - UTD: Uniform Target Detector, in which the anomaly is defined using \((1 - \mu)\) as the matched signature, rather than \((r - \mu)\). UTD and RXD work exactly the same, but instead of using a sample vector from the data (as with RXD), UTD uses the unit vector. UTD extracts background signatures as anomalies and provides a good estimate of the image background.
   - RXD-UTD: A hybrid of the RXD and UTD methods, in which \((r - 1)\) is used as the matched signature. This is a variant of the UTD approach. Subtracting UTD from RXD suppresses the background and enhances the anomalies of interest. The best condition to use RXD-UTD is when the anomalies have an energy level that is comparable to, or less than, that of the background. In this case, using UTD by itself does not detect the anomalies, but using RXD-UTD enhances them.

3. Using the Mean Source toggle button, specify whether the mean spectrum should be derived from the full dataset (Global) or from a localized kernel around the pixel (Local). If you choose Local, the Local Kernel Size field appears. Specify a kernel size, in pixels, around a given pixel that will be used to create a mean spectrum. The default value is 15.

4. Click the File or Memory button to output the result to file or memory. File output options include ENVI and TIFF/GeoTIFF.
5. Select the **Display Result** check box to automatically display the output result in the Image window. This check box overrides the **Auto Display Files On Open** preference. If you clear this check box, the output result does not automatically display after saving. ENVI Zoom remembers your last selection each subsequent time you create output.

6. Click **OK**. The Process Manager shows the status of RX Anomaly Detection processing. ENVI Zoom builds a covariance matrix and calculates a mean spectrum. Then, RXD runs line-by-line. ENVI Zoom adds the resulting output as a new layer to the Layer Manager.

You can load the layer to a new Portal and move the Portal around in the Image window, comparing the RXD layer to the top, visible layer in the Image window.
Pan Sharpening

Use Pan Sharpening to sharpen low spatial resolution multispectral data using high spatial resolution panchromatic data. If both datasets are georeferenced, ENVI Zoom will co-register them on-the-fly and perform Pan Sharpening on the overlapping area between the two images.

ENVI Zoom performs Pan Sharpening by doing the following:

1. Simulating a panchromatic band from the lower spatial resolution spectral bands.
2. Performing a Pan Sharpening transformation on the simulated panchromatic band and the spectral bands, using the simulated panchromatic band as the first band.
3. Swapping the high spatial resolution panchromatic band with the first Pan Sharpening band.
4. Applying the inverse Pan Sharpening transform to create the pan-sharpened spectral bands.

The low spatial resolution spectral bands used to simulate the panchromatic band must fall in the range of the high spatial resolution panchromatic band or they will not be included in the resampling process.

Both input images must be georeferenced using standard map information. Rational polynomial coefficient (RPC) information or a pseudo projection are currently not supported.

Reference

1. Use the Toolbox to initiate Pan Sharpening. Input a multispectral image with at least two bands, and perform optional spatial or spectral subsetting. For spectral subsetting, you must select two or more bands. For Landsat ETM+ data, select a `.txt` or `.met` metadata file instead of an image file.
2. In the Select High Spatial Resolution Pan Input Band dialog, select a single-band panchromatic image. You cannot spatially subset this image; the multispectral image determines the spatial extent.
3. Click OK. The Pan Sharpening Parameters dialog appears.
4. Select an option from the Sensor drop-down list:
   - **GeoEye-1**: Simulates a panchromatic image for GeoEye-1 using a filter function.
   - **IKONOS**: Simulates a panchromatic image for IKONOS using a filter function. This option is only available when you select a multispectral image with four bands.
   - **QuickBird**: Simulates a panchromatic image for QuickBird using a filter function. This option is only available when you select a multispectral image with four bands.
   - **Landsat ETM**: Simulates a panchromatic image for Landsat ETM+ using a filter function.
   - **Unknown**: Uses the mean of the multispectral bands to create a low resolution panchromatic image.

   The default is **Unknown**. If the selected input filename begins with “po_” (upper- or lower-case) and has four bands, the selection defaults to **IKONOS**.
5. Select the resampling method from the Resampling drop-down list. The choices are as follows:
   - **Nearest Neighbor**: Uses the nearest pixel without any interpolation to create the high resolution images.
• **Bilinear** (default): Performs a linear interpolation using four pixels to create the high resolution images.

• **Cubic Convolution**: Uses 16 pixels to resample the image. Cubic convolution resampling is significantly slower than the other methods.

6. Click the **File or Memory** button to output the result to file or memory. File output options include **ENVI** and **TIFF/GeoTIFF**.

7. Select the **Display Result** check box to automatically display the output result in the Image window. This check box overrides the **Auto Display Files On Open** preference. If you clear this check box, the output result does not automatically display after saving. ENVI Zoom remembers your last selection each subsequent time you create output.

8. Click **OK**. The Process Manager shows the status of Pan Sharpening processing. ENVI Zoom adds the output sharpened image to the Data Manager. The default preferences determine if it is added to the Layer Manager or not.
Vegetation Suppression

Use Vegetation Suppression to remove the vegetation spectral signature from multispectral and hyperspectral imagery, using information from red and near-infrared bands. This method helps you better interpret geologic and urban features and works best with open-canopy vegetation in medium spatial resolution (30 m) imagery.

The algorithm models the amount of vegetation per pixel using a vegetation transform. The model calculates the relationship of each input band with vegetation, then it decorrelates the vegetative component of the total signal on a pixel-by-pixel basis for each band. You can use the results of vegetation suppression for qualitative analysis, but not for subsequent spectral analysis.

Vegetation suppression is most commonly used in lithologic mapping and linear feature enhancement in areas with open canopies. For closed canopies in moderate-resolution data, vegetation suppression is primarily used for linear feature enhancement.

Reference


1. Use the Toolbox to initiate Vegetation Suppression. Input a multispectral file, and perform optional spatial or spectral subsetting. For spectral subsetting, you must select two or more bands.

   - If the associated header contains wavelength information, ENVI Zoom automatically determines the proper red and infrared bands to use for vegetation suppression. ENVI Zoom uses the band closest to 0.66 µm as the red band, and it uses the band closest to 0.83 µm as the near-infrared band.

   - If the header does not contain wavelength information, the Select Near Infrared Band dialog appears. Select the near-infrared band. Click OK. The Select Red Band dialog appears. Select the red band.

   - If the image file has wavelength information but does not have a near-infrared or red band, or if it has only one band, ENVI Zoom issues an error message and ends vegetation suppression.

2. In the Select Output File Parameters, click the File or Memory button to output the result to file or memory. File output options include ENVI and TIFF/GeoTIFF and requires a filename.

3. Select the Display Result check box to automatically display the output result in the Image window. This check box overrides the Auto Display Files On Open preference. If you clear this check box, the output result does not automatically display after saving. ENVI Zoom remembers your last selection each subsequent time you create output.

4. Click OK. The Process Manager shows the status of vegetation suppression processing. ENVI Zoom adds the output image to the Data Manager. The default preferences determine if it is added to the Layer Manager or not.
Chapter 6: Working with Vectors

In this chapter you will find:

About Vectors ................................................................................................................. 94
Working with Vector Records ........................................................................................... 95
Creating Vector Layers .................................................................................................... 97
Creating Vector Records ............................................................................................... 98
Editing Vector Records and Vertices ............................................................................. 100
Editing Vector Layer Properties .................................................................................... 108
Viewing Attributes ....................................................................................................... 109
Vector Tips and Tricks ................................................................................................. 110
About Vectors

You can create vector records in new and existing vector layers, and you can edit vector records and vertices. When a vector layer has been modified, the icon next to the layer name in the Layer Manager becomes shaded to indicate the layer has changed. You can save or discard those changes as needed, and are prompted to do so when you attempt to change the active vector layer or create a new vector layer. At any point while using the vector tools, you can do the following:

- Save the changes to the original file or to a new file (described in "Saving Files" on page 132).
- With the Vector Create tool selected, right-click in the Image window or right-click on the layer name in the Layer Manager and select Revert to clear all vector record edits and return the layer to the state it was in after it was last saved.

Note: You cannot edit a vector layer originating from a geodatabase or referenced by an ESRI layer. However, you can access and edit the source data for an ESRI layer. For more information on ESRI layers, see "Displaying ESRI Layers and Feature Classes" on page 63.

If an attribute table exists for the layer, the following occurs:

- When you add a new vector record, a new empty record is added to the table.
- When you group, join, or merge vector records, the records for the individual vectors are removed from the table and a new blank record is for the multipart or multipoint vector.
- When you ungroup multipart or multipoint records, the record for the multipoint or multipart vector is removed from the table and a new blank record is added for each individual vector.
- When you delete an existing vector record or vertex, its record is removed from the table.
- When you edit existing vector records or vertices, the attribute values are not changed. This may mean, depending on the type of edits made, that the values in that record are no longer valid.

For information on setting preferences for vectors, see "Vector Preferences" on page 48.
Working with Vector Records

Vector records can be either a point, multipoint, polyline, or polygon. For polylines and polygons, you can group two or more vector records to create a multipart vector record. For points, the layer must be already set up as a multipoint layer to be able to use multipoint functions, such as grouping individual points or creating a new multipoint.

Some examples follow.

Grouping Individual Vector Records

To group individual vector records into a single multipart vector record, use either the group or merge function:

Before grouping/merging:
Each polyline is an individual vector record; you can select them separately.

After grouping/merging:
The polylines are grouped into a single multipart vector record; selecting one polyline selects all in the multipart.

Merging Overlapping Polygons or Polylines

To merge two overlapping or touching polylines or polygons into a single polygon, use the merge function:

Before merging:
Separate, overlapping polygons, with one polygon selected.

Before merging:
Before completing the merge, you can preview how it will look.

After merging:
The polygons are merged into a single vector record.

Grouping Polygons

To group two polygons where one is inside the other and retain both polygons, use the group function. You cannot group polygons that are overlapping or touching. The result is a polygon with a hole:
Merging Polygons

Conversely, to merge two polygons where one is inside the other and remove the inner polygon, use the merge function. You cannot group polygons that are overlapping or touching. Using the merge function removes the polygon hole:

Merging and grouping affects the records in the attribute table (described in "Viewing Attributes" on page 109). These details are provided in "Creating Vector Records" on page 98 and "Editing Vector Records and Vertices" on page 100.
Creating Vector Layers

You can create new vector layers by using an existing vector or raster layer to define the extents and map projection.

1. From the menu bar, select File > New > Vector Layer, or right-click on the Layers folder in the Layer Manager and select New > Vector Layer. The Create New Vector Layer dialog appears.

2. Optionally enter a Layer Name for the new layer. If you do not enter a name, ENVI Zoom uses the default name New Vector until you save the layer.

3. Select the vector layer type from the Record Type drop-down list. The choices are Point, Multipoint, Polyline, and Polygon. The last selection used is the default.

4. Select the source file to use for the new layer’s base projection. Do one of the following:
   - Select a source file from the Source Data list. To view information about the file, select the filename and click File Information.
   - Open a new source file by clicking Open File, browsing for and selecting a file, then selecting it from the Source Data list.

5. Click OK. This adds the new layer to the Layer Manager as the active vector layer, and the button is selected on the toolbar.

6. Add new vector records as described in .

7. Save the new layer as a shapefile as described in . If you changed the name of the layer when you saved it, the Layer Manager updates to show the new name.
   
   Saving the new layer creates a new attribute table. The attribute table consists of the numeric attribute RECORD_ID. To view the attribute table, see "Viewing Attributes" on page 109.

Once created, you can hide, rename, remove, and reorder vector layers.
Creating Vector Records

You can add new vector records to a vector layer. The vector records you add will be of the same type that already exists in the layer (for example, new vector records added to a polygon layer will also be polygons).

Though you can create self-intersecting polygons, it is not recommended that you do so. See the ESRI Shapefile Technical Description for more information about self-intersecting polygons.

To create vector records, the layer to modify must be set as the active layer in the Layer Manager. If you have multiple annotation layers loaded and you need to set the active layer, right-click on the layer name and select Set as Active Layer.

If the vector layer has an associated attribute table, creating a vector record adds a new blank record to the attribute table.

Creating Polyline, Polygon, and Multipart Vector Records

Polygons must contain a minimum of three vertices. Polylines must contain a minimum of two vertices.

1. Click the Vector Create button.

2. In the Image window, add the new vector records.
   - To draw polygons or polylines, click and drag to draw a polygon or polyline.
   - To create polygons or polylines one vertex at a time, click and release where you want the first vertex to be, move the cursor to where the next vertex will be and click and release again. Repeat as many times as needed.
   - If needed, use the Backspace key to undo polygon or polyline vertices, or right-click and select Clear.

3. To accept the vector record, you can use one of the following:
   - Double click.
   - Press the Enter key.
   - Right-click and select Accept, Save, or Save As. For more information about selecting a save option, see "About Vectors" on page 94.

   If an attribute table exists for the vector layer, a new blank record for the vector is added.

4. If you want to group the two or more newly added polygons or polylines into a multipart vector record:
   - Use Shift-click to select the vectors you want to group. The polygons to group cannot be overlapping or touching.
   - Right-click and select Group. The vectors are grouped into a single multipart vector record. If an attribute table exists for the vector layer, the entries for the individual vector records are removed and a new blank entry for the multipart vector record is added.
   - Save or discard layer changes.

Creating Point and Multipoint Records

Points are added as individual vector records. If you want to add or group points into a single multipoint vector record, the point layer must already be designated as a multipoint file. Designating the file as a multipoint layer is done outside of ENVI Zoom.
1. Click the Vector Create button.

2. In the Image window, click and release at each location you want to add a point.

3. To accept the points, you can use one of the following:
   
   - Press the Enter key to accept the points as individual points.
   
   - Right-click and select Accept as Individual Points, to accept each point as an individual vector record.
   
   - Right-click and select Accept as Multipoint to accept the points as a single multipoint vector record. This option is available only if the layer is a multipoint file.
   
   - Right-click and select Save or Save As. For more information about selecting a save option, see "About Vectors" on page 94.

   If an attribute table exists for the vector layer, a new blank record for each individual point, or a new blank record for the multipoint, is added.

4. Save or discard layer changes.
Editing Vector Records and Vertices

You can edit vector records and vertices in a variety of ways. Editing a vector layer with an associated attribute table does not change the existing attribute values. Therefore, depending on the type of edits you make, this may mean the values in that record are no longer valid.

To perform any editing functions, the layer to edit must be set as the active layer in the Layer Manager. To set the active layer, right-click on the layer name and select Set as Active Layer.

If a reduced resolution level of the vector file is displayed, then updates (such as delete) do not immediately show until you save the file. Saving the file creates a new reduced resolution vector file.

To save or discard layer changes, see "About Vectors" on page 94 for details.

Selecting Vector Records or Vertices

To select vector records to edit, use the following methods when using the Vector Edit tool. Selected vectors appear in cyan highlight:

- Click to select or deselect an individual vector record. Repeat to select/deselect multiple vector records.
- Click and drag to draw a box around the vector record(s) to select. This method is recommended when selecting polygons with holes.
- Click the Select tool to select one or more vector records, then select the Vector Edit button to perform edits. Shift + click will add vector records to your selection. Ctrl + click will remove single selected records.
- To deselect all selected vector records, right-click and select Clear Selections.

To select vertices to edit, use the following methods when using the Vertex Edit tool.

- Click on the vector record to edit. The color of the selected vector changes to dark blue. When selecting a multipart vector record, only one part is selected.
- The vertex nearest the cursor position is highlighted by a pink square.
- Move the cursor over other vertices to change which one is selected.

Moving Points or Vertices

1. Click the Vertex Edit button.
2. Do one of the following:
   - To move points, select the point to move.
   - To move a vertex, select the polyline or polygon to edit, then place the cursor over the vertex to move.
   - Click and drag to move the point or vertex to the new location. You can optionally use the up, down, left, and right keyboard keys to move the location one screen pixel in the direction of the arrow.
   - Release the mouse button to reposition the point or vertex.
   - To accept the changes, either click off the point or vector record, or right-click and select Accept Changes, Save, or Save As.
To reject the changes, right-click and select **Clear Changes**.

**Snapping to a Nearby Vertex**

You can move a polyline or polygon vertex by snapping it to the nearest vertex.

1. Click the **Vertex Edit** button.
2. Select the vector record to edit.
3. Position the cursor over the vertex to move.
4. Right-click and select **Snap to Nearest Vertex**. The vertex position snaps to the next-nearest vertex in the display.
5. To accept the changes, either click off the vector record, or right-click and select **Accept Changes**, **Save**, or **Save As**.

To reject the changes, right-click and select **Clear Changes**.

**Adding a Vertex to a Polyline or Polygon**

You can add additional vertices to a polygon or polyline.

1. Click the **Vertex Edit** button.
2. Select the polyline or polygon to edit.
3. Position the cursor over or near the vector area where you want to add the vertex.
4. Right-click and select **Insert Vertex**.
5. To accept the changes, either click off the vector record, or right-click and select **Accept Changes**, **Save**, or **Save As**.

To reject the changes, right-click and select **Clear Changes**.

**Joining Polylines**

Use this option to join two polylines. You can see a preview of what a connection will look like before you accept the change.

1. Click the **Vector Join** button.
2. Select the first polyline to include in the join.
3. Click and hold the mouse over the vertex that you want to connect from.
4. Drag the cursor to the polyline you want to connect to. The preview line automatically snaps to the nearest vertex as you drag the cursor. Release the mouse button when the desired vertex is selected.
5. Right-click and select **Join**. If an attribute table exists for the vector layer, ENVI Zoom removes the entries for the individual polylines and adds a new blank entry for the joined polyline.

**Merging Polylines or Polygons**

You can merge two or more polylines or polygons to create a single multipart record. Use the **Merge** option when you have two or more overlapping or touching polylines or polygons you want to merge into one polyline or polygon. For examples of merging, see "Working with Vector Records" on page 95.

1. Click the **Vector Edit** button.
2. To preview what the polyline or polygon will look like before you complete the merge, right-click in the Image window and enable **Show Merge**.

3. Select the polylines or polygons to merge.

4. Right-click and select **Merge**. The polylines or polygons are merged into a single polyline or polygon. If an attribute table exists for the vector layer, ENVI Zoom removes the records for the individual polylines or polygons and adds a new blank record for the merged polyline or polygon.

### Grouping and Ungrouping Vector Records

You can group individual vector records into a single multipart vector record. If you want to group points, the point layer must already be designated as a multipoint file. For examples of grouping, see "Working with Vector Records" on page 95.

1. Click the **button.

2. Select the polylines or polygons to group or ungroup.

3. Right-click and select **Group**. The vector records are grouped into a single multipart vector record. If an attribute table exists for the vector layer, ENVI Zoom removes the records for the individual vectors and adds a new blank record for the multipart vector.

When you ungroup a multipart vector record, it breaks down the multipart vector into the individual vector records.

1. Click the **button.

2. Select the multipart vector record to ungroup.

3. Right-click and select **Ungroup**. The single multipart vector record is broken down into the individual vector records. If an attribute table exists for the vector layer, ENVI Zoom removes the record for the multipart vector and adds a new blank record for each individual vector.

### Splitting Polylines and Polygons

To split a polyline:

1. Click the **button.

2. Select the polyline to split.

3. Move the cursor over the polyline until you highlight the vertex where you want the split to occur.

4. Right-click and select **Split at Vertex**. The polyline is divided into two polylines. If an attribute table exists for the vector layer, ENVI Zoom removes the records for the individual polyline and adds a new blank record for the two new polylines.

5. To accept the changes, either click off the vector record, or right-click and select **Accept Changes**, **Save**, or **Save As**.

To reject the changes, right-click and select **Clear Changes**.

To split a polygon, mark the vertices where you want the split to occur:

1. Click the **button.

2. Select the polygon to split.

3. Position the cursor over a vertex to mark for the split.
4. Right-click and select **Mark Vertex**. This marks one of the two vertices between which the split will occur.

   To unselect the marked vertex, right-click and select **Clear Marks**.

5. Repeat the previous two steps to select and mark the second vertex. If there are vertices between the two that are marked, they are selected as well. The section to split is marked in cyan.

   To unselect the marked vertices, right-click and select **Clear Marks**.

6. Right-click and select **Split at Marked Vertices**. The polygon splits into two new polygons by dividing them at the marked vertices. If an attribute table exists for the vector layer and the selected part is within a multipart record, ENVI Zoom replaces the data from the original part by the data for one of the split-off parts and adds a new part for the other split-off part. If the selected part is the only part in the record, ENVI Zoom deletes the original record and adds one new record for each split-off part.

7. To accept the changes, either click off the vector record, or right-click and select **Accept Changes**, **Save**, or **Save As**.

   To reject the changes, right-click and select **Clear Changes**.

---

**Deleting Vertices**

To delete a single vertex from a polyline or polygon:

1. Click the **Vertex Edit** button.
2. Select the polyline or polygon to edit.
3. Position the cursor over the vertex to delete.
4. Right-click and select **Delete Vertex**.

To delete multiple vertices, mark the vertices in the vector record to delete:

1. Click the **Vertex Edit** button.
2. Select the polyline or polygon to edit.
3. Position the cursor over a vertex to delete.
4. Right-click and select **Mark Vertex**. This marks one of the vertices to delete in cyan.

   To unselect the marked vertex, right-click and select **Clear Marks**.

5. Repeat the previous two steps to select the second vertex to delete. If there are additional vertices between the two that are marked, they are selected as well. The entire section to delete is marked in cyan.

   To unselect the marked vertices, right-click and select **Clear Marks**.

   If the vertices selected between your marks are different from what you want, you can invert the selection by right-clicking and selecting **Invert Marks**.

6. Right-click and select **Delete Marked Vertices**.

---

**Removing Polygon Holes**

You can remove interior holes from multipart polygon vector records.

1. Click the **Vector Edit** button.
2. Select the vector record to edit.
3. Right-click and select **Remove Holes**. The hole is removed. If an attribute table exists for the vector layer, ENVI Zoom removes the record for the vector record.

**Deleting Vector Records**

You can delete one or more vector records at a time.

1. Click the **Vector Edit** button.
2. Select the vector record to edit.
3. Right-click and select **Delete**. The vector record is removed. If an attribute table exists for the vector layer, the record for the vector is removed.

**Smoothing Polygons**

Use the **Smooth** option to interactively smooth individual polygon vectors, using the Douglas-Peucker line-simplification algorithm.

This option allows you to smooth polygons on a case-by-case basis versus setting the **Smoothing Threshold** preference for Feature Extraction, which smooths all polygons at once when you export Feature Extraction vector results to shapefiles.

Follow these steps to smooth polygon vectors:

1. Click the **Vector Edit** button.
2. Select the polygon vector(s) to edit.
3. Right-click and select **Smooth**. The Choose Smoothing Threshold dialog appears.
4. Enter a **Smoothing Threshold (pixels)** integer value to indicate the level of generalization, if any. The default value is 1. A larger value results in straighter lines and less detail in your polylines and polygons. The maximum value is 99, although values greater than 10 are seldom useful. The following figure shows a comparison of different pixel values:
5. You can repeat this step as many times as necessary to achieve the desired smoothing.

Note: You cannot edit a vector layer originating from a geodatabase or referenced by an ESRI layer. However, you can access and edit the source data for an ESRI layer. For more information on ESRI layers, see "Displaying ESRI Layers and Feature Classes" on page 63.

Background

The Douglas-Peucker line-simplification algorithm uses the minimum number of vertices to describe a feature at a given scale. It is best suited for generalizing curved features such as rivers and not for structured objects such as buildings. The algorithm starts by identifying the first and last points in a polyline or polygon and drawing an imaginary line between them.
For all the points in between, the algorithm identifies the one with the greatest distance (d) to this baseline. If this distance is greater than the **Smoothing Threshold (pixels)** value that you specify, the algorithm keeps this point and defines two sub-polylines from the point. The algorithm repeats the process with each sub-polyline until none of the points’ distances from each successive baseline is greater than the **Smoothing Threshold (pixels)**. The points that are kept when the iteration finishes describe the new feature.

A smoothed polygon will have a minimum of five vertices, and a smoothed polyline will have a minimum of four vertices. ENVI Zoom determines how the image is projected and translates the **Smoothing Threshold (pixels)** value into map units before applying the smoothing.

**Reference**


**Rectangulating Polygons**

Use the **Rectangulate** option to smooth any polygon vectors so that they are more rectangular in shape. This is especially useful for rooftops, buildings, fields, parking lots, etc. Follow these steps:
1. Click the **Vector Edit** button.

2. Select the polygon vector(s) to edit.

3. Right-click and select **Rectangulate**. You can repeat this step as many times as necessary to achieve the desired smoothing.

Rectangulating first applies a Douglas-Peucker line simplification algorithm using a smoothing factor that is fixed at a slightly larger size than the pixel size for the shapefile. Once the polygons are smoothed, it finds the dominant edges in each polygon. If a vertex is close to one of the dominant edges, it moves to lie along the edge.

The process cleans the results and removes line segments that are smaller than the pixel size of the shapefile. The smoothed polygon always has the same or fewer number of vertices than the input vector.

The results of the smoothing algorithm depend on the quality of the input data. If the original polygon vectors contain a lot of irregularity and noise, it is best to first smooth the vectors with your favorite smoothing algorithm before using **Rectangulate**. You can also try setting a high **Smoothing Threshold (Pixels)** value with the **Smooth** tool before using **Rectangulate** (see Smoothing Polygons).

**Note:** Rectangulating may occasionally convert long, narrow objects into polylines.

**Reference**

Editing Vector Layer Properties

Edit the properties of a vector layer through the Properties dialog. Right-click on the layer name or portal name in the Layer Manager and select Properties to open the Properties dialog.

The parameters listed in the dialog vary, depending on if the vector layer contains points, polylines, or polygons.

To edit fields with drop-down lists, double-click in the field and select a value.

**Show**: Enable or disable showing the layer in the Image window and the Overview window. The default is True. You can also enable and disable showing the layer by right-clicking on the layer name in the Layer Manager and selecting Show.

**Record Type**: Displays the type of records in the layer (polygon, polyline, etc.).

**Color**: The color of the vectors in the layer. Colors are automatically assigned to the vectors when the layer is displayed. If you display multiple layers, different colors are assigned for each layer. For example, the first layer displayed is red, the second layer is green, the third layer is blue, and so forth.

**Line Style**: (Polylines and Polygons only) The line style for the polygons or polylines. Style choices range from no line to solid, dashed, or dotted lines.

**Thickness**: (Polylines and Polygons only) The line thickness. Choices range from 1 pt to 10 pts. thickness.

**Fill Interior**: (Polygons only) Enable or disable using a fill color for polygons.

**Fill Color**: (Polygons only) If the Fill Interior setting is True, the color to use for the polygon interior.

**Symbol**: (Points only) The symbol type for point vectors. The choices are plus symbol, asterisk, dot, diamond, triangle, square, and X.

**Symbol Size**: (Points only) The size of the symbol. Choices range from 1 pt to 100 pts.

**Note**: You cannot edit a vector layer originating from a geodatabase or referenced by an ESRI layer. However, you can access and edit the source data for an ESRI layer. For more information on ESRI layers, see "Displaying ESRI Layers and Feature Classes" on page 63.
Viewing Attributes

If a vector or ESRI feature class layer has an associated attribute table, you can open and view the attributes. Right-click on the layer name in the Layer Manager and select View Attributes to open the Attribute Viewer. If you have a vector layer with unsaved edits, the View Attributes option is unavailable. Either save the layer or revert the changes to enable the option.

When the attribute table is open, click on a vector in the Image window to highlight the record in the Attribute Viewer. Conversely, click on the row number in the Attribute Viewer to highlight the vector in cyan in the Image window. To select multiple records or rows, press and hold the Shift or Ctrl key as you click.

To sort the attribute table data, click on the heading of the row you want to sort by, then right-click for menu options. You can sort the column forward (ascending order), reverse (descending order), or you can return the column to its original sort order.

Attribute data for a selected vector also appears in the Cursor Value window.
Vector Tips and Tricks

When you create a new vector layer, you use the projection from an existing vector or raster file as the projection for the new layer. The new layer is not actually saved until you add vector records to it and then use the Save As option.

By default, the new vector layer is saved to the Output Directory. If you need to create many new vector layers, it may be helpful to change this preference to point to the directory you are working in. All vector layers you create in ENVI Zoom are saved as shapefiles (.shp).

You can export a vector layer to a geodatabase by using the Save to ArcGIS Geodatabase menu option. See "Saving Files" on page 132.

If you have not saved the vector layer, you can use the Undo option to undo creating the new layer. If you have saved the new vector layer, you must delete it via your operating system (e.g. Windows Explorer).

The additional files for vector layers are as follows:

- For .evf and .shp files, the application creates a quadtree file (.qtr) and a rasterization file (.zrf).
- If the Build Reduced Vertices File preference is enabled, the application performs data reduction on files with high-density vertex data and creates a reduced data file (filename_reduced.ext).
- Shapefiles have an attribute file (.dbf) and a shapefile shape index (.shx).
- If the polygons in a polygon vector layer are filled, the application creates a tessellation file (.tsl).

If you have a problem saving your vector layer, close the vector file but leave your session running, then try deleting the .qtr and .ztr files via your operating system (e.g. Windows Explorer). Reopening the vector file creates new versions of the quadtree and reduced data files. Make the desired changes to the layer and you should be able to save them.

In the case of very large vector files (those with over 50K records), it is recommended that you view individual attributes using the Cursor Value window rather than attempting to use the View Attributes option. Using this method will help to avoid lengthy wait times as the Attribute table is populated and displayed.

To open the attributes table, the layer must be saved for the View Attributes option to be enabled. If this option is disabled, either save the layer or revert the changes to the layer to enable the View Attributes option.

To move points, you need to use the Vertex Edit tool.

To group points, the original file must be a multipoint file.

To select a polygon/polyline, you must click near one of its vertices, though individual vertices are not initially visible. If you have difficulty selecting the object, typically it is because it is long and/or straight and has few vertices to select. Keep clicking along the area of the polygon/polyline at intervals and you will soon click near a vertex, which in turn selects the entire polygon/polyline.

Clicking outside of a vector in the Image window will select the nearest vector record. In the case of an ESRI feature class layer, you must be within four pixels of the vector record in order to select it.
Chapter 7: Working with Feature Counting

In this chapter you will find:

About Feature Counting ..................................................................................................... 112
About Feature Counting

The Feature Counting tool enables you to mark features in raster and vector data. You can mark multiple feature types and add descriptions of them. You can mark individual features, and you can create feature type categories to help differentiate the markings between feature types.
Marking, Editing, and Deleting Features

Marking Features

1. Click the **Feature Counting** button 🛠. The Feature Counting dialog displays.

2. Click the **Edit Feature Type Properties** button 📝. The Properties dialog displays.

3. Enter a **Name** for the feature type (for example, *WaterFeatures*). The name format accepts underscores (*Water_Features*) but does not accept spaces (*Water Features*).

4. Optionally enter a **Description** for the feature type. The description applies to all features you mark as this feature type. You can also add descriptions that are specific to individual features, which is described in Editing Feature Properties.

5. Click **OK**.

6. In the Image window, click on the feature you want to mark. A row is added to the Feature Counting dialog, containing the lat/lon location or pixel coordinates of the feature. A Feature Counting layer is added to the Layer Manager. All features you mark are included in that layer.

7. To add more information about the feature you marked, double-click in the **Description** field in the Feature Counting dialog and enter a description. Press **Enter** to accept the description.

Creating a Feature Type

You can add new feature types through the Feature Counting dialog to help organize marked features.

1. In the **Features** tab, click the **Add Feature Type** button 📝. ENVI Zoom adds a new feature type to the list, named *Feature_x*.

2. Select the new feature name and click the **Edit Feature Type Properties** button 📝, or right-click on the name and select **Edit Properties**. The Properties dialog appears.

3. Enter a **Name** for the new feature type (for example, *WaterFeatures*). The name format accepts underscores (*Water_Features*) but does not accept spaces (*Water Features*).

4. Optionally enter a **Description** that will apply to all features marked as this type. **Tip:** If needed, you can add a description for an individual feature after you mark it. See "Marking, Editing, and Deleting Features" on page 113 for details.

5. If desired, change the remaining properties for the new feature type.

6. Click **OK**.

Editing Feature Properties

The appearance of feature marks is determined by default settings in ENVI Zoom. You can change the settings for a feature type through the Feature Counting dialog.

1. In the Feature Counting dialog **Features** tab, select the name of the feature type you want to edit.

2. Either right-click and select **Edit Properties**, or click the **Edit Feature Properties** button 📝. The Properties dialog appears.
3. Edit the fields as needed. To edit fields with drop-down lists, double-click in the field and select a value. The following properties are available:

**Symbol:** The symbol to use for marking features. Click in this field and select **Edit** to open a dialog containing symbol choices. The available symbols are based on the selected **Font**. Select a symbol and click **OK**.

**Color:** The symbol color.

**Font:** The symbol font. The available symbols to choose from vary, depending on the font you specify.

**Size:** The symbol size.

**Name:** The name of the feature type. This name displays in the Feature Counting dialog **Features** tab. If you enter a name with spaces, the spaces do not display in the Feature Counting dialog.

**Description:** The description of the feature type. All features marked for a feature type show this description in the Feature Counting dialog **Features** tab. To add a description specific to a marked feature, edit the **Description** field in the **Features** tab row that contains the feature location.

4. Click **OK**.

**Deleting Features**

You can delete marks for individual features, and you can delete feature types by using the Feature Counting dialog.

To delete a feature counting mark:

1. In the **Features** tab, select the row of the feature you want to delete.

2. Click the **Delete Selected Feature** button \(\times\). The row is removed from the Feature Counting dialog, and the mark is removed from the Image window.

To delete a feature type:

1. In the **Features** tab, select the name of the feature type to delete (for example, **Feature_1**).

2. Either right-click and select **Delete Feature Type**, or click the **Delete Feature Type** button \(\xmark\) The feature type and all of the features marked as that type are removed from the Feature Counting dialog, and all the feature marks for that type are removed from the Image window. Deleting a feature type cannot be undone.
Saving the Feature Counting Layer

You can save the feature counting layer to a .dbz file so that you can restore the data in a future ENVI Zoom session. See "Restoring Features" on page 117 for details. You can save the feature counting layer to a new file each time you save it, or you can overwrite a previously saved .dbz file.

1. In the Feature Counting dialog Features tab, click the Save Features button. The Save Features dialog appears.
2. Enter a path and filename, then click OK.
Jumping to Features

Once you have features marked, you can "jump" to them and center the selected feature in the Image window.

Go to a feature using one of the following:

- Click on the **Jump to First Feature** button to go to the first feature listed in the data table.
- Click on the **Jump to the Previous Feature** button to go to the feature listed above the current selected feature in the data table.
- Click on the **Jump to the Next Feature** button to go to the feature listed below the current selected feature in the data table.
- Click on the **Jump to Last Feature** button to go to the last feature listed in the data table.
- With the **Enable Table Goto** check box enabled, click on a row in the data table. If you do not want the Image window to automatically center over features while you are selecting rows in the data table, disable this check box. (Clicking the **Jump to** buttons will still result in the Image window centering over features.)

ENVI Zoom centers the Image window over the selected feature.
Restoring Features

You can restore feature counting data that were previously saved.

1. In the Feature Counting dialog Features tab, click the Restore Features button 📊. The Restore Features dialog appears. If you have another feature counting layer open, ENVI Zoom first prompts you to save it.

2. Select the .dbz file to restore.

3. Click Open. ENVI Zoom opens the feature counting layer and displays the data in the Image window. The rows of the Feature Counting dialog show the feature data. If another feature counting layer was open, ENVI Zoom first closes that layer, then restores the one you selected.
Viewing the Feature Counting Report

The feature counting report provides a list of marked features. If you created multiple feature types, the report is divided by feature types.

1. In the Feature Counting dialog, select the Report tab.
2. Click Update Report. The Report tab is updated with information about all features types that were marked. To clear the report data, click Clear.
3. If you want to save the feature counting report as a text file, click Save. The Save Feature Counting Report dialog appears.
4. Enter a filename and location, then click OK.
Chapter 8: Working with Annotations

In this chapter you will find:

About Annotations ................................................................. 120
Creating Annotation Layers .................................................. 121
Adding Annotation Items to an Annotation Layer ......................... 122
Editing Annotation Item Properties ......................................... 126
Deleting Annotation Items ...................................................... 128
Annotation Tips and Tricks .................................................... 129
About Annotations

You can create new annotation layers in ENVI Zoom (.anz) and add annotation items to those layers to highlight features of interest. You can view annotation files that were created in ENVI (.ann) and NITF annotation segments. You can edit annotations and save them to new .anz files (you cannot edit them and save the changes to the original files).

When an annotation layer has been modified, the icon next to the layer name in the Layer Manager becomes shaded ☐️, to indicate the layer has changed. You can save or discard those changes as needed. At any point while using the Annotation tools, you can do the following:

- Save the changes to the original .anz file or to a new .anz file (described in "Saving Files" on page 132).
- With any Annotation tool selected, right-click in the Image window or right-click on the layer name in the Layer Manager and select Revert to clear all annotation item edits and return the layer to the state it was in after it was last saved.

Note: Pixel-based .anz and all .ann annotation files are not supported in the Print Layout view. If sending data to the Print Layout view does not produce desirable results, it is recommended you use the Chip Display to Print option. For more information see "Working with the Print Layout View" on page 141.

For information on setting preferences for annotations, see "Annotation Preferences" on page 46.
Creating Annotation Layers

You can create new annotation layers by using an existing raster, ESRI layer, vector, or annotation layer to define the extents.

One way to create a new annotation layer is to do the following:

1. Select one of the annotation toolbar buttons.

2. Add annotations in the Image window. ENVI Zoom adds the new layer to the Layer Manager using the default name New Annotation. ENVI Zoom uses the default name until you save the layer.

Another way to create a new annotation layer follows:

1. From the menu bar, select File > New > Annotation Layer, or right-click on the Layers folder in the Layer Manager and select New > Annotation Layer. The Create New Annotation Layer dialog appears.

2. Optionally enter a Layer Name for the new layer. If you do not enter a name, ENVI Zoom uses the default name New Annotation until you save the layer.

3. Select the source file to use to define the new layer’s extents and map projection.

4. Click OK. ENVI Zoom adds the new layer to the Layer Manager as the active annotation layer. The Text Annotation button is selected in the toolbar.

5. Add new annotation items as described in "Adding Annotation Items to an Annotation Layer" on page 122.

You can hide and remove annotation layers. You can reorder annotation layers in the Layer Manager, but the order is not maintained if you use File > Save As to save the image to a NITF output file. If you want to maintain reordered layers in output, use the File > Chip Display To option to burn in the annotation.

Transparency is available for annotation layers. All other Enhancement tools and Portal tools are not available for annotation layers.
Adding Annotation Items to an Annotation Layer

You can add new annotation items to an annotation layer.

To create annotation items, the layer to modify must be set as the active annotation layer in the Layer Manager. If you have multiple annotation layers loaded and you need to set the active layer, right-click on the layer name and select **Set as Active Annotation Layer**.

You can reorder annotation items in the Layer Manager.

**Note:** Pixel-based .anz and all .ann annotation files are not supported in the Print Layout view. If sending data to the Print Layout view does not produce desirable results, it is recommended you use the Chip Display to Print option. For more information see "Working with the Print Layout View" on page 141.

Creating Text Annotations

1. Click the **Text Annotation** button.

   **Tip:** To change preferences for a text annotation before you create it, or as you are creating it, select the annotation using the Select tool then right-click in the Image window and select **Preferences**. "Text Annotation Preferences" on page 46 describes the settings.

2. In the Image window, click where you want to add text and begin typing.
   - To create superscript text, press the Ctrl+U keys and type the text you want as superscript.
   - To create subscript text, press the Ctrl+D keys and type the text you want as subscript.
   - To return to regular text from superscript or subscript, press the Ctrl+N keys and type.
   - To insert a line break, press the Ctrl+Enter keys and type on the new line.
   - To add four spaces between letters, press the Tab key.
   - To delete typed text, you can highlight the text with the cursor and type over it, highlight the text and press the Delete key, or use the Backspace key.
   - To delete the text annotation before it is accepted, press the Esc key.
   - To move the selected annotation to a different location, click and drag.

3. To accept the text, press the Enter key. The annotation item is added to the Layer Manager under the annotation layer tree, and it is selected by default. To unselect it, press the Esc key.

4. To save the annotation, right-click in the Image window and select **Save** or **Save As**. For more information about selecting a save option, see "About Annotations" on page 120.

Creating Symbol Annotations

1. Click the **Symbol Annotation** button.

   **Tip:** To change preferences for a symbol annotation before you create it, or as you are creating it, select the annotation using the Select tool then right-click in the Image window and select **Preferences**. "Symbol Annotation Preferences" on page 46 describes the settings.

2. In the Image window, click in each location you want to add a symbol. The annotation item is added to the Layer Manager under the annotation layer tree. If you need to move the annotation to a different location, click on the selected symbol and drag.
3. To save the annotation, right-click in the Image window and select **Save** or **Save As**. For more information about selecting a save option, see "About Annotations" on page 120.

**Creating Polygon Annotations**

Polygons must contain a minimum of three vertices.

1. Click the **Polygon Annotation** button.

   **Tip:** To change preferences for a polygon annotation before you create it, or as you are creating it, select the annotation using the **Select** tool then right-click in the Image window and select **Preferences**. "Polygon Annotation Preferences" on page 47 describes the settings.

2. In the Image window, add the new polygons.
   - Click and drag to draw polygons.
   - To create polygons one vertex at a time, click where you want the first vertex to be, move the cursor to where the next vertex will be, and click again. Repeat as many times as needed.
   - To change the position of a vertex before adding the next one, place the cursor over the vertex until the object selector is visible (in pink), then click and drag it to a new location.
   - To delete the polygon and start again, press the **Esc** key.
   - To move the annotation to a different location, click on it in the Image window and drag.
   - To resize the polygon, click and drag on any of the selection handles.

3. To accept the polygon, you can use one of the following:
   - Double click.
   - Press the **Enter** key.
   - Right-click and select **Accept**, **Save**, or **Save As**. For more information about selecting a save option, see "About Annotations" on page 120.

   The annotation item is added to the Layer Manager under the annotation layer tree.

**Creating Polyline Annotations**

Polylines must contain a minimum of two vertices.

1. Click the **Polyline Annotation** button.

   **Tip:** To change preferences for a polyline annotation before you create it, or as you are creating it, select the annotation using the **Select** tool then right-click in the Image window and select **Preferences**. "Polyline Annotation Preferences" on page 47 describes the settings.

2. In the Image window, add the new polylines.
   - Click and drag to draw polylines.
   - To create polylines one vertex at a time, click where you want the first vertex to be, move the cursor to where the next vertex will be, and click again. Repeat as many times as needed.
   - To change the position of a vertex before adding the next one, place the cursor over the vertex until the object selector is visible (in pink), then click and drag it to a new location.
   - To delete the polyline and start again, press the **Esc** key.
Adding Annotation Items to an Annotation Layer

1. Click the **Rectangle Annotation** button.
   
   **Tip:** To change preferences for a rectangle annotation before you create it, or as you are creating it, select the annotation using the Select tool then right-click in the Image window and select Preferences. "Polygon Annotation Preferences" on page 47 describes the settings.

2. In the Image window, add the new rectangles.
   
   - To draw a rectangle, click and drag.
   - To draw a square, press the Ctrl key as you click and drag.
   - If needed, right-click and select **Delete** to delete the rectangle.
   - To move the annotation to a different location, click on the rectangle and drag.
   - To resize the rectangle, click and drag on any of the selection handles.

   The annotation item is added to the Layer Manager under the annotation layer tree.

3. To save the annotation, right-click in the Image window and select **Save** or **Save As**. For more information about selecting a save option, see "About Annotations" on page 120.

Creating Ellipse Annotations

1. Click the **Ellipse Annotation** button.
   
   **Tip:** To change preferences for an ellipse annotation before you create it, or as you are creating it, select the annotation using the Select tool then right-click in the Image window and select Preferences. "Polygon Annotation Preferences" on page 47 describes the settings.

2. In the Image window, add the new ellipse.
   
   - To draw an ellipse, click and drag.
   - To draw a circle, press the Ctrl key as you click and drag.
   - If needed, right-click and select **Delete** to delete the ellipse.
   - To move the annotation to a different location, click on the ellipse and drag.
   - To resize the ellipse, click and drag on any of the selection handles.

   The annotation item is added to the Layer Manager under the annotation layer tree.

3. To save the annotation, right-click in the Image window and select **Save** or **Save As**. For more information about selecting a save option, see "About Annotations" on page 120.
Creating Arrow Annotations

1. Click the **Arrow Annotation** button.

   **Tip:** To change preferences for an arrow annotation before you create it, or as you are creating it, select the annotation using the Select tool then right-click in the Image window and select **Preferences**. "Arrow Annotation Preferences" on page 46 describes the settings.

2. In the Image window, add the new arrows.
   - Click and drag to draw arrows.
   - If needed, right-click and select **Delete** to delete the arrow.
   - To move the annotation to a different location, click on the arrow and drag.
   - To move an endpoint, click and drag on any of the selection handles.

   The annotation item is added to the Layer Manager under the annotation layer tree.

3. To save the annotation, right-click in the Image window and select **Save** or **Save As**. For more information about selecting a save option, see "About Annotations" on page 120.

Creating Picture Annotations

You can add a picture annotation, such as an icon, using an image file that is one or three bands of byte data readable by ENVI Zoom. "Supported File Formats" on page 52 lists the supported formats.

1. Click the **Picture Annotation** button.

   **Tip:** To change preferences for a picture annotation before you create it, see "Picture Annotation Preferences" on page 47.

2. In the Image window, click where you want to place the picture annotation. The Select Input dialog appears.

3. In the Select Input File dialog, click **Open File**. The Open dialog appears.

4. Select an image file and click **Open**. The file is added to the top of the Select Input File dialog.

5. Select the filename from the list, then click **OK**. The picture is added to the annotation layer, and it is listed in the Layer Manager under the annotation layer tree. To move it to a different location, click on the picture and drag. To resize the picture, click and drag on any of the selection handles.

6. To save the annotation, right-click and select **Save** or **Save As**. For more information about selecting a save option, see "About Annotations" on page 120.
Editing Annotation Item Properties

You can change the properties of an annotation item after you create it.

To access the properties, right-click in the Layer Manager on the annotation item you want to modify and select Properties. (You do not need to change which annotation layer is the active layer beforehand.) You can also click on the annotation item in the Image window, then right-click and select Properties.

The Properties dialog appears, listing settings specific to the annotation item type. The example below shows settings specific to a text annotation item.

The following table describes all of the annotation properties you can change, listed alphabetically. Some of the properties are used by more than one annotation item type.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrow Head Fill</td>
<td>Enables or disables filling the interior of the arrow head for an arrow annotation.</td>
</tr>
<tr>
<td>Arrow Head Size</td>
<td>Changes the size of the arrow head for an arrow annotation, in points.</td>
</tr>
<tr>
<td>Arrow Heads</td>
<td>Changes the angle of the arrow head for an arrow annotation, in degrees.</td>
</tr>
<tr>
<td>Background Color</td>
<td>Changes the background color for a text or symbol annotation.</td>
</tr>
<tr>
<td>Background Fill</td>
<td>Changes the background fill color for a text or symbol annotation.</td>
</tr>
<tr>
<td>Character</td>
<td>Changes the character used for a symbol annotation.</td>
</tr>
<tr>
<td>Color</td>
<td>Changes the color of a text or symbol annotation.</td>
</tr>
<tr>
<td>Fill Color</td>
<td>Changes the fill color of a polygon, rectangle, or ellipse annotation.</td>
</tr>
<tr>
<td>Fill Interior</td>
<td>Enables or disables filling the interior of a polygon, rectangle, or ellipse annotation.</td>
</tr>
<tr>
<td>Font Name</td>
<td>Changes the font used for a text or symbol annotation.</td>
</tr>
<tr>
<td>Font Size</td>
<td>Changes the font size for a text or symbol annotation.</td>
</tr>
<tr>
<td>Font Style</td>
<td>Changes the font style (e.g., bold) for a text annotation.</td>
</tr>
<tr>
<td>Horizontal Alignment</td>
<td>Changes the horizontal alignment of a text annotation.</td>
</tr>
<tr>
<td>Line Color</td>
<td>Changes the line color for a polyline, arrow, polygon, rectangle, or ellipse annotation.</td>
</tr>
<tr>
<td>Line Style</td>
<td>Changes the line style (e.g., dashed line styles) for a polyline, arrow, polygon, rectangle, or ellipse annotation.</td>
</tr>
<tr>
<td>Line Thickness</td>
<td>Changes the thickness of lines on a polyline, arrow, polygon, rectangle, or ellipse annotation.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Rotate with View</td>
<td>Enables or disables rotating the annotation along with the data in the Image window.</td>
</tr>
<tr>
<td>Scale on Zoom</td>
<td>Enables or disables scaling the text, symbol, or picture annotation size according to the zoom level. If set to True, the item’s size increases or decreases accordingly when the zoom level increases or decreases. If set to False, the item’s size remains the same, regardless of the zoom level.</td>
</tr>
<tr>
<td>Show</td>
<td>Enables or disables showing the annotation in the Image window.</td>
</tr>
<tr>
<td>Show Outline</td>
<td>Enables or disables showing the outline of a polygon, rectangle, or ellipse annotation.</td>
</tr>
</tbody>
</table>
Deleting Annotation Items

There are two ways you can delete annotation items you added to a layer: select the annotation using the Select tool or select an item from the Layer Manager annotation tree. You can delete one or more items at a time.

To delete annotation items from the Image window:

1. Click the Select tool.
2. Click to select an individual annotation item, or click and drag to draw a box around multiple annotation items to select them. The selected annotation items appear in the Image window with red handles and are selected in the Layer Manager annotation tree.
3. Press the Delete key, or right-click and select Delete.

To delete annotation items from the Layer Manager:

1. In the Layer Manager, select the item to delete in the annotation tree.
2. Right-click and select Delete.

If you unintentionally delete an annotation item, use the Undo and Redo buttons or the Edit > Undo action option from the menu bar.
Annotation Tips and Tricks

When you create a new annotation layer, you use the extents from an existing annotation, vector, or raster file as the extents for the new layer. The new layer is not actually saved until you add annotation items to it and then use the Save As option.

By default, the new annotation layer is saved to the Output Directory. If you need to create many new annotation layers, it may be helpful to change this preference to point to the directory you are working in.

To select or edit an annotation item when you have annotation layers open with different extents, first double-click on the annotation item in the Layer Manager to bring it into view. Doing this also enables the right-click context menu, so you can edit the annotation item as needed.

Note: Pixel-based .anz and all .ann annotation files are not supported in the Print Layout view. If sending data to the Print Layout view does not produce desirable results, it is recommended you use the Chip Display to Print option. For more information see "Working with the Print Layout View" on page 141.
Chapter 9: Creating Output

In this chapter you will find:

Saving Files .................................................................................................................. 132
The Select Input File Dialog ......................................................................................... 136
Chipping the Display .................................................................................................... 138
Working with the Print Layout View ............................................................................. 141
Saving Files

Use **File > Save As** to output image data to memory or to disk in ENVI format, NITF (.ntf), or TIFF/GeoTIFF (.tif), or to output vector layer changes to an .evf file. For vector files, the vector layer you wish to save must be the active layer, and it must have been modified.

For images, ENVI Zoom does not retain display enhancements in the output file when you use **Save As**. These include rotating, zooming, contrast, brightness, sharpening, stretching, Portals, or viewing multiple layers. Use the **File > Chip Display To** options to retain display enhancements. (See "Chipping the Display" on page 138 for details.)

**Note:** You cannot edit or save an ESRI layer file.

### Saving the Image to Memory

When you output to memory, ENVI Zoom creates output in ENVI format and adds it to the Data Manager.

1. From the menu bar, select **File > Save As**. The Select Input File dialog appears.
2. Select an input file and perform optional spectral and spatial subsetting, then click **OK**. The Save File As Parameters dialog appears.
3. Click the **File or Memory** button to select [Output Result to Memory].
4. Select the **Display Result** check box to automatically display the output result in the Image window. This check box overrides the **Auto Display Files On Open** preference. If you clear this check box, the output result does not automatically display after saving. ENVI Zoom remembers your last selection each subsequent time you create output.
5. Click **OK**. If you selected the **Display Result** check box, ENVI Zoom automatically displays the result. The result is also added to the Data Manager. The output name includes {Memory}, followed by the file dimensions and data type.
6. If you did not select to automatically display the output, display the memory result using the Data Manager. See "Displaying Multispectral Images" on page 61 or "Displaying Grayscale or Classification Images" on page 62 for details.

If the memory output is a spatial subset of the original image and you display it with the original image, the Overview window and Image window show the extent of the subset with a red box when the layer is selected in the Layer Manager.

### Saving the Image to Disk

When you save a file to a new output format, you are saving it to disk at full resolution.

1. From the menu bar, select **File > Save As**. The Select Input File dialog appears.
2. Select an input file and perform optional spectral and spatial subsetting, then click **OK**. The Save File As Parameters dialog appears.
3. From the **Output File** drop-down list, select an output format. The following options are available:
   - **NITF**: NITF 2.0 and 2.1 or NSIF 1.0. If you select this option, the **Compression** drop-down list appears. See Saving NITF Files for more information about the available options.
• **ENVI**: ENVI image format. When you select this option, ENVI Zoom writes the data to ENVI format and creates and saves an associated header file (.hdr) to disk. This option is disabled for input NITF files with multiple image segments.

• **TIFF**: TIFF and GeoTIFF. This option is disabled for input NITF files with multiple image segments.

**Note**: If you previously saved an image to memory during this session, click the File or Memory button to enable the Output File drop-down list.

4. Click the **File Select** button to choose an output destination and filename. Click **Open**.

5. Select the **Display Result** check box to automatically display the output result in the Image window. This check box overrides the **Auto Display Files On Open** preference. If you clear this check box, the output result does not automatically display after saving. ENVI Zoom remembers your last selection each subsequent time you create output.

6. Click **OK**. If you selected the **Display Result** check box, ENVI Zoom automatically displays the result. The result is also added to the Data Manager.

7. If you did not select to automatically display the output, display the memory result using the Data Manager. See "Displaying Multispectral Images" on page 61 or "Displaying Grayscale or Classification Images" on page 62 for details.

   If your new file is a spatial subset of the original image and you display it with the original image, the Overview window and Image window show the extent of the subset with a red box when the layer is selected in the Layer Manager.

**Saving Vector or Annotation Changes to the Current File**

Use **Save** to output vector or annotation layer changes using the current filename. The layer to save must be the active layer, and must have been modified.

**Note**: The **Save** option overwrites the contents of the original file. To save changes and leave the original file as-is, use the **Save As** option described after these steps.

1. Select one of the following:
   - From the menu bar, select **File > Save**.
   - With any Vector or Annotation tool selected, right-click in the Image window and select **Save**.
   - Right-click on the layer name in the Layer Manager, and select **Save**.

   For vectors, a message dialog appears, warning that saving changes will permanently alter the contents of the file.

2. Click **OK**.

   If you attempt to exit ENVI Zoom and have a layer with unsaved changes, you are prompted to save the file. The current file will be overwritten. If you do not want to overwrite the original file, click **No**.

**Saving Vector or Annotation Changes to a New File**

Use **Save As** if you are saving a new vector or annotation layer for the first time, if you edited an ENVI annotation (.ann) file or a NITF annotation segment, or if you are saving an ENVI Zoom .anz file to a new filename.
1. Select one of the following:
   - From the menu bar, select File > Save As.
   - With any Vector or Annotation tool selected, right-click in the Image window and select Save As.
   - Right-click on the layer name in the Layer Manager and select Save As.

2. If you selected File > Save As from the menu bar, the Select Input File dialog appears. Select the layer to save from the list of open files and click OK. The Save As dialog appears.
   If you right-clicked in the Image window and selected Save As, ENVI Zoom assumes the layer to save is the active layer.

3. In the Save As dialog, enter a filename and/or directory and click Save. ENVI Zoom defaults to the Output Directory preference setting for the output directory. Navigate to a different directory as needed before saving.
   When you output vector or annotation layer changes to a new filename, ENVI Zoom makes the new file the active layer. The old file is removed from the Layer Manager, but it is still open and available to reload through the Data Manager.
   When you output edited NITF annotation segments to an .anz file, the file is not saved as a segment of the NITF file. It will be listed in the Data Manager as an individual file.

Selecting an Output Geodatabase

You can save raster and vector datasets that are open in ENVI or ENVI Zoom to a geodatabase. Follow these steps to continue:

1. Select one of the following menu options, depending on the program you are using:
   - Raster datasets in ENVI: From the ENVI main menu bar, select File > Save File As > ArcGIS Geodatabase.
   - Vector datasets in ENVI: In the Available Vectors List, select a vector layer by clicking on the name. Select File > Export Layers to ArcGIS Geodatabase.
   - Raster and vector datasets in ENVI Zoom: From the menu bar, select File > Save to ArcGIS Geodatabase.
   If you are saving raster datasets in ENVI or raster/vector datasets in ENVI Zoom, the Select Input File dialog appears.

2. Select a dataset, and click OK.
   The Process Manager updates to show export progress to a geodatabase. The Process Manager displays the progress, but the coordination between ENVI or ENVI Zoom and ArcMap does not allow the process to be canceled once initiated.
   The Select Output Geodatabase dialog appears. This dialog lists all available geodatabases to which ENVI or ENVI Zoom is connected.

3. If the destination geodatabase is not present in this list, click Connect. The Connection Properties dialog appears. See "Managing Connection Properties" on page 74 for instructions on connecting to a dataset. If successful, the new connection is added to the Destination Geodatabase list and selected by default.
4. Select a geodatabase from the **Destination Geodatabase** list.

5. In the Select Output Geodatabase dialog, enter a dataset name in the **Output Name** field. The default is the name of the input dataset. Dataset names must not exceed 128 characters.

6. Optionally set any configuration keywords. (For more information on configuration keywords, see the ArcGIS Help.)

7. Click **OK**. ENVI or ENVI Zoom verifies that the output geodatabase has sufficient write permissions and that you have a valid ArcGIS® license. (See also **ESRI License Type** in ENVI Zoom preferences.)

**Restrictions**

- You must have an ArcView license to save to a personal or file geodatabase and an ArcEditor or ArcInfo license to save to an enterprise geodatabase. Contact your ESRI sales representative to purchase a license.

- Personal geodatabases store datasets within a Microsoft Access data file (.mdb), which is limited in size to 2 GB.

- Enterprise geodatabases require a login. Users with read-only access cannot save data to an enterprise geodatabase.

- You cannot load vector data with unsaved edits to a geodatabase.

- You can save point, line, polygon, and multipoint vector data to a geodatabase. Vector files in ENVI vector format (.evf) with multiple record types are not supported.

- In ENVI, you cannot save virtual mosaics or spectral libraries to a geodatabase.

- In ENVI and ENVI Zoom, display enhancements you add to a raster image (contrast stretching, sharpening, etc.) are not retained when saving the image to a geodatabase. You can use the **Chip from Display** options in ENVI Zoom, or the **Save Image As** option from an ENVI display group, to retain display enhancements.

- ENVI stores any single-band raster data with a three-color lookup table as an RGB image upon saving to a geodatabase. ENVI Zoom retains color maps upon saving to a geodatabase.

- Traditional map information from input raster data will be retained upon saving to a geodatabase. RPC information, affine map transformations (kx/ky or a pseudo projection), and custom projections are not retained when saving to a geodatabase.

- You cannot save a vector dataset (feature class) to an ArcGIS feature dataset from ENVI or ENVI Zoom. After saving a feature class to a geodatabase, use ArcCatalog software to drag the feature class to a feature dataset if needed.

- For NITF data, you can only save individual image segments to a geodatabase. Annotation segments, files with multiple image segments, and composite images (in ENVI) are not supported. ENVI and ENVI Zoom will not export NITF metadata to a geodatabase.

- Metadata that is supported in both ENVI and ArcGIS will transfer upon saving to a geodatabase. However, ENVI-specific metadata (such as spectral information, band names, etc.) will not be stored in a geodatabase.

- Detailed information on geodatabase types, their structure, and their support in ArcGIS can be found in the ArcGIS Desktop help.
The Select Input File Dialog

When you use the File > Save As menu option or double-click any of the Processing items in the Toolbox, the Select Input File dialog appears. See the following sections for instructions on working with input files.

Opening New Files from the Select Input File Dialog

1. In the Select Input File dialog, click Open File. The Open dialog appears.
2. Select an input file and click Open. For ESRI layer files, expand the layer to select the source data, then click Open. The file is added to the top of the Select Input File dialog. The Select Input File dialog does not support vector files or ESRI feature classes.
3. Perform any optional spectral or spatial subsetting, as described later in this topic.
4. Expand the File Information category to view pertinent file information. See "Accessing File Information" on page 64 for details.
5. Click OK.

Selecting Previously Opened Files

The following steps describe how to select an input file from a list of files that you already opened. You will typically perform this step when initiating any of the Processing options.

1. In the Select Input File dialog, click a filename in the tree view. For ESRI layer files, expand the layer to select the source data. Note that the Select Input File dialog does not support vector files or ESRI feature classes.
2. Perform any optional spectral or spatial subsetting, as described later in this topic.
3. Expand the File Information category to view pertinent file information. See "Accessing File Information" on page 64 for details.
4. Click OK.

Selecting a Spectral Subset

When you perform spectral subsetting, you can only output to ENVI or TIFF formats, or you can create output to memory.

1. In the Select Input File dialog, expand the tree view next to a filename to see a list of bands for that file. All of the bands are selected by default.
2. To select a spectral subset, right-click on the filename and select Select None. Then, use the Ctrl key to select non-adjacent bands (or use the Shift key to select a range of bands).
3. If you decide to use all bands, right-click on the filename and select Select All. No spectral subsetting will be performed.

Selecting a Spatial Subset

Use spatial subsetting to limit applying a function to a spatial subset of the image.

1. In the Select Input File dialog, click Spatial Subset. The Spatial Subset dialog appears.
2. Choose an option for subsetting:
• Enter beginning and ending sample numbers in zero-based file coordinates in the **Samples** and **to** fields. The **Number** field updates accordingly.

• Enter beginning and ending line numbers in zero-based file coordinates in the **Lines** and **to** fields. The **Number** field updates accordingly.

• Enter a value in the **Number** field to adjust the ending numbers for the **Samples** and **Lines** fields accordingly.

• If available, click **Use Display Extent** to spatially subset based on the extent of the image displayed in the Image window. The **Samples**, **Lines**, **to**, and **Number** fields update with the respective image coordinates. This option is different from **Chip Display To** because display enhancements are not retained in the output. This option is disabled if you have rotated the image or if the selected image is not displayed.

• Click **Use Full Extent** to use the full extent of the image. The **Samples**, **Lines**, **to**, and **Number** fields update with the full range of samples and lines for the image.

3. Click **OK**. The spatial subset text on the Select Input File dialog is updated to show the new spatial subset.

If you display the subset with the original image, the Overview window and Image window show the extent of the subset with a red box.
Chipping the Display

Use the File > Chip Display To options to create a screen capture of all layers displayed in the Image window. Any display enhancements, zooming, rotating, or Portals that are displayed in the Image window are burned into the output image. ENVI Zoom creates an 8-bit, three-band image at screen resolution, even if the input data is a only single vector layer or consists of one band (a grayscale image).

You must display the layer(s) prior to using Chip Display To options. The menu options are disabled if you do not have any layers displayed. You can display any combination of image and/or vector layers for a chip.

Output Chip to Memory

1. Display the layer(s) you wish to chip in the Image window. You can use the Zoom, Pan, Rotate, or enhancement tools to customize the display.

2. From the menu bar, select File > Chip Display to > File or click the Chip to File button. The Chip to File Parameters dialog appears.

3. Click the File or Memory button to select [Output Result to Memory].

4. Select the Display Result check box to automatically display the output result in the Image window. This check box overrides the Auto Display Files On Open preference. If you clear this check box, the output result does not automatically display after saving. ENVI Zoom remembers your last selection each subsequent time you create output.

5. Click OK. If Display Result was enabled, the result is loaded in the Image window. The output is also added to the Data Manager. The output name includes {Memory}, followed by the file dimensions and data type.

6. If Display Result was disabled, display the memory result using the Data Manager. See "The Data Manager" on page 60 for details.

Output Chip to Disk

1. Display the layer(s) you wish to chip in the Image window. You can use the Zoom, Pan, Rotate, or enhancement tools to customize the display.

2. From the menu bar, select File > Chip Display To > File. The Chip to File Parameters dialog appears.

3. Select an output format from the Output File drop-down list. The following options are available:
   - NITF: NITF 2.0 and 2.1 or NSIF 1.0. If you select this option, the Compression drop-down list appears. See Saving NITF Files for more information about the available options. Note: You will lose all NITF metadata if you use Chip Display to > File. Default metadata values will be used based on NITF preferences. To save your metadata, use File > Save As to create output instead.
   - ENVI: ENVI image format. When you select this option, ENVI Zoom creates and saves an associated header file (.hdr) to disk.
   - TIFF: TIFF and GeoTIFF
   - JPEG: JPEG
   - JPEG2000: JPEG2000
Note: If you previously saved to memory during this session, click the File or Memory button to enable the Output File drop-down list.

4. Click the File Select button to choose an output destination and filename. Click Open.

5. Select the Display Result check box to automatically display the output result in the Image window. This check box overrides the Auto Display Files On Open preference. If you clear this check box, the output result does not automatically display after saving. ENVI Zoom remembers your last selection each subsequent time you create output.

6. Click OK. If Display Result was enabled, ENVI Zoom loads the result in the Image window. The output is also added to the Data Manager.

7. If Display Result was disabled, display the memory result using the Data Manager. See "The Data Manager" on page 60 for details.

Output Chip to the Print Layout View

1. Display the layer(s) you wish to chip in the Image window. You can use the Zoom, Pan, Rotate, or enhancement tools to customize the display.

2. From the menu bar, select File > Chip Display To > Print to export the chipped image display to the Print Layout view. Any display enhancements, zooming, rotating, or Portals that are displayed in the Image window are burned into the Print Layout image.

ENVI Zoom creates an 8-bit, three-band image at screen resolution, even if the input data is a only single vector layer or consists of one band (a grayscale image). This results in the creation of a Legend (if the Legend is included in the associated Map Template) displaying Chip as the layer name followed by the RGB information.

For more information on the Print Layout view, see "Working with the Print Layout View" on page 141.

Output Chip to ArcMap

Use Chip Display To > ArcMap to export a chipped image display to ArcMap. The exported image retains all display enhancements and annotations you added in ENVI Zoom. Follow these steps to proceed:

1. From the menu bar, select File > Chip Display To > ArcMap.

2. If ArcMap is not already running, ENVI Zoom will initiate it for you. The dataset will automatically display in ArcMap with the ArcMap default enhancements, and it will be added as a new layer to the ArcMap table of contents.

3. If you have one or more instances of ArcMap already running, an ArcMap Instances dialog appears. Select an instance to display your dataset, or start a new instance of ArcMap. Click OK.

Raster datasets in GeoTIFF or NITF format, those stored in a geodatabase, and those referenced by an ESRI layer file) can pass directly into ArcMap without any conversion. For all other formats, ENVI Zoom temporarily converts the datasets to GeoTIFF format before passing them to ArcMap. These are stored in the location you specify as the Temporary Directory in the Directories Preferences.

Datasets exported to ArcMap remain open in ENVI Zoom.

Output Chip to PowerPoint
This feature is only available on Windows 32-bit and 64-bit platforms with the PowerPoint presentation graphics program installed.

1. Display the layer(s) you wish to chip in the Image window. You can use the Zoom, Pan, Rotate, or enhancement tools to customize the display.

2. From the menu bar, select File > Chip Display To > PowerPoint. If you have not yet started the PowerPoint program, it will automatically start and the chipped image is added to a slide in a new presentation. If the PowerPoint program is already open, the PowerPoint Presentations dialog appears.

3. Choose one of the following options for the PowerPoint Presentations dialog:
   - If you have more than one presentation open in the PowerPoint program, select the presentation where you want the chip to be added, and click OK (or, double-click the presentation name). The chipped image is added to a new slide at the end of your presentation.
   - If you only have one presentation open, select the presentation name and click OK (or double-click the presentation name). The chipped image is added to a new slide at the end of your presentation.
   - Select Start a new presentation and click OK if you are running the PowerPoint program and want to start a new presentation while working in an existing presentation. The chipped image is added to a slide in a new presentation.

If your source image contains map information, the geographic coordinates of the chipped image are added to the Notes field in the presentation.
Working with the Print Layout View

From the menu bar, select File > Print. The Print Layout view provides a powerful way to view, modify, print, and export maps.

By default, the Print Layout view will be displayed in the ArcMap Normal template (`Normal.mxt`). You can change the Default Map Template and/or the Map Template Directory Printing preferences. You can also apply existing templates (`*.mxt`) using the Map Template button. Use ArcMap to create, edit, and save templates. For more information on setting preferences, see “Print Layout Preferences” on page 45. For more information on templates and the `Normal.mxt` template, see the ArcGIS Help.

The Print Layout view currently support datasets with the following types of georeferencing:

- Geographic coordinate systems
- Projected coordinate systems
- RPC coefficients

Images with any other types of georeferencing (RSM, affine map transformations kx/ky, pseudo projections, x/y start) are not supported in the Print Layout view. Pixel-based annotation files (`*.anz`) and all annotation files (`*.ann`) are not supported in the Print Layout view. If sending data to the Print Layout view does not produce desirable results, it is recommended you use the Chip Display to Print option.

Print Layout Tools

<table>
<thead>
<tr>
<th>Button</th>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Map Template..." /></td>
<td>Map Template</td>
<td>Select and apply an ArcMap map template (<code>*.mxt</code>) to the Print Layout view. Once applied, the template name appears next to the Map Template button.</td>
</tr>
<tr>
<td><img src="image" alt="Select Elements" /></td>
<td>Select Elements</td>
<td>Select, resize, and move text, graphics, and other objects in the Print Layout view.</td>
</tr>
<tr>
<td><img src="image" alt="Zoom In" /></td>
<td>Zoom In</td>
<td>Zoom in on the Print Layout view by clicking a point or dragging a box. You can also zoom in and out by rolling the mouse wheel. To exit this tool, click the Select Elements button.</td>
</tr>
<tr>
<td><img src="image" alt="Zoom Out" /></td>
<td>Zoom Out</td>
<td>Zoom out on the Print Layout view by clicking a point or dragging a box. You can also zoom in and out by rolling the mouse wheel. To exit this tool, click the Select Elements button.</td>
</tr>
<tr>
<td><img src="image" alt="Fixed Zoom In" /></td>
<td>Fixed Zoom In</td>
<td>Zoom in on the center of the Print Layout view.</td>
</tr>
<tr>
<td><img src="image" alt="Fixed Zoom Out" /></td>
<td>Fixed Zoom Out</td>
<td>Zoom out on the center of the Print Layout view.</td>
</tr>
<tr>
<td><img src="image" alt="Zoom Whole Page" /></td>
<td>Zoom Whole Page</td>
<td>Zoom to view the whole Print Layout view.</td>
</tr>
<tr>
<td><img src="image" alt="Zoom to 100%" /></td>
<td>Zoom to 100%</td>
<td>Zoom the Print Layout view to 100 percent (1:1).</td>
</tr>
<tr>
<td><img src="image" alt="Pan" /></td>
<td>Pan</td>
<td>Pan across the Print Layout view by dragging.</td>
</tr>
<tr>
<td><img src="image" alt="Refresh View" /></td>
<td>Refresh View</td>
<td>Refresh the Print Layout view.</td>
</tr>
<tr>
<td><img src="image" alt="Zoom In (Elements)" /></td>
<td>Zoom In (Elements)</td>
<td>Zoom in on a data frame inside the Print Layout view by clicking a point or dragging a box. To exit this tool, click the Select Elements button.</td>
</tr>
</tbody>
</table>
### Working with the Print Layout View

#### Selecting an Output Geodatabase

<table>
<thead>
<tr>
<th>Button</th>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Zoom Out (Elements)" /></td>
<td>Zoom Out (Elements)</td>
<td>Zoom out on a data frame inside the Print Layout view by clicking a point or dragging a box. To exit this tool, click the <strong>Select Elements</strong> button.</td>
</tr>
<tr>
<td><img src="image" alt="Zoom Full Extent (Elements)" /></td>
<td>Zoom Full Extent (Elements)</td>
<td>Zoom to view the entire data frame inside the Print Layout view.</td>
</tr>
<tr>
<td><img src="image" alt="Pan (Elements)" /></td>
<td>Pan (Elements)</td>
<td>Pan the data frame inside the Print Layout view by dragging.</td>
</tr>
<tr>
<td><img src="image" alt="Display Help" /></td>
<td>Display Help</td>
<td>Provide detailed information on the Print Layout view.</td>
</tr>
<tr>
<td><img src="image" alt="Print..." /></td>
<td>Print</td>
<td>Send the Print Layout view to a printer or plotter. There are a number of customizable options.</td>
</tr>
<tr>
<td><img src="image" alt="Export..." /></td>
<td>Export</td>
<td>Save the Print Layout view to an image or graphic interchange file type. Each export type contains customizable options. Click the <strong>Options</strong> drop-down arrow at the bottom of the page to expand/contract the Options pane. Right-click on field names in the Options pane and select <strong>What’s This?</strong> to access more information about each option.</td>
</tr>
</tbody>
</table>

- **Windows Enhanced Metafile (.emf)** - Can contain vector and raster data. Useful in Windows documents because the vectors can be resized without compromising quality. No support for font embedding and exclusively a Windows format.

- **Encapsulated PostScript (.eps)** - Uses PostScript, the publishing industry standard for print-ready documents. Can be inserted as a graphic in most page layout applications and can be edited in many drawing applications. Supports embedding of fonts (users without ESRI fonts can still view symbology). Colors can be defined in CMYK or RGB.

- **Adobe Illustrator Vector Graphic (.ai)** - Best format for post-processing in Adobe Illustrator. Preserves most layers but does not support font embedding. Colors can be defined in CMYK or RGB.

- **Portable Document Format (.pdf)** - Designed for distribution because they are consistently viewable and printable across different platforms. Editable in many graphics applications and retain annotation, labeling, and attribute data for map layers. Supports embedding of fonts. Colors can be defined in CMYK or RGB.
Selecting an Output Geodatabase

Working with the Print Layout View

<table>
<thead>
<tr>
<th>Button</th>
<th>Button Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Select Elements toolbar button</strong></td>
<td>Click to select text, graphics, and objects in the Print Layout view and move them, delete them, or resize them (text cannot be resized). Text can be modified by double-clicking on the text field then typing the text into the provided dialog. Legend Properties can be modified by double-clicking on the legend. For detailed information on each option or field in the Legend Properties dialog, right-click on an option in the dialog and choose <strong>What’s This?</strong>.</td>
</tr>
<tr>
<td></td>
<td><strong>Scalable Vector Graphics (.svg or svgz for compressed files)</strong></td>
<td>- Web-ready XML-based file format. Can contain vector and raster data. World Wide Web Consortium selection for standard vector web format. Supports font embedding. Compressed files can be created which results in the file extension changing to .svgz.</td>
</tr>
<tr>
<td></td>
<td><strong>Bitmap (.bmp)</strong></td>
<td>- Windows native raster image format commonly inserted as graphics in a variety of document types. Can store pixel data at several bit depths. Can be compressed using the lossless RLE method but are generally much larger than JPEG or PNG files. Vector files do not resize well (they lose quality).</td>
</tr>
<tr>
<td></td>
<td><strong>JPEG (.jpg)</strong></td>
<td>- Web-ready compressed image file commonly inserted as graphics in a variety of document types. Because JPEG files use a lossy compression algorithm, they are not the best option for vectors, text, or symbology (PNG and GIF provide better vector support). Support 24-bit color.</td>
</tr>
<tr>
<td></td>
<td><strong>Portable Network Graphics (.png)</strong></td>
<td>- Web-ready compressed raster format (usually smaller file size than GIF). Uses a lossless compression and supports 24-bit color and transparency.</td>
</tr>
<tr>
<td></td>
<td><strong>Tagged Image File Format (.tif)</strong></td>
<td>- Versatile raster format (but not viewable by a web browser). Can store pixel data at several bit depths. Can be compressed with lossy or lossless compression. Best choice for importing into cross-platform image editing applications.</td>
</tr>
<tr>
<td></td>
<td><strong>Graphics Interchange Format (.gif)</strong></td>
<td>- Web-ready standard raster format. Lossless RLE or LZW compression results in small file size. Supports transparency and 8 bits per pixel (256 colors). The limited color support means there is some color limitation for maps that contain continuous raster data.</td>
</tr>
<tr>
<td></td>
<td><strong>Close</strong></td>
<td>Close the Print Layout view.</td>
</tr>
</tbody>
</table>

Editing Text, Graphics, and Objects in the Print Layout View

Using the **Select Elements** toolbar button, click to select text, graphics, and objects in the Print Layout view and move them, delete them, or resize them (text cannot be resized). Text can be modified by double-clicking on the text field then typing the text into the provided dialog. Legend Properties can be modified by double-clicking on the legend. For detailed information on each option or field in the Legend Properties dialog, right-click on an option in the dialog and choose **What’s This?**.

Select an element and:
• Press the **Delete** key to delete it.
• Click and drag a corner to resize it. Text cannot be resized. If the map, data frame, or scale bar is enlarged or reduced, the scale bar will remain correct.
• Click on the element and drag it to move it.
Chapter 10: Working with the NITF Module

In this chapter you will find:

About the NITF/NSIF Module and NITF for ArcGIS ........................................................... 146
The NITF/NSIF Format ...................................................................................................... 147
Data Extension Segments and Tagged Record Extensions .............................................. 153
NITF Preferences .............................................................................................................. 158
Display Levels ................................................................................................................ ... 160
NITF Map Information ........................................................................................................ 162
Displaying NITF Images ..................................................................................................... 164
Viewing NITF Metadata ..................................................................................................... 165
Editing NITF Metadata ....................................................................................................... 167
Saving NITF Files ............................................................................................................. . 1 6 9
Chipping the Display to NITF ............................................................................................. 172
NITF Save As .................................................................................................................... 174
About the NITF/NSIF Module and NITF for ArcGIS

The National Imagery Transmission Format (NITF) standard is a raster format defined by the NITF Standards Technical Board. The Joint Interoperability Test Command (JITC) certifies systems implementing the NITF format for compliance with the standard. Both the NITF/NSIF Module and NITF for ArcGIS® provide JITC-compliant support for the NITF file format and they are required for compliant NITF support in ENVI and ArcGIS respectively. Both the ENVI 4.5 NITF/NSIF Module and NITF for ArcGIS 1.0 were tested by the JITC and both have been recommended for full compliance registration to complexity level 7 for NITF 2.1 and complexity level 6 for NITF 2.0 (the highest for each format). ENVI 4.7 and NITF for ArcGIS 1.1 are in compliance with these standards.

Contact the JICT (http://jict.fhu.disa.mil/) for detailed information about the NITF certification program, including functional read/write breakdown and testing anomalies.

The NITF/NSIF Module and NITF for ArcGIS are available at additional cost from ITT Visual Information Solutions or your ENVI distributor. The NITF for ArcGIS license is included with the NITF/NSIF Module license. It can also be purchased separately at additional cost from ITT Visual Information Solutions, ESRI®, or your ENVI Distributor. If you have ArcGIS 9.3 or later installed, you can license NITF then install and run NITF for ArcGIS. NITF for ArcGIS provides the ability to read NITF data within the ArcGIS environment and create data products with ArcGIS Desktop that comply with the latest NITF specifications.

NITF File Support

NITF is a complex imagery and image exploitation information format capable of containing a wide variety of image and non-image information. Currently, there are three different versions of the NITF specification: NITF 1.1, NITF 2.0, and NITF 2.1. Each is similar to the others in many ways, but each also has its own characteristics.

Both the NITF/NSIF Module and NITF for ArcGIS provide the ability to read NITF 2.0, NITF 2.1, NSIF 1.0 and legacy NITF 1.1 files, and write NITF 2.0, NITF 2.1, and NSIF 1.0 datasets.

The NITF format is used extensively in the United States. The multinational members of the North Atlantic Treaty Organization (NATO) use the NATO Secondary Image Format (NSIF). The NSIF 1.0 format is identical to the NITF 2.1 format, with the exception of the version name in the file header. In place of NITF02.10, this field contains NSIF01.00.

General information about the NITF format, and specific information about the NITF 2.1 format, also applies to the NSIF format.
The NITF/NSIF Format

A valid NITF dataset provides a main header identifying the file as a NITF dataset and describing the contents of the file. The header is usually followed by one or more data segments. Each data segment consists of a segment subheader identifying the type and properties of the data, followed by the data itself. See "NITF Segments" on page 148 for more information on data segments.

Main Header

A NITF dataset may contain any or all types of segments available for that version, but every NITF dataset must contain a main header. The main NITF header describes the entire file, including origination information, security information, file version and size, and the number and type of all data segments contained in the NITF dataset.

Data Segments

Data segments can be any of the following types:

- "Security Segments" on page 149
- "Image Segments" on page 149
- "Graphic/Symbol Segments" on page 151
- "Label Segments" on page 151
- "Annotation Segments" on page 151
- "Text Segments" on page 152
- "Data Extension Segments" on page 153

References

For more detailed information about the NITF/NSIF format and its components, see the technical specifications listed in the following table. These documents and others, including compression schemes are available from the NITF Technical Board (NTB) Web site.

<table>
<thead>
<tr>
<th>For information about...</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>NITF 2.1</td>
<td>MIL-STD-2500C</td>
</tr>
<tr>
<td>NITF 2.0</td>
<td>MIL-STD-2500A</td>
</tr>
<tr>
<td>NSIF 1.0</td>
<td>STANAG 4545</td>
</tr>
<tr>
<td>CGM Graphics</td>
<td>MIL-STD-2301A</td>
</tr>
<tr>
<td>Controlled Extensions for NITF 2.1</td>
<td>STDI-0002</td>
</tr>
<tr>
<td>Test program plan</td>
<td>N-0105-98</td>
</tr>
<tr>
<td>BIIF Profile for JPEG 2000, Version 01.00</td>
<td>BPJ2K01.00</td>
</tr>
<tr>
<td>Federal Information Processing Standards Publication 10-4</td>
<td>FIPS PUB 10-4</td>
</tr>
</tbody>
</table>
NITF Segments

While NITF datasets without graphical data are supported, most datasets contain one or more displayable segments. Displayable segments are image, graphic/symbol, or label segments that contain graphical information and text for display. These segments contain instructions about how the graphical data they contain should be displayed relative to any other displayable segments, resulting in a composite display encompassing all graphical information in the dataset.

Multiple Displayable Segments

The NITF format supports multiple image, graphical, and displayable text elements. A NITF dataset can contain all displayable segments (image, graphic/symbol, and label), making it possible for raw image information and additional exploitation material to co-exist nondestructively within the dataset. Each displayable segment contained in the NITF dataset contains information controlling the location of the display element in the composite. Each segment also contains a display level that determines which elements should be displayed on top of others, obscuring the lower-level displayable elements from view without corrupting the hidden portion of those lower-level displayable elements. For more information, see "Display Levels" on page 160. Below is an example of a NITF 2.1 dataset with multiple displayable segments.
In the image above, a close-up image is positioned on top of the main image, obscuring part of the image. However, because the inset image is contained in an image segment separate from the main image, it can be moved, hidden, or deleted without destroying information contained in the main image underneath it. Likewise, the CGM graphics (text and graphical annotations) can be hidden or displayed without affecting the underlying image.

**Security Segments**

The NITF format was designed to contain information deemed sensitive, so it includes header data describing the status of any information that is not available to the general public. The main file header contains security information describing the security level of the entire NITF dataset, and each segment also contains security information in its subheader, as the confidentiality of data within a file may vary. The security level of the entire file (T = Top Secret, S = Secret, C = Confidential, R = Restricted, U = Unclassified) is the same as or higher than that of the most restricted segment in the file. NITF 2.0 uses the same fields as NITF 1.1 to contain security information, while NITF 2.1 deprecated some security information fields and added new fields.

These changes are described below. For a detailed description of these security fields, consult the NITF specifications to determine which metadata are relevant to the version of your NITF file.

<table>
<thead>
<tr>
<th>NITF 1.1/2.0 Security Fields</th>
<th>NITF 2.1 Security Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Classification</td>
<td>Classification</td>
</tr>
<tr>
<td>Codewords</td>
<td>Classification System</td>
</tr>
<tr>
<td>Control and Handling</td>
<td>Control and Handling</td>
</tr>
<tr>
<td>Releasing Instructions</td>
<td>Releasing Instructions</td>
</tr>
<tr>
<td></td>
<td>Declassification Type</td>
</tr>
<tr>
<td></td>
<td>Declassification Date</td>
</tr>
<tr>
<td></td>
<td>Declassification Exemption</td>
</tr>
<tr>
<td></td>
<td>Downgrade</td>
</tr>
<tr>
<td></td>
<td>Downgrade Date</td>
</tr>
<tr>
<td></td>
<td>Classification Text</td>
</tr>
<tr>
<td></td>
<td>Classification Authority Type</td>
</tr>
<tr>
<td></td>
<td>Classification Authority</td>
</tr>
<tr>
<td></td>
<td>Classification Reason</td>
</tr>
<tr>
<td></td>
<td>Security Source Date</td>
</tr>
<tr>
<td>Control Number</td>
<td>Security Control Number</td>
</tr>
<tr>
<td>Downgrade</td>
<td></td>
</tr>
<tr>
<td>Downgrading Event</td>
<td></td>
</tr>
</tbody>
</table>

**Image Segments**

Image segments contain raster data, typically image data, intended for display or analysis. Image segments in a NITF file contain displayable image information. Each image segment contains a single image consisting of one or more bands of data (NITF 2.0 allows one, three, or four bands of data in an image, and NITF 2.1 allows up to 999 bands). All bands within an image segment must have the same data type, dimensions, storage order, and map information, although these characteristics can vary across different
image segments. Each image segment may contain specific display instructions, including color lookup
tables for single-band images and default display bands for multi-band images. Images can be stored in
integer data types in NITF 2.0 and in integer and real data types in NITF 2.1. Images can also be compressed
using a variety of algorithms including JPEG DCT, Vector Quantization, Bi-level, JPEG 2000 NPJE (NITF
2.1 only), and JPEG 2000 EPJE (NITF 2.1 only). Images can be broken into blocks, providing an orderly
set of subimages (or subarrays). Additional information describing the collection, intended use,
wavelengths, and comments can also be stored with the image.

### Image Masks

Mask information stored in image segments identifies pixels that are invalid or not intended to be displayed,
and should therefore not be displayed.

Images that are rotated or have gaps can also contain a mask indicating which portions of the image should
not be used for display or analysis. Two types of image masks are used in NITF files:

- **Blocked image masks** are used to mask entire blocks of image data.
- **Transparent pixel masks** are used for masking individual pixels or groups of pixels within an image
  block.

When an image segment containing masked blocks or pixels is displayed, pixels from images or graphics
underneath the image segment show through and are displayed even though they would ordinarily be
obscured. If a transparent pixel occurs with nothing displayed under it, or if for any other reason there is no
display information for a pixel, the background color specified in the main file header is displayed.

In the image below, the textual, symbol, and graphical annotations are CGM graphics.
Graphic/Symbol Segments

Symbol segments can contain Computer Graphics Metafile (CGM), bitmap, or object elements, while label segments contain graphical text elements. The CGM format allows direct control of all display elements contained in the graphic including color, size, and orientation of objects. CGM graphics can contain complex lines and polygons, as well as displayable text. Multiple annotations can be combined in a single CGM, so symbol segments with CGM graphics may actually contain multiple sets of graphical primitives.

NITF 2.1 files can contain graphic segments with CGM graphic and graphical text elements, while NITF 2.0 files contain two segment types for the same purpose: symbol segments and label segments. Both the NITF 2.0 symbol segment and the NITF 2.1 graphic segment can contain CGM graphics.

The NITF 2.1 graphic segment can only contain CGM graphics, but NITF 2.0 symbol segments can contain other graphical display elements as well. Symbol segments can contain bitmaps (color-mapped bitmaps to be displayed on the composite) or objects (graphics from a limited set of graphical primitives, including lines, arrows, circles, and rectangles).

For NITF 2.1, the bitmap and object symbol types as well as the label segment have been deprecated. Bitmaps are stored in image segments instead of symbols, and object symbols and labels have been removed in favor of the more general and powerful CGM.

Label Segments

Label segments, available only in NITF 2.0, contain displayable text intended to be drawn with the NITF display. In addition to this text, a label segment includes display instructions such as font, color, size, and a background color to display behind the text.

There are many required CGM elements to draw the data contained in a NITF 2.0 label segment. Element details are described in MIL-STD-2301A.

Annotation Segments

NITF 2.0 symbol and label segments, as well as NITF 2.1/NSIF 1.0 graphics segments, are collectively referred to as annotation segments in the software, as illustrated below.

Image, text, and extension segments are available in every version of NITF, while label and symbol segments can occur only in NITF 2.0 datasets. Graphic segments occur only in NITF 2.1 datasets.
Because of the similarity between the symbol segments and label segments in NITF 2.0 files, and the graphic segments in NITF 2.1 files, the software combines these segments into a single conceptual type (annotation segments). Annotation segments can contain symbol, label, or graphic segments, and they might include text, ellipses, polylines, bitmaps, and other objects. Annotation segments do not exist in any NITF file, and they are not mentioned in the NITF specification documents. They are a simplification used to reduce the overall number of segment types.

Annotation segments and image segments both carry information intended to be displayed graphically, and both are referred to as displayable segments in the documentation.

**Annotation Objects**

Because CGM graphics are capable of displaying multiple graphical elements, each annotation segment must be capable of storing multiple displayable features. In the software, these displayable features are referred to as annotation objects. Each annotation segment contains one or more annotation objects. NITF 2.0 and 2.1 annotation segments can contain multiple CGM annotation objects; each NITF 2.0 annotation segment can only contain one non-CGM label, bitmap, or object symbol annotation object. The type of object determines which fields will be filled in the annotation object.

**Text Segments**

Text segments contained in a NITF dataset consist of textual information that is not intended for graphical display. This information may be textual notes explaining target information, or the text segment may be used for passing US Message Text Format (USMTF) and text notes to other users.
Data Extension Segments and Tagged Record Extensions

Two types of extension segments, data and reserved, provide storage within the file structure for additional information that cannot be contained in the file or segment header. Data extension segments are used as necessary for storing Tagged Record Extensions (TREs), and the reserved extension segment is reserved for future expansion of the NITF format.

Data Extension Segments

Data Extension Segments (DESes) contain data that cannot be stored in the other NITF segments. An example is the NCDRD Attitude Data DES, CSATTA. A list of unclassified, registered DESes is available at http://jitc.fhu.disa.mil/nitf/tag_reg/des.htm.

Supported DESes

The software only supports NITF Commercial Dataset Requirements Document (NCDRD) DESes. You cannot edit, create, or delete NCDRD DESes through the Metadata Editor.

<table>
<thead>
<tr>
<th>Name</th>
<th>Filename</th>
<th>Long Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>CSATTA</td>
<td>CSATTA_DES.xml</td>
<td>Attitude Data</td>
</tr>
<tr>
<td>CSSHPA</td>
<td>CSSHPA_DES.xml</td>
<td>Shapefile</td>
</tr>
</tbody>
</table>

If a NITF file contains valid supported Data Extension Segments (DESes), the DESes are automatically saved in the output file. When opening a NITF image, the DES user-defined subheader will not be read if the input data format does not mirror the format in the accompanying XML definition file. When writing a NITF file that contains a DES with no corresponding XML file, the software passes through this unknown DES in NITF 2.1 and NSIF 1.0 files only. The software does not support unknown DESes in NITF 2.0 files. See also: "Preserving DESes" on page 176.

Tagged Record Extensions

TREs may be present in NITF files to contain types of information that cannot be stored in the NITF file header or segment subheaders. One or more TREs that apply to the entire NITF dataset can be present in the file header, and each segment (image or text) can also have one or more TREs associated with it. In some cases, TREs are applied to the data in a file or segment to enhance the utility of the data. Unless there is a large amount of data in a TRE, the TRE data is stored in the main header or segment subheader to which the TRE applies. For TREs too large to fit in the segment TRE area, a Data Extension Segment (DES) is created at the end of the file, and a pointer to this DES is stored within the header.

TREs come in two forms: Registered Extensions (REs) and Controlled Extensions (CEs). The NITF Standard Technical Board (NTB) maintains a registry of known CEs and REs: the main difference between them is that both the TRE name and TRE layout of CEs are controlled by the NTB, whereas only the TRE names of REs are registered with the NTB to prevent different users from using the same TRE name. Therefore, CEs can be interpreted based on the published information contained in the NTB repository, whereas REs require specific knowledge of the TRE contents available to the creator of the TRE that may not be available to the data consumer.
An example of a TRE is the RPC00B (Rapid Positioning Capability) TRE that can be associated with an image segment in a NITF dataset. This TRE provides coefficients that can be used to orthorectify the associated image segment. Other Controlled Extension TREs specify processing history, information about specific targets in an image, collection information, and other types of metadata.

The JITC repository of Controlled Extension and Registered Extension TREs can be viewed online at http://jitc.fhu.disa.mil/nitf/tag_reg/tagroup.htm.

For information on classified TREs, contact ITT Visual Information Solutions Technical Support.

**Supported TREs**

There are two levels of TRE support in the NITF/NSIF Module:

- **Unsupported TREs**: TREs for which no definition is available, or the definition does not match the physical layout of the TRE. Only the raw data of TREs of this type can be viewed.

- **Supported TREs**: TREs that match a valid TRE definition. The data in these TREs can be read and written. The data in these TREs can be viewed with the appropriate header information in the NITF Metadata Viewer (see: "Viewing NITF Metadata" on page 165). These TREs may be parsed into their specific components, and the value associated with each field in the TRE is displayed in the NITF Metadata Viewer. To view the information contained in this type of TRE, open the TRE container. Each field in the TRE is displayed as a single entry.

The data in these TREs can be written into file, image, and text segments of new NITF files. When saving to NITF, you can view these TREs in the NITF Metadata Viewer (see: "Editing NITF Metadata" on page 167). Although the supported TREs for writing data can be displayed in the editor, only PIA TREs can be added, edited, or removed from their associated file header, image, annotation, or text segment.

Each TRE supported by the software references an XML definition file. Definition files for a partial list of the NTB-registered CEs are installed with the software. Support for TREs can be added by creating TRE definitions for the desired TREs. For more information about these TREs, contact ITT Visual Information Solutions Technical Support.

When opening a NITF image, the software does not parse the TRE fields if there is no corresponding XML definition file. When writing a NITF file that contains a TRE with no corresponding XML file, the software passes through this unknown TRE.

The following table describes TREs that the software currently supports for reading and writing data. The Reference column provides links to the following NITF specification documents:

- **DIGEST**: The Digital Geographic Information Exchange Standard (DIGEST) Part 2, Annex D: IMAGE INTERCHANGE FORMAT (IIF) ENCAPSULATION SPECIFICATION
  http://164.214.2.51/ntb/baseline/docs/digest

- **ENGRDA**: Engineering Data (ENGRD) Support Data Extension (SDE) Version 1.0
  http://www.gwg.nga.mil/ntb/baseline/docs/stdi-0002_v3/App%20N.doc

- **ISOJ2K**: BIIF Profile for JPEG 2000
  http://www.ismc.nga.mil/ntb/baseline/docs/bpj2k01/ISOJ2K_profile.pdf

- **RSM**: Replacement Sensor Model Tagged Record Extensions Specification for NITF 2.1
  http://164.214.2.51/ntb/coordinationitems/RSM__NITF_TRE’s_delivery_July_23_04.pdf

- **STD10002**: The Compendium of Controlled Extensions for NITF version 2.1
  http://www.ismc.nga.mil/ntb/baseline/docs/stdi0002/final.pdf
- **STDI0006**: National Transmission Format (NITF) Version 2.1 Commercial Dataset Requirements Document (NCDRD)
  http://164.214.2.51/ntb/baseline/docs/stdi0006/STDI-0006-NCDRD-15Sep05.doc
- **VIMAS**: Visible, Infrared, and Multispectral Airborne Sensor Support Data Extensions (SDE) for NITF version 2.0

<table>
<thead>
<tr>
<th>TRE Name</th>
<th>Filename</th>
<th>Descriptive Name</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCHZB</td>
<td>ACCHZB.xml</td>
<td>Horizontal Accuracy Extension</td>
<td>DIGEST</td>
</tr>
<tr>
<td>ACCPOB</td>
<td>ACCPOB.xml</td>
<td>Positional Accuracy Extension</td>
<td>DIGEST</td>
</tr>
<tr>
<td>ACCVTB</td>
<td>ACCVTB.xml</td>
<td>Vertical Accuracy Extension</td>
<td>DIGEST</td>
</tr>
<tr>
<td>ACFTA</td>
<td>ACFTA.xml</td>
<td>Aircraft Information Version A</td>
<td>STDI0002</td>
</tr>
<tr>
<td>ACFTB</td>
<td>ACFTB.xml</td>
<td>Aircraft Information Version B</td>
<td>STDI0002</td>
</tr>
<tr>
<td>AIMIDA</td>
<td>AIMIDA.xml</td>
<td>Additional Image Identification Version A</td>
<td>STDI0002</td>
</tr>
<tr>
<td>AIMIDB</td>
<td>AIMIDB.xml</td>
<td>Additional Image Identification Version B</td>
<td>STDI0002</td>
</tr>
<tr>
<td>BANDSA</td>
<td>BANDSA.xml</td>
<td>Multispectral/Hyperspectral Band Parameters</td>
<td>STDI0002</td>
</tr>
<tr>
<td>BANDSB</td>
<td>BANDSB.xml</td>
<td>Extended Multispectral/Hyperspectral Band Parameters</td>
<td>STDI0002</td>
</tr>
<tr>
<td>BCKGDA</td>
<td>BCKGDA.xml</td>
<td>Background Data</td>
<td>STDI0002</td>
</tr>
<tr>
<td>BLOCKA</td>
<td>BLOCKA.xml</td>
<td>Image Block Information</td>
<td>STDI0002</td>
</tr>
<tr>
<td>BNDPLB</td>
<td>BNDPLB.xml</td>
<td>Bounding Polygon</td>
<td>DIGEST</td>
</tr>
<tr>
<td>CMETAA</td>
<td>CMETAA.xml</td>
<td>Complex Metadata Tagged Record Extension Version A</td>
<td>STDI0002</td>
</tr>
<tr>
<td>CSCRNA</td>
<td>CSCRNA.xml</td>
<td>Corner Footprint</td>
<td>STDI0006</td>
</tr>
<tr>
<td>CSDIDA</td>
<td>CSDIDA.xml</td>
<td>Dataset Identification</td>
<td>STDI0006</td>
</tr>
<tr>
<td>CSCCGA</td>
<td>CSCCGA.xml</td>
<td>Cloud Cover Grid</td>
<td>STDI0006</td>
</tr>
<tr>
<td>CSEPHA</td>
<td>CSEPHA.xml</td>
<td>Ephemeris Data</td>
<td>STDI0006</td>
</tr>
<tr>
<td>CSEXRA</td>
<td>CSEXRA.xml</td>
<td>Exploitation Reference Data</td>
<td>STDI0006</td>
</tr>
<tr>
<td>CSPROA</td>
<td>CSPROA.xml</td>
<td>Processing Information</td>
<td>STDI0006</td>
</tr>
<tr>
<td>CSSFAA</td>
<td>CSSFAA.xml</td>
<td>Sensor Field Alignment Data</td>
<td>STDI0006</td>
</tr>
<tr>
<td>ENGRDA</td>
<td>ENGRDA.xml</td>
<td>Engineering Data. To view this TRE, rename ENGRDA.xml_hold to ENGRDA.xml in the bin folder of your software distribution.</td>
<td>ENGRDA</td>
</tr>
<tr>
<td>EXOPTA</td>
<td>EXOPTA.xml</td>
<td>Exploitation Usability Optical Information</td>
<td>STDI0002</td>
</tr>
<tr>
<td>EXPLTA</td>
<td>EXPLTA.xml</td>
<td>Exploitation Related Information Version A</td>
<td>STDI0002</td>
</tr>
<tr>
<td>EXPLTB</td>
<td>EXPLTB.xml</td>
<td>Exploitation Related Information Version B</td>
<td>STDI0002</td>
</tr>
<tr>
<td>GEOLOB</td>
<td>GEOLOB.xml</td>
<td>Local Geographic (lat/long) Coordinate System Extension</td>
<td>DIGEST</td>
</tr>
<tr>
<td>GEOPSB</td>
<td>GEOPSB.xml</td>
<td>Geographical Positioning for geo-referencing parameters including datum, ellipsoids</td>
<td>DIGEST</td>
</tr>
<tr>
<td>GRDPSB</td>
<td>GRDPSB.xml</td>
<td>Grid Positioning Version B</td>
<td>DIGEST</td>
</tr>
<tr>
<td>HISTOA</td>
<td>HISTOA.xml</td>
<td>Softcopy History Tagged Record Extension</td>
<td>STDI0002</td>
</tr>
<tr>
<td>ICHIPA</td>
<td>ICHIPA.xml</td>
<td>Image Chip Support Data Extension Version A</td>
<td>DIGEST</td>
</tr>
<tr>
<td>ICHIPB</td>
<td>ICHIPB.xml</td>
<td>Image Chip Support Data Extension Version B</td>
<td>STDI0002</td>
</tr>
<tr>
<td>IOMAPA</td>
<td>IOMAPA.xml</td>
<td>Input/Output Mapping Tagged Record Extension</td>
<td>STDI0002</td>
</tr>
<tr>
<td>J2KLRA</td>
<td>J2KLRA.xml</td>
<td>JPEG 2000 Parameters</td>
<td>ISOJ2K</td>
</tr>
<tr>
<td>TRE Name</td>
<td>Filename</td>
<td>Descriptive Name</td>
<td>Reference</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>-----------</td>
</tr>
<tr>
<td>MAPLOB</td>
<td>MAPLOB.xml</td>
<td>Local Cartographic (x/y) Coordinate System Extension</td>
<td>STDI0002</td>
</tr>
<tr>
<td>MENSRA</td>
<td>MENSRA.xml</td>
<td>Airborne SAR Mensuration Data Version A</td>
<td>STDI0002</td>
</tr>
<tr>
<td>MENSRB</td>
<td>MENSRB.xml</td>
<td>Airborne SAR Mensuration Data Version B</td>
<td>STDI0002</td>
</tr>
<tr>
<td>MPDSRA</td>
<td>MPDSRA.xml</td>
<td>Mensuration Data</td>
<td>STDI0002</td>
</tr>
<tr>
<td>MSTGTA</td>
<td>MSTGTA.xml</td>
<td>Mission Target</td>
<td>STDI0002</td>
</tr>
<tr>
<td>MTIRPA</td>
<td>MTIRPA.xml</td>
<td>Moving Target Information Report Version A</td>
<td>STDI0002</td>
</tr>
<tr>
<td>MTIRPB</td>
<td>MTIRPB.xml</td>
<td>Moving Target Information Report Version B</td>
<td>STDI0002</td>
</tr>
<tr>
<td>NBLOCA</td>
<td>NBLOCA.xml</td>
<td>(Number of Bytes) Image Block or Frame is Offset.</td>
<td>STDI0002</td>
</tr>
<tr>
<td>OFFSET</td>
<td>OFFSET.xml</td>
<td>(NITF 2.1) Offset of the first pixel of an image from the first pixel of the full image.</td>
<td>STDI0002</td>
</tr>
<tr>
<td>PATCHA</td>
<td>PATCHA.xml</td>
<td>Patch Information Version A</td>
<td>STDI0002</td>
</tr>
<tr>
<td>PATCHB</td>
<td>PATCHB.xml</td>
<td>Patch Information Version B</td>
<td>STDI0002</td>
</tr>
<tr>
<td>PIAEQA</td>
<td>PIAEQA.xml</td>
<td>Profile for Imagery Archives Equipment</td>
<td>STDI0002</td>
</tr>
<tr>
<td>** **</td>
<td>PIAEVA.xml</td>
<td>Profile for Imagery Archives Event</td>
<td>STDI0002</td>
</tr>
<tr>
<td>** **</td>
<td>PIAEVA.xml</td>
<td>Profile for Imagery Access Event</td>
<td>STDI0002</td>
</tr>
<tr>
<td>PIAIMB</td>
<td>PIAIMB.xml</td>
<td>Profile for Imagery Archives Image</td>
<td>STDI0002</td>
</tr>
<tr>
<td>PIAIMC</td>
<td>PIAIMC.xml</td>
<td>Profile for Imagery Access Image</td>
<td>STDI0002</td>
</tr>
<tr>
<td>PIAPEA</td>
<td>PIAPEA.xml</td>
<td>Profile for Imagery Archives Person</td>
<td>STDI0002</td>
</tr>
<tr>
<td>PIAPEB</td>
<td>PIAPEB.xml</td>
<td>Profile for Imagery Access Person</td>
<td>STDI0002</td>
</tr>
<tr>
<td>PIAPRC</td>
<td>PIAPRC.xml</td>
<td>Profile for Imagery Archives Product</td>
<td>STDI0002</td>
</tr>
<tr>
<td>PIAPRD</td>
<td>PIAPRD.xml</td>
<td>Profile for Imagery Access Product</td>
<td>STDI0002</td>
</tr>
<tr>
<td>PIATGA</td>
<td>PIATGA.xml</td>
<td>Profile for Imagery Archives Target</td>
<td>STDI0002</td>
</tr>
<tr>
<td>** **</td>
<td>PIATGB.xml</td>
<td>Profile for Imagery Access Target</td>
<td>STDI0002</td>
</tr>
<tr>
<td>PRJPSB</td>
<td>PRJPSB.xml</td>
<td>Projection Parameters Extension</td>
<td>DIGEST</td>
</tr>
<tr>
<td>REGPTB</td>
<td>REGPTB.xml</td>
<td>Registration Points Extension</td>
<td>DIGEST</td>
</tr>
<tr>
<td>RPC00A</td>
<td>RPC00A.xml</td>
<td>Rapid Positioning Capability Support Data Extension</td>
<td>VIMAS</td>
</tr>
<tr>
<td>RPC00B</td>
<td>RPC00B.xml</td>
<td>Rapid Positioning Capability Support Data Extension</td>
<td>STDI0002</td>
</tr>
<tr>
<td>RSMIDA</td>
<td>RSMIDA.xml</td>
<td>RSM Identification</td>
<td>RSM</td>
</tr>
<tr>
<td>RSMPIA</td>
<td>RSMPIA.xml</td>
<td>RSM Polynomial Identification</td>
<td>RSM</td>
</tr>
<tr>
<td>RSMPCA</td>
<td>RSMPCA.xml</td>
<td>RSM Polynomial Coefficients</td>
<td>RSM</td>
</tr>
<tr>
<td>RSMDCS</td>
<td>RSMDCS.xml</td>
<td>RSM Direct Error Covariance</td>
<td>RSM</td>
</tr>
<tr>
<td>RSMAPA</td>
<td>RSMAPA.xml</td>
<td>RSM Adjustable Parameters</td>
<td>RSM</td>
</tr>
<tr>
<td>RSMeca</td>
<td>RSMeca.xml</td>
<td>RSM Error Covariance</td>
<td>RSM</td>
</tr>
<tr>
<td>RSMGIA</td>
<td>RSMGIA.xml</td>
<td>RSM Ground-to-image Grid identification</td>
<td>RSM</td>
</tr>
<tr>
<td>RSMGGA</td>
<td>RSMGGA.xml</td>
<td>RSM Ground-to-image Grid</td>
<td>RSM</td>
</tr>
<tr>
<td>SECTGA</td>
<td>SECTGA.xml</td>
<td>Secondary Target Information</td>
<td>STDI0002</td>
</tr>
<tr>
<td>SENSRA</td>
<td>SENSRA.xml</td>
<td>EO-IR Sensor Parameters</td>
<td>STDI0002</td>
</tr>
<tr>
<td>STDIDC</td>
<td>STDIDC.xml</td>
<td>Standard ID Extension</td>
<td>STDI0002</td>
</tr>
<tr>
<td>STREOB</td>
<td>STREOB.xml</td>
<td>Stereo Information</td>
<td>STDI0002</td>
</tr>
</tbody>
</table>
Displaying NCDRD DES Shapefiles

ENVI Zoom reads and displays vector shapefiles that are stored in the CSSHPA Data Extension Segment (DES). The NITF/NSIF Module in ENVI Zoom currently only supports reading, displaying, and passing through shapefiles from this DES.

1. Select **File > Open** from the menu bar, or click the **Open** button. The Open dialog appears.
2. Open a NITF file that contains one or more CSSHPA DESes. Click **OK**.
3. Open the Data Manager to see a list of the available vector shapefiles.
4. Right-click on a vector name in the Data Manager, and select **Load Vector**. The shapefile overlays the NITF image in the Image window.

<table>
<thead>
<tr>
<th>TRE Name</th>
<th>Filename</th>
<th>Descriptive Name</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>USE00A</td>
<td>USE00A.xml</td>
<td>Exploitation Usability Extension</td>
<td>STDI0002</td>
</tr>
</tbody>
</table>

* Indicates TREs that can be created, edited and deleted.

** Indicates TREs that can only be edited and deleted. These TREs cannot be added.
NITF Preferences

To edit NITF preferences, select File > Preferences from the menu bar, then select NITF in the ENVI Zoom Preferences dialog tree.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NITF File Cache Size</td>
<td>The cache size for the NITF image. The default is <strong>256 MB</strong>.</td>
</tr>
<tr>
<td>Automatically View Metadata</td>
<td>Enable or disable automatically displaying the NITF Metadata Viewer dialog when you open a NITF file. The default is <strong>False</strong>.</td>
</tr>
<tr>
<td>Suppress Input Warning Messages</td>
<td>Enable or disable showing NITF input warning messages when opening a NITF file. The default is <strong>True</strong>.</td>
</tr>
<tr>
<td>Originating Station ID</td>
<td>The station ID of the organization in which the image originated. If you enter your own value, that value will be used in the output file. If this preference field is initially empty, the software populates it with ENVI Zoom. Set this preference field to <strong>NO CHANGE</strong> (all uppercase) if you want the software to pass through the input value with no change.</td>
</tr>
<tr>
<td>Originator’s Name</td>
<td>The name of the image’s originator. If this preference field is initially empty, it remains empty in the output file. If you enter your own value, that value will be used in the output file. Set this preference field to <strong>NO CHANGE</strong> (all uppercase) if you want the software to pass through the input value with no change.</td>
</tr>
<tr>
<td>Originator’s Phone Number</td>
<td>The telephone number of the image’s originator. If this preference field is initially empty, it remains empty in the output file. If you enter your own value, that value will be used in the output file. Set this preference field to <strong>NO CHANGE</strong> (all uppercase) if you want the software to pass through the input value with no change.</td>
</tr>
<tr>
<td>File Title Chip Prefix</td>
<td>The prefix to add to the File Title metadata if you save a spatial subset. The default is <strong>Chip_hhmss_of_</strong>, where the hour (hh), minute (mm), and second (ss) reflect the time that you create the subset. If you remove this default value and enter your own text, the software appends your text to the filename.</td>
</tr>
<tr>
<td>IID2 Chip Suffix</td>
<td>The suffix to add to the IID2 field that indicates the output file contains chipped images (NITF 2.1 only). The default value is <strong>CHIP</strong>. If the original IID2 field plus the <strong>IID2 Chip Suffix</strong> field is larger than 80 characters, the <strong>IID2 Chip Suffix</strong> field will be truncated.</td>
</tr>
<tr>
<td>HISTOA Processing Site</td>
<td>The name of the company who performed the processing event. Enter up to 10 characters of text. This preference fills in the PSITE field of the HISTOA Processing Site.</td>
</tr>
</tbody>
</table>

New NITF File Metadata Preferences

This section of NITF preferences contains NITF file metadata defaults. Descriptions of the NITF file metadata fields are in MIL-STD-2500B or MIL-STD-2500A. These preferences only pertain to Chipping the Display, or when you save a non-NITF file to NITF format (using Save As).
New PIA TRE Metadata Preferences

This section of NITF preferences contains PIA TRE file metadata defaults. Descriptions of the PIA TRE metadata fields are in STDI-0002. These preferences only pertain to creating new PIA TREs, as described in "Editing NITF Metadata" on page 167.
Display Levels

Each displayable segment in a NITF dataset is assigned a display level that determines the order of display. Segments with higher display levels are displayed over those with lower display levels.

The image below shows these levels and their corresponding displayable segments.

The image above illustrates the composition of a composite NITF file. In this example, three annotation segments are displayed on top of a base image segment, another image segment is displayed as an inset, and the composite of these elements is displayed on a gray background.

The image below shows the composite of the three annotation segments, the two image segments, and the gray background. While the annotations obscure portions of the underlying image in the composite image, each annotation exists as a separate segment that can be displayed or hidden without affecting the underlying image.
Wavelength Information

Wavelength information can be stored in several different ways in a NITF image segment. The BANDSB TRE contains the most information, followed by the BANDSA TRE, and the band subcategory settings contain the least information. The software will attempt to read wavelength information from a NITF file from each of those locations, in order, until wavelength information is found. If no information is present in any of these locations, the file is opened without wavelength information.
NITF Map Information

Map information in a NITF file can come from multiple sources, which are found in rapid positioning capability (RPC) TREs, DIGEST GeoSDE TREs, or in the IGEOLO image header field. See "Order and Precedence for Reading NITF Map Information" on page 163 for the order in which the software reads this map information for NITF files. The following sections describe these types of map information.

RPC00A and RPC00B

If the RPC00A or RPC00B TRE exists, the RPC model is used to emulate a projection by default. If RPC information is available in a NITF file, the projection description in ENVI Zoom includes the string *RPC* prior to the name of the coordinate system in which the image resides.

If the Image Chip Support Data Extension Version B TRE (ICHIPB) is also present, information from this TRE is used to specify the offsets for the resulting map information. These offsets are needed to ensure the map information is consistent with the original positioning data.

For users with data containing RPC parameters in the RPC00A or RPC00B TRE, the NSDE TRE definition files and support code are required.

DIGEST GeoSDE TREs

The software uses Digital Geographic Information Exchange Standard (DIGEST) GeoSDE TREs to improve georeferencing accuracy in NITF images. The software can use the Geo Positioning Information Extension (GEOPSB) and Projection Parameters Extension (PRJPSB) TREs stored in the file header, and the Local Geographic (lat/long) Coordinate System Extension (GEOLOB) and Local Cartographic Coordinate System (MAPLOB) TREs stored in the image segment subheader. Only these GeoSDEs are supported.

A complete, valid GeoSDE TRE set requires a GEOPSB TRE in the file header. This TRE defines the basic coordinate system information including ellipsoid, datum, units, and whether the coordinate system is geographic or cartographic (projected). If the GEOPSB TRE specifies a cartographic coordinate system, it must also be accompanied in the file header by the PRJPSB TRE, which specifies the associated projection and defines the projection parameters, if required.

In addition, only one of the following TREs must be present in the image segment to which the map information applies: GEOLOB, MAPLOB, GRDPSB, or REGPTB. Because GRDPSB and REGPTB TREs are not supported, image segments containing these TREs must obtain map information from another source. The GEOLOB TRE is provided if the GEOPSB TRE specifies a geographic projection, and the MAPLOB TRE specifies a cartographic projection. Both TREs store the coordinate location of the upper-left corner of the image and the (x, y) pixel size.

NITF images containing projection codes are not supported. The software cannot use the MAPLOB TRE to find map information. Unrecognized datum codes default to WGS-84.

When packing NITF files, you cannot create, edit, or delete the DIGEST GeoSDE TREs. If the NITF file contains valid GEOLOB or GEOPSB TREs, they are preserved if you save the file to a NITF-formatted file. If you are chipping the scene, the ICHIPB TRE is added.

ICORDS and IGEOLO

The software uses the image coordinate representation (ICORDS) and image geolocation (IGEOLO) header field in the image subheader to calculate map information for an image.

These image subheader fields contain values relative to how map information is displayed:
• ICORDS: A character representing the coordinate system of the image. The character can specify either UTM or Geographic coordinates, or may specify that no corner coordinates are present.

• IGEOLO: The coordinates for each of the four corner points. If the corner points are rectified, the upper-left corner position and the pixel size are calculated and standard map information is generated for the image. Otherwise, the four corner points are used to calculate a polynomial warp used to individually calculate the coordinate location for each pixel. The polynomial warp process results in what is referred to in ENVI Zoom as a pseudo projection, which can be identified in the projection description by the inclusion of the string *pseudo* prior to the name of the coordinate system in which the image resides.

**Order and Precedence for Reading NITF Map Information**

If a NITF file contains multiple sources of map information, the order and precedence for reading the coordinate system is as follows. ENVI Zoom reads one sensor-based coordinate system (RPC) and up to one rectangular or warp coordinate system (tie point and pixel size, or affine map transformation).

1. RPC information: the software attempts to locate and use RPC map information for the file.

2. MAPLOB, PRJPSB, and GEOPSB TREs: Map information (if available) will be imported from these TREs, and tie point and pixel sizes will be created in the specified projection. If the projection is not supported, this information is considered invalid and the next georeferencing method is attempted.

3. GEOLOB and GEOPSB TREs: If available, tie point and pixel size will be imported from these TREs in a geographic coordinate system.

4. IGEOLO field in the NITF image subheader: the software parses this subheader field; if it finds valid coordinates, it determines if they are rectified. If so, tie point and pixel size are computed for the image. Otherwise, an affine map transformation is used to determine georeferencing for the image.
Displaying NITF Images

NITF files appear in the Data Manager with their own icon. Each NITF segment appears in that group as a separate layer. For NITF files with multiple image segments, they appear as subfolders under the NITF file. For NITF files with multiple image segments, the name of each image segment begins with the highest level of security found in the file, followed by the word Image, followed by the number of the image segment (Image #1 for example). The image segment name is then followed by the band names, which include the word Band and the index number (except in the case of a single-band image). An example is Band_1.

Displaying Images Using the NITF/NSIF Module

Following are some rules for displaying images using the NITF/NSIF Module:

- The NITF/NSIF Module reads and displays NITF 2.0 label and symbol segments including CGM graphics, object graphics, and bitmaps.
- The NITF/NSIF Module reads and displays data in NITF 2.1 graphics segments, including CGM graphics.
- The NITF/NSIF Module reads and displays vector shapefiles stored in the CSSHPA Data Extension Segment (DES).
- The NITF/NSIF Module does not read NITF files that contain no image segments.
- The NITF/NSIF Module does not currently support the M8 image compression format.
- The NITF/NSIF Module reads and displays files that contain a segment marked "no display." If the Suppress Input Warning Messages NITF preference is set to False, a message will display to notify you that a "no display" image is being opened.
- If a NITF file contains one or more image segments marked for display and one or more marked "no display," the "no display" image segments are ignored.

The NITF/NSIF Module uses specific rules to display an image, which take precedence over any Data Manager Preferences that you set.

Special Cases

The contents of the image representation (IREP) and band representation (IREPBAND) fields in the image subheader affect how NITF images display. The IREP values that occur most frequently are MONO (monochrome), RGB (three-band true color), RGB\LUT (single-band image with color palette), MULTI (multi-band imagery), and NODISPLY (image not intended for display). The IREPBAND values used in this process are R (Red), G (Green), B (Blue), M (Mono), and LU (Look-Up Table). The image contains one IREP value for the image segment, and one IREPBAND value for each band in the dataset.

- Images with the IREP value RGB\LUT will be displayed in true color by default, and the image will be decomposed into red, green, and blue bands.
- Multiple-band images with three bands identified as R, G, and B are displayed as RGB composites, and the three bands will be represented as red, green, and blue bands.
- If no RGB values are found in the image, and there is a band marked LU, this band will be displayed with the lookup table applied.
- If the image contains a band with the value M, it is displayed as a grayscale image.
- If a NITF file contains a lookup table and mask, the software ignores the lookup table and uses the mask.
Viewing NITF Metadata

The NITF Metadata Viewer allows you to view the metadata in the header and subheaders of a NITF file and optionally save the metadata to an ASCII file. You can also view the contents of TREs, DESes, annotation segments, and text segments in the file. To view the metadata of a NITF file, perform the following steps:

1. In the Data Manager or Layer Manager in ENVI Zoom right-click on the NITF filename and select **View NITF Metadata**. The NITF Metadata Viewer dialog appears. The number and type of items shown vary according to the dataset being displayed. The metadata displayed in each item vary per different versions of NITF.

2. Click the + next to the file header, image segment, text segment, or DES to expand the information available. See NITF Metadata Icons for information on identifying the types of metadata that may appear in a particular container. Metadata are grouped as follows:

**NITF File Header Metadata**
- Security Metadata
- TRE Metadata (if present)

**Image Segment Metadata**
- Security Metadata
- Band Metadata (one for each band)
- TRE Metadata (if present)

**Text Segment Metadata** (if present)
- Security Metadata
- TRE Metadata (if present)

**Data Extension Segments** (DESes, if present)
- Security Metadata
- User-defined Subheader (if present)

**Annotation Segment Metadata** (if present)
- Security Metadata
- Annotation Object Metadata (if present)
- TRE Metadata (if present)

*Note:* Header and segment fields are described in MIL-STD-2500C and MIL-STD-2500A.

3. To optionally save the metadata to an ASCII file, click **Save Metadata**. The Output Metadata Filename dialog appears. Enter an output filename (.txt) and click **Save**.

4. **Click Close** to dismiss the NITF Metadata Viewer.

NITF Metadata Icons

The following icons appear in the NITF Metadata Viewer to identify the types of metadata that may appear in a particular container:

<table>
<thead>
<tr>
<th>Container</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Header</td>
<td>📈</td>
<td>Contains metadata common to the entire NITF file. In addition to file metadata, this container can contain tags or security metadata pertaining to the entire file.</td>
</tr>
</tbody>
</table>
Viewing NITF Metadata from IAS Datasets

NITF metadata are only present for datasets on IAS servers that are in NITF format or that were converted from NITF to JPEG2000. To view NITF metadata from an IAS dataset:

1. Open the dataset using File > Open Remote Dataset (ENVI Zoom) or File > Remote Connection Manager (ENVI).

2. In the Data Manager (ENVI Zoom) or Available Bands List (ENVI), right-click on the image name and select View NITF Metadata. The NITF Metadata Viewer dialog appears.

3. If the NITF preference Automatically View Metadata in ENVI Zoom is set to True, the metadata are automatically displayed.

4. When you save an IAS dataset to NITF format, the NITF metadata are passed to the NITF output file, using the same rules as inheriting NITF metadata in the NITF/NSIF Module. See "Saving NITF Files" on page 169 for details.

Note: To stream and view NITF imagery and metadata from IAS servers, you must have a NITF/NSIF Module license.
Creating New PIA TREs

Profile for Imagery Access TREs and Profile for Imagery Archive TREs (both of which you can create, edit, and delete) are discussed in detail in "Preserving PIA TREs" on page 177. You can also set default PIA TRE file metadata using NITF Preferences.

To create new PIA TREs, perform the following steps:

1. Click the Metadata Editor button during Save As or when Chipping the Display to NITF.
2. Right click on the NITF file header, image segment, annotation segment, or text segment to which to add the PIA TREs, and select Add <PIA TRE> or click the Add PIAs button.
3. Select which PIA TREs and how many of the TREs you want, then click OK.

Note: The PIAPRD TRE is the only PIA TRE that you can attach to a file header, and you can only add one PIAPRD TRE. You can only add one PIAIMC TRE to an image segment.

Adding, Editing, or Deleting NITF Text Segments

Adding Text Segments

1. Click the Metadata Editor button during Save As or when Chipping the Display to NITF.
2. Right click on the NITF file header, image segment, annotation segment, or text segment to which to add the text segment, and select Add Text or click the Add Text button.
3. Type your text in the field provided, and click OK. You can alternatively click the Import ASCII button to import a text file, and click OK. A new text segment appears in the tree view. The properties for that text segment automatically display.

Editing Text Segments

To edit existing text, click in the Text field, click the right arrow, and select Edit.

Deleting Text Segments

1. Click the Metadata Editor button during Save As or when Chipping the Display to NITF.
2. Right click on the text segment you wish to delete, and select Delete Text or click the Delete Text button.
Deleting NITF Annotation Segments

1. Click the Metadata Editor button during Save As or when Chipping the Display to NITF.

2. Right click on the annotation segment you wish to delete, and select Delete Annotation or click the Delete Annotation button.
Saving NITF Files

There are a number of ways to save NITF files:

- Create a new file from an existing NITF dataset using NITF Save As. You can also use this to create a subset of a NITF image or edit NITF metadata.
- Create a new file from an existing raster dataset using NITF Save As.
- Create a screen capture of all layers in the display using File > Chip Display To.

The options listed above differ in the metadata that the software passes through or fills in by default. These differences are detailed in the Save As NITF and Chipping the Display to NITF help topics.

The software attempts to determine a reasonable set of default values for all of the file parameters before a file is exported; however, you have the ability to edit these values before creating an output file. Many of the default values, such as the image size and data type, are determined by the data being exported. The NITF Metadata Editor shows the information that you can edit in a NITF file.

Main Header

You must check the set of parameters to be added to the NITF header fields to ensure internal consistency with the requirements set forth in the NITF specification before you can write a NITF dataset. This validation is performed automatically before any new NITF dataset is created. If the validation fails, an error message is generated that indicates the source of the failure, including the name of the field causing the error and a short description of the error. In most cases, you will have the opportunity to correct any errors before continuing.

Supported Data Types for NITF Export

Supported data types and other criteria for export are described in the following table.

<table>
<thead>
<tr>
<th>Compression Type</th>
<th>NITF 2.0</th>
<th>NITF 2.1</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td># of Bands: 1, 3, or 4</td>
<td># of Bands: 1-999</td>
</tr>
<tr>
<td></td>
<td>Data Types:</td>
<td>Data Types:</td>
</tr>
<tr>
<td></td>
<td>- 8-bit unsigned integer</td>
<td>- 8-bit unsigned integer</td>
</tr>
<tr>
<td></td>
<td>- 16-bit unsigned integer</td>
<td>- 16-bit unsigned integer</td>
</tr>
<tr>
<td>JPEG DCT</td>
<td># of Bands: 1 or 3</td>
<td># of Bands: 1 or 3</td>
</tr>
<tr>
<td></td>
<td>Data Types: Byte</td>
<td>Data Types: Byte</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Saving NITF Files

**Supported Data Types for NITF Export**

You can edit all security and origination information contained in the file, along with image settings controlling how the image is written (including image blocking settings) using NITF Preferences. Many of these settings have no required values, some have only a short list of acceptable values, and others are dependent on the values present in other fields.

### NPJE

You can save NITF 2.1 images in NPJE (NSIF Preferred JPEG 2000 Encoding) with numerically lossless and visually lossless settings.

If you choose JPEG 2000 NPJE compression, the software creates a J2KLRA TRE and removes the existing J2KLRA TRE, if present. If you save a file containing a J2KLRA TRE to an uncompressed file, the software removes the J2KLRA TRE.

### EPJE

You can save NITF 2.1 images in Exploitation Preferred JPEG 2000 Encoding (EJPE) format with visually lossless and numerically lossless settings. When saving from a NITF file with an existing J2KLRA TRE, a new J2KLRA TRE is created because the image is being recompressed. NITF EPJE files display faster than NPJE files and EPJE is a required output format for IEC workstations.

The software cannot create an EPJE file without creating a temporary file. It uses the default temporary directory specified in NITF Preferences.
Transcoding

If you are saving a single C8 image segment without subsetting it, two additional options appear in the Compression drop-down list in the Save As dialog:

- Transcode NPJE to EPJE
- Transcode EPJE to NPJE

If you select one of these transcoding options, the image codestream is reordered to match the profile as closely as possible, and the codestream is neither decompressed nor recompressed.

The following changes may occur in the codestream, depending on the input profile of the codestream and the output option selected:

- Progression order (LRCP vs. RLCP)
- Segmentation and ordering of tile-parts
- PLT and TLM marker segments

The following do not change:

- Tile size
- Code-block size
- Quality
- Number of decomposition levels
- Wavelet transform
- Number of guard bits

If the image segment contains a J2KLRA or HISTOA TRE, these are updated with the appropriate information.

Note: Transcoding is not available for image segments that are embedded JPEG 2000 files.

NITF Compression Types

The types of compression available (if any) are determined by the data type and the NITF output version selected, as indicated in the table below. Higher compression rates result in smaller files with lower quality.

The following table shows the available compression types.

<table>
<thead>
<tr>
<th>NITF Output Version</th>
<th>Data Type</th>
<th>Compression Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>All versions</td>
<td>1- or 3-Band Byte</td>
<td>JPEG DCT (High compression)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>JPEG DCT (Medium compression)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>JPEG DCT (Low compression)</td>
</tr>
<tr>
<td>NITF 2.1 and NSIF 1.0 (NPJE, EPJE)</td>
<td>Any Integer data type</td>
<td>JPEG 2000 NPJE (Visually Lossless)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>JPEG 2000 NPJE (Numerically Lossless)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>JPEG 2000 EPJE (Visually Lossless)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>JPEG 2000 EPJE (Numerically Lossless)</td>
</tr>
<tr>
<td></td>
<td>Floating Point, Double</td>
<td>None</td>
</tr>
</tbody>
</table>
Chipping the Display to NITF

This topic describes using the **Chip Display To** option to create a screen capture of all layers in the display. All segments, vectors, and display properties are burned into the image and the software creates 8-bit, three-band output at the resolution you specify. Single-band images are output to three bands. To save an existing dataset as a new NITF file, see "NITF Save As" on page 174.

The software can create new NITF datasets in NITF 2.0, NITF 2.1 and NSIF 1.0 format from existing raster data. In addition, some of the information written to the file, such as origination information and security settings, will be the same for all files you create. For these settings, you can set NITF Preferences to populate these fields by default. It is highly recommended that you customize these settings prior to creating any new NITF datasets.

When you create a new file from an existing dataset using the **Chip Display To** option, the software generates all new header settings. The file date and time are set to the current date and time.

### Using Chip Display To

1. From the ENVI Zoom menu bar, select **File > Chip Display To > File** or click the **Chip to File** toolbar button.
2. Accept the default resolution, or change the resolution by typing in the **Resolution** field or by clicking the up/down arrows next to this field. Pixel width and height are displayed. Click **OK**.
3. Accept the default directory location and file name, or click **Browse** to select a directory location and type a file name. By default, the file name will be `untitled.ntf`.
4. Select a compression type from the **Compression** drop-down list.
5. Using the **Metadata Editor** button, you can optionally edit the NITF metadata and add PIA tags and text segments before saving the file.
6. Click **OK**.
7. Use the Data Manager in ENVI Zoom to display the output image.

If your new file is a spatial subset of the original image and you display it with the original image, the Overview window and Image window in ENVI Zoom show the extent of the subset with a red box when the layer is selected in the Layer Manager.

### Image Segments

NITF image segments can be created from any supported data type except 64-bit integer and complex. Image segments are populated in this way:

- **Security information, date and time:** The security information for the image segment is read from the NITF Preferences and the image date and time are set. For NITF 2.1 files, the date and time is set to `UNKNOWN`; for NITF 2.0 files, the date and time is set to Jan. 1, 1970 (because NITF 2.0 does not recognize `UNKNOWN`).

- **Rows, columns, bands, and data type:** The number of rows, columns, bands, and the data type of the output dataset is determined from the input dataset. If the number of rows and columns is less than 4096, the block size is set to the full image size. For larger images, the image is set to a block size of 1024x1024.

- **Compression:** By default, the image is uncompressed.
• **Map information:** If the image has map information in UTM, this information is written to the file using the MGRS representation supported in both NITF 2.0 and 2.1. Other map information will be converted into geographic coordinates for export.

The software may also create GEOPSB, PRJPSB, GEOLOB, or MAPLOB TREs if the input file contains map information.
NITF Save As

This topic describes using the Save As option to save an existing NITF or raster dataset to a new NITF file. To save a screen capture of all layers in the Image window, see "Chipping the Display to NITF" on page 172.

When you create a new NITF file from an existing dataset, the header settings from the source dataset are saved to the new file, except for the following values:

- The file date and time are set to the current date and time.
- The number of file copies is incremented (unless it is currently set to 0), and this copy number is set to the number of copies.
- For existing NITF files, any image segment with a compression setting not supported for output is set to uncompressed by default.
- For existing NITF files, the output version will be the same as the input version. For all other file types, the version number is set via the New NITF File Metadata, NITF Version field in the NITF Preferences.

Image segments cannot contain masks used to alter image values for display, when you create NITF output. The software passes through or fills in by default some metadata. For more information, see the following topics:

- "Preserving NITF Annotation Segments" on page 176
- "Preserving DESes" on page 176
- "Preserving TREs" on page 177
- "Preserving PIA TREs" on page 177
- "Preserving PIA TREs" on page 177
- "Preserving NITF Text Segments" on page 177

Saving an Existing NITF File to NITF Using Save As

When saving an existing NITF file to NITF using the Save As option, metadata that is contained in the original dataset will be passed through to the new NITF file.

NITF 2.1 images can be saved in NSIF Preferred JPEG 2000 Encoding (NPJE) format with numerically lossless and visually lossless compression settings. NITF 2.1 images can also be saved in Exploitation Preferred JPEG 2000 Encoding (EPJE) format with visually lossless and numerically lossless settings.

When saving with the NPJE compression, ENVI Zoom creates a J2KLRA TRE and removes the existing one, if present. If you save a file containing a J2KLRA TRE to an uncompressed file, ENVI Zoom removes the J2KLRA TRE.

ENVI Zoom cannot create an EPJE file without creating a temporary file. ENVI Zoom uses the Temporary Directory specified in the Preferences.

Saving a Raster File to NITF Using NITF Save As

The software can create new NITF datasets in NITF 2.0, NITF 2.1 and NSIF 1.0 format from existing raster data. Some of the information written to the file, such as origination information and security settings, will be the same for all files you create. For these settings, you can set NITF Preferences to populate these fields by default. It is highly recommended that you customize these settings prior to creating any new NITF datasets.
Using NITF Save As

1. From the ENVI Zoom menu bar, select File > Save As.

2. Optionally, expand the file name (in a file with one or more image segments) and select an individual segment to save. If a NITF file contains one or more image segments marked for display and one or more marked "no display," the "no display" image segments are not shown in this dialog. However, when you save this file using the Save As option, the "no display" image segments are passed through with the NITF file.

3. Perform optional spatial subsetting, then click OK.

4. Accept the default directory location and file name, or click Browse to select a directory location and type a file name. By default, the file name will be untitled.ntf.

5. Select a compression type from the Compression drop-down list. This option will be unavailable for files with multiple image segments. In this case, the compression type is passed through from the existing file.

6. Using the Metadata Editor button, you can optionally edit the NITF metadata and add PIA tags and text segments before saving the file. See "Editing NITF Metadata" on page 167 and for more information.

7. Click OK.

Image Segments

NITF image segments can be created from any supported data type except 64-bit integer and complex. Image segments are populated in this way:

- **Security information, date and time:** The security information for the image segment is read from the NITF Preferences, and the image date and time are set. For NITF 2.1 files, the date and time is set to UNKNOWN; for NITF 2.0 files, the date and time is set to Jan. 1, 1970 (because NITF 2.0 does not recognize UNKNOWN).

- **Rows, columns, bands, and data type:** The number of rows, columns, bands, and the data type of the output dataset is determined from the input dataset. If the number of rows and columns is less than 4096, the block size is set to the full image size. For larger images, the image is set to a block size of 1024x1024.

- **Compression:** By default, the image is uncompressed.

- **Map information:** If the image has map information in UTM, this information is written to the file using the MGRS representation supported in both NITF 2.0 and 2.1. Other map information will be converted into geographic coordinates for export.

The software supports creation of the RPC00B TRE when exporting to any NITF file containing RPC information. The RPC00B TRE is automatically created when this information is available, and the ICHIPB TRE is created if needed. These TREs will be stored in the image segment of the new NITF file. The ICHIPB TRE is required if a spatial subset of the input image is selected or the input image is a subset of a larger product.

The software may also create GEOPSB, PRJPSB, GEOLOB, or MAPLOB TREs if the input file contains map information.

- **Image and band representation:** For single-band images, the image representation field is set to MONO and the band representation is set to M, while three-band byte images have RGB as the image...
representation, with the band representations set to R,G, and B. For any other band count, the image representation will be set to MULTI and, if a set of default bands is specified for this file, these bands will have their representations set to R, G, and B to indicate that these bands should be displayed by default. See the table below for more information.

<table>
<thead>
<tr>
<th>Type of Image</th>
<th>Image (Representation)</th>
<th>Band (Representation)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single-band image</td>
<td>MONO</td>
<td>M</td>
</tr>
<tr>
<td>Three-band byte image</td>
<td>RGB</td>
<td>R,G,B</td>
</tr>
<tr>
<td>Other image</td>
<td>MULTI</td>
<td>R,G,B (if specified)</td>
</tr>
</tbody>
</table>

- **Wavelength information:** If wavelength information is not available for the file, or if only one band is being exported, the image category is set to VIS, and the band subcategory is left blank. If wavelength information is available, the software will attempt to convert the wavelength into nanometers, then write that information into the band subcategory. In this case, the image category is set based upon the number of input bands: HS is used for files with more than 200 bands, and MS is used for files with 2-200 bands. All other fields are left blank. The BANDSB TRE is automatically created and populated with all available information when the input file contains wavelength information.

**Preserving DESes**

When you save an existing NITF file to NITF format, supported DES segments are preserved in the new file. The software currently only supports NITF Commercial Dataset Requirements Document (NCDRD) DESes. See "Data Extension Segments" on page 153 for a list of supported DESes. You cannot edit, create, or delete NCDRD DESes through the NITF Metadata Editor. When writing a NITF file that contains a DES with no corresponding XML file, the software passes through this unknown DES.

**Preserving NITF Annotation Segments**

When you save an existing NITF file to NITF format, the software preserves CGM annotation segments. You cannot alter any data or metadata associated with the annotation segment, however you can edit the following fields in the NITF Metadata Editor: Annotation ID, Annotation Name, and Annotation Security Fields.

You cannot add annotation segments when creating a new NITF file from a non-NITF file. You can delete annotation segments from a NITF file when saving.

If you subset a NITF image file containing annotation segments, the following rules apply:

- If an annotation segment is attached to the file (level 0) and you subset the file, the annotation location does not change. The annotation will be in the same location in the input and output file but may not be in the same relative location to other objects in the file.

- If an image segment is entirely or partially inside the subset and has one or more annotation segments attached to it, the annotation segments are saved. In the output file, the annotation segments are in the same relative location to the image they are attached to as they are in the input file.

- If an image segment is outside the subset and has one or more annotation segments attached to it, the image and annotation segments are discarded. Any segments attached to the discarded annotation segment are also dropped.
Preserving NITF Text Segments

When you save a NITF file to a new NITF file, text segments and associated TREs are preserved (included) in the new file. In NITF 2.1, text segments are attached to either the file or an image segment of a NITF image file by using an attachment level field, TXTALVL. The attachment level is the display level of an image or graphic segment to which the text segment is attached; a value of 0 indicates the attachment is to the file header. Per the NITF Specification, NITF 2.0 text segments do not have attachment levels.

Preserving TREs

When you save a NITF file to a new NITF file, supported TREs associated with any exportable segments are preserved in the new file (see: "Tagged Record Extensions" on page 153). A warning message is provided if any TRE is not supported.

If you select a spatial subset of an input dataset for output, the ICHIPB TRE is used to maintain the relationship of the output image data to the source image data and to ensure the validity of any other TRE. The ICHIPB TRE contains the size and position of the subset and is written in the image segment. A new ICHIPB TRE is added to the list of TREs when you export an image segment with a TRE with any spatial subset other than the entire image. If the ICHIPB TRE already exists, it is modified for the new (smaller) subset of the initial subset to still contain the correct parameters from the original source image, not the initial subset.

If a NITF image segment contains HISTOA TREs and NEVENTS is not equal to the maximum value of 99 in the last HISTOA TRE, the software automatically updates this TRE upon output. If NEVENTS is equal to 99 in the last HISTOA TRE, the software creates a new HISTOA TRE. The software does not create a new HISTOA TRE if the input NITF image segment does not contain a HISTOA TRE.

Preserving PIA TREs

Profile for Imagery Access and Profile for Imagery Archive (PIA) TREs are used to hold information required by the Standards Profile for Imagery Access (SPIA). A variety of government agencies require these TREs in NITF image products. When you save a NITF file to a new NITF file, the PIA TREs associated with the file header and any image, symbol, label, or text segments are preserved in the new file.

There are 10 unique PIA TREs; newer PIA TREs are labeled Profile for Imagery Access, and older PIA TREs are labeled Profile for Imagery Archive.

You can edit, delete, and save both sets of PIA TREs in NITF files, but you can only create the Profile for Imagery Access TREs shown in the table below. You can create the TREs with user-defined default values using NITF Preferences, and you can save (pack) these to an output NITF file. The software updates PIAPRC and PIAPRD TREs with the current date and time when you create NITF output.

<table>
<thead>
<tr>
<th>PIA TRE</th>
<th>Header Location</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PIAPRD</td>
<td>File</td>
<td>Profile for Imagery Access Product Information about products derived from a source image</td>
</tr>
</tbody>
</table>
The table below lists Profile for Imagery Archive TREs from an output NITF file that you can edit or delete, but not create.

<table>
<thead>
<tr>
<th>PIA TRE</th>
<th>Header Location</th>
<th>Description</th>
</tr>
</thead>
</table>
| PIAIMC  | Image          | Profile for Imagery Access Image  
Additional image information       |
| PIATGB  | Image, Symbol, Label, or Text | Profile for Imagery Access Target  
Descriptive data about targets in a segment. One TRE per target |
| PIAPEB  | Image, Symbol, Label, or Text | Profile for Imagery Access Person  
Descriptive data about people in a segment. One TRE per identified person |
| PIAEVA  | Image, Symbol, Label, or Text | Profile for Imagery Access Event  
Descriptive data about events in a segment. One TRE per identified event |
| PIAEQA  | Image, Symbol, Label, or Text | Profile for Imagery Access Equipment  
Descriptive data about equipment in a segment. One TRE per identified piece of equipment |
| PIAPRC  | File           | Profile for Imagery Archive Product  
Information about products derived from a source image |
| PIAIMB  | Image          | Profile for Imagery Archive Image  
Additional image information |
| PIATGA  | Image, Symbol, Label, or Text | Profile for Imagery Archive Target  
Descriptive data about targets in a segment. One TRE per target |
| PIAPEA  | Image, Symbol, Label, or Text | Profile for Imagery Archive Person  
Descriptive data about people in a segment. One TRE per identified person |
| PIAEVA  | Image, Symbol, Label, or Text | Profile for Imagery Archive Event  
Descriptive data about events in a segment. One TRE per identified event |
| PIAEQA  | Image, Symbol, Label, or Text | Profile for Imagery Archive Equipment  
Descriptive data about equipment in a segment. One TRE per identified piece of equipment |

For detailed information on these TREs, see the NITFS Technical Board document STDI-0002.
Glossary

AATSR
Advanced Along-Track Scanning Radiometer; an ENVISAT sensor.

absorption feature
A region of the electromagnetic spectrum where a given material absorbs radiation, shown by a low point in a spectral curve. Each material has unique absorption features, which serve as identifying characteristics.

abundance image
In hyperspectral analysis, an image whose values represent the fractions of total spectrally integrated radiance or reflectance of a pixel contributed by each spectrally unique material.

ACRES
Australian Centre for Remote Sensing.

across track
The imaging direction perpendicular to the along track direction of a satellite or aircraft. The across track viewing angle determines the swath.

active layer
The layer that you select to edit, when multiple annotation or vector layers are open. The Crosshairs and Vector tools work on the active vector layer. The Annotation tools work on the active annotation layer.
adaptive filter

A type of spatial filter that uses the standard deviation of those pixels within a local box (kernel) surrounding each pixel to calculate a new pixel value. Typically, the original pixel value is replaced with a new value. Unlike a typical low-pass smoothing filter, adaptive filters preserve image sharpness and detail while suppressing noise.

adjacency effect

The change in a pixel value caused by photons that reflect off the ground and scatter into the sensor field-of-view; radiance from neighboring pixels affects the measured radiance of a target pixel. The algorithms in the Atmospheric Correction Module in ENVI account for this effect.

ADRG

ARC Digitized Raster Graphics; a National Geospatial-Intelligence Agency (NGA) data format.

aerosol scattering

Redirection of electromagnetic energy caused by aerosols, which are particles suspended in the atmosphere.

AIRSAR

Airborne Synthetic Aperture Radar; a NASA Jet Propulsion Laboratory (JPL) sensor.

algorithm

A step-by-step procedure for performing a specific task, such as a mathematical formula or a set of instructions on a computer program.

along track

The imaging direction parallel to the direction that a satellite or aircraft moves.

alpha residuals

In hyperspectral analysis, alpha residuals are spectra that are a function of emissivity only. They have a similar shape as emissivity spectra but have a zero mean.

annotation

A graphic element added to an image or map composition. Annotation objects include, but are not limited to, symbols, shapes, polylines, text, arrows, scale bars, borders, map keys, declination diagrams, color ramps, images, and plots.

anomalies

Targets whose signatures are spectrally distinct from their surroundings.

apparent reflectance

Reflectance recorded at the sensor; also defined as radiance normalized by solar irradiance. Apparent reflectance is not true reflectance because shadows and directional effects have not been accounted for.

arbitrary profile

Also called a transect; a line drawn on an image, whose underlying data values are graphed in a cross-section plot.
area-based matching
A method of automatic image-to-image registration that compares the gray scale values of patches of two or more images and tries to find conjugate image locations based on the similarity of the gray scale value patterns.

ASAR
Advanced Synthetic Aperture Radar; an ENVISAT sensor.

ASCII
American Standard Code for Information Interchange; a simple text format.

aspect
The direction (azimuth) that a surface faces, typically in degrees clockwise from North (0 degrees); a parameter used in topographic modeling.

ASTER
Advanced Spaceborne Thermal Emission and Reflection Radiometer; a NASA EOS sensor.

atmospheric correction
A method used to correct sensor radiance for atmospheric effects by mathematically modeling the physical behavior of radiation as it passes through the atmosphere.

atmospheric window
A region of the electromagnetic spectrum in which satellites and aircraft cannot acquire measurements because of substances that absorb solar radiation (the most common are water vapor and CO2).

ATSR
Along Track Scanning Radiometer; an ERS-1 and ERS-2 sensor.

attributes
Data that describe the properties of a point, line, or polygon record in a GIS. Attributes are typically stored in table format.

autocorrelation
In multivariate statistics, a measure of correlation among residuals from a regression equation. An autocorrelation (r) value of 1.0 or -1.0 indicates a strong relationship between successive residuals, and a value of 0 indicates no relationship. In remote sensing, autocorrelation provides an indication of the local homogeneity of a data set, by evaluating the overall pattern between proximity and similarity of pixel values.

AVHRR
Advanced Very High Resolution Radiometer (NOAA).

AVIRIS
Airborne Visible/Infrared Imaging Spectrometer (NASA/JPL).

background
All pixels in a scene that are not an anomaly or target.
band
A discrete portion of the electromagnetic spectrum measured by an aircraft or satellite sensor. Legacy multispectral sensors typically have fewer, wider bands, while modern hyperspectral sensors have hundreds of bands that each measure a very narrow range of wavelengths.

Band Math
An ENVI tool that allows you to define and apply mathematical expressions to spatial image data, resulting in a new output image.

band ratio
The process of dividing one spectral band by another to enhance their spectral differences and to reduce the effects of topography.

BandMax
An algorithm developed by the Galileo Group, Inc., used to increase classification accuracy of targets in hyperspectral analysis. BandMax determines an optimal set of bands to help separate targets from known background materials.

batch mode
Performing a linear sequence of ENVI processing tasks in a non-interactive manner.

batch mode routine
An IDL program that includes ENVI library routines to perform a non-interactive image processing task.

BIL
Band Interleaved by Line; a raster interleave type that stores the first line of the first band, followed by the first line of the second band, followed by the first line of the third band, interleaved up to the number of bands. Subsequent lines for each band are interleaved in similar fashion. This format provides a compromise in performance between spatial and spectral processing and is the recommended file format for most ENVI processing tasks.

BIP
Band Interleaved by Pixel; a raster interleave type that stores the first pixel for all bands in sequential order, followed by the second pixel for all bands, and so forth, interleaved up to the number of pixels. This format provides optimum performance for spectral (z) access of the image data.

BSQ
Band Sequential; a raster interleave type whereby each line of the data is followed immediately by the next line in the same spectral band. This format is optimal for spatial (x,y) access of any part of a single spectral band.

buffer
A user-specified extension zone around a point, line, or polygon. In a buffer zone image, each pixel represents the distance from that pixel to the nearest pixel of the selected class(es). Pixels that fall beyond a user-specified maximum distance threshold are set to that maximum distance.
byte order

The order of bytes in integer, long integer, 64-bit integer, unsigned 64-bit integer, floating-point, double-precision, and complex data types. Following are the two methods of byte order:
- Host (Intel): Least significant byte first (LSF); byte order=0 in the ENVI Header; used in Intel-based (Windows, Linux, MacIntel) platforms.
- Network (IEEE): Most significant byte first (MSF); byte order=1 in the ENVI Header; used in Macintosh and Unix platforms.

CADDRG

Compressed ARC Digitized Raster Graphics; an NGA data format.

CCRS

Canadian Centre for Remote Sensing.

change detection

The process of comparing two or more images acquired at different times.

color ramp

An annotation object that shows a gradual transition from one color to another. For a gray scale image, the transition is from the minimum to the maximum gray scale value. For a color image, the color ramp is the distribution of the selected color palette.

color space

A mathematical way of representing color in terms of intensity values, often as a 3D model.

color table

A special lookup table that associates screen brightness values with specific RGB values. For a color image, the output colors consist of different red, green, and blue values. For a gray scale image, the red, green, and blue data values are the same for a given data value.
**color transform**
A method used to convert RGB images to a different color space, and vice-versa; by applying a contrast stretch in another color space, you can highlight certain features in an image. Also see "data fusion" and "image sharpening."

**color-infrared composite**
Also called CIR, or false-color composite; An image where the near-infrared band (0.76 - 0.9 microns) is displayed in red, the red band (0.6 - 0.7 microns) is displayed in green, and the green band (0.5 - 0.6 microns) is displayed in blue.

**compound widget**
In ENVI programming, a predefined widget that ENVI automatically builds for you when you call the appropriate library routine in your user function (see the ENVI Reference Guide for a list of library routines). Each compound widget performs a specific task that is often needed in a custom graphical user interface for image processing.

**confusion matrix**
Also called a contingency matrix. A table used to assess classification accuracy and misclassification between categories. The matrix is size m x m, where m is the number of classes. The rows in the matrix represent classes that are assumed to be true, while the columns represent classes derived from remote sensing imagery. The matrix also lists errors of commission and omission.

**contour line**
A line that follows the same elevation on a topographic map.

**contrast stretch**
A method of improving the contrast of a remote sensing image by stretching the original range of digital numbers (DNs) across the full contrast range of the display. The most commonly used stretches in ENVI are Equalization, Gaussian, and Linear.

**convolution**
The process of applying a spatial filter on an image, where each pixel is based on a weighted average of coefficients within an n x n matrix surrounding the pixel (where n is an odd number).

**correlation**
A statistical measure of the linear relationship between two data sets. If they vary in the same direction, the correlation is positive; if they vary in the opposite direction, the correlation is negative.

**correlogram**
A plot of autocorrelation values at multiple lag distances; a measure of how autocorrelation decreases as distance increases. For example, if you specify a maximum lag distance of 5 pixels, autocorrelation is calculated for lags of 5, 4, 3, 2, and for each pixel's nearest neighbors.

**covariance**
A statistical measure of the tendency of two variables to move or vary together; more specifically, the simultaneous deviations of two variables from their means.

**data dimensionality**
The number of variables (bands) present in a data set.
data fusion

The process of displaying two data sets of the same area together in one RGB color composite. The data sets must be registered and resampled so that they have the same orientation, pixel size, and image dimensions. A popular example of data fusion is to apply an HSV color transform to one image, replace the value band with another image, then reverse the color transform. This produces an image that merges the color characteristics of one image with the spatial characteristics of another image.

datum

A reference point or surface against which position measurements are made, and an associated model of the shape of the earth for computing positions. Different nations and agencies use different datums based on local reference points. Examples include the NAD83 and NAD27.

decision tree

A classification technique that uses a series of binary decisions to place pixels into classes. Each decision point divides pixels into two classes based on an expression. Then you can divide each new class into two more classes based on another expression, and so on.

declination diagram

An annotation object that includes any combination of arrows pointing to true north, grid north, and magnetic north.

delaunay triangulation

An image-to-image warping method that fits triangles to irregularly spaced tie points and interpolates values to the output grid.

DEM

Digital elevation model; a raster data set where each pixel represents an elevation value.

density slice

A method for converting the continuous gray tone of an image into a series of density intervals, or slices, each corresponding to a specific digital range.

deskew

A preprocessing method used to correct systematic distortions caused by earth rotation and scan skew; these were especially evident in Landsat MSS imagery.

destripe

A preprocessing method used to remove periodic scan line striping in image data. This type of striping is often seen in Landsat MSS data (every 6th line) and, less commonly, in Landsat TM data (every 16th line).

DIMAP

Digital Image Map; a SPOT data format.

display group

A term that refers collectively to the Scroll window, Image window, and Zoom window in ENVI.

display group menu bar

The menu bar in the Image window of a display group.
DLG
Digital Line Graph; a USGS vector data format.

DMSP
Defense Meteorological Satellite Program (U.S. Air Force).

DN
Digital number; also called "pixel value."

DOQ
Digital Orthophoto Quadrangle; a USGS data format.

DRG
Digital Raster Graphics; a scanned topographic map generated by the USGS.

DTED
Digital Terrain Elevation Data; an NGA data format.

DXF
Data Exchange Format; a format for storing vector data in ASCII or binary files.

dynamic overlay
An ENVI feature that allows you to immediately overlay and toggle (flicker) between two linked images.

ECW
Enhanced Compressed Wavelet; a proprietary data format developed by Earth Resource Mapping that is primarily intended for aerial imagery.

EFFORT
Empirical Flat Field Optimal Reflectance Transformation; an algorithm that polishes out noise and errors that may appear in hyperspectral apparent reflectance data, thus improving the accuracy of the data and making apparent reflectance spectra appear more like spectra of real materials.

eigenvalues
Transformation coefficients in principle components analysis that can be used to determine the percent of total variance explained by each of the principle components.

eigenvectors
A set of weights applied to band values to obtain principal components; they show the relative contributions of the different original bands to the final principal components bands.

electromagnetic spectrum
The full spectrum of electromagnetic radiation, extending from short cosmic waves to long radio waves.

ellipsoid
A smooth mathematical surface that is used to represent the geometric model of the earth. Its axes approximate the dimensions of the earth, rotated around the polar axis. Examples include the Clark ellipsoid of 1866 and the GRS80 ellipsoid.
emissivity
The ratio of the radiance emitted from an object at a particular wavelength to the radiance that a black-body would emit at the same temperature and wavelength. An emissivity of 1.0 is a perfect blackbody (a perfect absorber). Most earth surface types have emissivities between 0.9 and 1.0.

endmember
A pure spectrally unique material that occurs in a scene.

enterprise
A computer network that allows information technology to be shared in an organization.

ENVI header file
A text file that must accompany an image file and reside in the same directory as the image file. The header file lists required image characteristics such as number of samples, number of lines, number of bands, offset, file type, byte order, data type, and storage order.

ENVI main menu bar
The main menu that appears when you start ENVI.

ENVI save files
Binary files that contain the basic ENVI library routines and internal variables required to run ENVI.

ENVISAT
Environmental Satellite (European Space Agency)

EOS
Earth Observing System (NASA)

EOSAT
Earth Observation Satellite Company

epipolar images
A stereo pair of images in which the left and right image are oriented such that ground control points (GCPs) have the same y-coordinates on both images, thus removing one dimension of variability. Epipolar images are generated based on epipolar geometry and are used to extract a DEM.

EROS
Earth Resources Observation System.

ERS
European Remote Sensing satellite (European Space Agency).

ESA
European Space Agency.

ESRI
Environmental Systems Research Institute.
ESRI layer
In ArcGIS, a layer file is a reference to a data source, such as a shapefile, coverage, geodatabase feature class, or raster, that defines how that data source should be symbolized on a map. ESRI layer can also refer to a layer dragged from ArcMap or ArcCatalog to the Image window.

ETM+
Enhanced Thematic Mapper; a Landsat-7 sensor.

event handler
IDL code that manages events generated by widgets.

EVF
ENVI vector file; a format that ENVI uses to store vector data, no matter what the input native format is. EVF is the most efficient format for storing and manipulating vector information within ENVI.

exterior orientation
In photogrammetry, the process of transforming image coordinates to object (ground) coordinates using ground control points (GCPs).

feathering
The process of blending the edges of overlapping areas in input images for pixel-based and map-based mosaicking.

feature
Also called "spatial feature." A user-defined geographic phenomenon that can be modeled or represented using geographic data sets. Examples include roads, buildings, grasslands, and water bodies.

feature class
A feature class is a collection of geographic features with the same shape type (point, line, or polygon), attributes, and spatial reference. Feature classes can be stored in geodatabases, shapefiles, or other formats.

feature-based matching
A method of automatic image-to-image registration that extracts distinct features from images and identifies features that correspond to one another (by comparing feature attributes and location).

FFT
Fast Fourier Transform; a filter used to transform image data into a complex output image showing its various spatial frequency components.

fiducial marks
A series of four or eight crosshairs placed along the edge of aerial camera film during exposure. The intersection of imaginary lines connecting opposite fiducial marks corresponds to the principal point of the photograph. Fiducial marks are used primarily to orthorectify aerial photographs.

field spectra
Spectra of natural features such as minerals or vegetation, analyzed in the field using a handheld spectrometer. Field spectra are often used as a baseline, or true spectra for identification of minerals or vegetation types from hyperspectral remote sensing imagery.
filter function
A function which is used to adjust the intensity of a pixel based on its distance from a geometric element.

FLAASH
Fast Line-of-sight Atmospheric Analysis of Spectral Hypercubes; a first-principles atmospheric correction modeling tool for retrieving spectral reflectance from hyperspectral radiance images. FLAASH is a separate add-on module in ENVI.

flat binary
A general raster format where data are stored as a binary stream of bytes in BSQ, BIP, or BIL format.

fly-through
A 3D animation along a hypothetical flight path in a 3D SurfaceView.

frame central projection
A modeling scenario used to compute rational polynomial coefficients (RPCs) in frame camera and digital (frame central) aerial photography. This projection has one perspective center, which is colinear in space with its object point and image point.

function
In ENVI programming, a program unit containing one or more IDL statements that returns a value. Functions take the following form: Result = FUNCTION_NAME(Argument [, Optional Argument])

FWHM
Full width half maximum; an engineering term that pertains to the signal curve of a sensor; in a plot of the measured signal (which approaches a near-Gaussian distribution), the FWHM is the horizontal distance between the two points on the signal curve that are half the maximum value. FWHM is an important measure of the quality of an imaging device and its spectral resolution.

gain
In ENVI, a value that is multiplied by the pixel value to scale it into physically meaningful units of radiance: radiance = DN * gain + offset

GCP
Ground control point; a point on the ground whose location is known through a horizontal coordinate system or vertical datum. A GCP relates a point in a remote sensing image (x,y) to a geographic point on the earth (latitude/longitude, for example).

GCTP
General Cartographic Transformation Package.

geographic coordinate system
A coordinate system for defining locations on the earth's surface using a 3D spherical model that includes an angular unit of measure, a prime meridian, and a datum.

geoid
An undulating surface that approximates the shape of the earth and mean sea level throughout the world. The direction of gravity is perpendicular to the geoid at every point. The geoid is the reference surface for surveying and some inertial navigation systems. An example is the OSU91A geoid.
GeoJP2
A format extension to JPEG2000 for embedding coordinate system and georeferencing information in a JPEG2000 JP2 format file. The GeoJP2 format was developed by Mapping Science, Inc.

generically corrected
An image that has been adjusted to remove geometric distortions caused by lens distortion, sampling rate variation, sensor drift, topographic relief, and other factors.

generate reference
To map a remote sensing image to a known location on the earth, by referencing it to a map projection.

generated
A defined location in physical space in map projections or coordinate systems.

GeoTIFF
A public-domain metadata standard that allows geographic information to be embedded within a TIFF file. Remote sensing software uses the metadata to position the geographic data.

GIS
Geographic information system.

GLT
Geographic lookup table; a binary file that maps an input pixel to an output pixel based on input geometry information. A GLT file contains integer pixel location values that are sign-coded to indicate if a certain output pixel is real or interpolated from nearest-neighbor resampling. The two bands of a GLT file refer to the original sample number and original line number, respectively. You can georeference your data directly from a GLT file.

GPS
Global positioning system.

gray scale
A range of black to white tones as displayed on a monitor or in an image; a gray scale image is created when the red, blue, and green color guns of the monitor are assigned the same value for each pixel.

HDF
Hierarchical Data Format; a data structure developed by the National Center for Supercomputing Applications.

HDF-EOS
Hierarchical Data Format - Earth Observing System; a format used for storing data from NASA EOS sensors that adds geolocation objects (grid, point, and swath) to the HDF format.

hill shade image
A color shaded-relief image created by transforming a color image into HSV color space, replacing the value band with a shaded-relief image, and transforming the color image back to RGB space.

histogram
A plot that shows the frequency of occurrence (y-axis) of the brightness values (x-axis) of an image. You can adjust the histogram for each band (red, green, and blue).
HLS
Hue-lightness-saturation color space.

HSV
Hue-saturation-value color space.

hyperspectral
A term used to describe data sets typically composed of 100 to 200 (or more) spectral bands of relatively narrow, contiguous, bands (5 to 10 nm). Hyperspectral imaging creates a large number of images from contiguous regions of the electromagnetic spectrum. This increases sampling of the spectrum (versus multispectral data) and greatly increases the amount of information available to a researcher. Also see "imaging spectrometer."

IDL
Interactive Data Language.

IGM
Input Geometry file; an ancillary file that provides map information in two bands: one for x coordinates and another for y coordinates. Many data sets include IGM files in their distribution. An IGM file itself is not georeferenced, but it contains georeferencing information for each original, raw pixel in an image.

IKONOS
A GeoEye high-resolution satellite that produces 1 m panchromatic and 4 m multispectral imagery.

image box
The red box inside a Scroll window that defines the area covered in the Image window.

image coordinates
Also called "pixel coordinates." The location of an image pixel in generic (sample, line) coordinates. Image coordinates always increase (one unit for every pixel) with increasing sample and line number. Also see XSTART and YSTART.

image cube
A color image created from a multispectral or hyperspectral file where the data set is shown with an image represented on the face of a cube and the spectral information of the edge pixels depicted on the other faces.

image sharpening
The process of merging a low-resolution color image with a high-resolution gray scale image (with resampling to the high-resolution pixel size).

Image window
The window in a display group that displays the image at full resolution. If the image is large, the Image window displays the subsection of the image defined by the Scroll window Image box. See Display Groups on page 46 for an example.
imaging spectrometer

A sensor designed to collect hyperspectral imagery. Examples include AVIRIS and HyMap. Many spectral images are acquired simultaneously, where each pixel in an image contains a continuous spectrum with typically hundreds of spectral measurements that is used to analyze surface features and atmospheric constituents.

incidence angle

In a radar system, the angle defined by the incident radar beam and the vertical (normal) to the intercepting surface. In pushbroom sensors, the along track incidence angle is the angle between the vertical position of the satellite and its forward or backward viewing direction. The across track incidence angle is the angle (in degrees) between the vertical position of the satellite and its side-viewing direction when the sensor is scanning along the side.

interactive user routine

In ENVI programming, a user function that performs some type of interactive analysis and is triggered by certain events or user selection. Examples include plot functions, Spectral Analyst functions, user-defined map projection types, user-defined units, user-defined RPC readers, and user move routines.

interior orientation

In photogrammetry, the process of transforming scanned image pixel coordinates to image coordinates defined by fiducial marks in the aerial photograph.

interleave

A term that refers to how raster image data are stored. See BSQ, BIL, and BIP.

IRS

Indian Remote Sensing satellite (Government of India, Department of Space).

JERS

Japanese Earth Resources Satellite (Japan Aerospace Exploration Agency).

JITC

Joint Interoperability Test Command; an organization that certifies systems implementing the NITF data format for compliance with NITF standards.

JPEG

Joint Photographic Experts Group image format.

JPL

Jet Propulsion Laboratory (NASA).

kernel

An array of pixels used for digital image filtering or to constrain an operation to a subset of pixels.

laboratory spectra

Spectra of materials (such as minerals or vegetation types) measured with a spectrometer in a controlled laboratory environment. Laboratory spectra are often used as a baseline, or true spectra for identification of materials from hyperspectral remote sensing imagery.
Lambertian

A surface that emits or reflects radiation isotropically, according to Lamberts law; a perfectly diffusing surface; the brightness (luminance, radiance) of a lambertian surface is constant regardless of the angle from which it is viewed.

LAS

A binary data format that contains LIDAR point data records.

Layer stacking

The process of building a multi-band file from georeferenced images of various pixel sizes, extents, and projections. The output file has a geographic extent that either encompasses all of the input file extents or encompasses only the data extent where all of the files overlap.

Library routines

DL programs that encompass nearly all of the functionality in ENVI. The ENVI Reference Guide contains a complete index and full reference page for each library routine.

Lidar

Light detection and ranging; a technology that determines distance to an object or surface by measuring the time delay between a laser pulse transmission and detection of the return signal.

Line

The y component of a raster image coordinate pair (x,y); same as row.

Line central projection

A model used to compute rational polynomial coefficients (RPCs) in imagery from pushbroom sensors and line central aerial photography. Each scan line has its own projection center.

Line of sight

A spatial analysis tool that determines which pixels can be seen from a specific pixel within any file that has an associated DEM; topographic features will obscure some pixels from view.

Logarithmic residual

An input spectrum divided by the spectral geometric mean (the mean of all bands for each pixel) of a data set, which is then divided by the spatial geometric mean (the mean of all pixels for each band). Logarithmic residuals are used to remove solar irradiance, atmospheric transmittance, instrument gain, topographic effects, and albedo effects from radiance data.

LUT

Lookup table; a static table that associates an image pixel value with a specific screen brightness value; used for contrast-stretching an image.

Majority analysis

A post-classification tool used to change spurious pixels within a large single class to that class. You specify a kernel size, and the center pixel in the kernel is replaced with the class value represented by the majority of the pixels in the kernel.

Map projection

A mathematical method of representing the earth on a flat plane. Hundreds of map projections are available to satisfy various project requirements (accurate distance, accurate navigation, equal area, etc.)
MAS

MODIS Airborne Simulator (NASA)

mask

An image consisting of zeros and ones that, when applied to another image, tells ENVI which pixels in that image to analyze (ones) and which pixels to ignore (zeros). A mask is useful, for example, if you want to calculate image statistics while ignoring missing data values.

mean spectrum

The average spectra of all pixels in an image or kernel.

MERIS

Medium Resolution Imaging Spectroradiometer; an ENVISAT sensor.

meta file

A virtual file in ENVI that is essentially a combination of image files or bands treated as the same input file. An ENVI meta file is a text file with names and locations of files on disk. When you select the meta file for input or processing, ENVI retrieves the image data from the individual disk files and treats them as if they were part of the same input file for processing.

minority analysis

A post-classification tool where you enter a kernel size, and the center pixel in the kernel is replaced with the class value represented by the minority of the pixels in the kernel.

MNF rotation

Minimum Noise Fraction; a transform used to determine the inherent dimensionality of image data, to segregate noise from the data, and to reduce the computational requirements for subsequent processing. MNF rotation consists of two principal component transformations, with a noise whitening step.

MODIS

Moderate Resolution Imaging Spectroradiometer; a NASA EOS sensor aboard the Aqua and Terra satellites.

MODTRAN

An atmospheric radiative transfer model developed by the Air Force Research Laboratory that predicts path radiances and transmissions through the atmosphere and can be used to describe vertical profiles of water vapor, ozone, and aerosols. The FLAASH module uses MODTRAN code.

morphological filter

A filter based on mathematical morphology that changes the shape and connectivity of an object. Unlike a convolution filter that multiplies neighborhood pixels by values you specify within a kernel, a morphological filter only works with the data in the neighborhood itself and uses either a statistical method or mathematical formula to modify the pixel upon which it is focused. The most common morphological filters are dilation, erosion, opening, and closing.

mosaic

A set of overlapping aerial or satellite-based images whose edges are matched to form a continuous pictorial representation of a portion of the Earth's surface.

MPEG

Moving Picture Experts Group; a data format for digital audio and video.
MRLC
Multi-Resolution Land Characteristic; a Landsat TM and DEM data format.

MSS
Multispectral Sensor; a Landsat sensor.

multiband file
A digital image that contains more than one band of data.

multilooking
A method for reducing speckle noise in synthetic aperture radar (SAR) data and for changing the size of a SAR file by averaging neighboring pixels throughout the image.

multispectral
The ability of a remote sensing instrument to detect wavelengths in two or more spectral bands.

nadir
The point on the ground that lies vertically beneath the perspective center of the aerial camera lens or satellite sensor.

NDVI
Normalized Difference Vegetation Index; a vegetation index used to transform multispectral data into a single image band whose values indicate the amount of green vegetation present in the pixel. ENVI uses the standard NDVI algorithm, where NIR is a near-infrared band: \[ \text{NDVI} = \frac{\text{NIR} - \text{Red}}{\text{NIR} + \text{Red}} \]

NITF
National Imagery Transmission Format.

NLAPS
National Landsat Archive Production System; a Landsat TM and MSS data format.

NMEA
National Marine Electronics Association data format; the NMEA-0183 format is commonly used with a GPS.

NOAA
National Oceanic and Atmospheric Administration.

normalize
To transform a set of measurements so they may be compared in a meaningful way. Normalization commonly refers to rescaling minimum and maximum values between two or more data sets so all of the values range from 0 to 1, allowing the data sets to be directly compared.

NSIF
NATO Secondary Image Format; a data format similar to NITF that is used by members of the North Atlantic Treaty Organization (NATO).

object
A region of interest with spatial, spectral, and/or texture characteristics (brightness, color, etc.) that define the region.
**object-based processing**

Techniques that classify a set of input objects rather than classifying pixels individually.

**offset**

In the context of remote sensing: A correction value added to or subtracted from every pixel in an image, typically by using image arithmetic (Band Math in ENVI). A variable added to the gain in a regression equation for sensor calibration. The number of bytes of embedded header information present in the file (ENVI skips these bytes when reading the file).

**OLS**

Operational Linescan System; a NOAA DMSP data format.

**orthorectify**

To remove the effects of radial relief displacement and imaging geometry from remote sensing imagery.

**panchromatic**

A sensor that detects electromagnetic energy in one very broad band, which includes most of the visible light spectrum. In aerial photography, panchromatic refers to a type of film that is sensitive to all wavelengths of visible light.

**PDS**

Planetary Data System data format.

**pedestal height**

The height of a polarization signature (above 0), calculated by averaging the following four polarization combinations from SAR data: Orientation (deg) Ellipticity (deg) ........................... ..............................

\[-45 90 \-45 0 45 90 45\]

**phase image**

An image derived from polarimetric SAR data whose values represent the phase difference between the horizontal and vertical polarizations. The phase difference is measured in either radians or degrees and ranges from -pi to pi, or -180 degrees to 180 degrees.

**PICT**

Windows QuickDraw Picture format

**Pixel Purity Index**

A tool used to find the most spectrally pure (extreme) pixels in multispectral and hyperspectral images. These typically correspond to mixing endmembers. The PPI is computed by repeatedly projecting n-dimensional scatter plots on a random unit vector. ENVI records the extreme pixels in each projection (those pixels that fall onto the ends of the unit vector) and it notes the total number of times each pixel is marked as extreme. A Pixel Purity Image is created where each pixel value corresponds to the number of times that pixel was recorded as extreme.

**pixel-based processing**

The traditional approach to exploitation and classification where each pixel in an image is treated as an independent data point.
plot function
In ENVI programming, a user function that you can add to and call from the Plot_Function menu of any ENVI plot window.

PNG
Portable Network Graphics image format.

polarization signature
A plot of radar backscattered power as a function of ellipticity and orientation angles of the incident radar wave.

polyline
A continuous line composed of one or more segments; a vector and annotation object.

Portal
A floating window in the Image window that allows you to view multiple layers in the Layer Manager simultaneously.

principal components analysis
A mathematical technique that transforms a multivariate data set into a new coordinate system such that the axes, or principal components, of the new coordinate system are uncorrelated. In remote sensing, an image is created for each principal component. Because the principal component rotation maximizes the variance in the first few principal components bands, these bands usually contain most of the coherent image information and can be used to isolate features in the data.

procedure
In ENVI programming, a sequence of one or more IDL statements that you can assign a name (thus creating an IDL program), compile, and call from the IDL or ENVI command line, using the following form: PROCEDURE_NAME, Argument [, Optional_Argument]

projected coordinate system
A coordinate system that uses Cartesian coordinates (x,y) to describe a geographic location.

proxy server
A server that sits between your computer and remote servers to which you connect. If you consistently have trouble connecting to remote servers, you may have a proxy server installed. The application does not attempt to connect through a proxy server, unless you specify one. JPIP/IAS servers do not support proxy servers.

pseudo projection
An affine map transformation that can be computed when a standard map projection is not available. ENVI applies a mathematical transformation to warp the image and calculate geographic coordinates for each pixel. The pixel size varies in the rectified image. This type of projection contains a high degree of variability and is not geographically accurate; the (x,y) locations in the rectified image are only "best guesses."

pyramid layers
Copies of a data set at various reduced resolutions. They are used to speed image display by reducing the resampling required when displaying large portions of an image at low resolution.
QUAC

Quick Atmospheric Correction; an automated atmospheric correction method in ENVI for retrieving spectral reflectance from multispectral and hyperspectral images.

QuickBird

A Digital Globe high-resolution satellite that provides 61 cm panchromatic and 2.4 m multispectral imagery.

QuickMap

An ENVI feature that allows you to quickly create a map composition from an image. You can add grid lines, scale bars, titles, north arrows, declination diagrams, and logos. You can save your settings as a QuickMap template that you can use with other images.

Quorum

A type of receiving station that creates AVHRR 16-bit High Resolution Picture Transmission (HRPT) files with two header frames. The Quorum format does not have georeferencing information.

RADARSAT

Radar Satellite (Canadian Space Agency).

radiance

A measure of the amount of electromagnetic radiation leaving a point on the surface. More precisely, it is the rate at which light energy is emitted in a particular direction per unit of projected surface area. The standard unit is W/m^2. Most remote sensing devices directly measure radiance.

raster

A grid-based data structure for storing images where each cell, or pixel, contains a single data value.

reflectance

The ratio of radiant energy reflected by a body to the energy incident on it, usually denoted as a percentage.

region

A broad term that refers to a group of pixels with the same spatial or spectral characteristics.

register

To geometrically align two or more images of the same scene so the images can be superimposed. The images can come from different viewpoints, different times, and different sensors. Following are the two most common methods of registration: Image-to-image registration: Correct a reference (warped) image to match base image geometry, using tie points between the two images. Image-to-map registration: Assign a reference image to geographic coordinates, using GCPs with known ground locations.

resample

To apply a geometric transformation to an original data set; more specifically, the interpolation method used to derive output pixel values based on input pixel values, taking into account the computed distortion. The most common resampling methods are Nearest Neighbor, Bilinear, and Cubic Convolution.
RGB
Red, Green, Blue; the primary colors that are mixed to display the color of pixels on a computer monitor.

RGB color composite
An image that uses the red, green, and blue guns of the display device to form a color additive representation of color.

RMS error
Root mean square error; a statistical measure that represents the difference between measured and predicted data points. In ENVI, RMS error is often used to evaluate a set of GCPs for georeferencing.

ROC curve
Receiver operating characteristic; a curve used to visualize the performance of a classification method, in order to select the proper decision threshold. ROC curves compare a series of rule image classification results for different threshold values with ground truth information.

ROI
Region of interest; a point, polyline, or polygon object drawn on an image, used to define a specific area of interest for extracting classification statistics, masking, and other operations in ENVI. From a processing standpoint, ROIs are pixel addresses with associated data.

routine
A general IDL programming term that refers to both functions and procedures.

RPC
Rational polynomial coefficients; used to build interior and exterior orientation in photogrammetry.

RSM
Replacement sensor model; an alternate representation of sensor geometric information that corrects the deficiencies of RPC-based sensor models. RSM contains a variety of enhancements over the RPC model, including: Increased accuracy over images with large number of rows or columns (such as image strips) by breaking the image into tiles with separate models. The ability to store varying degrees of complexity in the polynomial representation used.

RST
Rotation, scaling, and translation; a warping method used in image registration that uses an affine transformation with at least three ground control points.

rule image
An image calculated for each ROI in a supervised classification. They are called rule images because a rule is applied to the pixel values in the images to determine the class to which each pixel should be assigned. The pixel values in the rule images, and the rule used to assign classes, depend on the specific classifier used. For example, with Maximum Likelihood classification, the pixel values in a rule image for one class are equal to the likelihood that each pixel belongs to that class. Whichever rule image has the highest likelihood value for a pixel is the class to which that pixel is assigned.

RXD
Reed-Xiaoli anomaly detection algorithm.
sample

The x component of a raster image coordinate pair (x,y); same as column.

SAR

Synthetic aperture radar.

scale factor

A division factor used to convert integer-scaled reflectance or radiance data into floating-point values. For example, for reflectance data scaled into the range of 0 to 10,000, set the scale factor to 10,000. For uncalibrated integer data, set the scale factor to the maximum value the instrument can measure ((2^n) - 1, where n is the bit depth of the instrument).

scatter plot

A plot of measurements from two or more bands of data.

Scroll window

The window in a display group that displays the full image at subsampled resolution. This window appears only when an image is larger than what ENVI can display in the Image window at full resolution.

SDE

Spatial Database Engine; a database or information system containing spatial data that you can query. An "enterprise SDE" is a shared environment that allows multiple users to access the same database or information system.

SeaWiFS

Sea-viewing Wide Field-of-view Sensor; a NASA satellite that collects global ocean color data.

semivariance

A statistic that uses the squared difference between neighboring pixel values to provide a measure of dissimilarity within a dataset. It has the same units as the input dataset, and its values are greater than or equal to 0.

semivariogram

A plot of semivariance values at multiple lag distances; a measure of how autocorrelation decreases as distance increases.

shaded relief

An image created during the topographic modeling process that renders terrain in 3D by use of graded shadows that would be cast by the sun from a northwest direction.

shapefile

A vector file format; a set of files that contain points, arcs, or polygons that hold tabular data and a spatial location. One shapefile consists of three individual files, ending with .shp, .shx, and .dbf file extensions.

shift difference

The process of differencing adjacent pixels to the right and above each pixel and averaging the results to obtain the noise value to assign to the pixel being processed. The best noise estimate is gathered using the shift-difference statistics from a homogenous area rather than the whole image.
Sigma nought

A measure of the mean backscatter of a radar signal from an area of 1 m^2 on the earth's surface, typically denoted in decibels (dB). Sigma nought describes the backscattering strength of a distributed target, rather than a discrete target.

SIR-C

A synthetic aperture radar (SAR) instrument built by NASA/JPL and Ball Communication Systems Division for NASA. SIR-C flew aboard the Space Shuttle and provided L-band and C-band measurements.

slope

The percentage or degree change in elevation over distance; a parameter used in topographic modeling.

SMACC

Sequential Maximum Angle Convex Cone; a sub-pixel spectral tool in ENVI that finds spectral end-members and their abundance throughout an image.

smooth

To average pixel values within adjacent areas to produce more gradual transitions.

coldar azimuth

The angle a horizontal projection of a direct ray from the sun makes with the True North-south axis, typically denoted as clockwise from True North through 360 degrees.

coldar elevation

The angle of the sun above the horizon, extending from 0 degrees (horizon) to 90 degrees (directly overhead).

coldar spectrum

The part of the electromagnetic spectrum occupied by the wavelengths of solar radiation. About 99 percent of solar radiation is constrained to 300 nm (ultraviolet) to 3,000 nm (near-infrared).

spatial filter

A filter that removes certain spatial frequencies from an image and enhances features in the remaining image. A high pass filter enhances high spatial frequencies. A low pass filter enhances low frequencies in an image, thus smoothing the image. Following is a sample 3 x 3 kernel used for low-pass filters. An edge enhancement filter enhances edges of features in an image, making them easier to analyze.

spatial profile

A plot of pixel values along a line placed in the image.

spatial resolution

A measure of the smallest angular or linear separation between two objects that a sensor can resolve.

Spectral Analyst function

In ENVI programming, a user function that implements a custom spectral mapping method to match an unknown spectrum to the materials in a spectral library. You can add this user function to ENVI's Spectral Analyst and call it from the ENVI menu system.
Spectral Hourglass Wizard

A tool in ENVI that takes you through a step-by-step process for locating spectral endmembers within a hyperspectral data set and mapping their locations and sub-pixel abundances. When written in a certain format, the processing flow resembles an hourglass shape.

spectral library

A collection of spectra measured in the field or laboratory for materials (minerals, vegetation types, etc.) that are often used as a baseline, or true spectra, for identification of materials from spectral remote sensing imagery.

spectral mapping method

Also called a spectral similarity technique; a method in hyperspectral analysis for matching image spectra to known (reference) spectra, usually from a spectral library. Following are descriptions of the spectral mapping methods used in ENVI. Binary Encoding: A method that encodes data and endmember spectra into zeros and ones, based on whether a band falls below or above the spectrum mean, respectively. Linear Spectral Unmixing: A sub-pixel method that determines the relative abundance of materials depicted in multispectral or hyperspectral imagery based on the materials' spectral characteristics. LS-Fit: A linear band prediction method that uses least-squares fitting. You can use it to find regions of anomalous spectral response in a dataset. It calculates the covariance of the input data and uses it to predict the selected band as a linear combination of the predictor bands plus an offset. Matched Filtering: A method that finds the abundance of user-defined endmembers using a partial unmixing technique. Matched filtering maximizes the response of a known endmember and suppresses the response of the unknown background, thus matching the known signature. It provides a rapid means of detecting specific materials based on matches to library or image endmember spectra and does not require knowledge of all the endmembers within an image scene. Mixture Tuned Matched Filtering (MTMF): A method that performs Matched Filtering and adds an infeasibility image to the results. The infeasibility image is used to reduce the number of false positives that are sometimes found when using Matched Filtering. Spectral Angle Mapper (SAM): A physically-based spectral classification method that uses an n-D angle to match pixels to reference spectra. The algorithm determines the spectral similarity between two spectra by calculating the angle between the spectra and treating them as vectors in a space with dimensionality equal to the number of bands. Spectral Feature Fitting (SFF): A method that compares the fit of image spectra to reference spectra using a least-squares technique. SFF is an absorption-feature-based methodology. The reference spectra are scaled to match the image spectra after the continuum is removed from both data sets.

Spectral Math

An ENVI tool that allows you to apply mathematical expressions or IDL procedures to spectra and to selected multiband images, as long as the number of bands and spectral channels match.

spectral resolution

The wavelength range that a particular band measures. For example, Landsat-7 ETM+ Band 1 detects wavelengths from 0.45 microns to 0.52 microns. The Landsat-7 ETM+ panchromatic band detects wavelengths from 0.50 microns to 0.90 microns. So, Band 1 has a finer spectral resolution than the panchromatic band. Spectral resolution does not refer to the number of bands available from a particular sensor.

SPOT

Satellite Pour l'Observation de la Terra; a series of earth observation satellites launched by Spot Image of France; the spatial resolution of SPOT data varies from 2.5 to 20 m.
SRF
Spectral response function; engineering data that quantify the spectral response and sensitivity of detectors on an airborne or satellite sensor. The term SRF also refers to a data format that contains SRF data for particular sensors.

SRTM
Shuttle Radar Topography Mission (NASA/JPL).

statistics
Numbers or values that help describe the characteristics of a selected group of data.

subsample
To create an output image of reduced resolution based on every nth pixel from an input image.

super GLT
A geographic lookup table (GLT) file that contains information about how many and which input pixels contribute to the output pixel; a super GLT is not an image file.

synthesize
With respect to polarimetric radar data, the process of building an image representing backscatter at specified ellipticity and orientation angles from a scattering (or related) matrix.

system calibration
The process of converting digital numbers (DNs, which represent the sensor response) in a remote sensing image to radiance or reflectance above the atmosphere, using pre-launch gain and offset values.

targets
Materials with a known spectral signature that you want to identify in an image. Examples include minerals, vehicles, and vegetation types.

temporal resolution
How often a sensor obtains imagery of a particular area.

texture
The frequency of change and spatial arrangement of pixel values in an image, as a function of spatial scale. A flat image in which all digital numbers (DNs) are equal is said to have a uniform texture.

texture filter
A filter used to delineate surface features (for example, biophysical properties of a forest canopy) that cause local variations in image brightness. A texture filter is helpful for identifying objects that are more characterized by their texture than by intensity.

thermal band
A band that detects radiation from the far infrared part of the electromagnetic spectrum, between approximately 7.0 to 15 microns. A thermal band detects emitted, rather than reflected, radiation from the earth.
threshold
A value above which a process is performed and below which it will not be performed. For example, you can specify a change threshold of 50 percent in a K-Means supervised classification, which means the clustering process ends when the number of pixels in each class changes by 50 percent or less.

tie points
The location of a single feature across two overlapping images, used in image-to-image registration.

TIFF
Tagged Image File Format

tile
For ENVI to process images that are much larger than the total amount of RAM available on the system, large images are broken into pieces that are small enough for the system to handle. Each piece is called a tile. When the image is processed, only one tile is read into memory at a time.

TIMS
Thermal Infrared Multispectral Scanner; a NASA/JPL and Daedalus Enterprises sensor.

TM
Thematic Mapper; a Landsat sensor.

TOPSAR
Topographic Synthetic Aperture Radar; a NASA/JPL airborne radar interferometer.

transform
An image processing operation that changes data to another data space, usually by applying a linear function. The goal of most transforms is to improve the presentation of information. Transformed images are often more easily interpreted than the original data.

true-color composite
An image where the red band (0.6 to 0.7 microns) is displayed in red, the green band (0.5 to 0.6 microns) is displayed in green, and the blue band (0.4 to 0.5 microns) is displayed in blue.

user function
A custom program that you can write in IDL, C, Fortran, or another high-level programming language that performs an interactive ENVI processing task. If you write a user function in IDL, you can incorporate ENVI library routines into the code and call the user function from the ENVI menu system to run it.

user-defined RPC reader
In ENVI programming, a user function that reads a custom rational polynomial coefficients (RPC) file format. You can add the user function to, and call it from, the Generic RPC menu option in ENVI.

USGS
United States Geological Survey.
UTD
Uniform Target Detector; an anomaly detection algorithm in which the anomaly is defined using $(1 - m)$ as the matched signature, rather than $(r - m)$. UTD and the RXD algorithm work exactly the same, but instead of using a sample vector from the data (as with RXD), UTD uses the unit vector. UTD extracts background signatures as anomalies and provides a good estimate of the image background.

UTM
Universal Transverse Mercator map projection; a system of plane coordinates based upon 60 north-south zones, each 6 degrees of longitude wide, that circle the earth. UTM coordinates consist of the Zone number, an easting (distance in meters or kilometers east of the western edge of the Zone), and a northing (distance in meters or kilometers from the equator).

UUID
Universally Unique Identifier; an identifier standard used in software development that enables distributed systems to uniquely identify information without significant central coordination.

vector
A data structure for storing spatial data that consists of points, lines, and polygons. Lines (also called arcs) are defined by beginning and end points, which meet at nodes. The locations of these nodes and the topological structure are usually stored explicitly.

vegetation index
A measure of some vegetation property calculated from reflected solar radiation measurements made across the optical spectrum (400 to 3,000 nm). A vegetation index is constructed from reflectance measurements in two or more wavelengths to analyze specific characteristics of vegetation, such as total leaf area and water content.

vertical exaggeration
The process of multiplying all of the elevation values in a DEM by a scale factor to exaggerate the landscape's relief when viewed in a 3D perspective.

virtual border
An annotation object that consists of a temporary border around an image displayed in ENVI. You can enter the border width (in pixels) and place other annotation objects within the virtual border.

Virtual Mosaic
A saved mosaic template used as an alternative to saving a mosaic to disk. When you restore a Virtual Mosaic template file, ENVI opens the individual image files that make up the mosaic and puts them together on the fly. You can display a Virtual Mosaic file in ENVI and annotate it, stretch it, etc., like any other image. Using a Virtual Mosaic prevents multiple files from containing the same images and therefore saves disk space.

warp
To stretch an image to fit its ground control points (GCPs), so that distance and area are uniform in relationship to real-world measurements. ENVI performs warping with rotation, scaling, and translation (RST); polynomial, or Delaunay triangulation.

wavelength
Velocity divided by frequency of an electromagnetic wave. In general, the mean distance between maxima or minima of a roughly periodic wave pattern.
widget
A simple graphical object such as a push button or slider, created in IDL, that allows user interaction with a pointing device (usually a mouse) and a keyboard. You can construct and manipulate graphical user interfaces in IDL using widgets.

WorldView-1
A Digital Globe high-resolution satellite that provides 50 cm panchromatic imagery.

WorldView-2
A Digital Globe high-resolution satellite that provides 46 cm panchromatic imagery.

X Profile and Y Profile
A cross-section of data along the x-axis, and y-axis, of an image, respectively. X and Y Profiles are also called horizontal and vertical profiles, respectively.

XSTART and YSTART
Variables in an image header file that define the image coordinates for the first pixel in the image. For most images, ENVI sets the default XSTART and YSTART values to 1, defining the first pixel in an image with a coordinate of (1,1). Thus, if the image were an IDL 2D array variable, the data contained in subscript position [0, 0] correspond to image coordinates (1,1). If XSTART or YSTART are set to any other values (including negative numbers or 0), the image coordinates begin incrementing from these values.

XWD
X Windows Dump

Z Profile
A spectrum plot of the pixel under the cursor, through all bands of the image.

Zoom box
The red box inside an Image window that defines the extent of the Zoom window.

Zoom window
The window in a display group that displays the subsection of the image defined by the Image window Zoom box. The resolution is at a user-defined zoom factor based on pixel replication or interpolation.
Index

A
annotations 120
  adding to an annotation layer 122
  arrows 125
  creating layers 121
  deleting 128
  deleting segments (NITF) 168
  displaying 64
  editing properties 126
  in Print Layout view 141
  pictures 125
  polygons 123
  polylines 123
  segments (NITF) 151
  symbols 122
  text 122
  tips and tricks 129
  toolbar buttons 17
anomaly detection 88
ArcMap 61
  exporting datasets to 61
  exporting image display to 139
  geolink with image window 77
arrow annotations 125
attribute tables 109
automatically displaying files 40

B
band selection 62
base layers 28
blending 82
brightness 22

C
category bars 24
chipping 138
  the display 138
  the display to NITF 172
  to ArcMap 139
  to disk 138
  to memory 138
  to PowerPoint 139
  to Print Layout view 139
  toolbar button 16
closing files 64
compression types (NITF) 171
computer graphic metafile (CGM) 151
contrast 22
copyrights 2
crosshairs 16
CSSHPA DES 157
cursor path history 24
cursor value 35
custom development services 7

data extension segments (DESes) 153

data manager 60
  displaying annotation layers 64
  displaying ESRI layers and feature classes 63
  displaying grayscale images 62
  displaying multispectral images 61
  displaying vector layers 63
  file information 64
  preferences 40
  selecting bands 62
  toolbar 60

DIGEST TRE 162
directories 41
display levels (NITF) 160
  annotation segments 151
  image segments 149
Douglas-Peucker algorithm 105
DTED data 52
dynamic range adjustment 22

EPJE compression 171
equalization stretches 22
error messages 39

ESRI layers 63
exporting
  Adobe Illustrator Vector Graphic (.ai) 142
  Bitmap (.bmp) 142
  Encapsulated PostScript (.eps) 142
  Graphics Interchange Format (.gif) 142
  JPEG (.jpg) 142
  Portable Document Format (.pdf) 142
  Portable Network Graphics (.png) 142
  Scalable Vector Graphics (.svg or .svgz) 142
  Tagged Image File Format (.tif) 142
  Windows Enhanced Metafile (.emf) 142

favorite servers 75
feature class 63
feature counting 112
  creating feature types 113
  deleting 114
  editing properties 113
  jump to feature 116
  marking features 113
  restoring data 117
  saving layer 115
toolbar button 17
  viewing feature report 118

file formats 52
file information 64
flickering 83
flying 16

Gaussian stretches 22
geodatabases 68
  opening 75
  refreshing 73
  remote connections 71
  retaining display enhancements when saving 135
  saving 134
  specifying connection URLs 74
  supported platforms 66
GeoEye-1 data 54
geolink with ArcMap 77
GEOLOB TRE 162
GEOPSB TRE 162
GeoTIFF files with metadata 53
goto tool 20

graphic segments (NITF) 151

history 24

IAS servers 67
  managing connection properties 74
  NITF data 67
ICORDS 162
IGEOLO 162

image processing
  toolbox 32
image segments (NITF) 149
  chipping 172
  saving 175
image tiles 56
image window 13
  linking with ArcMap 77
input file formats 52
interactive stretching 23
interface 12
IREP field (NITF) 164
IREPBAND field (NITF) 164
J
JITC 146
JPEG 2000 servers 67
JPIP servers
  JPEG 2000 67
  JPIP 67
  managing connection properties 74
jumping to a location 20
L
label segments (NITF) 151
Landsat data 53
layer manager 27
layers 27
  active 29
  base 28
  creating annotation layers 121
  creating vector layers 97
  editing 29
  ESRI 63
  hiding and showing 31
  loading into portals 32
  ordering 31
  portal zoom options 85
  removing 31
  selecting 29
  spatial resolution 28
  turning on and off 31
  types 27
  zoom options 32
linear stretches 22
linking
  image window with ArcMap 77
logarithmic stretches 22
M
map information 28
  chipping in NITF 173
  layers 28
  NITF 162
  reading in NITF 163
  saving in NITF 175
map layout view 141
map template 141
  Print Layout view 45
MAPLOB TRE 162
masks
  NITF 174
measuring 21
mensuration 21
metadata (NITF)
  adding text segments 167
  creating PIA TREs 167
  editing 167
  icons 165
  viewing 165
multiple files 27
N
NITF 146
  adding, editing, deleting text segments 167
  annotation objects 152
  annotation segments 151
  chipping image segments 172
  chipping the display 172
  compression types 171
  data extension segments 153
  data segments 147
  deleting annotation segments 168
  display levels 160
  displaying wavelength information 161
  graphic segments 151
  IAS servers 67
  image segments 149
  label segments 151
  main header 147
  preferences 158
  rules for displaying images 164
  saving image segments 175
  saving wavelength information 176
  security segments 149
  segments 148
  symbol segments 151
  technical specifications 147
  text segments 152
  viewing metadata 165
NITF metadata
  adding text segments 167
  creating PIA TREs 167
  editing 167
  icons 165
NPJE compression 171
O
OGC servers 66
  keywords 69
  WCS 67
  WMS 67
opening 53
  file formats 52
  files in ArcMap 61
  files in ENVI 55
  geodatabases 66
Open in ENVI button 60
remote datasets 66
optimized linear stretches 22
output formats 132
output to memory 132
overview window 24
  multiple images 25
  path history 24
  view box 24

P
  pan sharpening 90
  panning 16
  path history 24
  performance tips and tricks 50
PIA TREs
  creating 167
  preserving 177
picture annotations 125
pixel information 16
polygons 123
  annotations 123
  ellipse 124
  rectangle 124
polyline annotations 123
portals 80
  blend, flicker, swipe 82
  closing 85
  loading layers 32
  moving 84
  panning 84
  resizing 85
  toolbar 82
  toolbar buttons 21
  working with 81
preferences 38
  annotations 46
  application 39
  arrow annotations 46
  data manager 40
  directories 41
  display 41
  NITF 158
  overview window 41
  picture annotations 47
  polygon annotations 47
  polyline annotations 47
  print layout 45
  pyramids 44
  symbol annotations 46
text annotations 46
  vectors 48
print layout exports 142
print layout view 141
process manager 14
projections 28
pyramids 56
  building 56
  preferences 44
Q
  quadtrees 58
R
  RapidEye data 53
  rectangulating polygons 106
  reduced resolution data sets 56
remote datasets 66
  authentication 71
  connecting directly to JPIP, IAS, OGC datasets 68
  connecting to servers and geodatabases 71
  connection properties 74
  editing properties 73
  favorites 75
  managing 71
  specifying URLs 74
  supported platforms 66
reprojecting images 28
rotating the display 18
RPC00A and RPC00B TREs 162
RPCs
  base layers 28
  NITF 162
  reading NITF 163
RSETs 56
RX anomaly detection 88
S
  saving files 132
  chipping the display to NITF 172
  exporting to other file types 142
  NITF 169
  NITF compression types 171
  NITF Save As 174
  preserving NITF TREs 177
scaling Print Layout view 45
screen captures
  chip to file 16
  output chip 138
security segments (NITF) 149
sharpening
display 23
pan 90
smoothing polygons 104
spatial subsetting 136
spectral subset 136
square root stretches 22
status bar 14
preferences 44
stretching 22
interactive 23
preferences 43
types 22
subsetting
spatial subset 136
spectral subset 136
supported formats 52
swiping 84
symbol segments (NITF) 151
symbols 122
annotations 122
system logging 39
T
tagged record extensions (TREs) 153
GeoSDE 162
PIA 167
preserving PIA TREs 177
preserving TREs 177
RPC00A 162
RPC00B 162
text annotations 122
text segments (NITF) 152
adding 167
toolbar buttons 15
toolbox 32
ENVI Favorites 33
training 7
transcoding (NITF) 171
transparency 23
troubleshooting
annotations 129
performance 50
vectors 110
U
US message text format (USMTF) 152
UTD anomaly detection 88
V
vectors 94
adding vertices 101
attribute tables 109
creating layers 97
creating records 98
data reduction 58
deleting records 104
deleting vertices 103
displaying 63
editing 100
grouping 102
joining polylines 101
layer properties 108
merging 101
moving points 100
multipart 98
multipoint 98
quad display 58
rectangularizing 106
removing holes 103
selecting 100
smoothing 104
splitting 102
tips and tricks 110
toolbar buttons 17
ungrouping 102
working with 95
vegetation suppression 92
vertices 100
adding 101
deleting 103
editing 100
moving 100
selecting 100
snapping 101
view box 24
W
wavelength information (NITF)
displaying 161
saving 176
WCS servers 67
managing connection properties 74
WMS servers 67
managing connection properties 74
workflows
toolbox 32
Z
zooming 19
layers 32
portal layers  85
preferences  41
toolbar buttons  19