Getting Started with ENVI
Restricted Rights Notice

The IDL®, IDL Advanced Math and Stats™, ENVI®, ENVI Zoom™, and ENVI® EX software programs and the accompanying procedures, functions, and documentation described herein are sold under license agreement. Their use, duplication, and disclosure are subject to the restrictions stated in the license agreement. ITT Visual Information Solutions reserves the right to make changes to this document at any time and without notice.

Limitation of Warranty

ITT Visual Information Solutions makes no warranties, either express or implied, as to any matter not expressly set forth in the license agreement, including without limitation the condition of the software, merchantability, or fitness for any particular purpose. ITT Visual Information Solutions shall not be liable for any direct, consequential, or other damages suffered by the Licensee or any others resulting from use of the software packages or their documentation.

Permission to Reproduce this Manual

If you are a licensed user of these products, ITT Visual Information Solutions grants you a limited, nontransferable license to reproduce this particular document provided such copies are for your use only and are not sold or distributed to third parties. All such copies must contain the title page and this notice page in their entirety.

Export Control Information

This software and associated documentation are subject to U.S. export controls including the United States Export Administration Regulations. The recipient is responsible for ensuring compliance with all applicable U.S. export control laws and regulations. These laws include restrictions on destinations, end users, and end use.

Acknowledgments

ENVI® and IDL® are registered trademarks of ITT Corporation, registered in the United States Patent and Trademark Office. ION™, ION Script™, ION Java™, and ENVI Zoom™ are trademarks of ITT Visual Information Solutions.

ESRI®, ArcGIS®, ArcView®, and ArcInfo® are registered trademarks of ESRI.

Portions of this work are Copyright © 2009 ESRI. All rights reserved.

PowerPoint® and Windows® are registered trademarks of Microsoft Corporation in the United States and/or other countries.

Macintosh® is a registered trademark of Apple Inc., registered in the U.S. and other countries.

UNIX® is a registered trademark of The Open Group.

Adobe Illustrator® and Adobe PDF® Print Engine are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.

Numerical Recipes™ is a trademark of Numerical Recipes Software. Numerical Recipes routines are used by permission.

GRG2™ is a trademark of Windward Technologies, Inc. The GRG2 software for nonlinear optimization is used by permission.

NCSA Hierarchical Data Format (HDF) Software Library and Utilities. Copyright © 1988-2001, The Board of Trustees of the University of Illinois. All rights reserved.

NCSA HDF5 (Hierarchical Data Format 5) Software Library and Utilities. Copyright © 1998-2002, by the Board of Trustees of the University of Illinois. All rights reserved.

CDF Library. Copyright © 2002, National Space Science Data Center, NASA/Goddard Space Flight Center.


SMACC. Copyright © 2000-2004, Spectral Sciences, Inc. and ITT Visual Information Solutions. All rights reserved.

This software is based in part on the work of the Independent JPEG Group.

Portions of this software are copyrighted by DataDirect Technologies, © 1991-2003.


Portions of this computer program are copyright © 1995-2008 Celartem, Inc., doing business as LizardTech. All rights reserved. MrSID is protected by U.S. Patent No. 5,710,835. Foreign Patents Pending.

Portions of this software were developed using Unisearch’s Kakadu software, for which ITT has a commercial license. Kakadu Software. Copyright © 2001. The University of New South Wales, UNSW, Sydney NSW 2052, Australia, and Unisearch Ltd, Australia. This product includes software developed by the Apache Software Foundation (www.apache.org/).


Portions of this software are copyrighted by Merge Technologies Incorporated.

Support Vector Machine (SVM) is based on the LIBSVM library written by Chih-Chung Chang and Chih-Jen Lin (www.csie.ntu.edu.tw/~cjlin/libsvm), adapted by ITT Visual Information Solutions for remote sensing image supervised classification purposes.

IDL Wavelet Toolkit Copyright © 2002, Christopher Torrence.

IMSL is a trademark of Visual Numerics, Inc. Copyright © 1970-2006 by Visual Numerics, Inc. All Rights Reserved.

Other trademarks and registered trademarks are the property of the respective trademark holders.
## Contents

### Chapter 1
**Introduction to ENVI** ................................................................. 9

- What is ENVI? .................................................................................. 10
- ENVI + IDL, ENVI, and IDL .......................................................... 11
- About ENVI Functionality ............................................................... 12
  - End-to-End Processing ............................................................... 12
  - Hyperspectral Data Analysis ....................................................... 13
- About ENVI Zoom ........................................................................... 14
- About ENVI EX ................................................................................ 15
- ENVI Add-On Modules .................................................................... 16
  - DEM Extraction ........................................................................... 16
  - ENVI Orthorectification .............................................................. 16
  - Atmospheric Correction: QUAC and FLAASH .......................... 16
  - NITF/NSIF .................................................................................. 17
- Using This Guide ............................................................................. 18
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Additional ENVI Documentation</td>
<td>19</td>
</tr>
<tr>
<td>ENVI Support</td>
<td>21</td>
</tr>
<tr>
<td>Contacting Technical Support</td>
<td>21</td>
</tr>
<tr>
<td>Contacting Sales</td>
<td>21</td>
</tr>
<tr>
<td>Training and Custom Development Services</td>
<td>22</td>
</tr>
<tr>
<td>ENVI Training</td>
<td>22</td>
</tr>
<tr>
<td>Additional Resources</td>
<td>23</td>
</tr>
<tr>
<td>ITT Visual Information Solutions Website</td>
<td>23</td>
</tr>
<tr>
<td>IDL Newsgroup</td>
<td>23</td>
</tr>
<tr>
<td>Chapter 2</td>
<td>25</td>
</tr>
<tr>
<td>Before You Begin</td>
<td>26</td>
</tr>
<tr>
<td>Starting and Exiting ENVI</td>
<td>26</td>
</tr>
<tr>
<td>Using Startup Scripts</td>
<td>26</td>
</tr>
<tr>
<td>Exiting ENVI</td>
<td>28</td>
</tr>
<tr>
<td>ENVI Image Files</td>
<td>29</td>
</tr>
<tr>
<td>ENVI Header Files</td>
<td>30</td>
</tr>
<tr>
<td>ENVI File Naming Conventions</td>
<td>31</td>
</tr>
<tr>
<td>ENVI Supported Input File Formats</td>
<td>33</td>
</tr>
<tr>
<td>ENVI Supported Output File Formats</td>
<td>35</td>
</tr>
<tr>
<td>Chapter 3</td>
<td>37</td>
</tr>
<tr>
<td>The ENVI Interface</td>
<td>38</td>
</tr>
<tr>
<td>The ENVI Main Menu Bar</td>
<td>38</td>
</tr>
<tr>
<td>The Available Bands List</td>
<td>39</td>
</tr>
<tr>
<td>Folding and Unfolding Data Sets</td>
<td>40</td>
</tr>
<tr>
<td>Opening Files from the Available Bands List</td>
<td>41</td>
</tr>
<tr>
<td>Opening Files in ArcMap</td>
<td>41</td>
</tr>
<tr>
<td>Opening Files in ENVI Zoom</td>
<td>42</td>
</tr>
<tr>
<td>Closing Files from the Available Bands List</td>
<td>42</td>
</tr>
<tr>
<td>Hiding and Showing the Available Bands List</td>
<td>43</td>
</tr>
<tr>
<td>Available Bands List Right-Click Menus</td>
<td>44</td>
</tr>
<tr>
<td>Locating Bands by Wavelength</td>
<td>45</td>
</tr>
<tr>
<td>Showing Displayed Band Information</td>
<td>45</td>
</tr>
<tr>
<td>Display Groups</td>
<td>46</td>
</tr>
<tr>
<td>Reduced Resolution Data Sets</td>
<td>48</td>
</tr>
<tr>
<td>Opening New Display Groups</td>
<td>48</td>
</tr>
</tbody>
</table>
Contents

Vector Window Mouse Button Functions ................................................................. 78
Plot Window Mouse Button Functions ................................................................. 79

Chapter 4
Opening and Displaying Files .............................................................................. 81
Opening Image Files in ENVI ......................................................................................... 82
  Supported Platforms ................................................................................................. 83
Opening External Image Files in ENVI ................................................................. 101
Opening Previously Opened Files ............................................................................ 102
Opening Vector Files ................................................................................................. 103
Opening Spectral Library Files ................................................................................... 106
Displaying Images ..................................................................................................... 107
  Displaying Gray Scale Images .............................................................................. 108
  Displaying RGB Images ...................................................................................... 109
  Displaying True Color or Color Infrared Images ............................................ 109
  Displaying Default RGB Combinations ................................................................ 111
Displaying Vectors ..................................................................................................... 112

Chapter 5
Working with Header Files ...................................................................................... 113
The ENVI Header Format ........................................................................................... 114
  Example ENVI Header File ................................................................................. 120
Creating Header Files ................................................................................................. 123
  Importing Header Information from Other Files ............................................. 124
  Entering Required Header Information ......................................................... 125
  Entering Optional Header Information ............................................................ 125
Editing Header Files .................................................................................................. 127
ENVI File Type File .................................................................................................. 128
ENVI Sensor File ........................................................................................................ 130

Chapter 6
Common Tools and Functions in ENVI ............................................................. 133
Working with ENVI Dialogs ..................................................................................... 134
  ENVI Dialog Components .................................................................................. 134
  The Input File Dialog .......................................................................................... 136
Selecting Multiple Items in Lists ............................................................................. 138
Selecting Output to File or Memory ........................................................................ 139
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Queuing ENVI Processes</td>
<td>140</td>
</tr>
<tr>
<td>Compressing Output</td>
<td>141</td>
</tr>
<tr>
<td>Closing Dialog Windows</td>
<td>142</td>
</tr>
<tr>
<td>Selecting Bands or Files for Processing</td>
<td>143</td>
</tr>
<tr>
<td>Selecting a Spatial Subset</td>
<td>143</td>
</tr>
<tr>
<td>Selecting a Spectral Subset</td>
<td>145</td>
</tr>
<tr>
<td>Selecting a Mask</td>
<td>145</td>
</tr>
<tr>
<td>ENVI Processing Status Window</td>
<td>147</td>
</tr>
<tr>
<td>Showing Display Group Information</td>
<td>148</td>
</tr>
<tr>
<td>Displaying Pixel Location</td>
<td>149</td>
</tr>
<tr>
<td>Displaying Cursor Location/Value</td>
<td>151</td>
</tr>
<tr>
<td>Cursor Location/Value Reporting Options</td>
<td>152</td>
</tr>
<tr>
<td>Collecting Points</td>
<td>154</td>
</tr>
<tr>
<td>Linking Display Groups</td>
<td>155</td>
</tr>
<tr>
<td>Using Dynamic Overlays</td>
<td>156</td>
</tr>
<tr>
<td>Annotating Displays</td>
<td>157</td>
</tr>
<tr>
<td>Defining Regions of Interest</td>
<td>159</td>
</tr>
<tr>
<td>Turning Off ROI Definition</td>
<td>161</td>
</tr>
<tr>
<td>Using the Available Files List</td>
<td>162</td>
</tr>
<tr>
<td>Viewing File Information</td>
<td>163</td>
</tr>
<tr>
<td>Editing Header Files from the Available Files List</td>
<td>163</td>
</tr>
<tr>
<td>Opening New Files from the Available Files List</td>
<td>163</td>
</tr>
<tr>
<td>Closing All Files from the Available Files List</td>
<td>163</td>
</tr>
<tr>
<td>Deleting Memory Items</td>
<td>164</td>
</tr>
<tr>
<td>Storing Files in Memory</td>
<td>164</td>
</tr>
<tr>
<td>Saving In-Memory Files to Disk</td>
<td>164</td>
</tr>
<tr>
<td>Deleting Files from Disk</td>
<td>164</td>
</tr>
<tr>
<td>Closing Selected Files</td>
<td>165</td>
</tr>
<tr>
<td>Chapter 7</td>
<td>167</td>
</tr>
<tr>
<td>Creating Output</td>
<td></td>
</tr>
<tr>
<td>Saving Image Files</td>
<td>168</td>
</tr>
<tr>
<td>Saving as Standard ENVI Files</td>
<td>168</td>
</tr>
<tr>
<td>Saving as ENVI Meta Files</td>
<td>170</td>
</tr>
<tr>
<td>Saving as ASCII Files</td>
<td>171</td>
</tr>
<tr>
<td>Saving Display Output</td>
<td>173</td>
</tr>
</tbody>
</table>
Printing in ENVI ............................................................................................................ 174
Changing Output Directories ......................................................................................... 176

Chapter 8
Configuring and Customizing ENVI .......................................................................... 177
Setting ENVI Preferences .............................................................................................. 178
  User-Defined File Preferences ................................................................................ 179
  Default Directory Preferences ............................................................................... 181
  Display Default Preferences ............................................................................... 181
  ENVI Graphics Colors ............................................................................................ 182
  Plot Default Preferences ....................................................................................... 183
  Grid Line Default Preferences ............................................................................... 185
  Previous Files List Preferences ............................................................................... 185
  Miscellaneous Preferences ...................................................................................... 186
Customizing ENVI ......................................................................................................... 188
  Customizing ENVI in a Multiple-User Windows Environment ............................. 188
  Customizing ENVI in UNIX ................................................................................... 189
  Platform-Specific Customization ............................................................................ 191
  Customizing Configuration and Definition Files .................................................... 193
Using IDL with ENVI .................................................................................................... 196
  Importing IDL Variables ....................................................................................... 196
  Exporting to IDL Variables ............................................................................... 197
  Compiling IDL Code ............................................................................................... 197

Appendix 9
Glossary ....................................................................................................................... 199
Index ............................................................................................................................. 229
This chapter provides a general overview of ENVI. It includes:

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>What is ENVI?</td>
<td>10</td>
</tr>
<tr>
<td>About ENVI Functionality</td>
<td>12</td>
</tr>
<tr>
<td>About ENVI Zoom</td>
<td>14</td>
</tr>
<tr>
<td>About ENVI EX</td>
<td>15</td>
</tr>
<tr>
<td>ENVI Add-On Modules</td>
<td>16</td>
</tr>
<tr>
<td>Using This Guide</td>
<td>18</td>
</tr>
<tr>
<td>Additional ENVI Documentation</td>
<td>19</td>
</tr>
<tr>
<td>ENVI Support</td>
<td>21</td>
</tr>
<tr>
<td>Training and Custom Services</td>
<td>22</td>
</tr>
<tr>
<td>Additional Resources</td>
<td>23</td>
</tr>
</tbody>
</table>
What is ENVI?

ENVI is the ideal software for the visualization, analysis, and presentation of all types of digital imagery. ENVI’s complete image-processing package includes advanced, yet easy-to-use, spectral tools, geometric correction, terrain analysis, radar analysis, raster and vector GIS capabilities, extensive support for images from a wide variety of sources, and much more.

ENVI’s unique approach to image processing combines file-based and band-based techniques with interactive functions. When you open a data input file, its bands are stored in a list where you can access them from all system functions. If you open multiple files, you can process bands of disparate data types as a group. ENVI’s interactive analysis capabilities include:

- Multiple dynamic overlay capabilities that allow easy comparison of images in multiple displays.
- Real-time extraction and linked spatial/spectral profiling from multispectral and hyperspectral data that provide you with new ways of looking at high-dimensional data.
- Interactive tools to view and analyze vectors and GIS attributes.
- Standard capabilities, such as contrast stretching and 2D scatter plots.

ENVI’s interface is complemented by its comprehensive library of processing algorithms. ENVI includes all the basic image processing functions. ENVI does not impose limitations on the number of spectral bands that you can process, so you can use either multispectral or hyperspectral data sets. ENVI also includes advanced tools for analyzing radar data sets.

ENVI addresses common image processing problem areas such as input of non-standard data types, viewing and analysis of large images, and simple extensions of analysis capabilities (add-on functions). The software includes essential tools required for image processing across multiple disciplines, and it has the flexibility to allow implementation of customized analysis strategies.
ENVI + IDL, ENVI, and IDL

ENVI is written in IDL (Interactive Data Language), a powerful structured programming language that offers integrated image processing. The flexibility of ENVI is due largely to IDL’s capabilities.

There are two types of ENVI licenses:

- ENVI + IDL: ENVI plus a full version of IDL
- ENVI: ENVI plus a runtime version of IDL

ENVI + IDL users can use IDL to customize their own command-line functions. Advanced ENVI + IDL users should find the flexibility offered by IDL’s interactive features helpful for their dynamic image analyses.
About ENVI Functionality

ENVI simplifies comprehensive interactive processing of large multiband data sets, screen-sized images, spectral plots and libraries, and image regions of interest (ROIs), while providing flexible display capabilities and geographic-based image browsing. ENVI provides a multitude of interactive functions, including:

- $x,y,z$ profiling
- Image transects
- Linear and non-linear histogramming and contrast stretching
- Color tables
- Density slicing
- Classification color mapping
- Quick filter preview
- ROI definition and processing
- Vector creation and display

ENVI provides methods for locating specific pixels and for interactive spatial/spectral pixel editing. It also offers interactive scatter plot functions, including 2D dancing pixels and the n-Dimensional Visualizer. With ENVI, you can interactively link images together and create dynamic overlays, create comprehensive vector overlays with GIS attributes, and add map grids as well as annotations to images. Other ENVI interactive functions include 3D (perspective) viewing and fly-through animation, surface shading, and geometric rectification and mosaicking.

ENVI functionality works with full data files and subsets. It provides a complete set of tools to process panchromatic images, AVHRR, Landsat TM, ASTER, MODIS, QuickBird, WorldView, IKONOS, Orbview-3, and ENVISAT data, as well as dozens of other data types. ENVI is also capable of processing many other multispectral and hyperspectral images, and data from advanced SAR systems.

End-to-End Processing

ENVI includes tools for complete end-to-end processing of any type of remotely sensed imagery. From orthorectification to information extraction to integration with geographic information systems (GIS), ENVI combines all the tools you need for any type of project.
Hyperspectral Data Analysis

ENVI provides a full suite of tools for processing hyperspectral data. Developed by experts in the field, ENVI’s spectral analysis tools are unequaled. Among others, ENVI provides tools for:

- Sub-pixel analysis
- Feature extraction
- Spectrum identification
- Anomaly detection
- Mapping of materials
- Target finding
About ENVI Zoom

ENVI Zoom is a simplified, yet powerful, version of ENVI that lets you display and manipulate remote sensing images, vectors, and annotation, with ease and efficiency. The interface provides quick access to common display tools such as contrast, brightness, sharpening, and transparency. You can also re-project and re-sample images and vectors on-the-fly. ENVI Zoom provides tools to help you keep track of multiple data sets and their properties, and it includes a Portal viewer to let you see multiple data sets at once. ENVI Zoom also contains the robust RX Anomaly Detection, Pan Sharpening, and Vegetation Suppression tools.

For more information, see the ENVI Zoom User’s Guide.
About ENVI EX

ENVI EX is ENVI’s image processing and analysis solution for GIS users. ENVI EX includes advanced image manipulation tools that allow you to interactively visualize your data.

With ENVI EX, you can perform image processing tasks like pan sharpening, vegetation suppression, and anomaly detection quickly and easily from the ENVI EX toolbox.

The ENVI EX automated image analysis workflows take the complexity out of image processing. They provide step by step procedures and instructions to guide you through orthorectifying images, detecting change in an area over time, finding features of interest over a wide area, and classifying land cover. All of the processing and analysis tools in ENVI EX are based on ENVI’s scientific algorithms and methods.
ENVI Add-On Modules

ITT Visual Information Solutions offers several add-on modules to extend ENVI’s functionality. User documentation for each are included in PDF format on the ENVI Resource DVD (included with your software), and in the ENVI Help. Each module requires an additional license in your installation; contact your ENVI sales representative to obtain a license.

DEM Extraction

The ENVI Digital Elevation Model (DEM) Extraction Module enables you to extract elevation data from pushbroom stereo images, such as those from the ALOS PRISM, ASTER, CARTOSAT-1, FORMOSAT-2, GeoEye-1, IKONOS, KOMPSAT-2, OrbView-3, QuickBird, WorldView-1, WorldView-2, and SPOT satellites. The DEM Extraction Module includes the DEM Extraction Wizard and three DEM tools the DEM Editing Tool, Stereo Pair 3D Measurement Tool, and Epipolar 3D Cursor Tool.

See the DEM Extraction Module User’s Guide for details about using the DEM Extraction Module.

ENVI Orthorectification

The ENVI Orthorectification Module allows you to build highly accurate orthorectified images by rigorously modeling the object-to-image transformation. The details of this transformation are mostly transparent, which means you can quickly create orthorectified images without defining any detailed model parameters.

For more information, see the ENVI Orthorectification Module User’s Guide.

Atmospheric Correction: QUAC and FLAASH

For those interested in quantitative analysis of surface reflectance, removing the influence of the atmosphere is a critical pre-processing step. ENVI’s Atmospheric Correction Module provides two options: Quick Atmospheric Correction (QUAC) and Fast Line-of-sight Atmospheric Analysis of Spectral Hypercubes (FLAASH).

The Atmospheric Correction Module allows you to accurately remove the obscuring effects of the atmosphere. QUAC and FLAASH were developed by Spectral Sciences, Inc., a world leader in optical phenomenology research, in collaboration with U.S. Air Force Research Laboratory (AFRL) and Spectral Information Technology Application Center (SITAC) personnel.
See the *Atmospheric Correction Module User’s Guide* for details about using QUAC and/or FLAASH.

**NITF/NSIF**

The ENVI National Imagery Transmission Format (NITF) and NATO Secondary Image Format (NSIF) Module and NITF for ArcGIS® support reading and writing image files in the NITF and NSIF formats. The NITF/NSIF Module and NITF for ArcGIS provide compliant NITF software environments that take advantage of ENVI’s image analysis capabilities. With the NITF/NSIF Module and NITF for ArcGIS, ENVI and ArcMap™ can read and display all compressed or uncompressed NITF version 2.0 and 2.1 and NSIF 1.0 files, as well as legacy NITF 1.1 files, and write NITF version 2.0 and 2.1 and NSIF 1.0 files.

See the *NITF/NSIF Module User’s Guide* for details about using the NITF/NSIF Module.

The NITF for ArcGIS license is included with the NITF Module license. It can also be purchased separately at additional cost from ITT Visual Information Solutions, ESRI®, or your ENVI Distributor. If you have ArcGIS 9.3 or later installed, you can license NITF then install and run NITF for ArcGIS. NITF for ArcGIS provides the ability to read NITF data within the ArcGIS environment and create data products with ArcGIS Desktop that comply with the latest NITF specifications.

ENVI also supports reading TFRD files, but requires a separate module license and install. These can be obtained by contacting ITT Visual Information Solutions.
Using This Guide

This guide describes the general concepts of ENVI and provides overviews of the more commonly used functions of the application. For detailed information on how to use specific ENVI functions, see ENVI Help. This guide discusses:

- ENVI basics, such as starting and exiting ENVI, image and header files, file naming conventions, supported image file formats.

- The most commonly used areas of the ENVI interface, including the ENVI main menu bar, the Available Bands List, display groups, the Available Vectors List, Vector windows, plot windows, and mouse button behavior for the different ENVI windows and displays.

- How to open and display image files and vector files in ENVI, the header files associated with a image files, and how to create output of ENVI data.

- How to configure and customize your ENVI installation.

For the Introduction to ENVI tutorial and other ENVI tutorials, visit the ITT Visual Information Solutions website.
Additional ENVI Documentation

ENVI provides the following documentation in addition to this guide. Most of the documentation is available as a download from the ITT Visual Information Solutions website and/or on the ENVI Resource DVD, which is included with your installation package.

- **ENVI Help**
  A compilation of all of the ENVI documentation in a searchable help format. ENVI Help is included with your ENVI installation, and you can access it by selecting Help → Start ENVI Help from the ENVI main menu bar. For Windows, you can optionally access Help by selecting Programs → ENVI x.x → ENVI Help from the Windows Start menu. For UNIX, you can optionally access ENVI Help by typing either envihelp, envi_tut, or envi man at the UNIX prompt (your environment variables must be appropriately set up).

- **ENVI Zoom Help**
  The ENVI Zoom User’s Guide in a searchable help format. ENVI Zoom Help is included with your ENVI Zoom installation, and you can access it by selecting Help from the ENVI Zoom menu bar.

- **Installation and Licensing Guide**
  Describes how to install and license ENVI on your machine.

- **ENVI User’s Guide**
  Provides step-by-step instructions for working with ENVI.

- **ENVI Zoom User’s Guide**
  Provides step-by-step instructions for working with ENVI Zoom.

- **ENVI Programmer’s Guide**
  Provides sample code and instructions on programming in ENVI.

- **ENVI Reference Guide**
  Alphabetically documents all ENVI library routines. Each routine includes a description, the syntax, arguments (if any), keywords (if any), and an example of using the routine.

- **ENVI Tutorials**
  Provides tutorials designed to lead a new user through ENVI’s basic and advanced functionality. You need a free customer login to access tutorials from the ITT Visual Information Solutions website. Tutorials are also provided in PDF format on the ENVI Resource DVD included with your ENVI installation.
• **ENVI DEM Extraction Module User’s Guide**  
  Describes how to use the DEM Extraction Module.

• **ENVI Orthorectification Module User’s Guide**  
  Describes how to use the Orthorectification Module.

• **ENVI Atmospheric Correction Module User’s Guide**  
  Describes how to use the Atmospheric Correction tools QUAC and FLAASH.

• **ENVI NITF/NSIF Module User’s Guide**  
  Describes how to use the NITF/NSIF Module.

If you purchased an ENVI + IDL license, the following IDL documentation is available:

• **IDL Online Help**  
  Provides all of the IDL documentation, compiled into a searchable help format.  
  IDL Online Help is included with your ENVI + IDL installation and is accessed by selecting **Help → Contents** from the IDL main menu bar.

• **Using IDL**  
  Provides the basics of using IDL. This document is included in IDL Online Help.

• **IDL Reference Guide**  
  Alphabetically documents all IDL Functions and procedures. This document is included in IDL Online Help.
ENVI Support

If you experience a problem with ENVI, first verify that the issue is not a result of misinterpreting the expected outcome of a specific function or action. Double-check the ENVI documentation and ENVI Help, or check with a local expert. Make sure your system is properly configured with enough virtual memory and sufficient operating system quotas.

If the problem still occurs, report it to Technical Support quickly, so that the issue can be resolved, or a workaround can be provided. If you cannot find the information you need in the ENVI documentation or ENVI Help, report this to Technical Support as well, so that the documentation can be updated.

Contacting Technical Support

To report a problem, you can call, e-mail, or go online to submit a Support Incident:

- Technical Support Direct: 303-413-3920
- E-Mail: support@ittvis.com
- Internet: Go to www.ittvis.com and select Support → Technical Support.

ITT Visual Information Solutions
4990 Pearl East Circle
Boulder, CO 80301 USA

Phone: 303-786-9900
Fax: 303-786-9909

Contacting Sales

Contact ITT Visual Information Solutions Sales to purchase add-on module licenses or additional ENVI licenses:

- ITT Visual Information Solutions
  4990 Pearl East Circle
  Boulder, CO 80301 USA

Phone: 303-786-9900
Fax: 303-786-9909

E-Mail: sales@ittvis.com
E-Mail (SPAN): ORION::IDL
Training and Custom Development Services

ITT Visual Information Solutions has a team of Professional Services Group (PSG) consultants who provide custom software development, consulting services, and training to commercial, research, and government markets. The PSG team can either help you define requirements and lead your development cycle from prototyping to final installation, or they can join your project mid-stream and provide expert assistance.

Each PSG team member offers expertise in areas such as image processing; data analysis; visualization; software development; a broad range of scientific application areas; and government civilian, defense, and intelligence community requirements. If needed, ITT Visual Information Solutions has staff with the necessary security clearances to support classified projects.

The PSG team is experienced in extending ENVI’s robust suite of user functions and batch programming capabilities, and has up-to-date knowledge on recent product enhancements and future product direction. Their contact information is as follows:

- Professional Services Group
  ITT Visual Information Solutions
  4990 Pearl East Circle
  Boulder, CO 80301 USA

  Phone: 303-786-9900
  Fax: 303-786-9909

  E-Mail: sales@ittvis.com

ENVI Training

ITT Visual Information Solutions offers training courses designed to teach users about ENVI functions. ITT Visual Information Solutions teaches regularly scheduled ENVI courses at our training facility in Boulder, Colorado. In addition, ITT Visual Information Solutions offers regional training classes every year at various locations in the United States, Europe, and Australia. For the latest training schedule, a detailed course outline, or the cost of a training course, call, send e-mail, or go online:

- Phone: 303-786-9900 (ask for Training)
- Fax: 303-786-9909

  E-Mail: training@ittvis.com
  Internet: Go to www.ittvis.com and select Events and Training.
Additional Resources

There are two additional resources for ENVI support, the ITT Visual Information Solutions website and the IDL newsgroup.

**ITT Visual Information Solutions Website**

The ITT Visual Information Solutions website has several links that provide additional ENVI support. The website includes access to user-contributed ENVI code, an ENVI user forum, an IDL user forum, and technical tips. Go to [www.ittvis.com](http://www.ittvis.com) and select User Community to select an option.

**IDL Newsgroup**

The Usenet newsgroup `comp.lang.idl-pvwave` is dedicated to the discussion of IDL. Users post questions and answers and share information about their own IDL projects. Note that many ITT Visual Information Solutions employees read this newsgroup, but do not usually post messages to the group.

Send problem reports and technical support questions to ITT Visual Information Solutions via phone or e-mail. See “Contacting Technical Support” on page 21.
Chapter 2
Before You Begin

This chapter describes the basic components of ENVI. It includes:

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starting and Exiting ENVI</td>
<td>26</td>
</tr>
<tr>
<td>ENVI Image Files</td>
<td>29</td>
</tr>
<tr>
<td>ENVI Header Files</td>
<td>30</td>
</tr>
<tr>
<td>ENVI File Naming Conventions</td>
<td>31</td>
</tr>
<tr>
<td>ENVI Supported Input File Formats</td>
<td>33</td>
</tr>
<tr>
<td>ENVI Supported Output File Formats</td>
<td>35</td>
</tr>
</tbody>
</table>
Starting and Exiting ENVI

Before starting ENVI, ensure that it is properly installed, as described in the Installation and Licensing Guide. The Installation and Licensing Guide also provides steps to start ENVI on Windows, UNIX, and Macintosh.

Using Startup Scripts

Use startup scripts in ENVI to automatically open image files, to load bands into displays, to open vector files, and to open region of interest (ROI) files. You can configure your ENVI preferences to run a script at ENVI startup, or you can run a script manually from the ENVI main menu bar. The format for the startup script is described below.

To configure your ENVI preferences to run a startup script each time you start ENVI, see User-Defined File Preference Settings in the ENVI User’s Guide.

To run a startup script manually:

1. From the ENVI main menu bar, select File → Execute Startup Script. The Input Script Filename dialog appears.
2. Select the startup script filename.
3. Click Open.

Startup Script Format

Create a startup script using a text editor and name the file using the extension .ini. The available startup commands and their formats are as follows:

<table>
<thead>
<tr>
<th>Action</th>
<th>Command Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open an image file</td>
<td>open file = filename</td>
</tr>
<tr>
<td>Load a gray scale image into a new display group</td>
<td>load band = band_number The band number refers to the file opened in the line above the load band command.</td>
</tr>
</tbody>
</table>

Table 2-1: Startup Script Command Syntax
Chapter 2: Before You Begin

27

Getting Started with ENVI

Starting and Exiting ENVI

Example Startup Script

```
open file = e:\data\canyon\canyon.tm
load bands = 4,3,2
open file = e:\data\canyon.tif
load band = 1
open roi = e:\data\canyon\canyon.roi
```

Table 2-1: Startup Script Command Syntax (Continued)

<table>
<thead>
<tr>
<th>Action</th>
<th>Command Syntax</th>
</tr>
</thead>
</table>
| Load an RGB color image into a new display | load bands = R_band_number, G_band_number, B_band_number
The band numbers refer to the file opened in the line above the load band command. |
| Open an ENVI vector file (.evf) | open evf = evf_filename |
| Open an ROI file | open roi = roi_filename |
| Open a saved display group | open display group = display_group_filename |

Saving a Session to a Script

Use **Save Session to Script** to save currently open image files and their bands, and display groups to an ENVI startup script. To execute this startup file, see “Using Startup Scripts” on page 26.

Note

The **Save Session to Script** option only works for files that you can open through the ENVI main menu bar option **File → Open Image File** (see “Opening Image Files in ENVI” on page 82).

1. From the ENVI main menu bar, select **File → Save Session to Script**. The Output ENVI Script Filename dialog appears.
2. Enter the startup filename (typically with the extension .ini).
Exiting ENVI

1. Save any open files or in-memory items you wish to keep.
2. From the ENVI main menu bar, select **File → Exit**. ENVI closes all open files and in-memory items and exits.
ENVI Image Files

ENVI uses a general raster data format consisting of a simple flat binary file and a small associated ASCII (text) header file. This enables ENVI’s flexible use of nearly any image format, including those with embedded header information. Because ENVI uses ASCII header files that are built on-the-fly if required, you typically do not need to convert your image file formats. ENVI supports MSS, TM, SPOT, ERS-1, AVHRR, AVIRIS, GERIS, GEOSCAN, TIMS, digitized aerial photographs, DEM data, AIRSAR, RADARSAT, and SIR-C data in their native formats (byte, signed and unsigned integer, long integer, floating point, double precision, 64-bit integer, unsigned 64-bit integer, complex, or double complex). The general raster data is stored as a binary stream of bytes either in Band Sequential Format (BSQ), Band Interleaved by Pixel Format (BIP), or Band Interleaved by Line Format (BIL) formats.

BSQ

BSQ format is the simplest format, where each line of the data is followed immediately by the next line in the same spectral band. This format is optimal for spatial (x,y) access of any part of a single spectral band.

BIP

BIP format stores the first pixel for all bands in sequential order, followed by the second pixel for all bands, followed by the third pixel for all bands, and so forth, interleaved up to the number of pixels. This format provides optimum performance for spectral (z) access of the image data.

BIL

BIL format stores the first line of the first band, followed by the first line of the second band, followed by the first line of the third band, interleaved up to the number of bands. Subsequent lines for each band are interleaved in similar fashion. This format provides a compromise in performance between spatial and spectral processing and is the recommended file format for most ENVI processing tasks.
ENVI Header Files

The ENVI header file is a separate text file that contains information ENVI uses to read an image data file. It is typically created the first time ENVI accesses a data file. The header file provides the following information:

- The dimensions of the image
- The imbedded header, if present
- The data format
- Other pertinent information

If the image file does not already have a header file, you enter the required header information interactively (see “Creating Header Files” on page 123). You can also edit the header file later (see “Editing Header Files” on page 127). If needed, you can generate an ENVI header using a text editor (see “The ENVI Header Format” on page 114).
ENVI File Naming Conventions

ENVI does not impose any constraints on filenames, with the exception of the use of the .hdr extension used for header files. Some ENVI functions pre-load lists of files with specific extensions for ease of use (see below). Use these extensions consistently when running ENVI to maximize file handling efficiency. (This does not preclude you from using different filenames, if desired.)

<table>
<thead>
<tr>
<th>File Type</th>
<th>Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>ENVI bad lines list</td>
<td>.bll</td>
</tr>
<tr>
<td>ENVI Band Math or Spectral Math expression</td>
<td>.exp</td>
</tr>
<tr>
<td>ENVI calibration factors</td>
<td>.cff</td>
</tr>
<tr>
<td>ENVI contour levels file</td>
<td>.lev</td>
</tr>
<tr>
<td>ENVI density slice range file</td>
<td>.dsr</td>
</tr>
<tr>
<td>ENVI display group</td>
<td>.grp</td>
</tr>
<tr>
<td>ENVI filter kernels</td>
<td>.ker</td>
</tr>
<tr>
<td>ENVI GCP file</td>
<td>.pts</td>
</tr>
<tr>
<td>ENVI grid file</td>
<td>.grd</td>
</tr>
<tr>
<td>ENVI header file</td>
<td>.hdr</td>
</tr>
<tr>
<td>ENVI image</td>
<td>None defined</td>
</tr>
<tr>
<td>ENVI look up table</td>
<td>.lut</td>
</tr>
<tr>
<td>ENVI map key</td>
<td>.key</td>
</tr>
<tr>
<td>ENVI mosaic template file</td>
<td>.mos</td>
</tr>
<tr>
<td>ENVI n-D visualizer state</td>
<td>.ndv</td>
</tr>
<tr>
<td>ENVI PPI count file</td>
<td>.cnt</td>
</tr>
<tr>
<td>ENVI region of interest</td>
<td>.roi</td>
</tr>
<tr>
<td>ENVI spectral library</td>
<td>.sli</td>
</tr>
<tr>
<td>ENVI startup script</td>
<td>.ini</td>
</tr>
</tbody>
</table>

Table 2-2: ENVI File Types
Chapter 2: Before You Begin

Cross-Platform File Portability for Header Files

When naming files in ENVI, consider cross-platform portability. This is particularly important for preserving the relationship between image files and their corresponding header files.

On UNIX, ENVI appends the image filename with .hdr when creating a header file, so a UNIX image file named image_1.img has a header file named image_1.img.hdr. If two image files have the same name but different extensions (for example, .img and .dat), the corresponding header filenames are image_1.img.hdr and image_1.dat.hdr.

On Windows, ENVI replaces the image file extension with .hdr when creating a header file, so a Windows image file named image_1.img has a header file named image_1.hdr. If there are two image files with the same name but different extensions (for example, .img and .dat), the files would have the same header filename of image_1.hdr. This could cause problems in ENVI if the two images are located in the same directory and have different sizes and characteristics.

If cross-platform portability of images is an issue, the easiest solution is not to name image files with an extension. As a result, an image file has the same header filename in both UNIX and Windows. Alternatively, you can rename images and header files to the Windows convention before moving the images from UNIX to Windows systems.

---

<table>
<thead>
<tr>
<th>File Type</th>
<th>Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>ENVI statistics file</td>
<td>.sta</td>
</tr>
<tr>
<td>ENVI statistics report</td>
<td>.txt</td>
</tr>
<tr>
<td>ENVI surface view path file</td>
<td>.pat</td>
</tr>
<tr>
<td>ENVI tape script</td>
<td>.fmt</td>
</tr>
<tr>
<td>ENVI vector file</td>
<td>.evf</td>
</tr>
<tr>
<td>ENVI vector template file</td>
<td>.vec</td>
</tr>
<tr>
<td>JPL AIRSAR compressed stokes matrix radar data</td>
<td>.stk</td>
</tr>
<tr>
<td>SIR-C compressed data product</td>
<td>.cdp</td>
</tr>
</tbody>
</table>

*Table 2-2: ENVI File Types (Continued)*
ENVI Supported Input File Formats

- **ALOS Formats**: PRISM, AVNIR-2, PALSAR
- **AVHRR Formats**: KLMN/Level 1b, Quorum, SHARP
- **ENVISAT Formats**: AATSR, ASAR, MERIS
- **EOS Formats**: ASTER, MODIS
- **EROS A Formats**: Level 1A, Level 1B (GeoTIFF)
- **Flat Binary Formats**: BSQ, BIL, BIP
- **FORMOSAT-2 Formats**
- **Generic Formats**: ASCII, HDF, JPEG, JPEG2000, MrSID, PICT, PNG, SRF, TIFF/GeoTIFF\(^1\), GeoTIFF with metadata (.txt and .met), TIFF world files (.tfw), XWD
- **GeoEye-1 Formats**: GeoTIFF, NITF
- **IKONOS Formats**: GeoTIFF, NITF
- **Image Processing Software Formats**: ArcView\textsuperscript{®} Raster (.bil), ECW, ERDAS IMAGINE, ER Mapper, ESRI\textsuperscript{®} GRID, PCI (.pix)
- **IRS Formats**: Fast, SuperStructured
- **KOMPASAT-2 Formats**: GeoTIFF
- **Landsat Formats**: ACRES CCRS, ESA CEOS, FAST, GeoTIFF, HDF, MRLC, NLAPS
- **Military Formats**: ADRG, CADRG, CIB, NITF, miscellaneous formats, ATSR, DMSP (NOAA), LAS LIDAR, OrbView files, GeoTIFF, NITF
- **QuickBird Formats**: GeoTIFF, NITF, QuickBird Tile Products (.tii)
- **Radar Formats**: AIRSAR, ASAR, COSMO-SkyMed, ERS, JERS, RADARSAT, TOPSAR
- **RapidEye**: GeoTIFF, NITF
- **SeaWIFS Formats**: CEOS, HDF
- **SPOT Formats**: ACRES SPOT, DIMAP, GEOSPOT, SPOT, Vegetation

---

1. ENVI supports the following input TIFF compression formats CCITT Group 3 and 4 algorithms, Macintosh PackBits algorithm, ThunderScan 4-bit RLE algorithm, NeXT 2-bit RLE algorithm, and LogLuv high dynamic range encoding.
• **TFRD**: (You must purchase a separate module through ITT Visual Information Solutions.)

• **Thermal Formats**: AATSR, ASTER, MASTER, TIMS

• **USGS and Digital Elevation Formats**: USGS DRG, USGS DOQ, USGS DEM, SDTS DEM, DTED, SRTM DEM

• **Vector Formats**: ArcInfo® interchange format, shapefile, DXF, ENVI vector file (.evf), MapInfo Interchange, Microstation DGN, USGS DLG, USGS DLG in SDTS format

• **WorldView Formats**: GeoTIFF, NITF, WorldView Tile Products (.til)
ENVI Supported Output File Formats

- **ENVI Flat Binary Formats**: BIL, BIP, BSQ
- **Generic Image Formats**: ASCII, BMP, HDF, JPEG, JPEG 2000, PICT, PNG, TIFF (GeoTIFF), TIFF world (.tfw), SRF, XWD
- **Image Processing Formats**: ArcView® raster (.bil), ER Mapper, ERDAS IMAGINE, ESRI® GRID, NITF 02.00/02.10, PCI (.pix)
- **Vector Formats**: shapefile, DXF, ENVI vector file (.evf)
ENVI Supported Output File Formats

Getting Started with ENVI
Chapter 3
The ENVI Interface

This chapter provides instructions about the ENVI interface components. It includes:

- The ENVI Main Menu Bar ............... 38
- The Available Bands List ............... 39
- Display Groups ......................... 46
- The Available Vectors List ............. 61
- The Remote Connection Manager ........ 67
- Vector Displays ......................... 68
- Plot Windows ............................ 73
- ENVI Mouse Buttons .................... 75

Getting Started with ENVI 37
The ENVI Main Menu Bar

When you start ENVI, the ENVI main menu bar appears. You initiate activities in ENVI by using the menus in the ENVI main menu bar, which may be oriented horizontally or vertically, as shown below. See Miscellaneous Preference Settings in the ENVI User’s Guide for details on how to orient your ENVI main menu bar.

![Figure 3-1: ENVI Main Menu Bar Oriented Horizontally (left) and Vertically (right)](image)

The ENVI Main Menu Bar
The Available Bands List

When you open a file for the first time during a session, ENVI automatically places the filename, with all of its associated bands listed beneath it, into the Available Bands List. If a file contains map information as well, a map icon appears under the filename.

ENVI also adds output files to the Available Bands List that are the results of processing your data using ENVI’s tools.

If you open multiple files, all of the files with all of their bands appear in the Available Bands List sequentially, with the most recently opened file at the top of the list. You can fold the bands displayed under each filename to shorten the list length (see “Folding and Unfolding Data Sets” on page 40).
Folding and Unfolding Data Sets

By default, data sets typically display in ENVI in an unfolded state, where a file and all of its bands are immediately visible in the list. In the Available Bands List and other band selection dialogs, many bands may be listed, particularly when using hyperspectral data. You can fold or hide all of the bands of a data set so that they appear on only one line. This keeps the lists shorter and easier to work with.

To fold a data set, either:

- Click on the minus symbol (–) next to the filename.
- Double-click on the filename of the data set.
- To fold all data sets in the Available Bands List, right-click in the Select Input Band field and select Fold All Files, or from the Available Bands List menu bar, select Options → Fold All Files.

All of the bands of the data set compress and the data set appears with the plus symbol (+) next to the filename, as illustrated in the example in Figure 3-3.

To unfold a data set, either:

- Click on the plus symbol (+) next to the filename.
- Double-click on the filename.
- To unfold all data sets in the Available Bands List, right-click in the Select Input Band field and select Unfold All Files.

![Figure 3-3: Folded and Unfolded Data sets](image)
All of the bands of the data set expand and the data set appears with the minus symbol (–) next to the filename, as illustrated in the example in Figure 3-3.

If a band is currently displayed as either a gray scale or RGB image, an asterisk (*) appears next to the filename when it is folded.

**Opening Files from the Available Bands List**

1. From the Available Bands List menu bar, select File → Open Image File. The Enter Data Filename dialog appears.
2. Select a filename.
3. Click Open. ENVI adds the new file to the top of the Available Bands List.

*Tip*
To display a list of all open files, from the Available Bands List, select File → Available Files List.

For additional ways to open image files in ENVI, see “Opening and Displaying Files” on page 81.

**Opening Files in ArcMap**

To open a file in ArcMap™ software, you must have ArcMap version 9.2 or higher installed and licensed on your system.

1. Right-click on a dataset in the Available Bands List, and select Open File in ArcMap.

*Note*
If you opened the dataset in a display group and added any image enhancements or annotations, those will not be retained when you open the image in ArcMap software. If you want to retain image enhancements or annotations, use File → Export Image to ArcMap from the display group menu bar.

2. If you have one or more instances of ArcMap software already running, an ArcMap Instances dialog appears. Select an instance to display your dataset, or start a new instance of ArcMap software. Click OK.

If ArcMap software is not already running, ENVI will initiate it for you. The dataset will display in ArcMap software with ArcMap software’s default
enlargements and will be added as a new layer to the ArcMap table of contents.

Raster datasets in GeoTIFF, MrSID, ERDAS IMAGINE, or NITF format, or those stored in a geodatabase, can pass directly into ArcMap software without any conversion. For all other formats, ENVI converts the datasets to GeoTIFF format before passing them to ArcMap software. These are stored in the location you specify as the Temp Directory. (See Default Directory Preference Settings in the ENVI User’s Guide.) Datasets exported to ArcMap software remain open in ENVI.

Opening Files in ENVI Zoom

From ENVI, you can open a file in ENVI Zoom from the Available Bands List. The file must be in a format supported by ENVI Zoom, and it must be a saved file; you cannot open in-memory files.

In the Available Bands List, right-click on the file to open and select Open in ENVI Zoom. The file is opened in ENVI Zoom, and is optionally displayed in the Image window depending on your Auto Display Files On Open preference setting. For details about using ENVI Zoom, see the ENVI Zoom User’s Guide.

Closing Files from the Available Bands List

You can close individual files or all open files from the Available Bands List.

Closing Selected Files

To close the file associated with the bands currently displayed in the Selected Band field or in the R, G, and B fields:

- From the Available Bands List menu bar, select File → Close Selected File.
- In the Available Bands List, right-click on the file to close and select Close Selected File.

Tip

If you close one band from a disk file, ENVI closes the entire file and all of the bands in the file disappear from the Available Bands List. However, the file still exists on disk, and you can reopen it using File → Open Image File.
Closing All Files

To close all files in the Available Bands List and delete any items in memory:

1. From the Available Bands List menu bar, select File → Close All Files. A warning dialog appears.

   **Note**
   When you delete an in-memory file, you cannot recover the image.

2. Click Yes to close all files.

Hiding and Showing the Available Bands List

To remove the Available Bands List from view while keeping open the image files it contains, select File → Cancel from the Available Bands List menu bar.

To recall the Available Bands List at any time, select Window → Available Bands List from the ENVI main menu bar.
Available Bands List Right-Click Menus

The Available Bands List has a right-click menu for easy access to common Available Bands List functions.

Right-click on any filename, band name, or map information icon. The right-click menu items differ depending upon which item you right-click.

Editing Map Information

If a file has map information associated with it, you can view or edit this information.

To view or edit the map information associated with a file, right-click on the Map Info icon in the Available Bands List and select Edit Map Information. For information on using the Edit Map Information dialog to edit the data, see Editing ENVI Headers in the ENVI User’s Guide.
Locating Bands by Wavelength

For files with associated wavelength values in the header file, use **Wavelength Locator** to locate the band that contains a specified wavelength.

To use the wavelength locator:

1. From the Available Bands List, select **Options → Wavelength Locator**. The Wavelength Locator dialog appears.
2. Enter the wavelength you want to locate.
3. Click **Apply**. ENVI highlights the band containing that wavelength in the Available Bands List.

Showing Displayed Band Information

To display the names and wavelengths of the bands being used in a display group:

1. In the Available Bands List, select the display from the **Display #n** button.
2. From the Available Bands List menu bar, select **Options → Show Current Displayed Bands**.

The band information appears in the **R**, **G**, and **B**, or **Selected Band** (for gray scale) fields.
Display Groups

When you select a file to display from the Available Bands List (see “Displaying Images” on page 107), a group of windows will appear on your screen allowing you to manipulate and analyze your image. This group of windows is collectively referred to as the display group. The default display group consists of the following:

- Image window: Displays the image at full resolution. If the image is large, the Image window displays the subsection of the image defined by the Scroll window Image box.
- Zoom window: Displays the subsection of the image defined by the Image window Zoom box. The resolution is at a user-defined zoom factor based on pixel replication or interpolation.
- Scroll window: Displays the full image at subsampled resolution. This window appears only when an image is larger than what ENVI can display in the Image window at full resolution.

ENVI displays all images with a default 2% linear stretch. You can change the Display Default Stretch preference setting or set a default stretch in the image header file (see Editing ENVI Headers in the ENVI User’s Guide).

You can have multiple display groups open at a time, with any combination of gray scale and color images on display.

The windows included in the default display group and the general appearance of the display group windows are controlled by the ENVI Display Default Preference Settings defined for all ENVI sessions. You can also set preferences for an individual display group for a single session (see Editing ENVI Headers in the ENVI User’s Guide).

Mouse button functions for each of the display group windows differ. See “ENVI Mouse Buttons” on page 75 for details on mouse button behavior for each window.
Chapter 3: The ENVI Interface

Getting Started with ENVI

Display Groups

Figure 3-5: Display Group
Reduced Resolution Data Sets

Some remote sensing images include Reduced Resolution Data Set (RRDS) files to speed the display of the imagery. RRDS files (also called RSETs) are versions of the original image at various reduced resolutions.

ENVI currently supports RRDS files generated by RemoteView software, with file extensions of .rv1 through .rvn. Each progressive number represents a spatial resampling twice that of the previous file. They are in NITF 2.1 uncompressed format, so you must have a NITF/NSIF Module license in order for ENVI to use them to display images.

ENVI uses the RRDS files to display imagery in the Scroll window when you zoom in or out of the display, only as the Scroll window allows.

Opening New Display Groups

To start a new display group, use one of the following:

- From the Display group menu bar, select Window → Start New Display Window.
- From the ENVI main menu bar, select Window → Start New Display Window.
- In the Available Bands List, click Display #n and select New Display.

An empty Image window appears. Each window started is numbered sequentially starting with Display #1. When you load an image into the empty Image window, the Zoom and Scroll windows associated with that image appear.

Resizing Display Group Windows

To change the size of any display group window, either:

- Dynamically resize the window up to the available screen size by clicking and grabbing one of the corners and dragging to the desired size.

  If you are resizing the Zoom window, the corresponding Zoom box in the Image window automatically changes its size and shape to match the resized Zoom window.

  If you are resizing the Scroll window, the resampling factor changes to reflect the new size of the Scroll window.
From the Display group menu bar, select File → Preferences and enter the size in the Display Preferences dialog (see “Setting Preferences for an Individual Display Group” on page 58).

Change the default window size parameters set in your ENVI preferences (see Display Default Preference Settings in the ENVI User’s Guide).

**Maximizing Open Displays**

To resize all display group windows to fit the available screen space, use one of the following:

- From the Display group menu bar, select Window → Maximize Open Displays.
- From the ENVI main menu bar, select Window → Maximize Open Displays.

For example, if four displays are open, each display is resized to fill one-fourth of the available screen.

**Positioning the Zoom and Scroll Windows**

You can control the positioning of the Zoom and Scroll windows as follows:

- To position the Zoom and Scroll windows with respect to the Image window, select Scroll/Zoom Position from the display group right-click menu.
- To position the Zoom or Scroll window, left-click and drag the title bar to the desired position.
- To group the Zoom and Scroll windows to move with the Image window, deselect the Scroll/Zoom Position → Auto Placement Off option in the display group right-click menu.
- To ungroup the window, select Scroll/Zoom Position → Auto Placement Off in the right-click menu.
- To ensure that windows remain where they are placed, select Scroll/Zoom Position → Auto Placement Off. The windows remain in place until you move them again.

**Displaying Scroll Bars**

Use scroll bars in the Image and/or Zoom windows to move around the image. When you move the scroll bars in the Image window, the Image box in the Scroll window moves to show what part of the whole image you are in. Likewise, when you move...
the scroll bars in the Zoom window, the Zoom box in the Image window moves to show the zoom area.

To display scroll bars, use one of the following:

- In either the Image window or Zoom window, right-click and select **Toggle → Display Scroll Bars**.
- From the Display group menu bar, select **File → Preferences**. The Display Preferences dialog appears, where you can change the default settings for the display group (see “Setting Preferences for an Individual Display Group” on page 58).
- From the ENVI main menu bar, select **File → Preferences**. The System Preferences dialog appears, where you can change the default settings for all ENVI display groups (see Display Default Preference Settings in the ENVI User’s Guide).

### Hiding and Unhiding Display Group Windows

To hide only the Zoom and/or Scroll windows on Microsoft Windows platforms, click the **X** button in the upper-right corner of the window.

To unhide the Zoom and/or Scroll windows, right-click in the associated Image window and click **<Find Display>** to bring up the hidden windows. You can also unhide display group windows by using the Window Finder (see “Using the Window Finder” on page 56).

### Display Group Right-Click Menus

The display group has several right-click menus for access to many options. The right-click menus provide secondary access to functions that are otherwise accessible from the ENVI main menu bar or the Display group menu bar. In some cases, the right-click menu may be the only means to access an option.
The right-click menu differs, depending on which of the display group windows you right-click in, and depending on the tools you are using (for example, if interactive linking is on or off).

Figure 3-6: Right-Click Menus for Image Window (left) and Zoom Window (right)

When you select from the right-click menu, the function applies only to the active display group.

For example, you can use the right-click menu in any of the three display group windows to quickly access display group options:

1. Right-click anywhere in any of the three display group windows.
2. Select from the following options:
   - Use **Display Window Style** to select which of the three display windows (Image, Scroll, and Zoom) to show.
   - Use **Scroll/Zoom Position** to place the Scroll and Zoom windows in the desired position with respect to the Image window and to turn the **Auto Placement** option off or on.
   - Use **<Find Display>** to locate the closed display group windows associated with the current display group window.
Controlling the Zoom Window

The Zoom window provides you with unlimited zoom capabilities, such as zooming in or out and panning.

See also “Zoom Window Mouse Button Functions” on page 76 for details about using mouse buttons in the Zoom window.

Controlling the Zoom Window from the Image Window

The Zoom box in the Image window outlines the area that displays in the associated Zoom window.

To change the region defined by the Zoom box:
- Click and drag the Zoom box around in the Image window.
- Use the arrow keys on the keyboard to move the Zoom box in the Image window by one pixel in the direction of the arrow.
- Use Shift + arrow keys to move the Zoom box in the Image window by five pixels in the direction of the arrow.
- Use scroll bars (see “Displaying Scroll Bars” on page 49).

Scrolling the Zoom Window

To scroll the Zoom window, use one of the following:
- Use the arrow keys on the keyboard to move the Zoom window by one pixel in the direction of the arrow.
- Use Shift + arrow keys to move the Zoom window by 10 pixels in the direction of the arrow.
- Use scroll bars (see “Displaying Scroll Bars” on page 49).
Controlling the Zoom Factor and Crosshairs

The current zoom factor displays as a number in brackets in the Zoom window title bar. The default zoom factor is 4.

Figure 3-7: ENVI Zoom Window with Zoom Controls
Use the different mouse buttons and the Zoom controls in the Zoom window to change the zoom factor and to turn the display crosshairs on and off in both the Zoom and Image windows. The following describes the Zoom controls and their associated mouse button functions.

### Table 3-1: Zoom Window Control Functions with Mouse Button Descriptions

<table>
<thead>
<tr>
<th>Zoom Window Control</th>
<th>Function</th>
</tr>
</thead>
</table>
| **Zoom In** 🔗      | Left-click to increase the zoom factor by 1.  
                        Middle-click to double the zoom factor with each click (such as, 2, 4, 8, 16).  
                        Right-click to return to the default zoom factor of 4. |
| **Zoom Out** ⏬      | Left-click to decrease the zoom factor by 1.  
                        Middle-click to decrease the zoom factor by half.  
                        Right-click to return to the default zoom factor of 4. |
| **Crosshairs** ⬅️    | Left-click to toggle crosshairs in the Zoom window on and off.  
                        Middle-click to toggle crosshairs in the Image window on and off.  
                        Right-click to toggle the Zoom box and crosshairs in the Image window on and off. |

You can also zoom in by a factor of 1 and enable/disable crosshairs using options from the Zoom window right-click menu:

- To zoom in by a factor of 1, right-click and select **Set Zoom Factor to 1**.
- To toggle crosshairs on/off, right-click and select **Toggle → Zoom Cross-hair**.

### Controlling Zoom Interpolation

You can set your preference for the type of interpolation to use in the Zoom window. The choices are:

- **Nearest Neighbor**: Interpolation using pixel replication (default)
- **Bilinear**: Linear interpolation using 4 pixels
- **Bicubic**: Interpolation using 16 pixels
Chapter 3: The ENVI Interface

- **Optimized Bicubic**: Best interpolation

To set the interpolation, either:

- In the Zoom window, right-click and select **Zoom Interpolation**, then select the interpolation method.
- From the Display group menu bar, select **File → Preferences** (see “Setting Preferences for an Individual Display Group” on page 58).
- From the ENVI main menu bar, select **File → Preferences** (see Display Default Preference Settings in the ENVI User’s Guide).

### Controlling the Scroll Window

The Image box in the Scroll window appears as an outlined area and represents the area that displays in full resolution in the Image window.

#### Controlling the Image Window from the Scroll Window

The size of the Image box in the Scroll window is affected by the size of the Image window.

- If you change the size of the Image window, the Scroll window Image box also changes sizes.
- If the display window style is set to **Scroll/Image/Zoom** and you resize the Image window so that the entire image appears at full resolution, the Scroll window is no longer needed and closes.
- If you resize the Image window so that the full image cannot be shown at full resolution, the Scroll window reopens.
- The Image box in the Scroll window outlines the area that displays in the associated Image window. To change the region defined by the Image box, click and drag the Image box around in the Scroll window.
- Use the arrow keys on the keyboard to move the Image box in the Scroll window by one pixel in the direction of the arrow. The Image window updates to show the new area.
- Use **Shift** + arrow keys to move the Image box in the Scroll window by five pixels in the direction of the arrow. The Image window updates to show the new area.

See also “**Scroll Window Mouse Button Functions**” on page 77 for details about using mouse buttons in the Scroll window.
Scroll Window Meta Zoom

When very large images display, ENVI may subsample the Scroll window image to the extent that it is difficult to see image features. When this occurs, use the Scroll window meta zoom capability to zoom into an area and reduce the subsampling factor in the Scroll window.

To enable or disable meta zoom:

- To enable meta zoom, middle-click and drag the Meta Zoom box around the desired area in the Scroll window. The selected area must be larger than the current Image window size. The meta zoomed area replaces the full image in the Scroll window and scroll bars appear.

- To re-display to the original Scroll window, right-click in the Scroll window and select Reset Scroll Range.

Using the Window Finder

Use the Window Finder to manage active ENVI windows and dialogs and to bring windows that are minimized or buried under other windows to the foreground. The list contains the names of major active windows in the order that they were opened. The list includes display group windows (Image, Scroll, Zoom), plot windows, scatter plots, ROI definition windows, and so forth.

1. From the ENVI main menu bar, select Window → Window Finder. The ENVI Window Finder appears with a list of open windows.
2. To call a window to the desktop foreground:
   - Click on the name of a specific display number to bring the Image window and its associated Scroll and Zoom windows to the front.
   - Click on any other window name to bring that window to the front.
   - If you click on the name of an overlay dialog (Annotation, ROI, Density Slice, etc.) that was hidden by selecting Overlay → Hide Layer in the dialog menu bar, double-click the dialog name to hide the dialog again. For details about hiding dialogs, (see Showing and Hiding Overlay Dialogs and Layers in the ENVI User’s Guide).

**Tip**
The ENVI Window Finder moves to the front of the display group if bringing an ENVI window forward causes it to be covered. If the Window Finder is hidden behind another window, select Window → Window Finder from the ENVI main menu bar to bring it to the front again.

---

**Saving Display Groups**

You can save a given display group in its present state to a file. When you save a display group, the displayed bands, window sizes and positions, stretch, any displayed overlays, any open profiles, any associated two-dimensional scatter plots, and any display preference settings are saved along with the display in a text file. Files that are not saved to disk (for example, only in memory) and files that cannot be opened directly using ENVI’s Open Image File function are not saved with the display group.

1. From the Display group menu bar, select File → Save As Display Group.
2. Enter an output filename.
3. Click OK. ENVI automatically appends the extension .grp to the filename.

**Restoring Saved Display Groups**

1. Use one of the following:
   - From the ENVI main menu bar, select File → Restore Display Group.
   - From the Display group menu bar, select File → Restore Display Group.
2. In the Input File dialog, select the .grp file.
3. Click **OK**. If you selected to restore the display group from the ENVI main menu bar, the display loads into a new display group. If you selected to restore the display group from the Display group menu bar, the display loads into the current display group.

### Setting Preferences for an Individual Display Group

For each display group you can set preferences that distinguish that display from other displays. For example, you can add virtual borders to an image, enable scroll bars, change the size of the Image, Zoom, or Scroll windows, and change the graphics display colors in those windows. These settings are in effect for only the current ENVI session, unless you save the display group to restore in a later ENVI session (see “Saving Display Groups” on page 57 and “Restoring Saved Display Groups” on page 57).
If you prefer to change preferences for all display groups and use the same preferences for all, see Display Default Preference Settings in the *ENVI User’s Guide*.

![Display Preference Dialog](image)

*Figure 3-9: Display Preference Dialog*

To set preferences for an individual display group:

1. From the Display group menu bar, select **File → Preferences**. The Display Preferences dialog appears. For complete descriptions of the dialog options, see Display Default Preference Settings in the *ENVI User’s Guide*.

2. Select the combination of the display group windows to use from the **Window Style** drop-down list.
3. To have a virtual border around the edge of the display group windows when an image is loaded, set the width (in pixels) in the Display Border fields. The left field controls the left border, the top field controls the top border, and so forth. Click Border Color to select the virtual border color.

4. In the Image Window fields, enter the Xsize and Ysize in pixels, and specify whether or not to include Scroll Bars.

5. In the Zoom Window fields, enter the Xsize and Ysize in pixels, specify whether or not to include Scroll Bars, and set the Zoom factor and Interpolation method.

6. In the Scroll Window fields, enter the Xsize and Ysize in pixels.

7. Click the Display Graphic Color color button to set the color of the Zoom box, Image box, and Zoom controls.

8. Click OK.

Closing Display Groups

To close a display group, use one of the following:

- From the Display group menu bar, select File → Cancel.
- In Microsoft Windows, click the button in the Image window.

The display group and any associated dialogs close.

To save a display group and its associated windows to a file, see “Saving Display Groups” on page 57.

Closing All Open Display Groups

To close all open display groups, use one of the following:

- From the Display group menu bar, select Window → Close All Display Windows.
- From the ENVI main menu bar, select Window → Close All Display Windows.
The Available Vectors List

When you load a vector file into memory for the first time during an ENVI session, ENVI automatically places the vector layers into the Available Vectors List. Data files that can appear in the Available Vectors List include ENVI vector files, DLG, Microstation DGN, MapInfo, SDTS, DXF, ArcInfo® Interchange, and shapefiles.

If you open multiple vector files, all of the files appear in the Available Vectors List sequentially, with the most recently opened file at the bottom of the list.

From the Available Vectors List, you can select vector files to display as an overlay in a display group, or in a separate Vector window (see “Displaying Vectors” on page 112).
Opening Files from the Available Vectors List

1. In the Available Vectors List, select File → Open Vector File. The Select Vector Filenames dialog appears.
2. Select the file type from the Files of type drop-down list.
3. Select the filename.
4. Click Open. ENVI adds the vector file to the Available Vectors List.

For additional ways to open vector files in ENVI, see “Opening Vector Files” on page 103.

Opening Vector Layers in ENVI Zoom

From ENVI, you can open one or more vector files in ENVI Zoom from the Available Vectors List. The file must be a saved file; you cannot open in-memory files. All vector files, including .shp files, open as .evf.

1. Select the file(s) to open.
2. From the Available Vectors List menu bar, select File → Open Layers in ENVI Zoom. The vector layer(s) are opened in ENVI Zoom, and are optionally displayed in the Image window depending on your ENVI Zoom Auto Display Files On Open preference setting. For details about using ENVI Zoom, see the ENVI Zoom User’s Guide.

Opening Vector Layers in ArcMap

To open data in ArcMap™ software, you must have ArcMap version 9.2 or higher installed and licensed on your system. At least one vector dataset must be open.

1. Select one or more vector datasets from the Available Vectors List to display in ArcMap software.
2. From the Available Vectors List menu bar, select File → Open Layers in ArcMap.
3. If you have one or more instances of ArcMap software already running, an ArcMap Instances dialog appears. Select an instance to display your dataset, or start a new instance of ArcMap software.
4. Click OK.
If ArcMap software is not already running, ENVI will initiate it for you. The
vector datasets will display in ArcMap software and will be added to the
ArcMap table of contents.

Vector datasets must be in shapefile format or consist of feature classes in a
gedatabase. You cannot export vector data to ArcMap software that have unsaved
edits. You must first commit your edits or revert back to the original vectors before
exporting them to ArcMap software.

Datasets exported to ArcMap software remain open in ENVI.

Opening New Vector Windows

To start a new empty Vector window and an associated parameters dialog, select
Options → Start New Vector Window.

Editing Layer Names

1. In the Available Vectors List, select Options → Edit Layer Names.
2. When the Edit Layer Names dialog appears, click on the name of the layer that
   you want to change. The name appears in the Edit Selected Item field.
3. Edit the name. To return the layer to its unedited name, click Reset.
4. Click OK.

Creating New Layers

Use Create New Vector Layer to create a new empty vector layer so you can add
polygons, lines, or points and attributes. These vector layers can have the same
projection and geographic boundaries (size) as existing vector layers, georeferenced
raster images, or you can base them on user-defined input. An empty vector layer can
also be created from non-georeferenced raster images for drawing vectors over those
images. For detailed instruction on creating new layers from existing layers,
projection and boundaries of a raster image, or from user-defined parameters, see
ENVI Help.

Tip
You can also create vector layers by selecting Vector → Create New Vector
Layer from the ENVI main menu (see Creating Vector Layers in the ENVI User’s
Guide).
Saving Vector Layers

Vector layers listed in the Available Vectors List are currently in memory. Use this procedure to save them to a file.

1. In the Available Vectors List, select the layer by clicking on the name.
2. Select File → Save Memory Layers to File.
3. Enter an output filename.

Selecting an Output Geodatabase

You can save raster and vector datasets that are open in ENVI or ENVI Zoom to a geodatabase. Follow these steps to continue:

1. Select one of the following menu options, depending on the program you are using:
   - Raster datasets in ENVI:
     From the ENVI main menu bar, select File → Save File As → ArcGIS Geodatabase.
   - Vector datasets in ENVI:
     In the Available Vectors List, select a vector layer by clicking on the name. Select File → Export Layers to ArcGIS Geodatabase.
   - Raster and vector datasets in ENVI Zoom:
     From the ENVI Zoom menu bar, select File → Save to ArcGIS Geodatabase.

If you are saving raster datasets in ENVI or raster/vector datasets in ENVI Zoom, the Select Input File dialog appears.

2. Select a dataset, and click OK.

   The Process Manager updates to show export progress to a geodatabase. The Process Manager displays the progress, but the coordination between ENVI or ENVI Zoom and ArcMap™ software does not allow the process to be cancelled once initiated.

   The Select Output Geodatabase dialog appears. This dialog lists all available geodatabases to which ENVI or ENVI Zoom is connected.

3. If the destination geodatabase is not present in this list, click Connect. The Connection Properties dialog appears. See “Managing Connection Properties” on page 96 for instructions on connecting to a dataset. If successful, the new
connection is added to the Destination Geodatabase list and selected by default.

4. Select a geodatabase from the Destination Geodatabase list.

5. In the Select Output Geodatabase dialog, enter a dataset name in the Output Name field. The default is the name of the input dataset.

6. Optionally set any configuration keywords. (For more information on configuration keywords, see the ArcGIS Help.)

7. Click OK. ENVI or ENVI Zoom verifies that the output geodatabase has sufficient write permissions and that you have a valid ArcGIS® license. (See also ESRI License Type in ENVI Zoom preferences.)

Restrictions

- You must have an ArcView® license to save to a personal or file geodatabase and an ArcEditor™ or ArcInfo® license to save to an enterprise geodatabase. Contact your ESRI sales representative to purchase a license.
- Personal geodatabases store datasets within a Microsoft Access data file, which is limited in size to 2 GB.
- Enterprise geodatabases require a login. Users with read-only access cannot save data to an enterprise geodatabase.
- You cannot load vector data with unsaved edits to a geodatabase.
- You can save point, line, polygon, and multipoint vector data to a geodatabase. Vector files in ENVI Vector Format (EVF) with multiple record types are not supported.
- In ENVI, you cannot save virtual mosaics or spectral libraries to a geodatabase.
- In ENVI and ENVI Zoom, display enhancements you add to a raster image (contrast stretching, sharpening, etc.) are not retained when saving the image to a geodatabase. You can use the Chip from Display or Chip Display to ArcMap option in ENVI Zoom, or the Save Image As option from an ENVI display group, to retain display enhancements.
- ENVI stores any single-band raster data with a three-color lookup table as an RGB image upon saving to a geodatabase. ENVI Zoom retains color maps upon saving to a geodatabase.
- Traditional map information from input raster data will be retained upon saving to a geodatabase. RPC information, affine map transformations (kx/ky
or pseudo projections), and custom projections are not retained when saving to a geodatabase.

- You cannot save a vector dataset (feature class) to an ArcGIS® feature dataset from ENVI or ENVI Zoom. After saving a feature class to a geodatabase, use ArcCatalog™ software to drag the feature class to a feature dataset if needed.

- For NITF data, you can only save individual image segments to a geodatabase. Composite images, annotation segments, and files with multiple image segments are not supported. ENVI and ENVI Zoom do not export NITF metadata to a geodatabase.

- Metadata that is supported in both ENVI and ArcGIS software will transfer upon saving to a geodatabase. However, ENVI-specific metadata (such as spectral information, band names, etc.) will not be stored in a geodatabase.

- Detailed information on geodatabase types, their structure, and their support in ArcGIS software can be found in the ArcGIS Desktop help.
The Remote Connection Manager

See “Using the Remote Connection Manager” on page 91 for steps.
Vector Displays

ENVI Vector windows are standalone GIS plots that display vector data and allow you to compose simple vector-only maps. You can also overlay vectors on display groups, which includes true vectorization of overlays in all windows, including the Zoom window. ENVI maintains full precision of vector data and avoids pixellation.

You can open vector files from a variety of input files, or you can create and draw new vector layers in a Vector window or over images in a display group. In ENVI Vector windows, you can also:

- Display latitude/longitude and map coordinate information in the Vector window status bar while interactively tracking vectors.
- Display attribute information in real-time as the cursor tracks each vector (see Vector Attributes in the ENVI User’s Guide).
- Query vector GIS attribute information directly to generate new layers of selected information with attributes (see Vector Attributes in the ENVI User’s Guide).
- Create shapefiles and associated .dbf attribute files and indexes, or DXF files from the internal ENVI .evf format (see Managing Vector Layer Files in the ENVI User’s Guide).

New vector layers you generate and changes you make to vector layers in ENVI are easily exported to industry-standard GIS formats.
When you select to display vector files in a Vector window, ENVI loads the vectors into a Vector window.
When you select to display vector files in a display group, ENVI overlays the vectors on the image in the selected display group.

Figure 3-12: Vector File Displayed Over Image in Display Group
Starting New Vector Windows

To start a new Vector window, select Window → Start New Vector Window from the ENVI main menu bar.

Each window is numbered sequentially starting with Vector Window #1. You can open new vector windows from the Available Vectors List (see “Opening New Vector Windows” on page 63).

Zooming In and Out of Vector Windows

To zoom in on a section of the Vector window:

- Middle-click and drag the cursor to define the region to magnify. ENVI redraws the enlarged zoom region in the Vector window.
- Shift + middle-click to zoom in to the display centered under the cursor.

To zoom out in the Vector window:

- Middle-click inside the zoomed region. The vector display steps backward through the previous zoom levels with one step per click.
- Right-click inside the Vector window and select Previous Range. The vector display steps backward through the previous zoom levels.
- Right-click inside the Vector window and select Reset Range to reset all zooming and set the vector display back to the original range.

Panning in Vector Windows

To pan to another region in the Vector window, left-click near any edge of the Vector window. The Mode in the status bar displays Pan direction, where direction is the direction of the pan, such as North, East, SE, and so forth.

Using Cursor Tracking in Vector Windows

If you are using image-to-map registration (see Registration in the ENVI User’s Guide), you need to know the location of your cursor. If vectors are overlaid on a display group, ENVI reports the position of the cursor by displaying it in the Location field of the Vector Parameters dialog associated with that display group. If vectors are displayed in a Vector window, ENVI reports the position of the cursor in the bottom-left of the Vector window status bar.
A check mark appears next to the active layer name when you right-click in the Vector window and select **Select Active Layer**. When a layer is active, the vector cursor snaps to the nearest vector in that layer. When a layer is not active, the cursor tracks the position anywhere in the window without using snap. In either case, left-click and drag in the Vector window to list the map coordinates of the cursor’s location in Easting, Northing order in the lower-left Vector window status bar. Latitude and longitude display directly under the Easting, Northing map coordinates.

**Vector Options**

Vector data often consist of multiple layers of data. Use the Vector options in a Vector window to control the appearance of vector layers, to add new vectors; to export vector layer coordinates for use in image-to-map registration; and to view, edit, and query vector attributes (see *Working with Vectors* in the *ENVI User’s Guide* for details).

**Vector Attributes**

When vector layers have attributes associated with them, ENVI can read and interact with shapefile attributes. Currently, ENVI only reads shapefile attributes or attributes added through ENVI.

You can use the cursor to select vectors in the Vector window and highlight the associated attributes or select an attribute and highlight the associated vector. You can do a vector attribute query to create new vector layers with attributes selected using simple mathematical and logical operators. ENVI also allows you to edit the existing attributes or to add new attributes to vectors. You can plot point attribute names in the Vector window and point symbol sizes associated with attribute values (see *Vector Attributes* in the *ENVI User’s Guide* for instructions).
Plot Windows

ENVI plot windows present a graphical representation of your data. Plot windows provide interactive analysis capabilities including moving plots between windows, data input and output, plot output, editing, annotation, and other options. Plot windows may contain spatial data (such as an X Profile), spectral data (such as a Z Profile), or any x,y data.

See the following topics in ENVI Help for details on plots:

- Extracting X and Y (Horizontal and Vertical) Profiles
- Extracting Z Profiles
- Using Interactive Plot Functions

![Figure 3-13: X Profile Plot Window](image)
Opening New Plot Windows

To open a new plot window, use one of the following:

- From the ENVI main menu bar, select **Window → Start New Plot Window**.
- From any plot window menu bar, select **Options → New Window: Blank**.
- To create a copy of the current plot window including the data within it, select **Options → New Window with Plots** from any plot window menu bar.

You can set up new plot windows as data collectors to hold useful plots from profiles and other plot windows.

To move plots and plot labels between windows, see Using Interactive Plot Functions in the *ENVI User’s Guide*.

To use **Annotate Plot** to annotate the x, y, and z profiles and other plots, see Annotating Images and Plots in the *ENVI User’s Guide*.

**Tip**
Resize both plot and Image windows to their final desired size before annotation. If you resize the plot window after annotation, the annotated objects are offset from their correct positions.

Closing All Plot Windows

To close all open plot windows, select **Window → Close All Plot Windows** from the ENVI main menu bar.
ENVI Mouse Buttons

To use all of ENVI’s functions, it is recommended that you have a three-button mouse, or a mouse with two buttons and a scroll wheel.

**Note**

On Macintosh platforms, where only one mouse button is available, use **Alt/Option**+click to emulate a middle mouse button. To emulate a left mouse button, use **Apple/Command**+click.

Because mouse button functions vary within ENVI windows, you can view applicable mouse functions through the Mouse Button Descriptions dialog. If you have this dialog open, ENVI updates the dialog with mouse button descriptions as you move the cursor from window to window.

---

**Figure 3-14: Mouse Button Descriptions Dialog**

To display mouse button descriptions, select one of the following:

- From the ENVI main menu bar, select **Window → Mouse Button Descriptions**.
- From the ENVI main menu bar, select **Help → Mouse Button Descriptions**.
- From the Display group menu bar, select **Window → Mouse Button Descriptions**.

**Tip**

Some interactive processes change the mouse functions listed in the following tables. These processes include defining regions of interest (ROIs), annotation, vector overlay, and dynamic overlay. These functions may be disabled to restore the
mouse buttons to their normal mode of operation. If the mouse buttons do not respond as you expect them to, display the Mouse Button Descriptions dialog to check which mode is in control of the cursor.

### Image Window Mouse Button Functions

<table>
<thead>
<tr>
<th>Mouse Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>Click inside the Zoom box and drag it to a new location. The Zoom window updates when you release the button. Click outside the Zoom box to center it over the current pixel position. Continue to hold the button and drag to continuously update the Zoom window. Double-click in the Image window to display the Cursor Location/Value dialog.</td>
</tr>
<tr>
<td>Middle</td>
<td>No function.</td>
</tr>
<tr>
<td>Right</td>
<td>Click to display the right-click menu.</td>
</tr>
</tbody>
</table>

*Table 3-2: Mouse Button Functions – Image Window*

### Zoom Window Mouse Button Functions

<table>
<thead>
<tr>
<th>Mouse Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>Click on the desired pixel to center the Zoom window on that pixel. Click and hold to pan from the center of the window in the direction of the cursor location. The speed of the pan varies with the cursor’s distance from the center of the Zoom window. The closer the cursor is to the center, the slower the pan.</td>
</tr>
</tbody>
</table>

*Table 3-3: Mouse Button Functions – Zoom Window*
### Scroll Window Mouse Button Functions

<table>
<thead>
<tr>
<th>Mouse Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>Click anywhere outside the Image box and drag. The Zoom window and Image window update continuously. Click, drag, and release the Image box to reposition the image. The Zoom window and Image window update when you release the button. Click to center the Image box and image display over the selected pixel.</td>
</tr>
<tr>
<td>Middle</td>
<td>Click and drag to create the meta Zoom box.</td>
</tr>
<tr>
<td>Right</td>
<td>Click to display the right-click menu.</td>
</tr>
</tbody>
</table>

*Table 3-4: Mouse Button Functions – Scroll Window*
Vector Window Mouse Button Functions

Mouse button functions in vector windows work differently than they do in ENVI display groups. Cursor functions in the vector windows change depending on the mode you select. See Controlling Cursor Modes in the ENVI User’s Guide for cursor functions in the other modes. The Vector window mouse button functions for the Cursor Query mode are:

<table>
<thead>
<tr>
<th>Mouse Button</th>
<th>Function</th>
</tr>
</thead>
</table>
| Left         | On active layers: Snap to a near active vector and track map coordinates and latitude/longitude. The coordinates display at the bottom of the Vector window.  
On inactive layers: Pan the display by clicking at any edge of the Vector window. When the cursor is near the edge of the Vector window, the Mode label in the Vector window status bar displays Pan and the direction of the pan.  
Note - To determine the active layer, right-click in the Vector window and select Select Active Layer. A check mark appears next to the active layer name. |
| Middle       | Click and hold and drag to form a Zoom box.  
Shift-click to zoom in to the display over the selected pixel.  
Click to decrease the zoom factor. |
| Right        | Click to display the right-click menu. |

*Table 3-5: Mouse Button Functions – Vector Window*
### Plot Window Mouse Button Functions

<table>
<thead>
<tr>
<th>Mouse Button</th>
<th>Action</th>
</tr>
</thead>
</table>
| Left         | Click and hold and drag inside a plot window over data plot to display the line-cursor, data point location, and x,y values.  
              | Click and drag the corner of plot window to resize the window.  
              | Click and drag to a new window on plot label to move plots to new window. |
| Middle       | Click and drag from any point inside the plot frame diagonally to form a box containing the desired subset rescale x,y plot ranges.  
              | Click inside the plot window to reset to the previous x,y plot ranges.  
              | Click the left side of the plot frame to set y axis to data range. |
| Right        | Click inside the plot window to toggle the plot name labels.  
              | Click on the plot label to delete a specific data plot. |

*Table 3-6: Mouse Button Functions – Plot Window*
Chapter 4
Opening and Displaying Files

This chapter provides instructions about opening files in ENVI, selecting files to display, and loading files into display groups. It includes:

- Opening Image Files in ENVI ............... 82
- Opening Remote Datasets ................. 83
- Opening External Image Files in ENVI .... 101
- Opening Previously Opened Files ......... 102
- Opening Vector Files .................... 103
- Opening Spectral Library Files ............ 106
- Displaying Images ........................ 107
- Displaying Vectors ...................... 112
Chapter 4: Opening and Displaying Files

Opening Image Files in ENVI

You can open ENVI image files or other binary image files of known format. ENVI automatically identifies and reads files of the following types:

- AVHRR
- BMP
- ER Mapper, PCI (.pix)
- ERDAS 7.x (.lan)
- ERDAS IMAGINE 8.x (.img)
- GeoTIFF
- GeoTIFF with metadata (.txt and .met for Landsat, *_metadata.txt for GeoEye-1, *_metadata.xml for RapidEye)
- HDF
- HDF SeaWiFS
- JPEG
- JPEG 2000
- Landsat 7 Fast (.fst)
- Landsat 7 HDF
- MAS-50
- MRLC (.dda)
- MrSID
- NLAPS
- PDS
- RADARSAT
- SRF
- TIFF
- NLAPS
- PDS
- RADARSAT
- SRF
- TIFF
- ERDAS 7.x (lan)
- ERDAS IMAGINE 8.x (.img)
- GeoTIFF
- GeoTIFF with metadata (.txt and .met for Landsat, *_metadata.txt for GeoEye-1, *_metadata.xml for RapidEye)
- HDF

The file retains its native format, and ENVI reads the necessary information from the file header. To open other file types, see “Opening External Image Files in ENVI” on page 101.

1. Choose one of the following options:
   - From the ENVI main menu bar, select File → Open Image File.
   - From the Available Bands List menu bar, select File → Open Image File.
   - From the Available Files List menu bar, select File → Open New File.
   - From any Input File dialog, click Open and select New File.

   The Enter Data Filenames dialog appears.

2. Select the file to open.

3. Click Open. ENVI adds the filename and bands to the Available Bands List.

Tip

If the Header Info dialog appears when opening an ENVI-supported file, use the Open External File option instead (see “Opening External Image Files in ENVI” on page 101).
Note
You can open multiple image files contained in an ASCII text file as long as the first line of the ASCII file begins with the line ENVI File List. This can then be followed by a list of filenames. Opening the ASCII text file causes ENVI to open all the files listed.

Opening Remote Datasets

Use File → Open Remote Dataset or File → Remote Connection Manager to access data from the following types of Web servers:

- OGC Servers for Web Map Service (WMS) and Web Coverage Service (WCS)
- JPEG 2000 Servers for JPEG 2000 Internet Protocol (JPIP) and Image Access Solutions (IAS)
- Geodatabases (only accessible from File → Remote Connection Manager)

See “Opening Datasets” on page 86 and “Using the Remote Connection Manager” on page 91 for steps.

Supported Platforms

Supported platforms vary by connection type:

<table>
<thead>
<tr>
<th>Connection Type</th>
<th>Windows</th>
<th>Mac OS X</th>
<th>Linux</th>
<th>Solaris</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>32-bit</td>
<td>64-bit</td>
<td>32-bit</td>
<td>64-bit</td>
</tr>
<tr>
<td>ArcGIS® geodatabase a,b</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Connect to and read from geodatabase</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save to file or personal geodatabase</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save to enterprise SDE geodatabase c</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>IAS and JPIP a</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>OGC WCS and WMS</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
</tbody>
</table>

Table 4-1: Remote Dataset Supported Platforms

a Windows users: these functions only run in 32-bit mode. If you have a 64-bit Windows PC and you want to use these functions, run ENVI in 32-bit mode as follows from the Windows Start menu: Program Files → ENVI x.x → 32-bit → ENVI or ENVI + IDL or ENVI Zoom.

Getting Started with ENVI Opening Image Files in ENVI
Chapter 4: Opening and Displaying Files

Opening Image Files in ENVI

**Getting Started with ENVI**

b Supported on ArcGIS® Desktop 9.2 and later; tested on Windows XP 32-bit and Vista 32-bit operating systems with ArcGIS® Desktop 9.3.

c Requires an ArcInfo® or ArcEditor™ license (ArcView® software does not support this feature).

**OGC Servers**

The Open Geospatial Consortium (OGC) provides a variety of protocol specifications for transmitting geospatial data via the web. ENVI and ENVI Zoom support two of these specifications: WMS and WCS. See [http://www.opengeospatial.org](http://www.opengeospatial.org) for more information.

OGC servers have several common features:

- Data are sent as image files. ENVI and ENVI Zoom support JPEG 2000, JPEG, and TIFF/GeoTIFF formats. If a dataset you are querying cannot be transmitted in one of these formats, you cannot open the dataset.

- You can customize data delivery by specifying a spatial extent, interpolation type, pixel size, and map projection, which saves you from reading unwanted data for regions you are not interested in. ENVI and ENVI Zoom manage the details of server requests, such as downloading data tiles, deleting temporary files, and reading data.

- OGC servers provide a directory listing service called GetCapabilities to list OGC datasets available on any server, or you can directly connect to an OGC dataset.

**OGC WCS**

WCS is a protocol for serving raster data that represent properties of geographic locations. WCS servers provide coverages that you can manipulate. WCS servers list datasets at one level instead of in a folder hierarchy.

**OGC WMS**

WMS is a protocol for serving maps that are generated on-the-fly for display purposes only. A powerful feature of WMS servers is that you can identify multiple datasets that meet your criteria, and the server combines them into one displayable map layer. WMS servers do not specify a pixel size for a given dataset, so ENVI or ENVI Zoom estimate a default pixel size. You can change this value by setting the **WMS Pixels Per Side** preference. WMS servers list datasets on the server in a folder hierarchy.
Chapter 4: Opening and Displaying Files

JPEG 2000 Servers

OGC and JPIP servers support delivery of image data at different resolutions that are automatically resampled by the servers. IAS and JPIP servers send compression parameters known as wavelets, while OGC servers send actual image files. This means that ENVI and ENVI Zoom read any IAS server dataset.

Note
If you are working on a Windows 64-bit platform, you need to start ENVI or ENVI Zoom in 32-bit mode to access data from JPIP or IAS servers.

To view datasets from IAS and JPIP servers, you need a server that uses the ISO/IEC 15444-9 JPEG 2000 standard (JPEG 2000 Internet Protocol). IAS 3.x and higher provides support for this version of the standard.

JPIP

JPIP is a client-server protocol used to serve JPEG 2000 compressed imagery (.jp2, .j2c, and .jpx). No directory listing service is available with JPIP servers; you must specify the full path to a dataset you want to view (for example, jpip://exampleserver:1234/file.jp2).

If a dataset from a JPIP server contains map information, it is stored in the file header using a GeoJP2 protocol. ENVI and ENVI Zoom attempt to read and import map information and apply it to the input file whenever possible.

IAS

The IAS product, available from ITT Visual Information Solutions, provides a server that streams JPEG 2000 and NITF 2.1 C8 compressed imagery using the JPIP protocol, which you can display and analyze. IAS supports full JPIP streaming capabilities, plus it provides a directory listing service, NITF support, and a tool to convert any image file to JPEG 2000 or NITF 2.1 C8 formats. ENVI and ENVI Zoom do not support opening CMYK compressed JPEG 2000 files using an IAS server.

An IAS server lists datasets in a hierarchy similar to that of a file system. You can browse data from an IAS server in ENVI and ENVI Zoom.

An IAS server can list datasets that are not JPEG 2000 compressed, but it cannot serve them; An error message appears if you attempt to open this type of dataset from an IAS server. Once you select a JPEG 2000 compressed dataset through an IAS server, you can also access metadata.
IAS servers retain and serve metadata associated with NITF datasets. ENVI and ENVI Zoom can read and interpret NITF metadata, including map and wavelength information, as well as file and image metadata, text segments (if present), and most tagged record extensions (TREs). If map information is not present in NITF metadata, the dataset is read in from a GeoJP2 UUID box, if present. See “Viewing NITF Metadata from IAS Datasets” on page 90 for details about viewing metadata.

For more information about IAS functionality, refer to the ITT Visual Information Solutions website.

Geodatabases

The ArcGIS® geodatabase is a data storage mechanism that allows for many types and sources of geographic data, both raster and vector, to be supported in a consistent manner. ENVI and ENVI Zoom support personal geodatabases (in Microsoft Access .mdb format), file geodatabases, and enterprise geodatabases.

Opening Datasets

You can open remote datasets using File → Open Remote Dataset, which is described here, or File → Remote Connection Manager, which is described in “Using the Remote Connection Manager” on page 91.

Using the Open Remote Dataset Dialog

Open Remote Dataset is useful when you are already familiar with the connection details of the dataset you want to open. You cannot use the Open Remote Dataset dialog to access a server, only a specific dataset. The Open Remote Dataset dialog only connects to datasets on JPIP, IAS, and OGC servers.

For JPIP and IAS servers, the connection string consists of the IP address or server (host) name, port number, the path (relative to the server root), and filename. Preface the URL with http:// or jpip://. For example:

```
jpip://ias-server:80/data/jpeg2000_file.jp2
```

For OGC servers, the connection string consists of the server name, port number, CGI get request (followed by a question mark), and optional OGC keywords. Preface the
URL with \url{http://}. “OGC Connection Keywords” on page 88 describes the keywords. For example:

\begin{verbatim}
ogc-server.org/cgi-bin/mapserv_dem?coverage=srtmplus_raw&
width=1000&height=1000&bbox=-105,39,-104,40
\end{verbatim}

where:

\begin{verbatim}
http://ogc-server.org/cgi-bin/mapserv_dem?coverage=srtmplus_raw&....
\end{verbatim}

Because no port number was specified in the example above, ENVI Zoom uses port 80 as the default.

You can also define a proxy server by setting the OGC Proxy Server preference.

Follow these steps to open a remote dataset:

1. Select File \rightarrow Open Remote Dataset from the ENVI Zoom menu bar or File \rightarrow Open Remote File from the ENVI main menu bar. The Open Remote Dataset dialog appears.

\begin{center}
\includegraphics[width=0.5\textwidth]{open-remote-dialog.png}
\end{center}

\textit{Figure 4-1: Open Remote Dataset Dialog}

2. There are two ways to open a dataset from this dialog:
   
   \begin{itemize}
   \item To open a new dataset, type (or paste) the connection string for the dataset in the \textbf{URL} field. Refer to the beginning of this section for examples and details about the format of the connection string.
   \item If you have previously opened datasets, an arrow appears next to the \textbf{URL} field. Click the arrow and select the dataset from the drop-down list.
   \end{itemize}

3. Click \textbf{OK}. 

\begin{center}
\textbf{Getting Started with ENVI} \\

Opening Image Files in ENVI
\end{center}
4. If a username and password are required to log in to a server, the Connection Authentication dialog appears. See “Connection Authentication” on page 90 for details on logging in.

After you click OK and after authentication is complete (if required), the dataset is displayed and added to the Data Manager in ENVI Zoom or the Available Bands List in ENVI. If you opened an IAS dataset that contains metadata, you can view that metadata as described in “Viewing NITF Metadata from IAS Datasets” on page 90.

**OGC Connection Keywords**

The OGC keywords specify details about what data to open on the server and how to open it. You specify the details by using standard keywords defined by OGC. Separate keywords from their values with =, and separate keyword/value pairs with & (for example, width=500&height=500). ENVI and ENVI Zoom support the following keywords:

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>bbox</strong></td>
<td>The geographic extent (or bounding box) of the dataset. The keyword value enables you to subset the data to open from the server (for example, if the dataset contains data for the whole world and you need only data for Colorado). Enter values in the following order: minx, miny, maxx, maxy. The default is to open the entire dataset. Example: bbox=23.73,37.97,23.752,37.984</td>
</tr>
<tr>
<td><strong>width</strong></td>
<td>The number of samples in the image when it is opened. The default for WCS is to use metadata from the image. The default for WMS is to use the base layer (if there is one) and use the pixel size of the base layer to calculate the width. If a base layer is not available, then width is determined by using the WMS Pixels Per Side preference. A square pixel size is selected, where the greater of the number of samples and lines are equal to the WMS Pixels Per Side value. Example: width=500</td>
</tr>
</tbody>
</table>

*Table 4-2: OGC Connection Keyword Descriptions*
### Chapter 4: Opening and Displaying Files

#### Getting Started with ENVI

### Opening Image Files in ENVI

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>height</td>
<td>The number of lines in the image when it is opened. The default for WCS is to use metadata from the image. The default for WMS is to use the base layer (if there is one) and use the pixel size of the base layer to calculate the height. If a base layer is not available, then height is determined by using the <strong>WMS Pixels Per Side</strong> preference. A square pixel size is selected, where the greater of the number of samples and lines are equal to the <strong>WMS Pixels Per Side</strong> value. Example: <code>height=500</code></td>
</tr>
<tr>
<td>format</td>
<td>The format in which to transmit the data across the Internet. The format must be among the list of formats supported by the OGC server. ENVI and ENVI Zoom support JPEG 2000, JPEG, and TIFF as transmission formats. The default is to first look for JPEG 2000 (lower transmission time). If the server does not support JPEG 2000, then it looks for any supported JPEG format, then any supported TIFF format. If the server does not support the specified format, it returns an error. Example for WMS: <code>format=image/jpeg</code> Example for WCS: <code>format=jpg</code></td>
</tr>
</tbody>
</table>

**WCS-only Keywords**

| coverage    | Required. The name of the dataset. Example: `coverage=srtmplus_raw`                                                                                                                                      |
| crs         | The coordinate reference system of the image. This keyword value must be a string that comes from the list of reference systems supported by the server. Example: `crs=EPSG:4326`                                               |

**WMS-only Keywords**

| layers      | Required. The name of the layer. You can specify multiple, comma-delimited, layers. ENVI and ENVI Zoom allow the server to combine the WMS layers and display them as a single layer. Example: `layers=streets` |

*Table 4-2: OGC Connection Keyword Descriptions (Continued)*
### Opening Image Files in ENVI

#### Getting Started with ENVI

If a username and password are required to log in to a server or geodatabase, the Connection Authentication dialog appears. Perform the following steps:

1. Enter a **Username**.
2. Enter a **Password**. Passwords are displayed as a series of asterisks representing each character you type.
3. Click **OK** in the Connection Authentication dialog to attempt a connection using the specified login information. If the connection fails, an error message appears and the Connection Authentication dialog remains open so that you can reenter the login information.

**Note**

Your username and password are retained for as long as the server or dataset is open.

### Viewing NITF Metadata from IAS Datasets

NITF metadata are only present for datasets on IAS servers that are in NITF format or that were converted from NITF to JPEG2000. To view NITF metadata from an IAS dataset:

1. Open the dataset using **File → Open Remote Dataset** (ENVI Zoom) or **File → Remote Connection Manager** (ENVI).

#### Table 4-2: OGC Connection Keyword Descriptions (Continued)

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>srs</code></td>
<td>The spatial reference system of the image. This value must be a string that comes from the list of reference systems supported by the server. Example: <code>crs=EPSG:4326</code></td>
</tr>
<tr>
<td><code>style</code></td>
<td>The display style from the server-supported style list. This specifies how to display certain features, if used (for example, display a 2-pixel yellow line for roads). Example: <code>style=visual</code></td>
</tr>
</tbody>
</table>
Chapter 4: Opening and Displaying Files

2. In the Data Manager (ENVI Zoom) or Available Bands List (ENVI), right-click on the image name and select **View NITF Metadata**. The NITF Metadata Viewer dialog appears.

   If the NITF preference **Automatically View Metadata** in ENVI Zoom is set to **True**, the metadata are automatically displayed.

   When you save an IAS dataset to NITF format, the NITF metadata are passed to the NITF output file, using the same rules as inheriting NITF metadata in the NITF/NSIF Module. See **Saving NITF Files** in the *NITF/NSIF Module User’s Guide* for details.

   **Note**

   To stream and view NITF imagery and metadata from IAS servers, you must have a NITF/NSIF Module license.

### Using the Remote Connection Manager

Use the Remote Connection Manager dialog to connect to geodatabases and servers, to add a connection to a list of frequently visited servers, and to manage connection properties. If accessing datasets on a WMS server, you can also use this dialog to combine two or more datasets into one displayable map layer.

To open a remote dataset from the Remote Connection Manager dialog:

1. Select **File → Remote Connection Manager** from the ENVI Zoom menu bar or **Window → Remote Connection Manager** from the ENVI main menu bar. The Remote Connection Manager dialog appears (see **Figure 4-2**).
2. There are two ways to connect to a server or geodatabase from this dialog.

   • The dialog is initially empty. Click **Connection**, then select **New** and see the steps in “Managing Connection Properties” on page 96 to create a new connection.

   • If you have a commonly used connection that you have saved as a favorite, click **Favorites**, then select the server name from the menu. To add favorites to the Favorites list, see “Managing Favorites” on page 98.

   **Note**
   
   Connection may be slow.

The icons that appear in the Remote Connection Manager dialog differ depending on the connection type, to help you easily distinguish among the four types.
3. Select the server or geodatabase from the Connection List. The list of available datasets appears in the Dataset List with icons that indicate the dataset type:

Select the dataset to open from the Dataset List. The properties for the selected dataset appear in the Properties List. If needed, you can edit some of the properties before opening the dataset, as described in “Editing Properties” on page 95.

Note
For OGC datasets only: if ENVI Zoom does not support one of the formats under the Supported Formats drop-down list (in the Properties List), you cannot open the dataset. You can view all of the dataset properties, but the Open button is disabled.

Additionally, some IAS datasets cannot be opened. When you select an IAS dataset from the Dataset List that cannot be opened, the properties do not display in the Properties List, and the Open button is disabled.

4. If you want to combine multiple datasets on a WMS server and open them as one map layer, select additional datasets from the Dataset List. You can multi-select datasets by pressing the Ctrl or Shift key as you select files.
5. Click **Open**. If ENVI and ENVI Zoom are both running from the same IDL session, the dataset is opened in both applications. Refer to the following if you are only running one application:

**ENVI:**
Raster datasets are added to the Available Bands List. Vector datasets are added to the Available Vectors List. You cannot use the Edit Header dialog to change header values for datasets on a server or in a geodatabase, and you cannot use ENVI’s vector tools to edit a vector layer originating from a geodatabase. If you opened an IAS dataset that contains NITF metadata, you can view that metadata as described in “Viewing NITF Metadata from IAS Datasets” on page 90.

**ENVI Zoom:**
The dataset may be automatically displayed and added to the Layer Manager, depending on your display preferences. (See “Display General Preferences” on page 141.) If you opened multiple WMS datasets as one displayable map layer, the Layer name in ENVI Zoom is a combination of all selected dataset names. If you opened an IAS dataset that contains metadata, you can view that metadata as described in “Viewing NITF Metadata from IAS Datasets” on page 90. You cannot use ENVI Zoom’s vector tools to edit a vector layer originating from a geodatabase.

6. If you have connected to a geodatabase and datasets are added to or removed from the geodatabase while you are working in ENVI Zoom, you can refresh the Remote Connection Manager to see the updates. In the Remote Connection Manager, **Connection** and select **Refresh**, or right-click on a geodatabase name in the Connection List and select **Refresh**. The Dataset List updates to show the changes.
Editing Properties

Edits you make to dataset properties apply to the current dataset only. The properties you can edit depend on the server type. The following describes the properties you can edit:

Geodatabases  You cannot edit properties in personal, file, or enterprise geodatabases.

IAS  All properties from IAS servers are read-only. Raw JPIP servers cannot display properties. The JPEG 2000 compression properties that are always available for viewing are Number of Layers, Number of Components, Number of Discard Levels, Progression, Number of Tiles, Bit Depth, and flags to indicate if the data are reversibly compressed, YCC rotated, or signed.
- If XML boxes or UUID boxes are present in the dataset, you can select from their respective drop-down lists to view them in a separate window.
- If NITF metadata is present in one of the XML boxes, the NITF metadata is imported if the file is opened, but only the XML data are accessible in the Remote Connection Manager dialog’s Properties List.
- If a GeoJP2 style UUID box is present, the map information is extracted and the following fields are added to the properties listing: Projection, Top Boundary, Left Boundary, X Pixel Size, and Y Pixel Size.

WCS  The WCS properties you can edit are Formats, Coordinate System, Boundary (Top, Bottom, Left, and Right), Interpolation Type, and Pixel Size (X and Y).
- Formats, Coordinate System, and Interpolation Type are drop-down lists containing the values provided by the server. Select the value from the drop-down list.
- Boundary and Pixel Size values are derived from the coverage data. You can manually edit these values to customize the geographic extent and resolution of the dataset to open.
Chapter 4: Opening and Displaying Files

Opening Image Files in ENVI

Managing Connection Properties

The Connection Properties dialog lets you enter connection information for a new connection or edit the name of an existing connection.

1. Choose one of the following:
   • To enter properties for a new connection, click **Connection** in the Remote Connection Manager and select **New**. The Connection Properties dialog appears. The fields are initially blank.
   • To edit the name of an existing connection, select the connection you want to edit. Click **Connection** and select **Properties**. Or, right-click on a server name in the Connection List and select **Properties**. The Connection Properties dialog appears. The fields are populated with the properties of that connection. You can only edit the connection name.

2. The **URL** field is optional and provides a convenient place for you to specify a path or connection details in a single string.
Chapter 4: Opening and Displaying Files

If you press Enter or move to another field in the dialog, the remaining fields are automatically populated from the information in the URL. You can edit the fields described in Steps 3-8 if necessary. Or, click OK after entering a URL to connect as described in Step 9.

Following are examples of URLs:

**IAS**

jpip://exampleserver:1234/

**OGC WCS**

http://exampleserver:1234/cgi-bin/mapserv.exe?
map=/ogc_data/wcs_test.map&service=wcs

**OGC WMS**

http://exampleserver:1234/cgi-bin/mapserv.exe?
map=/ogc_data/wms_test.map&service=wms

**Enterprise geodatabase**

exampleserver:5151

3. In the Name field, enter a custom name for the connection to help you recognize it in the Connection List. The default value is the name of the connection.

4. From the Type drop-down list, select from the available list of data sources. If you are editing existing connection properties, you cannot modify the selection. The choices are File Based Geodatabase, Personal Geodatabase, Enterprise (SDE) Geodatabase, OGC Web Coverage Service (WCS), OGC Web Map Service (WMS), and IAS Service. The list of available choices depends on your platform. Refer to the Installation and Licensing Guide for supported platforms. This guide is available from the ITT Visual Information Solutions web site or from the ENVI Tutorial Data DVD that shipped with your software.

5. Enter the Connection name you want to connect to.

6. Enter the Port number.

7. If the connection type is OGC, enter a required CGI Path for querying OGC connections.

8. If the connection type is OGC, you can enter an optional Prefix for querying OGC connections. This is a configuration string that is required to access the correct datasets on the server.

9. To open a file or personal geodatabase, select File Based Geodatabase or Personal Geodatabase from the Type drop-down list. Click the Open button.
The Browse for Folder dialog appears. Select a geodatabase from your computer, and click OK. The Path field in the Connection Properties dialog is populated with the path and filename of the geodatabase.

10. Click OK in the Connection Properties dialog. ENVI or ENVI Zoom confirms the information you entered is valid and returns you to the Remote Connection Manager dialog. You may be prompted for a username and password if they are required. See “Connection Authentication” on page 90 for details. If the connection does not respond or any of the connection information is invalid, an error message appears and the Connection Properties dialog remains open so that you can reenter the properties.

If you are connecting to an enterprise server and your database version string is not set to sde.DEFAULT, the Connection Details dialog appears. Select a transactional version from the Version Name list, or specify the details for a historical version. See “Creating Spatial Database Connections” in ArcGIS® Desktop Help for details.

The new or edited connection becomes the active connection in the Remote Connection Manager dialog, and ENVI or ENVI Zoom queries that connection for available datasets and displays them in the Dataset List.

Managing Favorites

You can add commonly used connections to a list of favorites, so that you can easily open those connections in the future.

**Note**

The Favorites menu option is disabled for connections that require a password.

1. In the Remote Connection Manager dialog, select the connection name from the Connection List.
2. Select one of the following:
   - Right-click on the connection name and select **Add to Favorites**.
   - Click **Favorites** and select **Add to Favorites**.
   The Add to Favorites dialog appears.
3. Do any of the following:
   - In the Name field, enter a custom name for the connection to help you recognize it in the Favorites List.
Chapter 4: Opening and Displaying Files

- If one or more folders exist in the Favorites List, select the folder into which to add the new favorite.

4. Click **OK**. The name is added to the Favorites List, which appears in the Remote Connection Manager dialog **Favorites** menu.

You can manage your Favorites List by creating folders in which to group favorites, by reordering favorites, and by deleting or renaming favorites. To manage favorites, click **Favorites** and select **Manage** to open the Favorites Manager dialog. This dialog contains the Favorites List.

- To create a new folder, right-click and select **New Folder**. The Enter Name dialog appears. Type a **Name** for the new folder and click **OK**. The new folder appears in the Favorites List.

- To reorder the Favorites List, or to move favorites to a folder, select the name from the Favorites List, then drag and drop the name to a new location.

- To rename a favorite or folder, right-click on the name in the Favorites List and select **Rename**. The Enter Name dialog appears. Type a new **Name** and click **OK**. The new name appears in the Favorites List.

- To delete a favorite or folder, right-click on the name and select **Delete**. The name is removed from the Favorites List. Deleting a folder deletes all of the connections and subfolders associated with it.

You can share your favorites with another user, but the operating systems and bit architecture (32-bit or 64-bit) must be the same. To share your favorites, give your user a copy of the ENVI Zoom preference file, `envizoom_prefs.sav`, which is in the following directory:

**Windows:**
Documents and Settings\username\.idl\itt\components-37-x_x-osname-bits\

**Unix and Linux:**
/home/username/.idl/itt/components-37-x_x-osname-bits/

Where `x_x` is the ENVI version number, `osname` is the operating system you are running, and `bits` is 32 or 64.

Your users should save this file to the `components-37-x_x-osname-bits` directory on their computer and restart ENVI Zoom. The next time the user clicks **Favorites** in the Remote Connection Manager, the favorites will be available.
Note

Copying a .sav file over an existing .sav file overwrites all ENVI Zoom preference settings or favorites that were previously set.

When you are finished working with the Favorites Manager dialog, click OK to close the dialog. To access a favorite connection, click Favorites and select the connection name.
Opening External Image Files in ENVI

While you can use the **Open Image File** and **New File** options (described in “Opening Image Files in ENVI” on page 82) to open most file types, it is often more convenient to use internal or external header information for specific known file types. Use the **Open External File** option to read several standard file types including formats for selected sensors, military formats, digital elevations model (DEM) formats, image processing software formats, and generic image formats. ENVI reads the necessary parameters from internal headers and it is usually not necessary for you to enter any information in the Header Information dialog.

For a list of ENVI’s supported input files, see “ENVI Supported Input File Formats” on page 33.

1. From the ENVI main menu bar, select **File → Open External File → file_type → file_format**.
   
   where:
   
   - *file_type* is the type of external file (for example, **Landsat**)
   - *file_format* is the format of the external file (for example, **HDF**)

   The Enter *file_type* Filenames dialog appears.

2. Select a file to open.

3. Click **Open**. ENVI automatically extracts the necessary header information, including the associated georeferencing information, and places the filename and bands in the Available Bands List.

Each file type and the associated file format options available from **File → Open External File** is discussed in detail in **Opening External Files** in the **ENVI User’s Guide**.
Opening Previously Opened Files

Use the previous files list to open a file from a list of the 25 most recently opened files in ENVI. When you open a new file, ENVI adds it to the top of the previous files list. When the list exceeds 25 filenames, ENVI removes the file at the bottom of the list. You can optionally stipulate that certain files always remain on the previous files list and always appear at the top of the list (see Previous Files List Preference Settings in the ENVI User’s Guide).

1. Open the previous files list with either of the following:
   • From the ENVI main menu bar, select File → Open Previous File.
   • From any Input File dialog, click Open and select Previous File.

2. Select the desired filename. ENVI adds the filename and bands to the Available Bands List.
Opening Vector Files

You can open vector files in ENVI in several ways. Vector files may be available in any of the following formats:

- ArcInfo® Interchange (*.e00)
- Shapefiles (*.shp)
- DXF vector files (*.dxf)
- ENVI vector files (*.evf)
- MapInfo Interchange format (*.mić)
- Microstation DGN (*.dgn)
- USGS DLG files (*.ddf, *.dlg)
- USGS SDTS files (*.dlg)
- ENVI vector files (*.evf)
- ArcInfo® Interchange format (*.mić)
- Microstation DGN (*.dgn)
- USGS DLG files (*.ddf, *.dlg)
- USGS SDTS files (*.dlg)

You may load as many vector layers as desired, but each file should contain one vector layer only.

1. Use one of the following:
   - From the ENVI main menu bar, select File → Open Vector File.
   - From the ENVI main menu bar, select Vector → Open Vector File.
   - From any Input File dialog, click Open and select EVF File.
   
   The Select Vector Filenames dialog appears.

2. In the Files of type drop-down list, select All Files (*).

3. Select one or more vector filenames and click Open. Either of the following occurs:
   - If you selected an internal vector file, ENVI adds the layers to the Available Vectors List.
   - If you selected an external vector file, the Import Vector Files Parameter dialog appears. This dialog enables you to open multiple vector files of different file types.
Chapter 4: Opening and Displaying Files

Opening Vector Files

Getting Started with ENVI

The **Selected Input Files** field lists the vector filenames. Select a filename, and the **Layer Name** and **Native File Projection** areas update with the information for that file. Because ENVI vector files (.evf) already contain layer name and map projection information, these dialog options are inactive.
4. To load another file, click **Input Additional Files**. The Select Vector Filenames dialog appears; choose one or more files of any vector type to open.

5. To send all of the non-EVF vector files to memory, click **Output to Memory for All**. Click **OK**, and the files are listed in the Available Vectors List. EVF files are native to ENVI and do not require conversion to file or memory.

6. To apply the current map projection parameters to all files in the list with unknown projections, click **Apply Projection to Undefined**. Unknown projections are listed as Arbitrary in the map projections list box of the dialog.

   **Note**
   Files listed with known projections are not converted to the current map projection when you click **Apply Projection to Undefined**.

7. Click **OK** to start the specified conversions. When the conversions are complete, ENVI adds the vector layers to the Available Vectors List.
Opening Spectral Library Files

To open a spectral library to use for processing:

1. From any Input File dialog, click **Open** and select **Spectral Library**. The Input File dialog appears.

2. Select the desired spectral library.

3. Click **Open**. The Input File dialog re-appears, and ENVI lists the Spectral Library file in the Input File dialog **Select Input File List**, and also in the Available Bands List.
Displaying Images

Use the Available Bands List to access the files and the individual bands of each file that you have open during the current session. From the Available Bands List you can display gray scale and color images and view meta file components and displayed band information.

If the image header file contains default bands to load, you do not need to use the Available Bands List to initiate a display; ENVI automatically loads the image into a display group when you open the file (see Editing ENVI Headers in the ENVI User’s Guide).

The options you see in the Available Bands List vary, depending upon whether you want to display an image in gray scale, or in RGB color.

Figure 4-4: Available Bands List Gray Scale Band option (right) and RGB Bands option (left)

If the Available Bands List is hidden, bring it to the front of other open ENVI windows by selecting Window → Available Bands List from the ENVI main menu bar.
When there are no open display groups, the button at the bottom of the Available Bands List reads No Display. When one or more display groups are open, the button at the bottom of the Available Bands List reads Display #n, where n is the number corresponding to the number in a display group title bar.

The first image you load automatically appears in a new window. When loading subsequent images, you can load them into an existing display group, or you can load them into a new display group. The selected display is called the active display group.

If RRDS files are available for a given image, ENVI uses these to display the image in the display group. See “Reduced Resolution Data Sets” on page 48 for more information.

**Displaying Gray Scale Images**

To display a gray scale image:

1. In the Available Bands List, select the Gray Scale radio button.
2. If no display groups are open, proceed to the next step. If one or more display groups are open, select where to display the image. Either:
   - Click Display #n and select New Display to open a new, empty display group.
   - Click Display #n and select the desired display group.
3. Select the input band name. The band name appears under the Selected Band area.
4. Click Load Band. ENVI loads the band into the display group.

To display a gray scale band:

1. In the Available Bands List, right-click on the band name.
2. Select either:
   - Load Band to New Display, to load the band to a new display group.
   - Load Band to Current Display, to load the band to the active display group.

**Tip**

You can also load the gray scale image by double-clicking the band name.
Displaying RGB Images

To display an RGB image:

1. In the Available Bands List, select the RGB radio button.
2. If no display groups are open, proceed to the next step. If one or more display groups are open, select where to display the image. Either:
   - Click **Display #n** and select **New Display** to open a new, empty display group.
   - Click **Display #n** and select the desired display group.
3. Select in sequence the red, green, and blue bands to display (or on individual R, G, or B bands using the radio buttons).
4. Click **Load RGB**. ENVI loads the bands into the display group.

**Tip**

You can also load the image by double-clicking the band name you select for the B band.

Displaying True Color or Color Infrared Images

If an input file has wavelengths for each band stored in the header and the file contains bands in the needed wavelength ranges, you can display a true color image or a CIR (color infrared) image from the Available Bands List without having to designate the individual bands for red, green, and blue.

ENVI displays the true-color image band in the red wavelength region (0.6-0.7 μm) in red, the band in the green region (0.5-0.6 μm) in green, and the band in the blue region (0.4-0.5 μm) in blue. ENVI displays the CIR image band in the near-infrared wavelength region (0.76-0.9 μm) in red, the band in the red region in green, and the band in the green region in blue.

If the file does not have bands in the needed wavelengths, ENVI uses the bands nearest to the wavelengths. This may produce a gray scale image if red, green, and blue are set to the same band.

To display a true-color or CIR image:

1. In the Available Bands List, right-click on the filename.
2. Select either:
• **Load True Color** or **Load CIR**, to load the image to a new display group if no display groups are open.
• **Load True Color to <new>** or **Load CIR to <new>**, to load the image to a new display group.

• **Load True Color to <current>** or **Load CIR to <current>**, to load the image to the active display group.

**Displaying Default RGB Combinations**

If the header file has default bands to load (see Editing ENVI Headers in the *ENVI User’s Guide*), you can select to load the default bands through the Available Bands List right-click menu. Typically, ENVI automatically loads default bands when you open the file; however, the menu option is available if you need to load the display again while the file is listed in the Available Bands List.

1. In the Available Bands List, right-click on the filename.

2. Either:
   - Select **Load Default RGB** to load the image to a new display group if no display groups are open.
   - Select **Load Default RGB <new>** to load the image to a new display group.
   - Select **Load Default RGB <current>** to load the image to the active display group.
Displaying Vectors

Use the Available Vectors List to load vectors into a Vector window or to overlay them on a displayed image. You can simultaneously overlay vector layers of different projection types or overlay vector layers that have projection types different than the image. The image or the first vector layer displayed sets the projection type, and all other layers are automatically converted to that projection type.

If the Available Vectors List is hidden, bring it to the front of other open ENVI windows by selecting Window → Available Vectors List from the ENVI main menu bar.

1. In the Available Vectors List, select the layer name. To display all of the layers, click Select All Layers.
2. Click Load Selected.
   • If no display groups or other Vector windows are open, ENVI loads the vector to a new Vector window.
   • If a display group and/or Vector window are open, the Load Vector Layers dialog appears.
3. If the Load Vector Layers dialog appears, select a vector destination display window.
   • If any display groups are open, the display names (for example, Display #1) appear in the list. Select the desired display group to which to plot the vectors and click OK. ENVI overlays the vectors on the displayed image.
   • If any Vector windows are open, the Vector window names (such as, Vector Window #1) appear in the list. Select the desired Vector window to which to plot the vectors and click OK. ENVI adds the vectors to the open Vector window.
   • To plot the vectors in a new Vector window, select New Vector Window and click OK.

Chapter 5
Working with Header Files

This chapter describes how to create and edit ENVI header files. It includes:

- The ENVI Header Format ............... 114
- Creating Header Files ............... 123
- Editing Header Files ............... 127
- ENVI File Type File ............... 128
- ENVI Sensor File ............... 130
The ENVI Header Format

The ENVI header file contains information ENVI uses to read an image data file. ENVI typically creates a header file the first time you access a data file in a format that it does not automatically recognize. You enter the required information in the Header Info dialog, which appears when the file is opened (see “Creating Header Files” on page 123). You can later edit the information using the Edit ENVI Header option (“Editing Header Files” on page 127).

You can also generate an ENVI header outside ENVI using a text editor. The file must start with the text string `ENVI` for ENVI to recognize it as a native file header. Keywords within the file indicate critical file information. You can add comments to the file by inserting a line with a semicolon as the first character. ENVI ignores these lines when parsing the header file. Comments can appear anywhere within a header file, but they must be on their own line, and the semicolon must be the first character of that line. Comments cannot follow a keyword/value pair.

A description of the keywords (in alphabetical order) for an ENVI header file follows. See “Example ENVI Header File” on page 120 for an example header file.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>band names</td>
<td>Allows entry of specific names for each band of an image.</td>
</tr>
<tr>
<td>bands</td>
<td>The number of bands per image file.</td>
</tr>
<tr>
<td>bbl</td>
<td>Lists the bad band multiplier values of each band in an image, typically 0 for bad bands and 1 for good bands.</td>
</tr>
</tbody>
</table>
| byte order  | The order of the bytes in integer, long integer, 64-bit integer, unsigned 64-bit integer, floating point, double precision, and complex data types. Use one of the following:  
  - Byte order=0 (Host (Intel) in the Header Info dialog) is least significant byte first (LSF) data (DEC and MS-DOS systems).  
  - Byte order=1 (Network (IEEE) in the Header Info dialog) is most significant byte first (MSF) data (all other platforms). |
| class lookup| This keyword pertains to classification files. It lists RGB color definitions for each respective class, and class names. |

Table 5-1: Header File Keywords
### Field | Description
--- | ---
class names | This keyword pertains to classification files. It lists the classification names.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>classes</td>
<td>This keyword pertains to classification files. It defines the number of classes, including the unclassified.</td>
</tr>
<tr>
<td>complex function</td>
<td>Specifies the values to calculate from a complex image and to use when displaying the image, calculating statistics for the image, or writing the image to a new file. Values include Real, Imaginary, Power, Magnitude, and Phase. The default value is Phase.</td>
</tr>
</tbody>
</table>

*Table 5-1: Header File Keywords (Continued)*
When you save a georeferenced file to ENVI raster format, ENVI adds a coordinate system string field to the header file. It lists the parameters used for a geographic coordinate system or projected coordinate system. Following are some examples:

A **geographic coordinate system** (for example, Geographic Lat/Lon) string contains the word GEOGCS and lists the coordinate system name, datum, spheroid, prime meridian, and units:

```
coordinate system string =
GEOGCS("GCS_WGS_1984",
DATUM["D_WGS_1984",
SPHEROID["WGS_1984",6378137.0,298.257223563]],
PRIMEM["Greenwich",0.0],
UNIT["Degree",0.0174532925199433]]
```

A **projected coordinate system** string contains the word PROJCS and lists all of the geographic coordinate system parameters, plus detailed parameters that describe the projected coordinate system:

```
coordinate system string =
PROJCS["WGS_1984_South_Georgia_Lambert",
GEOGCS["GCS_WGS_1984",
DATUM["D_WGS_1984",
SPHEROID["WGS_1984",6378137.0,298.257223563]],
PRIMEM["Greenwich",0.0],
UNIT["Degree",0.0174532925199433]],
PROJECTION["Lambert_Conformal_Conic"],
PARAMETER["False_Easting",0.0],
PARAMETER["False_Northing",0.0],
PARAMETER["Central_Meridian",-37.0],
PARAMETER["Standard_Parallel_1",-54.0],
PARAMETER["Standard_Parallel_2",-54.75],
PARAMETER["Latitude_Of_Origin",-55.0],
UNIT["Meter",1.0]]
```

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>coordinate system string</td>
<td>When you save a georeferenced file to ENVI raster format, ENVI adds a coordinate system string field to the header file. It lists the parameters used for a geographic coordinate system or projected coordinate system. Following are some examples:</td>
</tr>
</tbody>
</table>

**Table 5-1: Header File Keywords (Continued)**
### Chapter 5: Working with Header Files

**Getting Started with ENVI**

The ENVI Header Format

---

#### Table 5-1: Header File Keywords (Continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| coordinate system string | Refer to the ITT Visual Information Solutions Tech Tips for a list of predefined geographic and projected coordinate system strings:  
2. In the **Enter Keyword** field, type **projection engine**.  
3. Click **Submit**.  
4. In the search results, open the Tech Tip titled, “ESRI Projection Engine Reference v1.0.” |
| data gain values       | Gain values for each band.                                                                                                                   |
| data ignore value      | Currently used only in ENVI programming (see **ENVI_FILE_QUERY** in the **ENVI Reference Guide** for more information).                     |
| data offset values     | Offset values for each band.                                                                                                                |
| data type              | The type of data representation, where 1=8-bit byte; 2=16-bit signed integer; 3=32-bit signed long integer; 4=32-bit floating point; 5=64-bit double-precision floating point; 6=2x32-bit complex, real-imaginary pair of double precision; 9=2x64-bit double-precision complex, real-imaginary pair of double precision; 12=16-bit unsigned integer; 13=32-bit unsigned long integer; 14=64-bit signed long integer; and 15=64-bit unsigned long integer. |
| default bands          | If set, indicates which band numbers to automatically load into the Available Bands List gray scale or R, G, and B fields every time the file is opened. By default, a new image is automatically loaded when a file that has default bands defined in its header is opened. If only one band number is used, then ENVI loads a gray scale image. |
| default stretch        | Determines what type of stretch (% linear, linear range, Gaussian, equalization, square root) to use when ENVI displays the image. |

---

*Table 5-1: Header File Keywords (Continued)*
### Field | Description
--- | ---
**dem band** | Path and filename of a DEM that you associate with an image.
**dem file** | Index (starting at 1) of a selected DEM band that you associate with an image. The dem band is not written if the DEM file contains a single band, or if the first band of an image was chosen. In these cases, the dem band value defaults to 0. See Editing ENVI File Headers in the ENVI User’s Guide.
**description** | A character string describing the image or the processing performed.
**file type** | The ENVI-defined file type, such as a certain data format and processing result. The available file types are listed in the filetype.txt file (see “ENVI File Type File” on page 128). The file type ASCII string must match an entry in the filetype.txt file verbatim, including case.
**fwhm** | Lists full-width-half-maximum (FWHM) values of each band in an image. Units should be the same as those used for wavelength and set in the wavelength units parameter.
**geo points** | Geographic corners for non-georeferenced files. You can enter between one and four pixel locations and their corresponding latitudes and longitudes. Following is an example:
geo points = (1.0000, 1.0000, 32.89380137, -117.07201460, 1002.0000, 1.0000, 32.87364744, -116.95855862, 1.0000, 1002.0000, 32.80628336, -117.09960891, 1002.0000, 1002.0000, 32.78615422, -116.98625969)
**header offset** | The number of bytes of imbedded header information present in the file (for example, 128 bytes for ERDAS 7.5 .lan files). ENVI skips these bytes when reading the file.
**interleave** | Refers to whether the data are BSQ, BIP, or BIL.
**lines** | The number of lines per image for each band.

*Table 5-1: Header File Keywords (Continued)*
## Chapter 5: Working with Header Files

### The ENVI Header Format

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>map info</td>
<td>Lists geographic coordinates information in the order of projection name (UTM), reference pixel x location (in file coordinates), pixel y, pixel easting, pixel northing, x pixel size, y pixel size, projection zone, North or South (UTM only).</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> - In ENVI, pixel values always refer to the upper-left corner of the pixel. Map coordinates also typically refer to the upper-left corner of the pixel. However, if you entered “magic pixel” coordinates in the ENVI header, the map coordinates would refer to the x,y coordinates entered. For example, x=1.5, y=1.5 would make the map coordinates refer to the center of the pixel.</td>
</tr>
<tr>
<td>pixel size</td>
<td>Indicates x and y pixel size in meters for non-georeferenced files.</td>
</tr>
<tr>
<td>major frame offsets</td>
<td>The number of extra bytes to skip at the beginning and ending of the major frame. See Editing ENVI File Headers in the ENVI User’s Guide.</td>
</tr>
<tr>
<td>minor frame offsets</td>
<td>The number of extra bytes to skip at the beginning and ending of the minor frame. See Editing ENVI File Headers in the ENVI User’s Guide.</td>
</tr>
<tr>
<td>projection info</td>
<td>Describes user-defined projection information. This keyword is added to the ENVI header file if a the file uses a user-defined projection instead of a standard projection. ENVI uses this information to read the file on machines that do not contain this user-defined projection in the map_proj\map_proj.txt file.</td>
</tr>
<tr>
<td>reflectance scale factor</td>
<td>The value that, when divided into your data, would scale it from 0-1 reflectance.</td>
</tr>
<tr>
<td>rpc info</td>
<td>Lists rational polynomial coefficient (RPC) geolocation information if your input file has this associated information. See Editing ENVI File Headers in the ENVI User’s Guide.</td>
</tr>
<tr>
<td>samples</td>
<td>The number of samples (pixels) per image line for each band.</td>
</tr>
</tbody>
</table>

Table 5-1: Header File Keywords (Continued)
Table 5-1: Header File Keywords (Continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sensor type</td>
<td>Instrument types, such as Landsat TM, SPOT, RADARSAT, and so on. The available sensor types are the sensor.txt file described in “ENVI Sensor File” on page 130. The sensor type ASCII string defined here must match one of the entries in the sensor.txt file verbatim, including case.</td>
</tr>
<tr>
<td>spectra names</td>
<td>This keyword pertains to spectral library files only. It contains a comma-separated list of ASCII names enclosed in {curly brackets}.</td>
</tr>
<tr>
<td>wavelength</td>
<td>Lists the center wavelength values of each band in an image. Units should be the same as those used for the fwhm field (described next) and set in the wavelength units parameter.</td>
</tr>
<tr>
<td>wavelength units</td>
<td>Text string indicating the wavelength units.</td>
</tr>
<tr>
<td>x start and y start</td>
<td>Defines the image coordinates for the upper-left hand pixel in the image. Images that are spatial subsets of larger images often use an image coordinate system that references the parent (or larger) image so that you can link and dynamically overlay the two images. The default values are (1,1) so that the upper-left hand pixel has an image coordinate of (1,1). Note - Changing these values does not affect the way ENVI reads the image data from the file.</td>
</tr>
<tr>
<td>z plot average</td>
<td>Values indicate the number of pixels in the x and y directions to average for Z plots.</td>
</tr>
<tr>
<td>z plot range</td>
<td>Values indicating the default minimum and maximum values for Z plots.</td>
</tr>
<tr>
<td>z plot titles</td>
<td>Allows entry of specific x and y axis titles for Z plots.</td>
</tr>
</tbody>
</table>

**Example ENVI Header File**

A typical ENVI header file looks like this:

```
ENVI
description = {
```
samples = 709
lines   = 946
bands   = 7
header offset = 0
file type = ENVI Standard
data type = 1
interleave = bsq
sensor type = Landsat TM
byte order = 0
map info = (UTM, 1, 1, 295380.000, 4763640.000, 30.000000, 30.000000, 13, North)
z plot range = (0.00, 255.00)
z plot titles = (Wavelength, Reflectance)
pixel size = (30.000000, 30.000000)
default stretch = 5.0% linear
band names = {
    Warp (Band 1:rs_tm.img), Warp (Band 2:rs_tm.img), Warp (Band 3:rs_tm.img), Warp (Band 4:rs_tm.img), Warp (Band 5:rs_tm.img),
    Warp (Band 6:rs_tm.img), Warp (Band 7:rs_tm.img)}
wavelength = (0.485000, 0.560000, 0.660000, 0.830000, 1.650000, 11.400000, 2.215000)
fwhm = (0.070000, 0.080000, 0.060000, 0.140000, 0.200000, 2.100000, 0.270000)
Classification results files include the following additional keywords:

```plaintext
classes = 4
class lookup = { 0, 0, 0, 255, 0, 0, 0, 255, 0, 255, 255, 0}
class names = {
    Unclassified,
    region 1,
    region 2,
    region 3}
```

Spectral library files include the following additional keywords:

```plaintext
spectra names = {
    ACTINOLITE IN-4A, ALBITE TS-6A, ALMANDINE GARNET NS-4A, ALUNITE SO-4A,
    AMBLYGONITE P-3A, ANALCIME TS-18A, ANATASE SYNTHETIC O-12A,
    ANDESINE TS-4A, ANGLESITE SO-10A, ANHYDRITE SO-1A, ANORTHITE TS-5A,
    ANTHOPHYLLITE IN-8A, ANTLERITE SO-11A, APATITE P-1A, APHTHITALITE SO-9A}
```
Creating Header Files

When ENVI first opens a file, it requires specific information regarding the file characteristics. If the file is an ENVI format file, the necessary information is contained in a separate text header file, located in the same directory as the image file. The header file uses the same name as the image file, with the file extension `.hdr`. If ENVI locates the header file, it opens the file and adds it to the Available Bands List.

If you open an image file directly from a CD, ENVI saves the header file to the directory designated in the **Alternate Header Directory** preference.

If ENVI cannot find the header file or other valid header information when you open a file, the Header Info dialog appears for you to enter information that creates the header file.

![Figure 5-1: Header Info Dialog](image)

You must enter the required information to create a header file before ENVI can display the image. Some header information is required, while other information is optional. You can import header information an existing header file, or you can enter the information directly in the Header Info dialog.
Required header information is:

- Number of samples or pixels
- Number of lines
- Number of bands
- Offset in bytes from the start of the file to where the data begins
- File type
- Byte order
- Data type
- Storage order

Optional header information includes:

- Default Z Plot range
- Default stretch for display
- Georeferencing information
- Associated wavelengths and associated FWHM (full-width-half-maximum) values
- Sensor type
- Band names
- Bad bands

**Importing Header Information from Other Files**

To import header information from one file into the header of the current file:

1. In the Header Info dialog menu bar, click **Input Header Info From** and select **Other File**. The Select File for Header Input dialog appears.
2. Select the file containing the header information.
3. Click **OK**. The Header Info dialog re-appears.
4. Click **OK**. ENVI adds the header information to the file. If the image file was open in a display group, ENVI closes that display group. Re-open the image from the Available Bands List.
Entering Required Header Information

Use caution when setting the required header parameters for files not in the ENVI file format. For example, changing the data type of an image in HDF format does not affect the data type of the displayed or returned data; the HDF format overrides any settings you add or change. To change the data type of an HDF image, first save the data to an ENVI file (see “Saving as Standard ENVI Files” on page 168), then change the data type. This is also true for many external format files opened in ENVI.

In the Header Info dialog, set the following required parameters, which are described in the table for “The ENVI Header Format” on page 114:

- **Samples**: See samples.
- **Lines**: See lines.
- **Bands**: See bands.
- **Offset**: See header offset.
- **File Type**: See file type.
- **xstart/ystart**: See x start and y start.
- **Data Type**: See data type.
- **Byte Order**: See byte order.
- **Interleave**: See interleave.

Use the text field at the bottom of the dialog to describe the data file (see description).

Entering Optional Header Information

ENVI headers may have associated ancillary information (band names, spectral library names, wavelengths, bad bands list, FWHM) depending on the image data type.
In the Header Info dialog, click **Edit Attributes** and select the desired option to edit optional header information. For more information on editing optional header information, see **Entering Optional Header Information** in the *ENVI User’s Guide*.

**Figure 5-2: Header Info Dialog – Edit Attributes Options**
Chapter 5: Working with Header Files

Editing Header Files

1. Open the header file with one of the following:
   - From the ENVI main menu bar, select File → Edit ENVI Header, select the image filename from the Edit Header Input File dialog, then click OK. The Header Info dialog appears.
   - From the Available Files List, right-click on the filename and select Edit Header. The Header Info dialog appears.

2. Modify required header information as described in “Entering Required Header Information” on page 125. Modify optional header information as described in Entering Optional Header Information in the ENVI User’s Guide.

3. When the edits are complete, click OK in the Header Info dialog.

   **Note**
   
   If you edit the header of a file that is currently open, ENVI closes that file and re-opens it when you click OK in the Header Info dialog. Because the display groups using that file close when the file closes, you must restart those displays from the Available Bands List.
ENVI File Type File

The `menu\filetype.txt` is an ASCII file that specifies the file types available in the Header Info dialog File Type drop-down list. Using the File Type field in the Header Info dialog allows image files to have an ENVI header, but still exist in their native formats. The file types include ENVI-specific files such as meta files, classification results, virtual mosaics, spectral libraries, and FFT results. The file types also include data-specific formats such as ADRG and AVHRR, TIFF, BMP, ERDAS 8.x, and PCI files.

You can edit the `filetype.txt` file and add your own, user-defined file types. The first (bracketed) entry contains the full file type name, the second entry contains an abbreviated name to use in the Header Info dialog, and the third entry contains the name of the routine used to read the data (see Creating Custom File Input in the ENVI Programmer’s Guide).

The following is the default `filetype.txt` file included in your ENVI installation.

```
{ACRES CEOS} {ACRES CEOS} {envi_acres_read_ceos}
{ADRG} {ADRG} {envi_read_adrg}
{AVHRR CD} {AVHRR} {envi_read_avhrr}
{BMP} {BMP} {envi_read_bmp}
{CEOS Generic} {CEOS} {envi_read_ceos}
{COSMO-SkyMed} {COSMO-SkyMed} {envi_read_cosmoskymed}
{ECW} {ECW} {envi_read_ecw}
{ENVI} {ENVI} {envi_read_envisat}
{ERDAS 8.X} {ERDAS 8.X} {envi_read_erdas}
{ERDAS IMAGINE} {ERDAS IMAGINE} {envi_read_erdas}
{ESA Landsat TM} {ESA TM} {envi_read_esa_tm}
{ESA SHARP} {ESA SHARP} {envi_read_esa_sharp}
{ESRI GRID} {ESRI GRID} {envi_read_grid}
{HDF EOS ASTER} {HDF ASTER} {envi_read_aster}
{HDF EOS MODIS} {HDF MODIS} {envi_read_modis}
{HDF Landsat} {HDF Landsat} {envi_read_landsat_hdf}
{HDF Modis Simulator} {HDF MAS-50} {envi_read_mas50}
{HDF Scientific Data} {HDF SD} {envi_read_hdf_sd}
{HDF SeaWiFS} {HDF SeaWiFS} {envi_read_seawifs_hdf}
{JPEG2000} {JPEG2000} {envi_read_jpeg2000}
{KOMPSAT-2} {KOMPSAT-2} {envi_read_kompasat2}
{Landsat} {Landsat} {envi_read_landsat}
{Landsat} {Landsat} {envi_read_landsat_hdf}
{NITF} {NITF} {envi_read_nitf}
{NLAPS CD} {NLAPS} {envi_read_nlaps}
{NOAA DMSP} {NOAA DMSP} {envi_read_dmsp}
{PCI} {PCI} {envi_read_pci}
{PDS Image} {PDS Image} {envi_read_pds}
{RADARSAT} {RADARSAT} {envi_read_radarsat}
{RapidEye} {RapidEye} {envi_read_rapideye}
```
Chapter 5: Working with Header Files

{SPOT CD} (SPOT) { envi_read_spot }
(TIFF) (TIFF) { envi_read_tiff }
{Tiled QuickBird} (Tiled QB) { envi_mosaic_tiled_qb_product }
{Tiled WorldView} (Tiled WV) { envi_mosaic_tiled_wv_product }
{TFRD} (TFRD) { envi_read_tfrd }
(Zoom) (ENVI Zoom) { envi_read_zoom }
This menu\sensor.txt file is an ASCII file that lists sensor types that you can select in the sensor parameter in an ENVI header. You can modify or add new sensors to the list using any text editor. The sensor list is shown here:

AATSR
ADAR
ADEOS
ADRG
Air Photo
AIRSAR
AISA
ALOS
ASAR
ASTER
AVHRR
AVIRIS
CARTOSAT-1
CASI
COSMO-SkyMed
DMSP
QuickBird
EROS
ERS
FORMOSAT-2
GER63
GeoEye-1
GEOSCAN
HYDICE
HyMap
Hyperion
IKONOS
IRS LISSIII
IRS Pan
IRS WIFS
JERS-1
KOMPSAT-2
Landsat ETM
Landsat MSS
Landsat TM
MAS
MASTER
MERIS
MIVIS
MODIS
MOMS-02
OrbView-3
RADARSAT-1
RADARSAT-2
RapidEye
Scanned Image
SEAWIFS
SEBASS
SIR-C
SPIN-2
SPOT
TIMS
TMS
TRWIS III
USGS DEM
WorldView
X-SAR

Sensor types specified in the header file must match an entry in this list verbatim, including case.
# Chapter 6

## Common Tools and Functions in ENVI

This chapter describes how to work with the basic components of ENVI. It includes:

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working with ENVI Dialogs</td>
<td>134</td>
</tr>
<tr>
<td>Selecting Bands or Files for Processing</td>
<td>143</td>
</tr>
<tr>
<td>ENVI Processing Status Window</td>
<td>147</td>
</tr>
<tr>
<td>Showing Display Group Information</td>
<td>148</td>
</tr>
<tr>
<td>Displaying Pixel Location</td>
<td>149</td>
</tr>
<tr>
<td>Displaying Cursor Location/Value</td>
<td>151</td>
</tr>
<tr>
<td>Collecting Points</td>
<td>154</td>
</tr>
<tr>
<td>Linking Display Groups</td>
<td>155</td>
</tr>
<tr>
<td>Using Dynamic Overlays</td>
<td>156</td>
</tr>
<tr>
<td>Annotating Displays</td>
<td>157</td>
</tr>
<tr>
<td>Defining Regions of Interest</td>
<td>159</td>
</tr>
<tr>
<td>Using the Available Files List</td>
<td>162</td>
</tr>
</tbody>
</table>
Working with ENVI Dialogs

This section describes common options and functions in ENVI dialogs, as well as some common dialogs you may encounter when using ENVI.

ENVI Dialog Components

The following components are mentioned in procedures throughout the ENVI documentation:

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Choose" /></td>
<td>Button. Click to access another dialog.</td>
</tr>
<tr>
<td><img src="image" alt="Open" /></td>
<td>Drop-down button. Click and select the desired option from the resulting menu.</td>
</tr>
<tr>
<td><img src="image" alt="Output Result to" /></td>
<td>Radio button. Click on the desired option. You may select only one option at a time.</td>
</tr>
<tr>
<td><img src="image" alt="Drop-down List" /></td>
<td>Drop-down list. Click the arrow to open a list and select from multiple choices.</td>
</tr>
<tr>
<td><img src="image" alt="Sliders" /></td>
<td>Sliders. Slide the bar back or forth, or click on either arrow, to set the value from a continuous range of possible values.</td>
</tr>
<tr>
<td><img src="image" alt="Field" /></td>
<td>Field. Type the desired value. In some cases, such as file or directory selection, a Choose button accompanies the field. You can optionally click Choose, navigate to the desired file or directory, and select the value to populate the field.</td>
</tr>
</tbody>
</table>

Table 6-1: Basic Dialog Component Descriptions
Increase/decrease buttons. Click on either arrow to increase or decrease the value. Increase/decrease buttons typically include a field into which you can optionally type the value.

Toggle buttons. Click the button to alternate between two choices and select the desired value.

Color button. Left-click on the color button to cycle forward through the color choices, middle-click to cycle backward through the color choices, or right-click and select a color from the resulting menu.

Check box. Select (or clear) one or more check boxes as needed to enable (or disable) one or more options. In some ENVI dialogs, selecting a check box causes additional fields to appear on the dialog.

Some ENVI menus provide options that you can toggle between. Select one item from a menu as needed to enable an option; a check mark appears next to the selected item. You may enable only one option at a time.

Table 6-1: Basic Dialog Component Descriptions (Continued)
The Input File Dialog

Before you apply any of ENVI’s processing capabilities to a specific data set, you must first select the file containing the data to process. Nearly every ENVI image processing function displays a standard Input File dialog. From the Input File dialog, you can select an input file or a single band for processing, perform spatial or spectral subsetting, and, in some cases, mask the input data. When file selection is complete, ENVI proceeds with processing or prompts you for additional settings.

The title of the Input File dialog changes to reflect the function you select. For example, Figure 6-1 shows Global Spatial Statistics Input File in the title bar, whereas the Input File dialog for stretching data would show Data Stretch Input File in the title bar.

The dialog options vary depending on whether you choose to select input by a file (Figure 6-1), or by the bands within the file (Figure 6-2).

![Figure 6-1: Input Selection by File]

Title varies by selected function
Details about how to use the Input File dialog are in “Selecting Bands or Files for Processing” on page 143.
Selecting Multiple Items in Lists

Some ENVI dialogs contain lists from which you select a filename or option. In some of those lists you can select more than one item, either consecutively or randomly.

![Image of ENVI dialog](image.png)

Figure 6-3: Selecting Individual and Multiple Items in a Dialog

Selecting Items

To select multiple files that are listed consecutively, do one of the following:

- Select the first file in the group, press and hold the **Shift** key, and select the last file in the group.
- Left-click and hold the button down, and drag the cursor over the group of items. The items are selected when they are highlighted.
- If the dialog you are working in has a **Select All Items** button, click the button to select all of the items in the list.

To select multiple files that are not listed consecutively, press and hold the **Ctrl** key on your keyboard and select each desired file.
De-Selecting Items

To de-select a single item, hold the **Ctrl** key down and click on the item.

To de-select multiple items, click on a single item to de-select all items except the one you just clicked on.

If the dialog you are working in has a **Clear All Items** or **Clear** or **Deselect** button, click it to de-select all of the items in the list.

Selecting Output to File or Memory

For most functions, ENVI offers the option of either writing image processing results to a **File** or to **Memory**. If your machine has a large amount of random access memory (RAM), it can efficiently process images without repeatedly having to store intermediate processing results in disk files, which makes storing results in memory feasible.

Saving an image to memory saves it in your computer’s system memory and adds the file to the Available Bands List or the Available Vectors List for later display. When you close ENVI, the image is deleted. Saving an image to a file saves the image to your computer’s hard drive, and adds it to the Available Bands List or the Available Vectors List for later display. When you close ENVI, the file is retained on your machine for reuse in future ENVI sessions.

![Output Result to File or Memory](image)

*Figure 6-4: File or Memory Output Option*
To select the output type:

1. In any dialog where you have the option to specify output, select either:
   - File
   - Memory

2. If you select File, either:
   - Type the output filename in the Enter Output Filename field.
   - Click Choose to select an output filename.

Queuing ENVI Processes

Some ENVI dialogs include a Queue button, which enables you to prepare multiple functions in advance for processing, but queue them for processing at a later time. Queueing functions are useful when their processing time is lengthy.

**Note**

Results from one queued function (procedure) cannot be used as input into another function.

When queuing is available in a dialog:

1. Set all dialog parameters as needed.
2. Select output to File and enter a filename.
3. Click Queue instead of clicking OK. This places the function in the ENVI Queue Manager.
4. When you are ready to process that function, either on its own or with other queued functions, start it from the ENVI Queue Manager, described next.

![Queue Button](image)

*Figure 6-5: Queue Button*

To process queued functions:

1. Ensure that all of the files needed to run the queued functions are open and listed in the Available Bands List.
2. From the ENVI main menu bar, select **File → ENVI Queue Manager**. The ENVI Queue Manager dialog displays, with a list of all queued functions.

![ENVI Queue Manager Dialog](image)

**Figure 6-6: ENVI Queue Manager Dialog**

3. In the **Queued Procedures List**, select one or more procedures to run. To select all of the procedures, click **Select All**.

   To view information about a procedure in the **Procedure Information** field, click on the procedure name.

4. Click **Execute Selected**. ENVI removes the names from the list and processes the functions. The resulting filenames appear in the Available Bands List.

**Compressing Output**

Some ENVI dialogs include a **Compress** check box. When you select the check box, it prompts ENVI to compress your output. This check box is only available in functions that output files sequentially. ENVI applies a lossless GZIP format compression to the output file. When you open a compressed file, ENVI reads the file and un-compresses it on-the-fly.
Note

Compressed files are slower to output and input than un-compressed files.

Be aware that ENVI cannot read compressed files that are larger than 2 GB. If you compress a large file and it remains larger than 2 GB when compressed, you cannot read it with ENVI.

To compress an output a file, select the Compress check box if it is available in the dialog, then click OK.

Closing Dialog Windows

Dialogs in ENVI include a Cancel option, which closes the dialog. On some ENVI dialogs, this option is accessible from the menu bar of the dialog by selecting File → Cancel, while on other dialogs you can click a Cancel button at the bottom of the dialog.

When you select the Cancel option, ENVI closes the active dialog and does not save or process any of the settings you chose during the time the dialog was open.

Figure 6-7: Cancel Option from the File Menu (left) and as a Dialog Button (right)
Selecting Bands or Files for Processing

1. From any ENVI menu, select the tool you want to use. The Input File dialog appears (see “The Input File Dialog” on page 136).

2. Click the Select By toggle button to select File or Band input.

3. Select the desired file or band name from the Select Input File or Select Input Band column.

   If the Select By area is set to File, you can optionally subset the input by clicking Spatial Subset or Spectral Subset and using the standard subsetting procedures (see “Selecting a Spatial Subset” on page 143 or “Selecting a Spectral Subset” on page 145).

4. To start the selected function, without selecting any subsetting, either:

   • Double-click on the selected file or band name.

   • Click OK.

Selecting a Spatial Subset

Use spatial subsetting to limit applying a function to a spatial subset of the image. For subsetting by spectral bands instead of by spatial regions, see “Selecting a Spectral Subset” on page 145. You can select spatial subsets by using the following methods:

• Entering samples and line values.

• Selecting interactively from the image.

• Entering map coordinates.

• Using the same spatial subset that was previously used on another file.

• Using the image shown in the meta scroll window.

• Using the bounding box around a region of interest.
The options in the Spatial Subset dialog vary depending on whether the current data are sample-line-based or georeferenced. Additionally, if the same image is open in more than one display group, you can specify which display number to apply the subset to.

See the following topics in ENVI Help for detailed information:

- Subsetting by Samples/Lines
- Subsetting by Images
- Subsetting by Map Coordinates
- Subsetting Using Another File’s Subset
- Subsetting Using ROIs
- Subsetting by Scroll Window
Chapter 6: Common Tools and Functions in ENVI

145

Selecting Bands or Files for Processing

Selecting a Spectral Subset

Use spectral subsetting to limit application of a function to selected bands of an image. For subsetting by spatial regions instead of spectral bands, see “Selecting a Spatial Subset” on page 143.

![File Spectral Subset Dialog](image)

Figure 6-9: File Spectral Subset Dialog

See the following topics in ENVI Help for detailed information:

- Subsetting by Bands
- Subsetting Using Previous Subsets
- Subsetting by Ranges
- Subsetting from an ASCII File

Selecting a Mask

Certain ENVI functions allow spatial masking before processing. These functions include:

- Statistics
- Classification
- Un-mixing
- Matched filtering
- Continuum removal
- Spectral feature fitting

When you select a file to process, you can apply a previously defined spatial mask. When you use a mask, ENVI does not apply the selected function to the masked portion of the image. You can build a spatial mask from data ranges, regions of interest (ROIs), and other types of input.

See the following topics in ENVI Help for detailed information:
- Building Masks
- Masking Options
- Masking
ENVI Processing Status Window

Most ENVI functions report the processing status in a window as calculations proceed. The status window appears immediately after processing begins. The status window shows:

- The function being processed in the title bar.
- Whether the results are being placed in memory or in an output file.
- A percent complete progress bar, which updates as ENVI processes data.
- The size of each data increment processed, based on the tile size (see “Image Tile Size” on page 1161). The function automatically determines the size of the processing increment.

Use the Cancel button to terminate processing if the increment is less than 100%. If the increment is equal to 100%, interruption of the function is not possible.
Showing Display Group Information

Use **Display Information** to view information about the display group in which the cursor is currently located. The information is updated as you move the cursor between the open display group windows. The Display Information window shows:

- Display number.
- Number of colors used.
- Bands displayed.
- Type of stretch currently applied to each band.

To show display information, select one of the following options:

- From the ENVI main menu bar, select **Window → Display Information**.
- From the Display group menu bar, select **Window → Display Information**.

The Display Information window appears.

![Display Information Window](image)

*Figure 6-12: Display Information Window*
Displaying Pixel Location

Use the Pixel Locator to manually enter a sample and line location that positions the cursor at the center of the Zoom window. If the image contains georeferenced data, you can optionally locate pixels using map coordinates. The Pixel Locator pertains to the display group from which it was opened. You can open a Pixel Locator for each display group shown on your screen.

1. To open the pixel locator, use one of the following:
   - From the Display group menu bar, select Window → Pixel Locator.
   - In the display group, right-click and select Pixel Locator.

   The Pixel Locator dialog appears, showing the values of the selected pixel. If the image contains an associated DEM, elevation information displays as well. In the Zoom window, crosshairs outline the selected pixel.

2. If the image header contains $x_{\text{start}}$ and $y_{\text{start}}$ data, specify whether to use an image offset by enabling or disabling Options → Use Image Offset from the Pixel Locator dialog menu bar. The default is Yes. If the header file does not contain $x_{\text{start}}$ and $y_{\text{start}}$ data, this option is unavailable.
3. To locate a pixel, either:

- Enter a **Sample** (horizontal) and **Line** (vertical) location into the corresponding fields and click **Apply**. The Zoom box jumps to the specified pixel location.

- To move the selected pixel one pixel at a time, click the arrow buttons at the bottom of the Pixel Locator dialog.

- If the displayed image is georeferenced, click the Proj toggle button to choose between map coordinates and geographic coordinates (latitude/longitude), enter the desired easting (E) and northing (N) or latitude and longitude, and click **Apply**. The Zoom box jumps to the specified pixel location.

4. If ENVI’s image-to-map registration function is active, click **Export** to deliver map coordinates (including elevation, if available) to the Ground Control Points Selection dialog (see Image-to-Map Ground Control Points in the **ENVI User’s Guide**).

The **Export** button produces no effect if a registration session is not active.
Displaying Cursor Location/Value

Use the Cursor Location/Value tool in any display group to display the sample (horizontal, x) and line (vertical, y) coordinates, the data value of the pixel under the cursor, and the geographic coordinates (for georeferenced data) of the pixel under the cursor. The position is continuously updated as you move the cursor around the image.

**Note**
For complex data, the Cursor Location/Value tool reports the real and imaginary components.

To open the Cursor Location/Value window, use one of the following:
- In the display group, double-left-click.
- In the display group, right-click and select **Cursor Location/Value**.
- From the Display group menu bar, select **Tools → Cursor Location/Value**.
- From the Display group menu bar, select **Window → Cursor Location/Value**.
- From the ENVI main menu bar, select **Window → Cursor Location/Value**.

The Cursor Location/Value window appears.

**Note**
In ENVI, pixel values always refer to the upper-left corner of the pixel. Map coordinates also typically refer to the upper-left corner of the pixel. However, if you entered image pixel coordinates in the map information in the ENVI header, the map coordinates would refer to the x,y coordinates entered (for example, x=1.5, y=1.5 would make the map coordinates refer to the center of the pixel).

The Cursor Location/Value window applies to all open display groups. When you move the cursor from one display group to another, the window shows information for the display group the cursor is over. The Cursor Location/Value window displays the following data:

- For all images: The display group number and stretched image (Scrn) and raw data (Data) values.
- For RGB images: The red, green, and blue values for the displayed bands.
- For georeferenced images: The appropriate projection name, the map coordinates, and latitude and longitude.
Chapter 6: Common Tools and Functions in ENVI

Displaying Cursor Location/Value

• For classification images: The class names, along with the cursor location and value.
• For linked displays: The data values for the current pixel for all the linked display groups.

Cursor Location/Value Reporting Options

You can specify how you want the Cursor Location/Value window to report information. For example, you can report the cursor location in the Zoom window as an integer number or as a floating-point number, show fractions of a pixel, change the displayed format of the latitude and longitude information, and set the precision of the numbers reported (the number of digits displayed after the decimal). The upper-left-corner of a pixel is the position of the whole number coordinates and the x and y values increase to the right and bottom of the pixel, respectively. The pixel fraction is shown proportional to the zoom factor. For example, at a zoom of 4x, the pixels are divided into fourths. The values reported for the Zoom window are from the original data, not the interpolated data.

To set cursor/location value options from the Cursor Location/Value window menu bar:

• To view floating-point pixel image locations in the Zoom window, select Options → Floating Point Locations.
• To view integer pixel image locations in the Zoom window, deselect Options → Floating Point Locations.
• To view pixel locations, including the x and y offset values read from the header, select Options → Use Image Offset. This is the default selection.
For georeferenced data sets: To view latitude and longitude information in decimal degrees, deselect Options → Lat/Lon DDS.

To view latitude and longitude information in degrees, minutes, and seconds, select Options → Lat/Lon DMS (for georeferenced data sets). This is the default selection.

By default, the Cursor Location/Value window is set to move to front of all other windows when opened, to disable this option, deselect Options → Auto Raise Window.

Setting Numeric Precision

The numeric precision is the number of digits displayed after the decimal.

1. In the Cursor Location/Value window menu bar, select Options → Set Report Precision. The Set Report Precision dialog appears.

2. To set the precision to use to display the map coordinates, enter the value in the Map Precision field.

3. To set the precision of the display when Lat/Lon:DD is the selected option for georeferenced data sets, enter the value in the Lat/Lon Precision field.

4. To set the precision to use to display the floating point data values, enter the value in the Data Precision field. Any changes do not affect the display of byte and integer data.

5. Select Scientific or Normal as the Floating Report format, from the toggle button. A normal number is the number in decimal format (for example, 25.88), whereas a scientific number shows a single digit, followed by a decimal, and e (exponential) power (for example, 2.588e+001).

6. Click OK.
Collecting Points

Use the Point Collection tool to collects points (both pixel locations and map locations) from display group windows. The points display in a table in the ENVI Point Collection window.

To collect points, use one of the following:

- From the ENVI main menu bar, select Window → Point Collection.
- From the Display group menu bar, select Tools → Point Collection.

For detailed information and instructions about collecting points, see Collecting Points in the ENVI User’s Guide.
Linking Display Groups

You can link multiple display groups so that all actions in one display are mirrored in all other linked display group windows. For example, moving the Zoom box in the Image window or the Image box in the Scroll window, changing the zoom factor, or resizing one Image window in one display group is mirrored in another, linked display group. Ideally, you should only link images when they are the same size, or when one image is a subset of the other image. Dynamic overlays are active when displays are linked.

To link display groups, use one of the following:

- From the ENVI main menu bar, select Window → Link Displays.
- From the Display group menu bar, select Tools → Link → Link Displays.
- In the display group, right-click and select Link Displays.

The Link Displays dialog appears.

Using Dynamic Overlays

You can use dynamic overlays for real-time overlay, and to toggle (flicker) multiple gray scale or color images. By default, dynamic overlays are activated automatically when two or more windows are first linked. Multiple overlays are active in all linked Image windows simultaneously and in each Zoom window.

1. To use multiple dynamic overlays, use one of the following:
   - From the ENVI main menu bar, select **Window → Link Displays**.
   - From the Display group menu bar, select **Tools → Link → Link Displays**.
   - In the display group, right-click and select **Link Displays**.

2. Link the displays as described in **Linking Displays** in the *ENVI User’s Guide*.

3. When the displays are linked, you can use the **Dynamic Overlay** option to select **On** and **Off** using the following Image window menu bar selections:
   - Select **Tools → Link → Dynamic Overlay On**
   - Select **Tools → Link → Dynamic Overlay Off**

See **Working with Multiple Dynamic Overlays** in the *ENVI User’s Guide* for complete details on using the multiple dynamic overlays.
Annotating Displays

You can annotate images and plots with text, symbols, polygons, lines, polylines, shapes, map information, and gray scale or color bars. For classification images, you can also add class keys. For display groups, you can place annotations in the Image window, the Scroll window, the Zoom window, or in the virtual borders.

Annotation options are similar for images, plots or, surface views. You can save annotations to files and include them in output options.

You can also use the QuickMap tool to overlay grid lines, titles, declination diagrams, North arrows, and borders on georeferenced images. See Creating QuickMaps in the ENVI User's Guide.

To use virtual borders, append the border to the image before annotating it (see Setting Virtual Display Borders in the ENVI User's Guide).
To create annotations:

1. Select one of the following options:
   - From the Display group menu bar select **Overlay → Annotation**.
   - From any plot menu bar, including surface plots and x, y, or z profiles, select **Options → Annotation**.
     The Annotation dialog appears.

2. Select **Object → annotation_type**. **Text** annotation is the default mode.

For details on annotation, see *Annotating Images and Plots* in the *ENVI User’s Guide*. 
Defining Regions of Interest

Regions of interest (ROIs) are portions of images, either selected graphically or selected by other means, such as thresholding. Typical uses of ROIs include extracting statistics for classification, masking, and other functions. You can use any combination of polygons, points, or vectors as an ROI. ENVI allows you to define multiple ROIs and draw them in any of the Image, Scroll, or Zoom windows. In addition, you can grow ROIs to adjacent pixels that fall within a specified pixel value threshold.

Figure 6-16: ROIs in the Display Group
Defining Regions of Interest

Note

ROIs are explicitly related to the spatial size of the image in which they are defined. If you open images of equal spatial size with their associated ROI Tool dialogs, ROIs drawn in one image are displayed in all other image displays of the same spatial size. You can edit or delete shared ROIs from within any of the ROI Tool dialogs.

To draw an ROI:

1. Select one of the following options for the active display group:
   - From the Display group menu bar, select **Overlay → Region of Interest**.
   - From the Display group menu bar, select **Tools → Region of Interest → ROI Tool**.
   - From the ENVI main menu bar, select **Basic Tools → Region of Interest → ROI Tool**.
   - In the display group, right-click and select **ROI Tool**.

The ROI Tool dialog appears.

![ROI Tool Dialog](image)

*Figure 6-17: ROI Tool Dialog*
2. Select whether to use the **Image**, **Scroll**, or **Zoom** window to draw the ROIs.

3. Draw ROIs as described in *Drawing ROIs* in the *ENVI User’s Guide*.

You can also add, edit, and create additional ROIs, as described in ENVI Help.

**Turning Off ROI Definition**

When the ROI Definition function is enabled, actions such as zooming, panning and other display operations are not enabled.

To enable these interactive mouse operated functions without leaving ROI Definition, select the **Off** radio button in the ROI Tool dialog.
Chapter 6: Common Tools and Functions in ENVI

Using the Available Files List

Use the Available Files List to view information about the files that are currently open in ENVI and in memory. You can also use the Available Files List to open new files, to close files, to save memory items to disk, and to edit ENVI headers.

Tip
Use the Available Files List on a regular basis to remove memory-only calculations from system memory.

To open the Available Files List, use one of the following:

- From the ENVI main menu bar, select **Window → Available Files List**.
- From the Available Bands List menu bar, select **File → Available Files List**.

The Available Files List appears.

![Available Files List](image)

*Figure 6-18: Available Files List*
Chapter 6: Common Tools and Functions in ENVI

Viewing File Information

To view important information about each file, select a filename in the Available Files List. ENVI displays information and parameters from the ENVI header file, including:

- Full path and image name.
- Number of lines, samples, and bands (Dims).
- File size.
- Interleave (BSQ, BIL, BIP).
- Data type (byte, integer, and so forth).
- File type.
- Byte order of the data (Host or Network).
- Whether or not the data is georeferenced.
- Whether or not any wavelengths are associated with the bands.

Editing Header Files from the Available Files List

You can edit header files from the Available Files List. For details, see “Editing Header Files” on page 127.

Opening New Files from the Available Files List

You can open ENVI image files or other binary image files of known format. For details, see “Opening Image Files in ENVI” on page 82.

ENVI opens the file and adds it to the Available Files List. The file information appears in the right side of the dialog.

Closing All Files from the Available Files List

To close all files (including memory items, which are automatically deleted), select File → Close All Files from the Available Files List menu bar.
Deleting Memory Items

To remove files that exist only in memory without closing open disk files, select File → Delete All Memory Items from the Available Files List menu bar.

**Note**

Memory items removed in this fashion are not recoverable.

Storing Files in Memory

To store large image files as an in-memory item for faster processing:

**Note**

This option is dependent on the amount of RAM available on your system.

1. Select one or more filenames in the Available Files List.
2. From the Available Files List menu bar, select File → Add Selected Files to Memory. All selected image files, including their parameters, are added as in-memory items to the Available Bands List.

Saving In-Memory Files to Disk

1. Select the item to save in the Available Files List.
2. From the Available Files List menu bar, select File → Save Selected File to Disk. The Memory to File Storage dialog appears.
3. Enter an output filename.
4. Click OK.

Deleting Files from Disk

1. Select the file(s) to delete in the Available Files List.
2. Select File → Delete Selected File from Disk. Because this is a permanent action, a warning message appears to verify that you want to permanently delete the file.
3. Click Yes to delete the file.
Closing Selected Files

1. Select the file(s) to close in the Available Files List.

2. Select File → Close Selected File.

   If a warning box appears, it means that one or more bands from the file are currently displayed in one of the display groups. Select Yes to close the file and to remove the associated bands from the display.

   If the file is a memory item, ENVI removes it from memory and closes any associated displays.
Chapter 7
Creating Output

This chapter describes creating various types of output in ENVI. It includes:

- Saving Image Files ..................... 168
- Saving Display Output .................. 173
- Printing in ENVI .......................... 174
- Changing Output Directories .......... 176
Saving Image Files

Use **Save File As** to create a new standard ENVI disk file or an ENVI meta file from bands contained in the Available Bands List and to output image data to various image processing formats. You can create output to image processing formats such as ArcView® Raster (.*bil*), ER Mapper, ERDAS IMAGINE (.*img*), JPEG 2000 (.*jp2*), NITF (.*ntf*), PCI (.*pix*), TIFF (including GeoTIFF or world files (.*tfw*)), and ESRI® GRID files. In addition, you can output your image to an ASCII (.*txt*) file.

**Note**

You can only create new files from bands that have the same spatial dimensions. Use ENVI’s subsetting capabilities to choose individual bands and to perform on-the-fly subsetting of files to the correct dimensions. See **Subsetting Data** in the **ENVI User’s Guide**.

This section describes how to save data as standard ENVI files, meta files, and ASCII files. For information on saving output to other image processing formats, see the following topics in ENVI Help:

- Saving Files as ArcView Raster Files
- Selecting an Output Geodatabase
- Saving Files as ER Mapper Files
- Saving Files as IMAGINE Files
- Saving Files as JPEG 2000 Files
- Saving Files as NITF Files
- Saving Files as PCI Files
- Saving Files as TIFF Files
- Saving Files as ESRI GRID Data

**Saving as Standard ENVI Files**

Use **ENVI Standard** to create disk files from a combination of ENVI files, external (foreign) files, or memory items.

1. From the ENVI main menu bar, select **File → Save File As → ENVI Standard**. The New File Builder dialog appears.
2. Click **Import File**. The Create New File Input File dialog appears.
3. Select one or more files to include and perform optional spatial subsetting and spectral subsetting. You can subset a group of files if they are the same size; the subset is applied to each file. For subsetting details, see **Subsetting Data** in the *ENVI User’s Guide*. 

*Figure 7-1: New File Builder Dialog*
4. Repeat the file selection using the **Import File** button for each input file to include in the new file. Input files are listed in the **Selected ENVI Files for New File** list.
   
   - To delete a file from the list in the New File Builder dialog, select the filename and click **Delete**.
   
   - To change the order in which the files and/or bands are imported, click **Reorder Files** to open the Reorder Files dialog, and click on a filename or band name and drag it to the desired position in the list.
   
   - To remove the component files, use the **Remove Superfluous Files?** toggle button to select **Yes** (remove files), or **No**, next to the text label.

**Note**

Removing component files physically removes the files from the Available Bands List and the disk:

- If transferring memory items to the new file and you select **Remove Superfluous Files?**, the items are deleted from memory when the new file is created.
- If transferring all of the bands from a disk file to the new file and **Remove Superfluous Files?** is selected, the original disk file is physically deleted from the disk when the new file (either memory or disk file) is created.

5. Select output to **File** or **Memory**.

6. Click **OK** to build the new file. ENVI creates the file in BSQ format.

### Saving as ENVI Meta Files

A meta file is a virtual file, in which no new disk file is actually created. Instead, you associate files or image bands through a small text file, which contains the names of the files to treat as a virtual file. When you later select the meta file for input or processing, ENVI retrieves the image data from the individual disk files and treats them as if they were part of the same input file for processing. ENVI meta files can contain images with different data types (byte, integer, floating point, and so forth), which allows you to combine processing of diverse data sets. ENVI does not need to perform file conversions, and does not need to create intermediate processing files.
Note

Files to include in a meta file must reside on disk as ENVI format files. Convert foreign files imported to ENVI (for example, TIFF files) or files/bands created as memory items within ENVI to ENVI disk files before creating the meta file.

1. From the ENVI main menu bar, select File → Save File As → ENVI Meta. The New File Builder dialog appears.
2. Click Import File. The Create New File Input File dialog appears.
3. Select one or more files to include and perform optional spatial subsetting and spectral subsetting. You can subset a group of files if they are the same size; the subset is applied to each file. For subsetting details, see Subsetting Data in the ENVI User’s Guide.
4. Repeat the file selection using the Import File button for each input file to include in the new file. Input files are listed in the Selected ENVI Files for New File list.
   - To delete a file from the list in the New File Builder dialog, select the filename and click Delete.
   - To change the order in which the files and/or bands are imported, click Reorder Files to open the Reorder Files dialog, and click on a filename or band name and drag it to the desired position in the list.
5. In the Enter Output Filename field, enter a filename.
6. Click OK to build the new file. ENVI adds the bands in the meta file to the Available Bands List. The actual meta file, on disk, is a text file that only contains the names of the imported files.

Saving as ASCII Files

ASCII (.txt) output files contain the DN values for every pixel. You may select the output format of the DN values (field size including decimal point, white spaces, and number of decimal places). If you output multiple bands, the file interleave (BSQ, BIL, BIP) is the same as the input file. The format of the ASCII file is that of a 2D array.

Note

If your output file contains three asterisks (** * ), then your ASCII output format is incorrect for the data type of your DN values.
1. From the ENVI main menu bar, select **File → Save File As → ASCII**. The Output File to ASCII Input Filename dialog appears.

2. Select a file and perform any subsetting.

3. Click **OK**. The Output to ASCII Parameters dialog appears.

4. Enter an integer value for **Total Field Size** to set the total number of characters in the field.

5. To set the number of digits that follow the decimal point in the output data, enter a value for **Decimal Precision**.

6. In the **Enter Output Filename** field, enter a filename.

7. Click **OK**. ENVI creates an output ASCII file, which you can view using any text editor.

### Saving DEMs to ASCII Format

If your input file is a DEM, the **Output Style** drop-down list appears in the Output to ASCII Parameters dialog. Select an output format:

- **ENVI Standard**: Output will be consistent with ENVI raster format, where each data point represents the elevation (in meters) for the corresponding pixel.

- **ESRI ASCIIGRID**: Output will be consistent with ESRI GRID format, where each data point represents the elevation (in meters) for the corresponding pixel.

- **X Y Z**: If you select this option, you must enter values for **XY Field Size** and **XY Decimal Precision**. Output will contain a five-line header, followed by six columns of data per line (two sets of x,y,z data side-by-side in one line, as in the following example).

```plaintext
ENVI ASCII Output of file: C:\test\hdemsub.img [Tue Jul 24 09:17:00 2007]
File Dimensions: 799 samples x 909 lines x 1 band
Line Format: (f14.2,f14.2,17.0)

270793.56 4911156.00 1276 270823.56 4911156.00 1276
270833.56 4911156.00 1276 270863.56 4911156.00 1277
270913.56 4911156.00 1277 270943.56 4911156.00 1277
270973.56 4911156.00 1277 271003.56 4911156.00 1277
271033.56 4911156.00 1278 271063.56 4911156.00 1278
271103.56 4911156.00 1278 271133.56 4911156.00 1278
271153.56 4911156.00 1279 271183.56 4911156.00 1279
271213.56 4911156.00 1279 271243.56 4911156.00 1279
271273.56 4911156.00 1279 271303.56 4911156.00 1279
271333.56 4911156.00 1279 271363.56 4911156.00 1279
```
You can save ENVI display groups, plot windows, or Vector windows to PostScript files, image files, or directly to printers. You can include (burn into) all overlays (annotation, grid lines, vectors, and so forth) in the output.

The image file types you can save to are:

- ENVI file (RGB binary image with an ASCII header file)
- BMP
- HDF
- JPEG and JPEG 2000
- PICT
- Portable Network Graphics (PNG)
- Sun Raster File (SRF)
- TIFF (including GeoTIFF and TIFF World [.tfw])
- X-Windows Dump (XWD)
- ERDAS (.lan)
- ER Mapper, PCI (.pix)
- ArcView® (.bil) files

For detailed instruction on saving files and setting options for page size, image scaling, graphics overlays, masks, and more, see Saving Images from Displays in the ENVI User's Guide.
Printing in ENVI

You can send output of display groups, plot windows, and Vector windows directly to system printers. You can send output to any of your system printers or plotters through your native system printer dialog.

1. Select one of the following options:
   - To output a displayed image to a system printer, select **File → Print** from the Display group menu bar.
   - To output a plot or Vector window to a system printer, select **File → Print** from the plot or Vector window menu bar.

   The Print dialog appears.

2. Set any options specific to your system.

3. Click **OK**. The Output Display to Printer dialog appears.

4. If the image is georeferenced, you can set the output x or y print size or set the desired output map scale in the **xsize** and **ysize** fields. When you set a size, the other size parameters change to preserve the aspect ratio of your image.

   **Note**
   To maintain the relative aspect between x and y when one dimension is changed, select the **Aspect** check box.

5. Set the position of the image origin on the page (with respect to the lower left corner) using the **xoff** and **yoff** parameters. An outline of the image showing its relative size and position on the page appears within the draw window in the upper-right of the dialog.
   - To position the image on the output page, left-click and hold the mouse button inside the image outline in the draw window and drag the image to a new position.
   - To center the image outline on the page using your mouse, right-click anywhere on the output page.

6. Click the toggle button to select **Landscape** or **Portrait** page orientation.

7. To scale an image to a specified map scale, enter a value in the **Map Scale 1** field. The **xsize** and **ysize** field values change automatically based on the image pixel size (ENVI uses a default size of 30 meters no pixel size is present in the header).
8. If desired, perform optional spatial subsetting and spectral subsetting. For subsetting details, see Subsetting Data in the ENVI User’s Guide.

9. To resize the image, enter a resize factor (less than 1 for subsampling) in the Input Image Resize Factor field.

10. To set graphics overlay options, see Setting Graphics Overlay Options in the ENVI User’s Guide.

11. Click OK in the Output Display to Printer dialog to print the image or plot.
Changing Output Directories

You can change the output directory for the current ENVI session. To change the default ENVI directory for all ENVI sessions, see Default Directory Preference Settings in the ENVI User’s Guide.

2. Enter the full path of the directory to which you want ENVI to send the output.
3. Click OK to change the current output directory to the new path.
Chapter 8
Configuring and Customizing ENVI

This chapter describes how to set ENVI preferences and how to customize your ENVI installation. It includes:

---

Setting ENVI Preferences .......... 178  Using IDL with ENVI .......... 196
Customizing ENVI .......... 188
Setting ENVI Preferences

ENVI is installed with system defaults that control a variety of system preferences. You change these settings through the ENVI interface, or by editing the ENVI configuration file (`menu\envi.cfg`) in a text editor.

To set ENVI preferences in the ENVI interface:

1. From the ENVI main menu bar, select **File → Preferences**. The System Preferences dialog appears with the parameters to set located under various tabs.

2. Click on the tab category that you want to modify. The dialog options change depending on the tab you select. The tabs are detailed in the following sections:
   - “User-Defined File Preferences” on page 179
   - “Default Directory Preferences” on page 181
   - “Display Default Preferences” on page 181
   - “Plot Default Preferences” on page 183
   - “Grid Line Default Preferences” on page 185
   - “Previous Files List Preferences” on page 185
   - “Miscellaneous Preferences” on page 186

3. In the System Preference dialog tabs, edit the parameters as needed. The parameters are detailed in the following ENVI Help topics:
   - User-Defined File Preference Settings
   - Default Directory Preference Settings
   - Display Default Preference Settings
   - Plot Default Preference Settings
   - Grid Line Default Preference Settings
   - Previous Files List Preference Settings
   - Miscellaneous Preference Settings

4. Click **OK**. ENVI prompts you to save the preferences to a file. Either:
   - Click **No** to use the preference settings for this ENVI session only.
Click **Yes** to save the preference settings to a file. Saving to a file makes the preferences available for use in all future ENVI sessions, as well as for the current session.

5. If you select **Yes** to save to a file, either:
   - Click **OK** without entering a new filename to overwrite the current `envi.cfg` file.
   - Enter the new configuration filename and click **OK**.

**Note**
ENVI uses only a file named `envi.cfg` for preference settings. If you intend to use the new configuration file, you must rename the old `envi.cfg` file and change your newly saved filename to `envi.cfg`.

**User-Defined File Preferences**

Use the **User Defined Files** tab to specify user-defined files for graphics colors, graphics color table, ENVI menus, map projections, previous files list, tape device name, ENVI startup script, math expressions, and user-defined ENVI routines.
For detailed information on the fields in this dialog, see User-Defined File Preference Settings in the ENVI User’s Guide.

![System Preferences Dialog – User Defined Files Tab](image)

**Figure 8-1: System Preferences Dialog – User Defined Files Tab**
Chapter 8: Configuring and Customizing ENVI

Getting Started with ENVI
Setting ENVI Preferences

Default Directory Preferences

Use the Default Directories tab to specify the default directories for input and output files, temporary files, IDL custom routines, spectral library files, and alternative header file locations for input originating from a CD.

For detailed information on the fields in this dialog, see Default Directory Preference Settings in the ENVI User’s Guide.

![Figure 8-2: System Preferences Dialog – Default Directories Tab](image)

Display Default Preferences

Use the Display Defaults tab to set the display group window sizes, turn on/off Image and Zoom window scroll bars, set Zoom window interpolation, select which display group windows to use, choose Scroll/Zoom window graphics colors, display default stretch, display retain value, set the Scroll/Zoom window positions, and set the 8-bit color division preferences. You can also change the system graphics colors and system color tables from this dialog.

Note

If one or more display groups are open when you modify the settings in this tab, the new settings apply only to subsequent display groups. The open display groups retain the preference settings that were in effect before you modified them.
If you prefer to change display preferences for a single display group, see “Setting Preferences for an Individual Display Group” on page 58.

For detailed information on the fields in this dialog, see Display Default Preference Settings in the ENVI User’s Guide.

![Figure 8-3: System Preferences Dialog – Display Defaults Tab](image)

**ENVI Graphics Colors**

Use the Edit Graphic Colors dialog to edit the colors ENVI uses for graphics. The color definitions are stored in the `menu\colors.txt` file, which ENVI uses unless you specify a different default graphic colors file (described in “User-Defined File Preferences” on page 179).

To edit the graphics colors file, see Editing System Graphics Colors in the ENVI User’s Guide. To add new colors to the graphic colors file, use a text editor to append
the colors to the end of the file. You can also edit the ENVI color table, which is described in **Editing System Color Tables** in the *ENVI User’s Guide*.

![Figure 8-4: Edit Graphic Colors Dialog](image)

**Plot Default Preferences**

Use the **Plot Defaults** tab to set the background and foreground colors, fonts, character size, axis thickness, the number of minor tick marks and length, window size, and margin sizes to use in ENVI plot windows. See **Installing Other TrueType Fonts with ENVI** in the *ENVI User’s Guide* for additional details about fonts.
For detailed information on the fields in this dialog, see Plot Default Preference Settings in the ENVI User’s Guide.

![Figure 8-5: System Preferences Dialog – Plot Defaults Tab](image)
Chapter 8: Configuring and Customizing ENVI

Grid Line Default Preferences

Use the Grid Line Defaults tab to set the colors, fonts, character size, line thickness, and labels to use in grid line plotting.

![Figure 8-6: System Preferences Dialog – Grid Line Defaults Tab](image)

For detailed information on the fields in this dialog, see Grid Line Default Preference Settings in the ENVI User’s Guide.

Previous Files List Preferences

Select the Previous Files List tab to manage files that appear in the previous files list when you select File → Open Previous File from the ENVI main menu bar or Open → Previous File from any Input File dialog. In addition to removing files from
the list, you can specify files to always keep on the previous files list and to place at the top of the list when opening a file. This is referred to as making a file sticky.

For detailed information on the fields in this dialog, see Previous Files List Preference Settings in the ENVI User’s Guide.

![Figure 8-7: System Preferences Dialog – Previous Files List Tab](image)

### Miscellaneous Preferences

Use the Miscellaneous tab to set the configuration name, the ENVI main menu bar orientation, maximum number of multilist items, maximum histogram bins, number of drop-down button items, maximum vertices in memory, PostScript output parameters, turn on/off IDL command line blocking, the auto apply option for interactive stretching, and memory usage parameters. You can also set whether to exit IDL when exiting ENVI, to show a status window for input, to automatically append
default extensions to filenames, to automatically load default bands, and to open applicable files to memory.

For detailed information on the fields in this dialog, see **Miscellaneous Preference Settings** in the *ENVI User’s Guide*.

![Figure 8-8: System Preferences Dialog – Miscellaneous Tab](image-url)
Customizing ENVI

You can set up custom menus, system configuration variables, and even add your own ENVI routines to the ENVI menu. Several files are used for custom configurations (located in the menu and map_proj subdirectories):

- **colors.txt**: ENVI graphics colors RGB file.
- **display.men**: Display group menu bar file (see “Display Group Menu Bar Definition File” on page 194).
- **display_shortcut.men**: Display group right-click menu (see “Display Group Right-Click Menu Definition File” on page 195).
- **e_locate.pro**: ENVI directory locator file.
- **envi.cfg**: System configuration file (see “ENVI Configuration File” on page 194).
- **envi.men**: Main menu file (see “Display Group Menu Bar Definition File” on page 194).
- **filetype.txt**: List of ENVI file types and the routine name used to read the files that need specialized spatial and spectral readers.
- **map_proj.txt**: User-defined map projections file (see ENVI Map Projections File in the ENVI User's Guide).
- **sensor.txt**: List of sensor types that appears in the ENVI header (see “ENVI Sensor File” on page 130).
- **useradd.txt**: Used to define parameters for user-defined plot routines, Spectral Analyst routines, user-defined map projection routines, user-defined map projection units, and/or user-defined RPC readers.
- **usersym.txt**: Contains user-defined symbols.

Customizing ENVI in a Multiple-User Windows Environment

Customizing the above files on machines where multiple users work with the same installation of ENVI may cause problems, as some users may not have access to the custom files when they start ENVI. One way to avoid problems is to define an IDL_PATH user variable in the Windows Control Panel.
To customize ENVI files on a Windows machine without affecting other users who may run the same installation of ENVI, perform the following steps:

1. Copy the ENVI files you want to customize from the default ENVI installation directories to your personal directory.

2. Copy the `menu\e_locate.pro` file into your personal directory. Files in this directory with a `.pro` extension cause IDL to add the personal directory to the search path when it starts up, allowing ENVI to find the copy of your customized `envi.cfg` file.

3. In the Windows Control Panel User Variables area, add an `IDL_PATH` user variable that places your personal directory before the default installation path. For instance, for an installation of ENVI in the default `C:\Program Files\ITT\` location, the appropriate Value of the `IDL_PATH` Variable for a user called `jones` would be something like:

   ```
   C:\users\jones;+C:\Program Files\ITT\IDLxx\products\ENVIx\lib;+
   C:\Program Files\ITT\IDLxx\examples
   ```

   where `xx` is the current software version.

4. Edit the `envi.cfg` file in your personal directory to point to the custom files in your personal directory.

5. Edit the ENVI files in your personal directory. The changes are implemented when you start ENVI.

6. Create a directory named `save_add` in your personal directory.

7. Edit your personal `envi.cfg` to specify the new default `save_add` directory. The next time you start ENVI, it looks in the new `IDL_PATH` for the `envi.cfg` file, finds one in the first place it looks (your personal directory), then reads the ENVI configuration file to determine where to find the rest of the setup files and your personal `save_add` folder.

### Customizing ENVI in UNIX

Most ENVI users on UNIX systems do not have permissions to change the files listed under “Customizing ENVI” on page 188, or to add their own procedures to the ENVI `save_add` directory. This is because installation of ENVI on UNIX must be performed by a system administrator logged in as `root`. Also, multiple users may be working with the same installation of ENVI, so customizing these files may not be feasible.
To customize ENVI files on a UNIX system without affecting other users who may run the same installation of ENVI, perform the following steps:

Copy the ENVI files you want to customize from the default ENVI installation directories to your home directory. For a typical UNIX installation, the menu and map_proj directories are located in

```
/usr/local/itt/idlxx/products/envixx
```

where `xx` is the current software version. (The installation path may be slightly different on your machine.)

8. Copy the `menu\e_locate.pro` file into your home directory. Files in this directory with a `.pro` extension cause IDL to add the personal directory to the search path when it starts up, allowing ENVI to find the copy of your customized `envi.cfg` file.

9. Add lines to your `.cshrc` (or `.tcshrc`) file in your home directory to execute the ENVI setup file when you start a new csh (or tcsh) shell and to add your home directory tree into the IDL file search path. This ensures that ENVI finds the files in your home directory before it finds copies in the default installation location where you do not have write permission. Following is an example of lines to add:

```csh
#Set up environment for ENVI x.x and modify IDL search path variable (IDL_Path).
#(Expecting previously defined IDL search path variable definition)
source /usr/local/itt/idlxx/products/envixx/bin/envi_setup
setenv IDL_PATH "+/home/myusername:'$IDL_PATH
```

where `xx` is the current software version

You will need to change the home directory path (shown above as 

```
+/home/myusername
```

) to your own home directory path. You may also need to change the directory path to the `envi_setup` file if your ENVI installation is in a location other than `/usr/local/itt`.

If you anticipate that `$IDL_PATH` will be undefined (no prior IDL search path customizations), then be sure to use the string `<IDL_DEFAULT>` in place of `$IDL_PATH` at the end of the second command. Notice in the following example that `<IDL_DEFAULT>` is inside the right single-quote character:

```csh
#Set up environment for ENVI x.x and modify IDL search path variable (IDL_Path).
#(Expecting previously defined IDL search path variable definition)
source /usr/local/itt/idlxx/products/envixx/bin/envi_setup
unsetenv IDL_PATH
setenv IDL_PATH "+/home/myusername:<IDL_DEFAULT>"
```

where `xx` is the current software version
Bash Shell

Your ENVI installation also contains a setup file for the Bash shell. Place the following equivalent commands in the .bashrc file in your home directory:

Using a previously defined IDL search path definition:

```
#Set up environment for ENVI x.x and modify IDL search path variable (IDL_Path).
#(Expecting previously defined IDL search path variable definition)
./usr/local/itt/idlxx/products/envixx/bin/envi_setup.bash
IDL_PATH='+/home/myusername:'$IDL_PATH
export IDL_PATH
```

where xx is the current software version

Not using a previously defined custom IDL search path definition:

```
#Set up environment for ENVI x.x and modify IDL search path variable (IDL_Path).
#(Expecting previously defined IDL search path variable definition)
./usr/local/itt/idlxx/products/envixx/bin/envi_setup.bash
unset IDL_PATH
IDL_PATH='+/home/myusername:<IDL_DEFAULT>'
export IDL_PATH
```

where xx is the current software version

10. Edit the envi.cfg file in your home directory to point to its customized files.

11. Edit the ENVI files in your personal directory. The changes will be implemented when you start ENVI.

12. Create a directory named save_add in your personal directory.

13. Edit your personal envi.cfg to specify the new default save_add directory. The next time you start ENVI, it looks in the new IDL_PATH for the envi.cfg file, finds one in the first place it looks (your personal directory), then reads the ENVI configuration file to determine where to find the rest of the setup files and your personal save_add folder.

Platform-Specific Customization

Some modifications may be necessary for specific platforms, including:

- Windows SCSI tape support
- UNIX fonts
• UNIX window auto-placement
• UNIX color flashing on 24-bit displays
• UNIX pseudocolor on 24-bit displays

SCSI Tape Support for Windows

ENVI includes tape support for PCs running Microsoft Windows 2000 and Windows XP. To install the tape drivers for Windows, open the `aspi_v470.exe` self-extracting archive in the `\tape32` directory on the ENVI for Windows installation CD. See the included `README.DOC` file for installation instructions.

When installed, this routine provides transparent access to ENVI tape tools using the ASPI32 interface provided with Windows. All ENVI tape functions work the same as their UNIX counterparts on any SCSI tape device that runs under ASPI32. Tape32 for ENVI supports reading of many known tape formats including Landsat MSS, Landsat TM, AVHRR, AVIRIS, SPOT, etc. See the ENVI Tape Utilities menu option for a complete list. Use ENVI’s Scan Tape and Dump Tape functions to read other formats that ENVI does not directly support.

From the ENVI main menu bar, select File → Tape Utilities → tape_function.

Window Auto-Placement on UNIX

On some UNIX platforms, new windows may require your input for screen placement. It is recommended that you disable this function.

For example, on SGI systems using 4Dwm, the following two lines placed in the `.Xdefaults` file will allow auto-placement of windows. See your system documentation for other options.

```
4Dwm*InteractivePlacementfalse
4Dwm*ClientAutoPlacefalse
```

Setting the Font on UNIX Platforms

You can select any font available to the X server for your IDL and ENVI session. The X windows command `xlsfonts` lists all the available fonts. The recommended font for ENVI is either a 12 or 14-point courier (fixed width), or a 12- or 14-point Times-Bold (proportional). For more information, see the Using IDL manual.
To enable a particular font for your IDL session, include the following line in your .Xdefaults file with your selected font replacing the example.

```
Idl*fontList-adobe-times-bold-r-normal--12-120-75-75-p-67-iso8859-1
```

**Color Flashing on 24-Bit UNIX Machines**

ENVI display groups sometimes flash on 24-bit displays when other programs or the windowing system requires some of the colors.

You may be able to stop this flashing by entering the following into your .Xdefaults file.

```
Idl.gr_visualTrueColor
Idl.gr_depth24
```

**Pseudocolor on 24-Bit UNIX Machines**

ENVI automatically configures for both 8-bit and 24-bit displays. For more information see the *Using IDL* manual.

To run ENVI in an 8-bit mode on a 24-bit display, enter the following line in your .Xdefaults file to force your system to operate in 8-bit mode whenever IDL is started.

```
Idl.gr_visualPseudoColor
Idl.gr_depth8
```

**Customizing Configuration and Definition Files**

You can customize ENVI to:

- Optimize hardware configurations.
- Configure the ENVI main menu bar and Display group menu bar.
- Configure the right-click menu.
ENVI Configuration File

Use the ENVI configuration file (envi.cfg) to customize ENVI and to optimize specific hardware configurations to suit your preferences. The file is an ASCII text file containing keywords and associated values. You can change the way ENVI uses memory, handles color, and other setup parameters by specifying new values.

The ENVI configuration file must have the keywords ENVI CONFIGURATION FILE at the top of the file. Keywords determine the ENVI startup configuration. See ENVI Preference Settings in the ENVI User’s Guide for keyword descriptions.

Edit the file using a text editor or word processor, or change the file from within ENVI by selecting File → Preferences from the ENVI main menu bar (see “Setting ENVI Preferences” on page 178).

Note: The envi.cfg file must be in a directory that is in the IDL search path.

ENVI Main Menu Bar Definition File

The ENVI main menu bar definition file is named envi.men. The entire main menu bar is user-configurable. You can reposition existing items and add new items to suit your needs. ENVI does not distinguish between ENVI and user functions, which enables easy integration of user functions. One of ENVI’s most powerful features is this potential for customization. The specifics of how to configure the menu are included in the menu file text.

To use your created main menu file as the default menu, enter the complete filename in the envi.cfg file or enter it using File → Preferences (see “User-Defined File Preferences” on page 179).

Display Group Menu Bar Definition File

The Display group menu bar definition file is named display.men. The entire menu is user-configurable. You can reposition existing items and add new items to suit your needs. Instructions for customizing the menu are included in the menu file text.

To use your own Display group menu bar file as the default menu, enter the complete filename in the envi.cfg file or enter it using File → Preferences (see “User-Defined File Preferences” on page 179).

Note: If your changes to envi.men or display.men do not take effect, see When the New Menu Button Does Not Appear in the ENVI Programmer’s Guide.
Display Group Right-Click Menu Definition File

The display group right-click menu definition file is named display_shortcut.men. The entire menu is user-configurable. You can reposition existing items and add new items to suit your needs. Instructions for customizing the menu are included in the menu file text.

To use your own Display group menu bar file as the default menu, enter the complete filename in the envi.cfg file or enter it using File → Preferences (see “User-Defined File Preferences” on page 179).
Using IDL with ENVI

If you have an ENVI + IDL installation, you can configure how IDL multi-threading is handled (see Modifying IDL CPU Parameters in the ENVI User’s Guide).

In addition to setting IDL multi-threading parameters, this section describes how to:

- Import and export IDL variables
- Compile IDL code

**Importing IDL Variables**

Use **Import IDL Variables** to import IDL variables into ENVI. The variables must be defined on the ENVI command line. The **Import IDL Variables** function is not available in the ENVI-only license.

To import IDL variables:

1. From the ENVI main menu bar, select **File → Import IDL Variables**. The Import IDL Variables dialog appears with a list of all defined variables.
2. Select the desired variable names to import by clicking in the check box next to the name.
   - To add a range of variable names, enter the starting and ending variable numbers and click **Add Range**.
   - To select all the variable names, click **Select All**.
   - To clear the selected variable names, click **Clear**.
3. To save a copy of the data in IDL, use the arrow toggle button to select **Yes**.

   **Note**
   
   If you select **No**, the data is imported into ENVI and deleted from IDL.

4. Click **OK** to import the selected variables.

   All one-dimensional variables are placed in a plot window; the 2D and 3D variables appear in the Available Band List as memory items.
Exporting to IDL Variables

Use **Export to an IDL Variable** to export and/or subset an ENVI band or file to an IDL variable on the ENVI command line.

**Tip**
If the ENVI command line is not visible in the IDL window, select **Window → Command Input** from the IDL main menu bar. **Export to an IDL Variable** is not available in the ENVI-only license.

To export IDL variables:

1. From the ENVI main menu bar, select **File → Export to an IDL Variable**. The Export to IDL Input File/Band dialog displays.
2. Select an input file or band and perform optional spatial subsetting and spectral subsetting. For subsetting details, see **Subsetting Data** in the **ENVI User’s Guide**.
3. In the Export Variable Name dialog, select one of the following options:
   - If the variable was previously defined, select on the name in the **Select variable to receive export** list.
   - If the variable is a new one, enter the name of an undefined IDL variable in the **New Variable Name** field.
4. Click **OK**. The exported data is available to use at the ENVI command line.

Compiling IDL Code

Use **Compile IDL Module** if you have written your own IDL code to use in ENVI. Each time you modify your IDL code, you must compile it. Optionally, you can have the code automatically re-compiled each time ENVI starts by saving it in the **save_add** directory. See **Default Directory Preference Settings** and **Compiling** in the **ENVI User’s Guide** for additional information.

To compile IDL code:

1. From the ENVI main menu bar, select **File → Compile IDL Module**. The Enter Module Filename dialog appears.
2. Select the module filename.
3. Click **OK**. Any compile errors are shown in the main IDL window.
This glossary supplements ENVI Help by listing some terms that are frequently referenced in ENVI documentation or that are unique to ENVI functionality. It is not an exhaustive list of remote sensing terms. For terms that describe an ENVI function, see ENVI Help for complete details.

**AATSR** Advanced Along-Track Scanning Radiometer; an ENVISAT sensor.

**absorption feature** A region of the electromagnetic spectrum where a given material absorbs radiation, shown by a low point in a spectral curve. Each material has unique absorption features, which serve as identifying characteristics.

**abundance image** In hyperspectral analysis, an image whose values represent the fractions of total spectrally integrated radiance or reflectance of a pixel contributed by each spectrally unique material.

**ACRES** Australian Centre for Remote Sensing.

**across track** The imaging direction perpendicular to the along track direction of a satellite or aircraft. The across track viewing angle determines the swath.
**adaptive filter**  A type of spatial filter that uses the standard deviation of those pixels within a local box (kernel) surrounding each pixel to calculate a new pixel value. Typically, the original pixel value is replaced with a new value. Unlike a typical low-pass smoothing filter, adaptive filters preserve image sharpness and detail while suppressing noise.

**adjacency effect**  The change in a pixel value caused by photons that reflect off the ground and scatter into the sensor field-of-view; radiance from neighboring pixels affects the measured radiance of a target pixel. The algorithms in the Atmospheric Correction Module in ENVI account for this effect.

**ADRG**  ARC Digitized Raster Graphics; a National Geospatial-Intelligence Agency (NGA) data format.

**aerosol scattering**  Redirection of electromagnetic energy caused by aerosols, which are particles suspended in the atmosphere.

**AIRSAR**  Airborne Synthetic Aperture Radar; a NASA Jet Propulsion Laboratory (JPL) sensor.

**along track**  The imaging direction parallel to the direction that a satellite or aircraft moves.

**alpha residuals**  In hyperspectral analysis, alpha residuals are spectra that are a function of emissivity only. They have a similar shape as emissivity spectra but have a zero mean.

**annotation**  A graphic element added to an image or map composition. Annotation objects include, but are not limited to, symbols, shapes, polylines, text, arrows, scale bars, borders, map keys, declination diagrams, color ramps, images, and plots.

**apparent reflectance**  Reflectance recorded at the sensor; also defined as radiance normalized by solar irradiance. Apparent reflectance is not true reflectance because shadows and directional effects have not been accounted for.

**arbitrary profile**  Also called a transect; a line drawn on an image, whose underlying data values are graphed in a cross-section plot.

**area-based matching**  A method of automatic image-to-image registration that compares the gray scale values of patches of two or more images and tries to find conjugate image locations based on the similarity of the gray scale value patterns.

**ASAR**  Advanced Synthetic Aperture Radar; an ENVISAT sensor.

**ASCII**  American Standard Code for Information Interchange; a simple text format.

**aspect**  The direction (azimuth) that a surface faces, typically in degrees clockwise from North (0 degrees); a parameter used in topographic modeling.
ASTER  Advanced Spaceborne Thermal Emission and Reflection Radiometer; a NASA EOS sensor.

atmospheric correction  A method used to correct sensor radiance for atmospheric effects by mathematically modeling the physical behavior of radiation as it passes through the atmosphere. Following are some atmospheric correction methods available in ENVI:

- **Dark Subtraction**: A method that uses the darkest pixel in a remote sensing image to remove path radiance and scattering effects. The method assumes that each band in an image contains some pixels at or close to a zero brightness value, and that atmospheric effects and path radiance add a constant value to each pixel in a band. Subtracting this constant value from the particular spectra removes the first-order scattering component. Dark subtraction, however, does not account for water vapor and ozone absorption.

- **Empirical Line**: A method that forces image spectra to match reference spectra (field or laboratory) through linear regression.

- **FLAASH**: Fast Line-of-sight Atmospheric Analysis of Spectral Hypercubes; an atmospheric correction modeling tool in ENVI for retrieving spectral reflectance from hyperspectral radiance images. FLAASH incorporates the MODTRAN4 radiation transfer model to compensate for atmospheric effects.

- **Flat Field**: A method that calculates the mean spectra for a region assumed to have no spectral variation. The method divides each pixel spectrum by the Flat Field spectrum.

- **IAR**: Internal Average Reflectance; a method that calculates the mean spectrum for the entire scene. The method divides each pixel spectrum by the scene-average spectrum.

- **QUAC**: Quick Atmospheric Correction; an automated atmospheric correction method in ENVI for retrieving spectral reflectance from multispectral and hyperspectral images.

atmospheric window  A region of the electromagnetic spectrum in which satellites and aircraft cannot acquire measurements because of substances that absorb solar radiation (the most common are water vapor and CO$_2$).

ATSR  Along Track Scanning Radiometer; an ERS-1 and ERS-2 sensor.

attributes  Data that describe the properties of a point, line, or polygon record in a GIS. Attributes are typically stored in table format.

autocorrelation  In multivariate statistics, a measure of correlation among residuals from a regression equation. An autocorrelation ($r$) value of 1.0 or -1.0 indicates a
strong relationship between successive residuals, and a value of 0 indicates no
relationship. In remote sensing, autocorrelation provides an indication of the local
homogeneity of a data set, by evaluating the overall pattern between proximity and
similarity of pixel values.

**AVHRR**  Advanced Very High Resolution Radiometer (NOAA).

**AVIRIS**  Airborne Visible/Infrared Imaging Spectrometer (NASA/JPL).

**band**  A discrete portion of the electromagnetic spectrum measured by an aircraft or
satellite sensor. Legacy multispectral sensors typically have fewer, wider bands,
while modern hyperspectral sensors have hundreds of bands that each measure a very
narrow range of wavelengths.

**BandMax**  An algorithm developed by the Galileo Group, Inc., used to increase
classification accuracy of targets in hyperspectral analysis. BandMax determines an
optimal set of bands to help separate targets from known background materials.

**Band Math**  An ENVI tool that allows you to define and apply mathematical
expressions to spatial image data, resulting in a new output image.

**band ratio**  The process of dividing one spectral band by another to enhance their
spectral differences and to reduce the effects of topography.

**batch mode**  Performing a linear sequence of ENVI processing tasks in a non-
interactive manner.

**batch mode routine**  An IDL program that includes ENVI library routines to
perform a non-interactive image processing task.

**BIL**  Band-interleaved-by-line; an interleave format that stores the first line of the first
band, followed by the first line of the second band, followed by the first line of the
third band, interleaved up to the number of bands.

**BIP**  Band-interleaved-by-pixel; an interleave format that stores the first pixel for all
bands in sequential order, followed by the second pixel for all bands, followed by the
third pixel for all bands, and so forth, interleaved up to the number of pixels.

**BSQ**  Band-sequential; an interleave format where each line of the data is followed
immediately by the next line in the same spectral band. This format is optimal for
spatial (x,y) access of any part of a single spectral band.

**buffer**  A user-specified extension zone around a point, line, or polygon. In a buffer
zone image, each pixel represents the distance from that pixel to the nearest pixel of
the selected class(es). Pixels that fall beyond a user-specified maximum distance
threshold are set to that maximum distance.
Appendix 9: Glossary

**byte order** The order of bytes in integer, long integer, 64-bit integer, unsigned 64-bit integer, floating-point, double-precision, and complex data types. Following are the two methods of byte order:

- **Host (Intel)**: Least significant byte first (LSF); byte order=0 in the ENVI Header; used in Intel-based (Windows, Linux, MacIntel) platforms.
- **Network (IEEE)**: Most significant byte first (MSF); byte order=1 in the ENVI Header; used in Macintosh and Unix platforms.

**CADRG** Compressed ARC Digitized Raster Graphics; an NGA data format.

**change detection** The process of comparing two or more images acquired at different times.

**CCRS** Canadian Centre for Remote Sensing.

**CIB** Controlled Image Base; an NGA data format.

**classification** The process of assigning pixels of a multispectral image to discrete categories. Following are some popular classification methods available in ENVI:

- **Supervised**: A general technique that uses information derived from a few areas of known identity to classify unknown pixels in the remaining image.
  
  - **Binary Encoding**: A technique that encodes data and endmember spectra into zeros and ones, based on whether a band falls below or above the spectrum mean, respectively.
  
  - **Maximum Likelihood**: Pixels are assigned to the class in which they have the highest probability of being a member.
  
  - **Minimum Distance**: A technique that uses the mean vector of each endmember and calculates the Euclidean distance from each unknown pixel to the mean vector for each class.
  
  - **Spectral Angle Mapper**: An algorithm that determines the spectral similarity between two spectra by calculating the angle between them and treating them as vectors in a space with dimensionality equal to the number of bands.

- **Unsupervised**: An automated technique that searches for natural groups, or clusters, of pixels based on their brightness in several bands. Unlike the supervised method, unsupervised classification does not begin with a predefined set of classes.
  
  - **K-Means**: A technique that calculates initial class means evenly distributed in the data space, then iteratively clusters the pixels into the nearest class using a minimum distance technique.
• **Isodata**: A technique that calculates class means evenly distributed in the data space, then iteratively clusters the remaining pixels using minimum distance techniques.

**clustering** The statistical analysis of a set of pixels to detect their inherent tendency to form clusters in n-dimensional (n-D) measurement space.

**color-infrared composite** Also called CIR, or false-color composite; An image where the near-infrared band (0.76 - 0.9 \( \mu \text{m} \)) is displayed in red, the red band (0.6 - 0.7 \( \mu \text{m} \)) is displayed in green, and the green band (0.5 - 0.6 \( \mu \text{m} \)) is displayed in blue.

**color ramp** An annotation object that shows a gradual transition from one color to another. For a gray scale image, the transition is from the minimum to the maximum gray scale value. For a color image, the color ramp is the distribution of the selected color palette.

**color table** A special lookup table that associates screen brightness values with specific RGB values. For a color image, the output colors consist of different red, green, and blue values. For a gray scale image, the red, green, and blue data values are the same for a given data value.

**color transform** A method used to convert RGB images to a different color space, and vice-versa; by applying a contrast stretch in another color space, you can highlight certain features in an image. Also see data fusion and image sharpening.

**compound widget** In ENVI programming, a predefined widget that ENVI automatically builds for you when you call the appropriate library routine in your user function (see the ENVI Reference Guide for a list of library routines). Each compound widget performs a specific task that is often needed in a custom graphical user interface for image processing.

**confusion matrix** Also called a contingency matrix. A table used to assess classification accuracy and misclassification between categories. The matrix is size \( m \times m \), where \( m \) is the number of classes. The rows in the matrix represent classes that are assumed to be true, while the columns represent classes derived from remote sensing imagery. The matrix also lists errors of commission and omission.

**contour line** A line that follows the same elevation on a topographic map.

**contrast stretch** A method of improving the contrast of a remote sensing image by stretching the original range of digital numbers (DNs) across the full contrast range of the display. Following are the most commonly used stretches in ENVI:

- **Equalization**: Also called a histogram equalization stretch; you select the number of output gray scale classes (bins) to redistribute the data into, based on an image's histogram. The program assigns near-equal numbers of pixels into each bin. This type of stretch greatly enhances the most populated range of
brightness values in the image and automatically reduces the contrast in the very light or very dark parts of an image.

- **Gaussian**: A type of stretch based on a Gaussian curve, centered on a mean DN value that you specify. The range of data values that fall within a given standard deviation (that you specify) of the mean are stretched from 0 to 255.

- **Linear**: A type of stretch that sets a minimum and maximum input value to 0 and 255, respectively. All values in between are linearly aligned to intermediate output values.

- **Square root**: A linear stretch applied to the square root of a histogram.

**convolution** The process of applying a spatial filter on an image, where each pixel is based on a weighted average of coefficients within an $n \times n$ matrix surrounding the pixel (where $n$ is an odd number).

**correlation** A statistical measure of the linear relationship between two data sets. If they vary in the same direction, the correlation is positive; if they vary in the opposite direction, the correlation is negative.

**correlogram** A plot of autocorrelation values at multiple lag distances; a measure of how autocorrelation decreases as distance increases. For example, if you specify a maximum lag distance of 5 pixels, autocorrelation is calculated for lags of 5, 4, 3, 2, and for each pixel's nearest neighbors.

**covariance** A statistical measure of the tendency of two variables to move or vary together; more specifically, the simultaneous deviations of two variables from their means.

**data dimensionality** The number of variables (bands) present in a data set.

**data fusion** The process of displaying two data sets of the same area together in one RGB color composite. The data sets must be registered and resampled so that they have the same orientation, pixel size, and image dimensions. A popular example of data fusion is to apply an HSV color transform to one image, replace the value band with another image, then reverse the color transform. This produces an image that merges the color characteristics of one image with the spatial characteristics of another image.

**datum** A reference point or surface against which position measurements are made, and an associated model of the shape of the earth for computing positions. Different nations and agencies use different datums based on local reference points. Examples include the NAD83 and NAD27.

**decision tree** A classification technique that uses a series of binary decisions to place pixels into classes. Each decision point divides pixels into two classes based on
Getting Started with ENVI

an expression. Then you can divide each new class into two more classes based on another expression, and so on.

**declination diagram** An annotation object that includes any combination of arrows pointing to true north, grid north, and magnetic north.

**delaunay triangulation** An image-to-image warping method that fits triangles to irregularly spaced tie points and interpolates values to the output grid.

**DEM** Digital elevation model; a raster data set where each pixel represents an elevation value.

**density slice** To convert the continuous gray tone of an image into a series of density intervals, or slices, each corresponding to a specific digital range.

**deskew** A preprocessing method used to correct systematic distortions caused by earth rotation and scan skew; these were especially evident in Landsat MSS imagery.

**destripe** A preprocessing method used to remove periodic scan line striping in image data. This type of striping is often seen in Landsat MSS data (every 6th line) and, less commonly, in Landsat TM data (every 16th line).

**DIMAP** Digital Image Map; a SPOT data format.

**display group** A term that refers collectively to the Scroll window, Image window, and Zoom window in ENVI. See “Display Groups” on page 46 for an example.

**display group menu bar** The menu bar in one window of a display group. See “Display Groups” on page 46 for an example.

**DLG** Digital Line Graph; a USGS vector data format.

**DMSP** Defense Meteorological Satellite Program (U.S. Air Force).

**DN** Digital number; also called pixel value.

**DOQ** Digital Orthophoto Quadrangle; a USGS data format.

**DRG** Digital Raster Graphics; a scanned topographic map generated by the USGS.

**DTED** Digital Terrain Elevation Data; an NGA data format.

**DXF** Data Exchange Format; a format for storing vector data in ASCII or binary files.

**dynamic overlay** An ENVI feature that allows you to immediately overlay and toggle (flicker) between two linked images.

**ECW** Enhanced Compressed Wavelet; a proprietary data format developed by Earth Resource Mapping that is primarily intended for aerial imagery.
**eigenvalues** Transformation coefficients in principle components analysis that can be used to determine the percent of total variance explained by each of the principle components.

**eigenvectors** A set of weights applied to band values to obtain principal components; they show the relative contributions of the different original bands to the final principal components bands.

**electromagnetic spectrum** The full spectrum of electromagnetic radiation, extending from short cosmic waves to long radio waves.

**ellipsoid** A smooth mathematical surface that is used to represent the geometric model of the earth. Its axes approximate the dimensions of the earth, rotated around the polar axis. Examples include the Clark ellipsoid of 1866 and the GRS80 ellipsoid.

**emissivity** The ratio of the radiance emitted from an object at a particular wavelength to the radiance that a blackbody would emit at the same temperature and wavelength. An emissivity of 1.0 is a perfect blackbody (a perfect “absorber”). Most earth surface types have emissivities between 0.9 and 1.0.

**endmember** A pure spectrally unique material that occurs in a scene.

**EFFORT** Empirical Flat Field Optimal Reflectance Transformation; an algorithm that “polishes” out noise and errors that may appear in hyperspectral apparent reflectance data, thus improving the accuracy of the data and making apparent reflectance spectra appear more like spectra of real materials.

**ENVI header file** A text file that must accompany an image file and reside in the same directory as the image file. The header file lists required image characteristics such as number of samples, number of lines, number of bands, offset, file type, byte order, data type, and storage order.

**ENVI main menu bar** The main menu that appears when you start ENVI.

**ENVI save files** Binary files that contain the basic ENVI library routines and internal variables required to run ENVI.

**ENVISAT** Environmental Satellite (European Space Agency)

**EOS** Earth Observing System (NASA)

**EOSAT** Earth Observation Satellite Company

**epipolar images** A stereo pair of images in which the left and right image are oriented such that ground control points (GCPs) have the same y-coordinates on both images, thus removing one dimension of variability. Epipolar images are generated based on epipolar geometry and are used to extract a DEM.

**EROS** Earth Resources Observation System.
ERS  European Remote Sensing satellite (European Space Agency).
ESA  European Space Agency.
ESRI® Environmental Systems Research Institute.
ETM+  Enhanced Thematic Mapper; a Landsat-7 sensor.
exterior orientation  In photogrammetry, the process of transforming image coordinates to object (ground) coordinates using ground control points (GCPs).
event handler  IDL code that manages events generated by widgets.
EVF  ENVI vector file; a format that ENVI uses to store vector data, no matter what the input native format is. EVF is the most efficient format for storing and manipulating vector information within ENVI.
feathering  The process of blending the edges of overlapping areas in input images for pixel-based and map-based mosaicking.
feature  Also called spatial feature; A user-defined geographic phenomenon that can be modeled or represented using geographic data sets. Examples include roads, buildings, grasslands, and water bodies.
feature-based matching  A method of automatic image-to-image registration that extracts distinct features from images and identifies features that correspond to one another (by comparing feature attributes and location).
FFT  Fast Fourier Transform; a filter used to transform image data into a complex output image showing its various spatial frequency components.
fiducial marks  A series of four or eight crosshairs placed along the edge of aerial camera film during exposure. The intersection of imaginary lines connecting opposite fiducial marks corresponds to the principal point of the photograph. Fiducial marks are used primarily to orthorectify aerial photographs.
field spectra  Spectra of natural features such as minerals or vegetation, analyzed in the field using a handheld spectrometer. Field spectra are often used as a baseline, or “true” spectra for identification of minerals or vegetation types from hyperspectral remote sensing imagery.
flat binary  A general raster format where data are stored as a binary stream of bytes in BSQ, BIP, or BIL format.
FLAASH  Fast Line-of-sight Atmospheric Analysis of Spectral Hypercubes; a first-principles atmospheric correction modeling tool for retrieving spectral reflectance from hyperspectral radiance images. FLAASH is a separate add-on module in ENVI.
fly-through  A 3D animation along a hypothetical flight path in a 3D SurfaceView.
frame central projection  A modeling scenario used to compute rational polynomial coefficients (RPCs) in frame camera and digital (frame central) aerial photography. This projection has one perspective center, which is collinear in space with its object point and image point.

function  In ENVI programming, a program unit containing one or more IDL statements that returns a value. Functions take the following form:

\[
\text{Result} = \text{FUNCTION\_NAME}(\text{Argument}[,\ \text{Optional\ Argument}])
\]

FWHM  Full width half maximum; an engineering term that pertains to the signal curve of a sensor; in a plot of the measured signal (which approaches a near-Gaussian distribution), the FWHM is the horizontal distance between the two points on the signal curve that are half the maximum value. FWHM is an important measure of the quality of an imaging device and its spectral resolution.

Gain  In ENVI, a value that is multiplied by the pixel value to scale it into physically meaningful units of radiance:

\[
\text{radiance} = \text{DN} \times \text{gain} + \text{offset}
\]

GCP  Ground control point; a point on the ground whose location is known through a horizontal coordinate system or vertical datum. A GCP relates a point in a remote sensing image (x,y) to a geographic point on the earth (latitude/longitude, for example).

GCTP  General Cartographic Transformation Package.

geographic coordinate system  A coordinate system for defining locations on the earth’s surface using a 3D spherical model that includes an angular unit of measure, a prime meridian, and a datum.

géoid  An undulating surface that approximates the shape of the earth and mean sea level throughout the world. The direction of gravity is perpendicular to the géoid at every point. The géoid is the reference surface for surveying and some inertial navigation systems. An example is the OSU91A géoid.

géometrically corrected  An image that has been adjusted to remove geometric distortions caused by lens distortion, sampling rate variation, sensor drift, topographic relief, and other factors.

géoreference  To map a remote sensing image to a known location on the earth, by referencing it to a map projection.

GeoTIFF  A public-domain metadata standard that allows geographic information to be embedded within a TIFF file. Remote sensing software uses the metadata to position the geographic data.

GIS  Geographic information systems.
GLT  Geographic lookup table; a binary file that maps an input pixel to an output pixel based on input geometry information. A GLT file contains integer pixel location values that are sign-coded to indicate if a certain output pixel is “real” or interpolated from nearest-neighbor resampling. The two bands of a GLT file refer to the original sample number and original line number, respectively. You can georeference your data directly from a GLT file.

GPS  Global positioning system.

gray scale  A range of black to white tones as displayed on a monitor or in an image; a gray scale image is created when the red, blue, and green color guns of the monitor are assigned the same value for each pixel.

HDF  Hierarchical Data Format; a data structure developed by the National Center for Supercomputing Applications.

HDF-EOS  Hierarchical Data Format - Earth Observing System; a format used for storing data from NASA EOS sensors that adds geolocation objects (grid, point, and swath) to the HDF format.

hill shade image  A color shaded-relief image created by transforming a color image into HSV color space, replacing the value band with a shaded-relief image, and transforming the color image back to RGB space.

histogram  A plot that shows the frequency of occurrence (along the vertical axis) of individual measurements or data values (along the horizontal axis); a frequency distribution.

HLS  Hue-lightness-saturation color space.

HSV  Hue-saturation-value color space.

hyperspectral  A term used to describe data sets typically composed of 100 to 200 (or more) spectral bands of relatively narrow, contiguous, bands (5 to 10 nm). Hyperspectral imaging creates a large number of images from contiguous regions of the electromagnetic spectrum. This increases sampling of the spectrum (versus multispectral data) and greatly increases the amount of information available to a researcher. Also see imaging spectrometer.

IDL  Interactive Data Language.

IGM  Input Geometry file; an ancillary file that provides map information in two bands: one for x coordinates and another for y coordinates. Many data sets include IGM files in their distribution. An IGM file itself is not georeferenced, but it contains georeferencing information for each original, raw pixel in an image.

IKONOS  A GeoEye high-resolution satellite that produces 1 m panchromatic and 4 m multispectral imagery.
image box  The red box inside a Scroll window that defines the area covered in the Image window. See “Display Groups” on page 46 for an example.

image coordinates Also called pixel coordinates; the location of an image pixel in generic (sample, line) coordinates. Image coordinates always increase (one unit for every pixel) with increasing sample and line number. Also see XSTART and YSTART.

image cube  A color image created from a multispectral or hyperspectral file where the data set is shown with an image represented on the face of a cube and the spectral information of the edge pixels depicted on the other faces.

image sharpening The process of merging a low-resolution color image with a high-resolution gray scale image (with resampling to the high-resolution pixel size).

Image window The window in a display group that displays the image at full resolution. If the image is large, the Image window displays the subsection of the image defined by the Scroll window Image box. See “Display Groups” on page 46 for an example.

imaging spectrometer A sensor designed to collect hyperspectral imagery. Examples include AVIRIS and HyMap. Many spectral images are acquired simultaneously, where each pixel in an image contains a continuous spectrum with typically hundreds of spectral measurements that is used to analyze surface features and atmospheric constituents.

incidence angle In a radar system, the angle defined by the incident radar beam and the vertical (normal) to the intercepting surface. In pushbroom sensors, the along track incidence angle is the angle between the vertical position of the satellite and its forward or backward viewing direction. The across track incidence angle is the angle (in degrees) between the vertical position of the satellite and its side-viewing direction when the sensor is scanning along the side.

interactive user routine In ENVI programming, a user function that performs some type of interactive analysis and is triggered by certain events or user selection. Examples include plot functions, Spectral Analyst functions, user-defined map projection types, user-defined units, user-defined RPC readers, and user move routines.

interior orientation In photogrammetry, the process of transforming scanned image pixel coordinates to image coordinates defined by fiducial marks in the aerial photograph.

interleave A term that refers to how raster image data are stored. See BSQ, BIL, and BIP.

IRS Indian Remote Sensing satellite (Government of India, Department of Space).
**JERS** Japanese Earth Resources Satellite (Japan Aerospace Exploration Agency).

**JITC** Joint Interoperability Test Command; an organization that certifies systems implementing the NITF data format for compliance with NITF standards.

**JPEG** Joint Photographic Experts Group image format.

**JPL** Jet Propulsion Laboratory (NASA).

**kernel** An array of pixels used for digital image filtering or to constrain an operation to a subset of pixels.

**laboratory spectra** Spectra of materials (such as minerals or vegetation types) measured with a spectrometer in a controlled laboratory environment. Laboratory spectra are often used as a baseline, or “true” spectra for identification of materials from hyperspectral remote sensing imagery.

**Lambertian** A surface that emits or reflects radiation isotropically, according to Lambert’s law; a perfectly diffusing surface; the brightness (luminance, radiance) of a lambertian surface is constant regardless of the angle from which it is viewed.

**LAS** A binary data format that contains LIDAR point data records.

**layer stacking** The process of building a multi-band file from georeferenced images of various pixel sizes, extents, and projections. The output file has a geographic extent that either encompasses all of the input file extents or encompasses only the data extent where all of the files overlap.

**library routines** IDL programs that encompass nearly all of the functionality in ENVI. The *ENVI Reference Guide* contains a complete index and full reference page for each library routine.

**LIDAR** Light detection and ranging; a technology that determines distance to an object or surface by measuring the time delay between a laser pulse transmission and detection of the return signal.

**line central projection** A model used to compute rational polynomial coefficients (RPCs) in imagery from pushbroom sensors and line central aerial photography. Each scan line has its own projection center.

**line of sight** A spatial analysis tool that determines which pixels can be seen from a specific pixel within any file that has an associated DEM; topographic features will obscure some pixels from view.

**line** The y component of a raster image coordinate pair (x,y); same as row.

**logarithmic residual** An input spectrum divided by the spectral geometric mean (the mean of all bands for each pixel) of a data set, which is then divided by the spatial geometric mean (the mean of all pixels for each band). Logarithmic residuals
are used to remove solar irradiance, atmospheric transmittance, instrument gain, topographic effects, and albedo effects from radiance data.

**LUT** Lookup table; a static table that associates an image pixel value with a specific screen brightness value; used for contrast-stretching an image.

**majority analysis** A post-classification tool used to change spurious pixels within a large single class to that class. You specify a kernel size, and the center pixel in the kernel is replaced with the class value represented by the majority of the pixels in the kernel.

**map projection** A mathematical method of representing the earth on a flat plane. Hundreds of map projections are available to satisfy various project requirements (accurate distance, accurate navigation, equal area, etc.)

**MAS** MODIS Airborne Simulator (NASA).

**mask** An image consisting of zeros and ones that, when applied to another image, tells ENVI which pixels in that image to analyze (ones) and which pixels to ignore (zeros). A mask is useful, for example, if you want to calculate image statistics while ignoring missing data values.

**MERIS** Medium Resolution Imaging Spectroradiometer; an ENVISAT sensor.

**meta file** A virtual file in ENVI that is essentially a combination of image files or bands treated as the same input file. An ENVI meta file is a text file with names and locations of files on disk. When you select the meta file for input or processing, ENVI retrieves the image data from the individual disk files and treats them as if they were part of the same input file for processing.

**minority analysis** A post-classification tool where you enter a kernel size, and the center pixel in the kernel is replaced with the class value represented by the minority of the pixels in the kernel.

**MNF rotation** Minimum Noise Fraction; a transform used to determine the inherent dimensionality of image data, to segregate noise from the data, and to reduce the computational requirements for subsequent processing. MNF rotation consists of two principal component transformations, with a noise whitening step.

**MODIS** Moderate Resolution Imaging Spectroradiometer; a NASA EOS sensor aboard the Aqua and Terra satellites.

**MODTRAN** An atmospheric radiative transfer model developed by the Air Force Research Laboratory that predicts path radiances and transmissions through the atmosphere and can be used to describe vertical profiles of water vapor, ozone, and aerosols. The FLAASH module uses MODTRAN code.
**morphological filter**  A filter based on mathematical morphology that changes the shape and connectivity of an object. Unlike a convolution filter that multiplies neighborhood pixels by values you specify within a kernel, a morphological filter only works with the data in the neighborhood itself and uses either a statistical method or mathematical formula to modify the pixel upon which it is focused. The most common morphological filters are dilation, erosion, opening, and closing.

**mosaic**  A set of overlapping aerial or satellite-based images whose edges are matched to form a continuous pictorial representation of a portion of the Earth's surface.

**MPEG**  Moving Picture Experts Group; a data format for digital audio and video.

**MRLC**  Multi-Resolution Land Characteristic; a Landsat TM and DEM data format.

**MSS**  Multispectral Sensor; a Landsat sensor.

**multiband file**  A digital image that contains more than one band of data.

**multilooking**  A method for reducing speckle noise in synthetic aperture radar (SAR) data and for changing the size of a SAR file by averaging neighboring pixels throughout the image.

**multispectral**  The ability of a remote sensing instrument to detect wavelengths in two or more spectral bands.

**nadir**  The point on the ground that lies vertically beneath the perspective center of the aerial camera lens or satellite sensor.

**NDVI**  Normalized Difference Vegetation Index; a vegetation index used to transform multispectral data into a single image band whose values indicate the amount of green vegetation present in the pixel. ENVI uses the standard NDVI algorithm, where NIR is a near-infrared band:

\[
NDVI = \frac{(NIR - Red)}{(NIR + Red)}
\]

**NITF**  National Imagery Transmission Format.

**NLAPS**  National Landsat Archive Production System; a Landsat TM and MSS data format.

**NMEA**  National Marine Electronics Association data format; the NMEA-0183 format is commonly used with a GPS.

**NOAA**  National Oceanic and Atmospheric Administration.

**normalize**  To transform a set of measurements so they may be compared in a meaningful way. Normalization commonly refers to rescaling minimum and maximum values between two or more data sets so all of the values range from 0 to 1, allowing the data sets to be directly compared.
NSIF  NATO Secondary Image Format; a data format similar to NITF that is used by members of the North Atlantic Treaty Organization (NATO).

object  A region of interest with spatial, spectral, and/or texture characteristics (brightness, color, etc.) that define the region.

object-based processing  Techniques that classify a set of input objects rather than classifying pixels individually.

offset  In the context of remote sensing:
- A correction value added to or subtracted from every pixel in an image, typically by using image arithmetic (Band Math in ENVI).
- A variable added to the gain in a regression equation for sensor calibration.
- The number of bytes of embedded header information present in the file (ENVI skips these bytes when reading the file).

OLS  Operational Linescan System; a NOAA DMSP data format.

orthorectify  To remove the effects of radial relief displacement and imaging geometry from remote sensing imagery.

panchromatic  A sensor that detects electromagnetic energy in one very broad band, which includes most of the visible light spectrum. In aerial photography, panchromatic refers to a type of film that is sensitive to all wavelengths of visible light.

PDS  Planetary Data System data format.

pedestal height  The height of a polarization signature (above 0), calculated by averaging the following four polarization combinations from SAR data:

<table>
<thead>
<tr>
<th>Orientation (degrees)</th>
<th>Ellipticity (degrees)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>-45</td>
</tr>
<tr>
<td>90</td>
<td>-45</td>
</tr>
<tr>
<td>0</td>
<td>45</td>
</tr>
<tr>
<td>90</td>
<td>45</td>
</tr>
</tbody>
</table>

Table 9-1: Polarization Combinations

phase image  An image derived from polarimetric SAR data whose values represent the phase difference between the horizontal and vertical polarizations. The phase
difference is measured in either radians or degrees and ranges from -π to π, or -180 degrees to 180 degrees.

PICT  Windows QuickDraw Picture format.

pixel-based processing  The traditional approach to exploitation and classification where each pixel in an image is treated as an independent data point.

Pixel Purity Index  A tool used to find the most spectrally pure (extreme) pixels in multispectral and hyperspectral images. These typically correspond to mixing endmembers. The PPI is computed by repeatedly projecting n-D scatter plots on a random unit vector. ENVI records the extreme pixels in each projection (those pixels that fall onto the ends of the unit vector) and it notes the total number of times each pixel is marked as extreme. A Pixel Purity Image is created where each pixel value corresponds to the number of times that pixel was recorded as extreme.

plot function  In ENVI programming, a user function that you can add to and call from the Plot_Function menu of any ENVI plot window.

PNG  Portable Network Graphics image format.

polarization signature  A plot of radar backscattered power as a function of ellipticity and orientation angles of the incident radar wave.

doline  A continuous line composed of one or more segments; a vector and annotation object.

polynomial function  A mathematical function with the following form:

\[ f(x) = a_n x^n + a_{n-1} x^{n-1} + \ldots + a_1 x + a_0 \]

Where:

- \( n \) is a nonnegative integer
- \( a_n, a_{n-1}, \text{ etc.} \) are coefficients.

The degree of the polynomial function is the highest value for \( n \), where \( a_n \) is not equal to 0.

principal components analysis  A mathematical technique that transforms a multivariate data set into a new coordinate system such that the axes, or principal components, of the new coordinate system are uncorrelated. In remote sensing, an image is created for each principal component. Because the principal component rotation maximizes the variance in the first few principal components bands, these bands usually contain most of the coherent image information and can be used to isolate features in the data.
procedure  In ENVI programming, a sequence of one or more IDL statements that you can assign a name (thus creating an IDL program), compile, and call from the IDL or ENVI command line, using the following form:

    PROCEDURE_NAME, Argument [, Optional_Argument]

projected coordinate system  A coordinate system that uses Cartesian coordinates (x,y) to describe a geographic location.

pushbroom sensor  Also called an along-track scanner; a sensor with a line array of small, sensitive detectors stacked side-by-side, where each detector corresponds to a pixel in the resulting image. As the satellite advances along the ground track, the array of detectors receives radiation simultaneously. Examples of pushbroom sensors include ASTER, IKONOS, OrbView-3, QuickBird, SPOT, and CARTOSAT-1.

pyramid layers  Copies of a data set at various reduced resolutions. They are used to speed image display by reducing the resampling required when displaying large portions of an image at low resolution.

QUAC  Quick Atmospheric Correction; an automated atmospheric correction method in ENVI for retrieving spectral reflectance from multispectral and hyperspectral images.

QuickBird  A Digital Globe high-resolution satellite that provides 61 cm panchromatic and 2.4 m multispectral imagery.

QuickMap  An ENVI feature that allows you to quickly create a map composition from an image. You can add grid lines, scale bars, titles, north arrows, declination diagrams, and logos. You can save your settings as a QuickMap template that you can use with other images.

Quorum  A type of receiving station that creates AVHRR 16-bit High Resolution Picture Transmission (HRPT) files with two header frames. The Quorum format does not have georeferencing information.

RADARSAT  Radar Satellite (Canadian Space Agency).

radiance  A measure of the amount of electromagnetic radiation leaving a point on the surface. More precisely, it is the rate at which light energy is emitted in a particular direction per unit of projected surface area. The standard unit is W/m². Most remote sensing devices directly measure radiance.

raster  A grid-based data structure for storing images where each cell, or pixel, contains a single data value.

reflectance  The ratio of radiant energy reflected by a body to the energy incident on it, usually denoted as a percentage.
**region** A broad term that refers to a group of pixels with the same spatial or spectral characteristics.

**register** To geometrically align two or more images of the same scene so the images can be superimposed. The images can come from different viewpoints, different times, and different sensors. Following are the two most common methods of registration:

- **Image-to-image registration**: Correct a reference (warped) image to match base image geometry, using tie points between the two images.
- **Image-to-map registration**: Assign a reference image to geographic coordinates, using GCPs with known ground locations.

**resample** To apply a geometric transformation to an original data set; more specifically, the interpolation method used to derive output pixel values based on input pixel values, taking into account the computed distortion. Following are the most common resampling methods:

- **Nearest neighbor**: Each pixel in the output image receives its value from the nearest pixel in the input (reference) image.
- **Bilinear**: Each estimated pixel value in the output image is based on a weighted average of the four nearest neighboring pixels in the input image.
- **Cubic convolution**: Each estimated pixel value in the output image is based on a weighted average of 16 nearest neighboring pixels in the input image. Cubic convolution is the slowest method, but it yields the smoothest results.

**RGB** A color space defined by red, green, and blue values.

**RGB color composite** An image that uses the red, green, and blue guns of the display device to form a color additive representation of color.

**ROC curve** Receiver operating characteristic; a curve used to visualize the performance of a classification method, in order to select the proper decision threshold. ROC curves compare a series of rule image classification results for different threshold values with ground truth information.

**ROI** Region of interest; a point, polyline, or polygon object drawn on an image, used to define a specific area of interest for extracting classification statistics, masking, and other operations in ENVI. From a processing standpoint, ROIs are pixel addresses with associated data.

**RMS error** Root mean square error; a statistical measure that represents the difference between measured and predicted data points. In ENVI, RMS error is often used to evaluate a set of GCPs for georeferencing:
Appendix 9: Glossary

\[ \text{RMS}_{\text{error}} = \sqrt{(x' - x)^2 + (y' - y)^2} \]

Where:
- \( x \) and \( y \) are the original row and column coordinates
- \( x' \) and \( y' \) are the estimated coordinates

**routine**  A general IDL programming term that refers to both functions and procedures.

**RPC**  Rational polynomial coefficients; used to build interior and exterior orientation in photogrammetry.

**RSM**  Replacement sensor model; an alternate representation of sensor geometric information that corrects the deficiencies of RPC-based sensor models. RSM contains a variety of enhancements over the RPC model, including:
- Increased accuracy over images with large number of rows or columns (such as image strips) by breaking the image into tiles with separate models.
- The ability to store varying degrees of complexity in the polynomial representation used.

**RST**  Rotation, scaling, and translation; a warping method used in image registration that uses an affine transformation with at least three ground control points:
\[
\begin{align*}
  x &= a_1 + a_2X + a_3Y \\ 
  y &= b_1 + b_2X + b_3Y
\end{align*}
\]

**rule image**  An image calculated for each ROI in a supervised classification. They are called “rule images” because a rule is applied to the pixel values in the images to determine the class to which each pixel should be assigned. The pixel values in the rule images, and the rule used to assign classes, depend on the specific classifier used. For example, with Maximum Likelihood classification, the pixel values in a rule image for one class are equal to the likelihood that each pixel belongs to that class. Whichever rule image has the highest likelihood value for a pixel is the class to which that pixel is assigned.

**RXD**  Reed-Xiaoli anomaly detection algorithm.

**sample**  The x component of a raster image coordinate pair \((x,y)\); same as column.

**SAR**  Synthetic aperture radar.

**scale factor**  A division factor used to convert integer-scaled reflectance or radiance data into floating-point values. For example, for reflectance data scaled into the range
of 0 to 10,000, set the scale factor to 10,000. For uncalibrated integer data, set the scale factor to the maximum value the instrument can measure \((2^n - 1\), where \(n\) is the bit depth of the instrument).

**scatter plot**  A plot of measurements from two or more bands of data.

**Scroll window**  The window in a display group that displays the full image at subsampled resolution. This window appears only when an image is larger than what ENVI can display in the Image window at full resolution. See “Display Groups” on page 46 for an example.

**SeaWiFS**  Sea-viewing Wide Field-of-view Sensor; a NASA satellite that collects global ocean color data.

**segmentation**  The process of partitioning an image into connected regions by grouping neighboring pixels with similar feature values (brightness, texture, color, etc.). These segments ideally correspond to real-world objects.

**semivariance**  A statistic that uses the squared difference between neighboring pixel values to provide a measure of dissimilarity within a dataset. It has the same units as the input dataset, and its values are greater than or equal to 0.

**semivariogram**  A plot of semivariance values at multiple lag distances; a measure of how autocorrelation decreases as distance increases.

**shaded relief**  An image created during the topographic modeling process that renders terrain in 3D by use of graded shadows that would be cast by the sun from a northwest direction.

**shapefile**  A vector file format; a set of files that contain points, arcs, or polygons that hold tabular data and a spatial location. One shapefile consists of three individual files, ending with .shp, .shx, and .dbf file extensions.

**shift difference**  The process of differencing adjacent pixels to the right and above each pixel and averaging the results to obtain the noise value to assign to the pixel being processed. The best noise estimate is gathered using the shift-difference statistics from a homogenous area rather than the whole image.

**Sigma nought**  A measure of the mean backscatter of a radar signal from an area of 1 m² on the earth's surface, typically denoted in decibels (dB). Sigma nought describes the backscattering strength of a distributed target, rather than a discrete target.

**SIR-C**  A synthetic aperture radar (SAR) instrument built by NASA/JPL and Ball Communication Systems Division for NASA. SIR-C flew aboard the Space Shuttle and provided L-band and C-band measurements.
Appendix 9: Glossary

slope The percentage or degree change in elevation over distance; a parameter used in topographic modeling.

SMACC Sequential Maximum Angle Convex Cone; a sub-pixel spectral tool in ENVI that finds spectral endmembers and their abundance throughout an image.

smooth To average pixel values within adjacent areas to produce more gradual transitions.

solar azimuth The angle a horizontal projection of a direct ray from the sun makes with the True North-south axis, typically denoted as clockwise from True North through 360 degrees.

solar elevation The angle of the sun above the horizon, extending from 0 degrees (horizon) to 90 degrees (directly overhead).

solar spectrum The part of the electromagnetic spectrum occupied by the wavelengths of solar radiation. About 99 percent of solar radiation is constrained to 300 nm (ultraviolet) to 3,000 nm (near-infrared).

spatial filter A filter that removes certain spatial frequencies from an image and enhances features in the remaining image. Following are the most popular types of spatial filters:

- **High pass**: Enhances high spatial frequencies. Following is a sample 3 x 3 kernel used for high-pass filters:
  
  \[
  \begin{bmatrix}
  -1 & -1 & -1 \\
  -1 & 9 & -1 \\
  -1 & -1 & -1 
  \end{bmatrix}
  \]

- **Low pass**: Enhances low frequencies in an image, thus smoothing the image. Following is a sample 3 x 3 kernel used for low-pass filters:
  
  \[
  \begin{bmatrix}
  1 & 1 & 1 \\
  1 & 1 & 1 \\
  1 & 1 & 1 
  \end{bmatrix}
  \]

- **Edge enhancement**: Enhances edges of features in an image, making them easier to analyze. Following is a sample 3 x 3 kernel used for edge enhancement filters:
  
  \[
  \begin{bmatrix}
  1 & 1 & 1 \\
  1 & -2 & 1 \\
  -1 & -1 & -1 
  \end{bmatrix}
  \]
spatial profile  A plot of pixel values along a line placed in the image.

spatial resolution  A measure of the smallest angular or linear separation between two objects that a sensor can resolve.

Spectral Analyst function  In ENVI programming, a user function that implements a custom spectral mapping method to match an unknown spectrum to the materials in a spectral library. You can add this user function to ENVI's Spectral Analyst and call it from the ENVI menu system.

spectral library  A collection of spectra measured in the field or laboratory for materials (minerals, vegetation types, etc.) that are often used as a baseline, or “true” spectra, for identification of materials from spectral remote sensing imagery.

Spectral mapping method  Also called a spectral similarity technique; a method in hyperspectral analysis for matching image spectra to known (reference) spectra, usually from a spectral library. Following are descriptions of the spectral mapping methods used in ENVI.

- **Binary Encoding**: A method that encodes data and endmember spectra into zeros and ones, based on whether a band falls below or above the spectrum mean, respectively.

- **Linear Spectral Unmixing**: A sub-pixel method that determines the relative abundance of materials depicted in multispectral or hyperspectral imagery based on the materials' spectral characteristics.

- **LS-Fit**: A linear band prediction method that uses least-squares fitting. You can use it to find regions of anomalous spectral response in a dataset. It calculates the covariance of the input data and uses it to predict the selected band as a linear combination of the predictor bands plus an offset.

- **Matched Filtering**: A method that finds the abundance of user-defined endmembers using a partial unmixing technique. Matched filtering maximizes the response of a known endmember and suppresses the response of the unknown background, thus matching the known signature. It provides a rapid means of detecting specific materials based on matches to library or image endmember spectra and does not require knowledge of all the endmembers within an image scene.

- **Mixture Tuned Matched Filtering (MTMF)**: A method that performs Matched Filtering and adds an infeasibility image to the results. The infeasibility image is used to reduce the number of false positives that are sometimes found when using Matched Filtering.

- **Spectral Angle Mapper (SAM)**: A physically-based spectral classification method that uses an n-D angle to match pixels to reference spectra. The
algorithm determines the spectral similarity between two spectra by calculating the angle between the spectra and treating them as vectors in a space with dimensionality equal to the number of bands.

- **Spectral Feature Fitting (SFF)**: A method that compares the fit of image spectra to reference spectra using a least-squares technique. SFF is an absorption-feature-based methodology. The reference spectra are scaled to match the image spectra after the continuum is removed from both data sets.

**Spectral Math**  An ENVI tool that allows you to apply mathematical expressions or IDL procedures to spectra and to selected multiband images, as long as the number of bands and spectral channels match.

**spectral profile**  see Z Profile.

**Spectral Hourglass Wizard**  A tool in ENVI that takes you through a step-by-step process for locating spectral endmembers within a hyperspectral data set and mapping their locations and sub-pixel abundances. When written in a certain format, the processing flow resembles an hourglass shape. See Spectral Hourglass Wizard in the ENVI User’s Guide for a diagram of the hyperspectral processing flow.

**spectral resolution**  The wavelength range that a particular band measures. For example, Landsat-7 ETM+ Band 1 detects wavelengths from 0.45 μm to 0.52 μm. The Landsat-7 ETM+ panchromatic band detects wavelengths from 0.50 μm to 0.90 μm. So, Band 1 has a finer spectral resolution than the panchromatic band. Spectral resolution does not refer to the number of bands available from a particular sensor.

**SPOT**  Satellite Pour l’Observation de la Terra; a series of earth observation satellites launched by Spot Image of France; the spatial resolution of SPOT data varies from 2.5 to 20 m.

**SRF**  Spectral response function; engineering data that quantify the spectral response and sensitivity of detectors on an airborne or satellite sensor. The term SRF also refers to a data format that contains SRF data for particular sensors.

**SRTM**  Shuttle Radar Topography Mission (NASA/JPL).

**statistics**  Numbers or values that help describe the characteristics of a selected group of data.

**stretch**  See contrast stretch.

**subsample**  To create an output image of reduced resolution based on every nth pixel from an input image.

**super GLT**  A geographic lookup table (GLT) file that contains information about how many and which input pixels contribute to the output pixel; a super GLT is not an image file.
synthesize  With respect to polarimetric radar data, the process of building an image representing backscatter at specified ellipticity and orientation angles from a scattering (or related) matrix.

system calibration  The process of converting digital numbers (DNs, which represent the sensor response) in a remote sensing image to radiance or reflectance above the atmosphere, using pre-launch gain and offset values.

temporal resolution  How often a sensor obtains imagery of a particular area.

texture  The frequency of change and spatial arrangement of pixel values in an image, as a function of spatial scale. A flat image in which all digital numbers (DNs) are equal is said to have a uniform texture.

texture filter  A filter used to delineate surface features (for example, biophysical properties of a forest canopy) that cause local variations in image brightness. A texture filter is helpful for identifying objects that are more characterized by their texture than by intensity.

thermal band  A band that detects radiation from the far infrared part of the electromagnetic spectrum, between approximately 7.0 to 15 μm. A thermal band detects emitted, rather than reflected, radiation from the earth.

threshold  A value above which a process is performed and below which it will not be performed. For example, you can specify a change threshold of 50 percent in a K-Means supervised classification, which means the clustering process ends when the number of pixels in each class changes by 50 percent or less.

tie points  The location of a single feature across two overlapping images, used in image-to-image registration.

TIFF  Tagged Image File Format.

tile  For ENVI to process images that are much larger than the total amount of RAM available on the system, large images are broken into pieces that are small enough for the system to handle. Each piece is called a tile. When the image is processed, only one tile is read into memory at a time.

TIMS  Thermal Infrared Multispectral Scanner; a NASA/JPL and Daedalus Enterprises sensor.

TM  Thematic Mapper; a Landsat sensor.

TOPSAR  Topographic Synthetic Aperture Radar; a NASA/JPL airborne radar interferometer.

transform  An image processing operation that changes data to another data space, usually by applying a linear function. The goal of most transforms is to improve the
presentation of information. Transformed images are often more easily interpreted than the original data.

**true-color composite**  An image where the red band (0.6 μm to 0.7 μm) is displayed in red, the green band (0.5 μm to 0.6 μm) is displayed in green, and the blue band (0.4 μm to 0.5 μm) is displayed in blue.

**user-defined RPC reader**  In ENVI programming, a user function that reads a custom rational polynomial coefficients (RPC) file format. You can add the user function to, and call it from, the **Generic RPC** menu option in ENVI.

**user function**  A custom program that you can write in IDL, C, Fortran, or another high-level programming language that performs an interactive ENVI processing task. If you write a user function in IDL, you can incorporate ENVI library routines into the code and call the user function from the ENVI menu system to run it.

**USGS**  United States Geological Survey.

**UTD**  Uniform Target Detector; an anomaly detection algorithm in which the anomaly is defined using \((1 - \mu)\) as the matched signature, rather than \((r - \mu)\). UTD and the RXD algorithm work exactly the same, but instead of using a sample vector from the data (as with RXD), UTD uses the unit vector. UTD extracts background signatures as anomalies and provides a good estimate of the image background.

**UTM**  Universal Transverse Mercator map projection; a system of plane coordinates based upon 60 north-south zones, each 6 degrees of longitude wide, that circle the earth. UTM coordinates consist of the Zone number, an easting (distance in meters or kilometers east of the western edge of the Zone), and a northing (distance in meters or kilometers from the equator).

**vector**  A data structure for storing spatial data that consists of points, lines, and polygons. Lines (also called arcs) are defined by beginning and end points, which meet at nodes. The locations of these nodes and the topological structure are usually stored explicitly.

**vegetation index**  A measure of some vegetation property calculated from reflected solar radiation measurements made across the optical spectrum (400 to 3,000 nm). A vegetation index is constructed from reflectance measurements in two or more wavelengths to analyze specific characteristics of vegetation, such as total leaf area and water content. See ENVI Help for the names and definitions of each vegetation index calculated in ENVI.

**vertical exaggeration**  The process of multiplying all of the elevation values in a DEM by a scale factor to exaggerate the landscape's relief when viewed in a 3D perspective.
virtual border  An annotation object that consists of a temporary border around an image displayed in ENVI. You can enter the border width (in pixels) and place other annotation objects within the virtual border.

Virtual Mosaic  A saved mosaic template used as an alternative to saving a mosaic to disk. When you restore a Virtual Mosaic template file, ENVI opens the individual image files that make up the mosaic and puts them together on the fly. You can display a Virtual Mosaic file in ENVI and annotate it, stretch it, etc., like any other image. Using a Virtual Mosaic prevents multiple files from containing the same images and therefore saves disk space.

warp  To stretch an image to fit its ground control points (GCPs), so that distance and area are uniform in relationship to real-world measurements. ENVI performs warping with rotation, scaling, and translation (RST); polynomial, or Delaunay triangulation.

wavelength  Velocity divided by frequency of an electromagnetic wave. In general, the mean distance between maxima or minima of a roughly periodic wave pattern.

widget  A simple graphical object such as a push button or slider, created in IDL, that allows user interaction with a pointing device (usually a mouse) and a keyboard. You can construct and manipulate graphical user interfaces in IDL using widgets.

WorldView-1  A Digital Globe high-resolution satellite that provides 50 cm panchromatic imagery.

WorldView-2  A Digital Globe high-resolution satellite that provides 46 cm panchromatic imagery.

X Profile and Y Profile  A cross-section of data along the x-axis, and y-axis, of an image, respectively. X and Y Profiles are also called horizontal and vertical profiles, respectively.

XWD  X Windows Dump

XSTART and YSTART  Variables in an image header file that define the image coordinates for the first pixel in the image. For most images, ENVI sets the default XSTART and YSTART values to 1, defining the first pixel in an image with a coordinate of (1,1). Thus, if the image were an IDL 2D array variable, the data contained in subscript position [0, 0] correspond to image coordinates (1,1). If XSTART or YSTART are set to any other values (including negative numbers or 0), the image coordinates begin incrementing from these values.

Z Profile  A spectrum plot of the pixel under the cursor, through all bands of the image.

Zoom box  The red box inside an Image window that defines the extent of the Zoom window. See “Display Groups” on page 46 for an example.
Zoom window  The window in a display group that displays the subsection of the image defined by the Image window Zoom box. The resolution is at a user-defined zoom factor based on pixel replication or interpolation. See “Display Groups” on page 46 for an example.
Index

A

add-on modules, 16
ArcMap
  exporting image files to, 41
  exporting vector layers to, 62
ASCII
  output from DEMs, 172
  output from images, 171
available bands list, 39
  closing files, 42
  color composites, 109
  displaying images, 107
  folding and unfolding datasets, 40
  gray scale images, 108
  hiding and showing, 43
  locating bands by wavelength, 45
  opening files, 41
  opening files in ENVI Zoom, 42
  right-click menus, 44
  true-color and color-infrared images, 109
available files list, 162
  editing ENVI header, 163
  opening new files, 163
available vectors list, 61
  editing layer names, 63
  opening files, 62
  opening vectors in ENVI Zoom, 62
  saving layers, 64
  starting new vector windows, 63
  supported data types, 61

B

BIL format, 29
Index

BIP format, 29
blocking IDL command line, 186
BSQ format, 29

C
color buttons, 135
color composite images, 109
color-infrared images, 109
colors	editing system preferences, 182
prevent color flashing, 193
combining bands, 168
compressing output, 141
contacting ITT, 21
copyrights, 2
crosshair cursor, 54
cross-platform file portability, 32
cursors
crosshair, 54
custom development services, 22
customizing
See also programming in ENVI.
color flashing, 193
display group menu bars, 194
ENVI configuration files, 194
ENVI main menu bars, 194
fonts on UNIX, 192
multiple Windows PC users, 188
platform dependencies, 191
pseudocolor, 193
right-click menus, 195
SCSI tape support, 192
UNIX, 189
window auto-placement, 192

D
data types
changing in ENVI header, 125
DDF format, 103
default output directories, 176
DEMs
output to ASCII, 172
DGN format, 103
dialog components, 134
display groups, 46
hiding zoom and scroll windows, 50
maximizing, 49
opening new, 48
output options, 173
positioning zoom and scroll windows, 49
preferences, 181
resizing, 48
scroll bars, 49
DLG format, 103
drop-down buttons, 134
drop-down lists, 134
DXF format, 103

E
e00 format, 103
ENVI + IDL licenses, 11
ENVI configuration files, 194
ENVI header file, 114
changing data types, 125
creating, 123
cross-platform portability, 32
editing, 127
format
required parameters, 125
ENVI image format, 29
output, 168
ENVI licenses, 11
ENVI vector files. See EVF
EVF, 103
exiting ENVI, 28
external file formats, 101
F
favorite servers, 98
file formats, 33
  ASCII
    file types (filetype.txt), 128
    sensor types (sensor.txt), 130
ENVI images, 29
  supported
    input, 33
    output, 35
file management
  available files list, 162
  closing all files, 163
  opening files, 81
  saving images, 168
file naming conventions, 31
  cross-platform portability, 32
  extensions, 31
file types, 128
finding windows, 56
folding datasets, 40
fonts
  setting for UNIX, 192

G
geodatabases, 86
  connecting to enterprise, 96
  opening, 97
  refreshing, 94
  retaining display enhancements when saving, 65
  saving, 64
  glossary, 199
graphics colors, 182
gray scale images, 108

H
headers

See also ENVI header file

I
IAS servers, 85
  connecting, 96
  summary, 85
IDL, 11
  command line blocking, 186
  exporting variables, 197
  importing variables, 196
  newsgroup, 23
image windows, 46
  crosshairs, 54
  displaying scroll bars, 49
  maximizing, 49
  mouse button functions, 76
  opening new, 48
  positioning zoom and scroll windows, 49
  resizing, 48
images, 82
  displaying, 107
  ENVI format, 29
  opening files, 82
  saving, 168
  saving display groups, 173
  increase/decrease buttons, 135
input file dialogs, 136
input file formats, 33
interactive analysis tools
  pixel locator, 149
interleaving
  BIL, 29
  BIP, 29
  BSQ, 29
JPEG 2000 format, 85
  servers, 85
| JPIP servers, 85 |
| connecting, 96 |
| summary, 85 |

| L |
| legalities, 2 |
| licensing |
| ENVI, 11 |
| ENVI + IDL, 11 |
| ENVI modules, 16 |

| M |
| menus, 38 |
| definition files, 194 |
| meta files, 170 |
| MIF format, 103 |
| modules, 16 |
| Atmospheric Correction, 16 |
| DEM Extraction, 16 |
| FLAASH, 16 |
| NITF/NSIF, 17 |
| QUAC, 16 |
| mouse buttons, 75 |
| emulating on Macintosh, 75 |
| image windows, 76 |
| plot windows, 79 |
| scroll windows, 77 |
| vector windows, 78 |
| zoom windows, 76 |

| O |
| OGC servers, 84 |
| connecting, 96 |
| keywords, 88 |
| summary, 84 |
| WCS, 84 |
| WMS, 84 |
| opening files |
| external, 101 |
| images, 82 |
| ENVI format, 29 |
| previous, 102 |
| spectral libraries, 106 |
| vectors, 103 |
| output |
| directories, 176 |
| display options, 173 |
| file vs. memory, 139 |
| printing, 174 |
| output formats, 35 |
| ASCII, 171 |
| ENVI images, 29, 168 |
| ENVI meta files, 170 |
| supported types, 35 |
| overlays |
| ROIs |

| P |
| pixels, 149 |
| locations, 149 |
| platform dependencies, 191 |
| plots, 73 |
| closing, 74 |
| mouse button functions, 79 |
| new windows, 74 |
| output options, 173 |
| windows, 73 |
| preferences, 178 |
| colors, 182 |
previous files
  opening, 102
printing, 174
processing status, 147
  windows, 147
Professional Services Group, 22
pseudocolor in UNIX, 193

R
radio buttons, 134
reduced resolution data sets
regions of interest. See ROIs
remote datasets, 83
  authentication, 90
  connecting directly to JPIP, IAS, OGC datasets, 86
  connecting to servers and geodatabases, 91
  connection properties, 96
  editing properties, 95
  favorites, 98
  managing, 91
  specifying URLs, 96
RGB, 109
  displaying images, 109
ROIs
  Rsets. See reduced resolution data sets

S
saving
  See also output formats.
  data to IDL variables, 197
  images, 168
scripts
  saving sessions, 27
  startup, 26
scroll bars, 49
scroll windows, 46, 55
  controlling, 55
  hiding, 50
  meta zoom, 56
  mouse button functions, 77
  positioning, 49
  resizing, 48
SCSI tape support, 192
sensor types, 130
SHP format. See shapefiles
spectral libraries
  opening files, 106
starting ENVI, 26
startup scripts, 26
  format, 26
  saving sessions, 27

T
technical support, 21
toggle buttons, 135
trademarks, 2
training, 22
true-color images, 109

U
uncompressing files, 141
unfolding datasets, 40
UNIX
  preventing color flashing, 193
  pseudocolor, 193
  setting fonts, 192
  window auto-placement, 192

V
vector windows, 68
  cursor tracking, 71
  mouse button functions, 78
  opening new, 63
  panning, 71
starting new, 71
zooming, 71
vectors
   available vectors list, 61
layers
   editing names, 63
   saving, 64
opening files, 103
output types, 173

W
wavelengths
   locating bands, 45
WCS servers, 84
   connecting, 96
   summary, 84
windows
   See also display groups.

auto-placement on UNIX, 192
finding, 56
plot, 73
processing status, 147
vector, 68
WMS servers, 84
   connecting, 96
   summary, 84

Z
zoom windows, 46
   controlling, 52
   crosshairs, 54
   hiding, 50
   interpolating, 54
   mouse button functions, 76
   positioning, 49
   resizing, 48