>  Docs Center  >  Using ENVI  >  ENVI LiDAR  >  Start a New Project

Start a New Project

Start a New Project

Create and Process a Project Tutorial

You can start a new project in the following ways:

Before You Begin


  • You can view file header information in the Operations Log window. Select File > View File Header from the menu bar, then select the file in the Open dialog. The header information displays in the Operations Log. You can also drag and drop a .las, .ntf, Terrasolid .bin, .sid, or .laz file from Windows Explorer to the Operations Log window to display the header information.
  • When you create a project using a file that contains coordinate system information in its header, ENVI LiDAR applies that information to the project by default. You can override the defaults, if needed. ENVI LiDAR looks for the following GeoKeys in the header:

    GTModelTypeGeoKey

    Defined Codes:

    ModelTypeGeographic = 2, Geographic latitude-longitude system

    ModelTypeGeocentric = 3 , Geocentric (X,Y,Z) coordinate system

    ProjectedCSTypeGeoKey or GeographicTypeGeoKey

    ProjLinearUnitsGeoKey

    Defined codes:

    9001 = METERS

    9002 = FEET INTERNATIONAL

    9003 = FEET US SURVEY

  • You need to have read and write privileges to the directory you are saving the project to. If you do not have write privileges, the project cannot be saved to that location and you will be prompted to select a different directory. A project located in a read-only location cannot be opened.
  • For faster processing time, save projects to your local drive rather than to a location on a network.
  • At project creation, only the All Points layer is available in the Layer Manager; this is the unclassified point layer. After you generate products to classify point clouds, you can view the vector and point cloud layers that were created during processing in QA Mode.
  • When you create or open a project, it will be locked to avoid access by multiple users.

Open a File to Create  a New Project


You can start a new project by opening a .las, .ntf, .sid, .bin, or .laz file. If you have write permission to the input file directory, ENVI LiDAR automatically creates a project in the same directory. Any products you generate for the project will be located in that project directory.

  1. Select File > Open from the menu bar. The Open dialog appears.
  2. Navigate to a directory with LiDAR raw data and select the input file(s), then click Open. To select multiple files, use Ctrl+click or Shift+click.
  3. ENVI LiDAR creates a project directory using the name of the input file. If you select multiple files, the first file selected will be the project name. If the input file is in a read-only directory, ENVI LiDAR prompts you to save the project to a directory where you have write permission.
  4. If the header for the input file contains the GeoKeys described previously, ENVI LiDAR applies that information to the project. An information dialog shows the coordinate system settings that will be used. To approve, click Yes; to change the settings, click No.
  5. If you click No, or the GeoKeys are not in the header, the Convert Format dialog appears. Use the steps in Convert Format Dialog to manually set the coordinate system for the project.
  6. Click OK. ENVI LiDAR imports the data. The Navigate window shows a color DSM, and the Main window shows the raw point cloud. ENVI LiDAR creates a project directory and a project file (.ini) in the same directory as the input file.

Tip: If the color Digital Surface Model (DSM) in the Navigate window shows the same color and does not contain blue, there are "under terrain" or high "birds" noise in the data. To adjust this, go to the Production Parameters tab and adjust the Clip Minimum Height value and save the change to recalculate the elevation map.

Be careful not to create holes in the data when adjusting Clip Minimum Height. If holes appear in the color DSM, recheck and update the value. If necessary, you can also adjust Clip Maximum Height, though this adjustment is rarely needed and should be done carefully to avoid deleting antennas or power lines.

Create a New Project


You can create a project in a specified directory by naming the directory and opening a .las, .ntf, .sid, .bin, .laz, or .txt file. The files that you open and any products you generate for the project will be located in that project directory.

  1. Click the New Project button on the toolbar, or select File > New Project from the menu bar. The Save As dialog appears.
  2. Navigate to the directory where you want to save the project and enter a project filename, then click Save. ENVI LiDAR creates a directory for the project and saves the .ini file in that directory.
  3. Click OK in the message dialog prompting you to select data files to import. The Open dialog appears.
  4. Navigate to a directory with LiDAR raw data and select the input file(s), then click Open. To select multiple files, use Ctrl+click or Shift+click.
  5. To import more files from a different directory, click Yes at the message dialog prompting you to import more raw material data files into the project. If you do not need to select additional files, click No.
  6. If the header for the input file contains the GeoKeys described previously, ENVI LiDAR uses that information for the project. An information dialog shows the coordinate system settings that will be used. To approve, click Yes; to change the settings, click No.
  7. The Convert Format dialog appears if you clicked No, if the GeoKeys were not in the header, or if the input file was a .txt or .bin file. Use the steps in Convert Format Dialog to manually set the coordinate system for the project.
  8. Click OK. ENVI LiDAR imports the data. The Navigate window shows a color DSM, and the Main window shows the raw point cloud. ENVI LiDAR creates a project directory and a project file (.ini) in the location you specified, using the project name you entered.

Tip: If the color Digital Surface Model (DSM) in the Navigate window shows the same color and does not contain blue, there are "under terrain" or high "birds" noise in the data. To adjust this, go to the Production Parameters tab and adjust the Clip Minimum Height value and save the change to recalculate the elevation map.

Be careful not to create holes in the data when adjusting Clip Minimum Height. If holes appear in the color DSM, recheck and update the value. If necessary, you can also adjust Clip Maximum Height, though this adjustment is rarely needed and should be done carefully to avoid deleting antennas or power lines.

Convert Format Dialog

The Convert Format dialog appears when the input file does not contain the GeoKeys, if you need to change coordinate system settings, or if the input data is from a .txt or .bin file.

  1. For LAS and LAZ input, the Convert Format dialog displays information in the File Content columns based on the LAS point records. To view this information from the header, click View LAS Header.
  2. If the data is imported from an ASCII text file, do the following:

    • Manually select the X, Y, Z columns, and (if present) INTENSITY and/or R,G,B columns to display by clicking on a column name to select the heading name.
    • If the file contains header lines, specify the number of lines in the header from the Skip Header Lines drop-down list. This prevents the header lines from appearing in the file content.
  3. Select the Input Projection System from the drop-down list. The options are:

    • Geographic Lat/Lon. When selected for an input file that has x,y geographic coordinates, the UTM Zone of the first point in the list is automatically selected, and the Calculated LON LAT field displays the coordinate of that point.
    • UTM. When selected for a LAS file, the real-world point location values are determined by the Input Datum and UTM Zone you select. The Calculated LON LAT field displays the coordinate of the first point. Select the following from the remaining drop-down lists:

      • Input Datum
      • Input Units. The choices are: Meters, Feet in International Standard, Feet in US Survey Standard.
      • UTM Zone
    • Geocentric (ECEF). When selected, the UTM Zone is automatically selected, and the Calculated LON LAT field displays the coordinate of the first point in the list.
    • ESPG Code. When selected, the ESPG Code dialog appears for you to enter the code associated with the input data.
    • Arbitrary. Choose this option when you do not know the projection information for the file, but want to continue creating the project. Select the units from the Units drop-down list that appears.

      When using arbitrary coordinates, the following features are not available: export to Google Earth KML, cursor location coordinate system selection, and jump to location coordinate system selection. You can export products, but only with arbitrary coordinates (no projection information).

    • Advanced. If you do not find the projection system you need, select this option, or click the Advanced button to select a projection system using the Select Coordinate System dialog.

  4. Click OK.

Start a New Project from an Existing Project


You can start a new project by using the LiDAR data of an existing project. This is useful to process a different area of data than what was processed in the existing project. All settings from the original project, including the coordinate system settings, are saved in the new project. Any changes made to the original project while you are in QA Mode will need to be manually imported.

  1. Click the Open an Existing Project or LAS Files button on the toolbar to open the project. The Open dialog appears.
  2. Select File > New from Current Project from the menu bar.
  3. Navigate to the project and select it, then click Open. The project opens.

    Tip: You can bypass these first few steps if the project is already open by selecting File > New from Current Project from the menu bar.

  4. In the Select Rectangle dialog, click and drag to select part of the elevation map to process. You can also use the fields in the dialog to navigate the map and to enter X Min/Max (Easting) and Y Min/Max (Northing) coordinates, or to specify the full rectangle by clicking the Entire Area button. If needed, click Load New Layer to load a vector or other layer (DEM, DSM) that will aid in selecting the area to process. If needed, unload a previous layer by clicking Unload Last Layer.
  5. When you are done, click OK. The Save As dialog appears.
  6. Navigate to the desired directory and enter a project filename, then click Save. ENVI LiDAR creates a directory for the project and saves the .ini file in that directory.

To import the manual changes made in the original project into the new project:

  1. In the new project, select Edit > Merge List from the menu bar.
  2. Select the CorrectionList.dat file in the project directory of the original project. The changes made to the original project that are relevant to the new project are applied.

Display Project Information


You can display project information for the open project in the Operations Log by selecting File > Project Information from the menu bar. The project information includes the following:

  • Import file data and coordinate systems
  • Area coordinates
  • Area size
  • Point height range
  • Number of points in the point cloud
  • Average density
  • Number of buildings
  • Number of trees
  • Number of power poles
  • Build time and date



© 2019 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us