4272 Rate this article:
No rating

How to update the SSL security certificate for the Harris FlexNet 2016 License Server

Beginning on March 7, 2018, the 2016 version of the Harris FlexNet License Server will require an updated SSL security certificate file (flexnet.certs) to allow new license activations or rehosting.

Without the updated security certificate, when you attempt to activate licensing to the license server, you will encounter an error like this:


ERROR: {  "key" : "glsErr.sslMisconfigured",  "arguments" : [ "I/O error on POST request for \"https://harrisgeospatial.flexnetoperations.com/control/xlsv/deviceservices\": sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target; nested exception is javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target" ],  "message" : "SSL is misconfigured:...


Note that if the new security certificate file is not installed, the 2016 License Server will still continue to properly serve licenses to clients.


The 2017R2 version of the Harris FlexNet License Server, available for download from the Harris Download and License Center with ENVI 5.5 and IDL 8.7, includes the updated flexnet.certs file. If you've already upgraded to this version of the license server then no further action is required.


Steps to update the 2016 license server SSL security certificate file:


A. Download the updated flexnet.certs file.


  1. Log into the Harris Download and License Center.

  2. Under the Download section of the web site, browse to the ENVI or IDL product item to access and download the updated flexnet.certs file.

Downloading the FlexNet license server installer or the flexnet.certs file requires access to a current ENVI or IDL product maintenance contract. To renew your product maintenance, please contact your local Harris Geospatial Solutions office or distributor, or visit our Contact Us page.


B. Install the new flexnet.certs file to the Harris FlexNet License Server.


Windows


Administrative privileges are required to complete the following steps.


  1. Replace the old flexnet.certs file located under the server subdirectory of the license server installation with the updated flexnet.certs file, for example: 

    C:\Program Files\Harris\flexnetls-x64_windows-2016.03.0\server\flexnet.certs

  2. Stop and restart the FNLS-idl_lmgrd license server service through the Windows Services control panel utility.
    • Stop: In the Services tab, right-click FNLS-idl_lmgrd (FlexNet Licensing Server - idl_lmgrd) and select Stop.
    • Start: In the Services tab, right-click FNLS-idl_lmgrd (FlexNet Licensing Server - idl_lmgrd) and select Start


Linux


Root or sudo privileges are required to complete the following steps.


  1. Replace the old flexnet.certs file for the license server installation with the updated flexnet.certs file in the following location

    /opt/flexnetls/idl_lmgrd/flexnet.certs

  2. Stop and then restart the license server service:

    /sbin/service flexnetls-idl_lmgrd stop
    /sbin/service flexnetls-idl_lmgrd start


Written by JU (2.21.2018)

Please login or register to post comments.