>  Docs Center  >  Using ENVI  >  Supported File Formats Background

ENVI

Supported File Formats Background

Supported Data Types Background

Supported Data Types Background


This topic provides further instructions on opening various file formats.

Airbus Defence & Space Files

SPOT and Pleiades data files are available in a mosaic tiled format, as well as NITF format. Use File > Open and select a .til file in a product directory to open the tiled dataset. Select individual .ntf files to open the images as standard NITF files, preserving NITF-specific metadata tags.

ADS40 and ADS80 Files

ADS40 and ADS80 are the Airborne Digital Sensor instruments developed by Leica Geosystems. They can acquire panchromatic or multispectral imagery.

The following ancillary files are required for ENVI to automatically compute rational polynomial coefficient (RPC) map information so that the data are georeferenced and ready for orthorectification or DEM extraction. Be sure to put these ancillary files in the same directory as the image file (.tif):

  • ADS header file (*.ads)
  • Camera calibration file (*.cam)
  • Meta information support file in Socet Support File Format (*.sup)
  • Orientation data file (*.odf)
  • Orientation data file after bundle adjustment (*.adj)

The *.ads, *.cam, and *.sup files must exist, and either *.odf or *.adj must exist. If both of the latter exist, then the *.adj file is used over the *.odf file because the *.adj file is assumed to be more accurate.

If any of the required ancillary files are missing, ENVI opens the ADS40 or ADS80 file as a regular TIFF file and does not calculate RPC map information.

ALOS PALSAR Files

ENVI reads the following products. Supported operational modes include ScanSAR (1.1), fine-beam, single polarization (HH or VV), dual polarization (HH+HV or VV+VH), and full polarization (HH+HV+VH+VV).

ALOS-1

  • Level 1.1 (complex) imagery, including Amplitude, Q (imaginary or in-phase), and I (real or quadrature) components for each transmit/receive polarization pair (for example, HH)
  • Level 1.5 georeferenced Amplitude imagery for each transmit/receive polarization pair

ALOS-2

  • Level 1.1 (complex) imagery, including Amplitude, Q (imaginary or in-phase), and I (real or quadrature) components for each transmit/receive polarization pair.
  • Note: ENVI does not read ALOS-2 Level 1.1 Ultra Fine-Beam Single (UBS) polarization data in CEOS format. Please use the SARscape® Basic or Interferometry (InSAR/DInSAR) Module to read this type of data.

  • Level 1.5 georeferenced Amplitude, 2.1, and 3.1 imagery for each transmit/receive polarization pair

In all cases, use the File > Open or File > Open As > Radar Sensors > ALOS-PALSAR menu option and select a volume file (VOL*) or leader file (LED*).

Use the SARscape® modules for ENVI to read ALOS-2 Level 1.1 data.

Annotation Files

From .ann files, text, square/rectangle, circle/ellipse, polygon, polyline, arrow, symbol, and picture annotation items are supported. Map scale bars, image color ramp, map key, declination arrow and plot annotation items are not supported and therefore will not display if present in the annotation file.

ASCII Files

You can open an ASCII file as an image. ENVI reads each ASCII value as a pixel DN value and skips lines at the top of the file that have non-numeric characters or that start with a semicolon. The ASCII values must be separated by white spaces or commas, and the image data must be in the format of an image array. You will be prompted to enter the interleave type (BSQ, BIL, or BIP), data type, and number of bands. Also see the ASCII Coordinate Conversion tool.

ATSR Files

ENVI reads gridded brightness temperature/reflectance (GBT) data, the gridded browse (GBROWSE) data, and the gridded sea surface temperature (GSST) data. ENVI automatically opens all the image product contents within the file. For forward view and nadir view images, the band names contain FV or NV respectively. The band names also supply the image units.

AVHRR Files

ENVI reads the following types of AVHRR data:

  • KLMN Level-1B formatted files that are produced and distributed by NOAA only. It reads files that do not have TBM or ARS headers. It reads 10-bit packed format data as integers, uncompressed formats as integers, and 8-bit format data as bytes. You can use the embedded information to georeference the data.
  • SHARP European Space Agency-format AVHRR data, including the five spectral bands plus latitudes/longitudes, coastlines, and state boundaries. These last three items are provided as separate mask bands.
  • Quorum receiving station; data from this station lacks the required header information that enables you to calibrate or georeference the data. Quorum data files are typically 16-bit High Resolution Picture Transmission (HRPT) files with two header frames.

To view an AVHRR header, select Raster Management > Data-Specific Utilities > AVHRR Display Header from the Toolbox. The AVHRR File Information dialog appears. To save the header information to a text file, select File > Save Text to ASCII from the AVHRR File Information dialog.

See the following related topics:

CADRG Files

To open individual frame files, use the NITF file reader. You must have a ENVI NITF/NSIF Module license to read CADRG files. To save raster data to CADRG file format, use the Toolbox option Raster Management > Save File as CADRG.

CIB Files

To open individual frame files, use the NITF file reader. You must have a ENVI NITF/NSIF Module license to read CIB files. To save raster data to CIB file format, use the Toolbox option Raster Management > Save File as CIB.

DigitalGlobe Format Files

GeoEye-1, QuickBird, and WorldView data files are available in a mosaic tiled format, as well as NITF and GeoTIFF. Within a given product folder (for example, *P001_PAN or *P001_MUL), select File > Open from the menu bar and select the .TIL file. ENVI reads the associated metadata, particularly the spectral metadata required for radiometric calibration. Opening individual NITF files will only read the images as generic NITF or TIFF files without the associated metadata.

When using tools such as NNDiffuse Pan Sharpening, open the multispectral dataset (.til) separately from the panchromatic dataset (.til).

WorldView-3 shortwave-infrared (SWIR) bands are grouped separately from the multispectral and panchromatic bands. To open the SWIR data, select the .til file in the *P001_SWR folder.

You can combine different band groups into one image by using the Layer Stacking tool or the ENVIMetaspectralRaster API routine.

DubaiSat-1 Files

Use the File > Open menu option and select a .tif file to open TIFF imagery, or select a .txt file to open TIFF imagery with associated metadata. ENVI uses the metadata to georeference the imagery to a standard map projection.

Or, Use the File > Open As > Optical Sensors > DubaiSat > DubaiSat-1 menu option and select a .cat or .txt file to open.

To open RAW-format files, select File > Open As > Generic Formats > Binary from the menu bar. Select a .raw file. Make sure the directory containing the RAW file has write permissions. Enter required header information in the Edit Raster Metadata dialog, then click OK. You will need to know the image specifications before opening the RAW format this way.

For RAW-format files, you can also use the File > Open menu option and select a .cat or DMAC*.cat file (typically in a Metadata folder distributed with the data) to open imagery with associated metadata. ENVI uses the map information in the metadata file to georeference the imagery.

DubaiSat-2 Files

Use the File > Open menu option and select a .tif file to open TIFF imagery, or select a .xml file to open TIFF imagery with associated metadata. Or, use the File > Open As > Optical Sensors > DubaiSat > DubaiSat-2 menu option and select a .xml file to open.

ECRG Files

Use the File > Open option, navigate to an ECRG archive, and open the TOC.xml file. The Select ECRG Dataset dialog lists all available datasets in the middle column. Each dataset may consist of multiple NITF frames. The left panel shows metadata associated with the archive. The right panel shows metadata describing the map type, zone, number of frames, and spatial extent of the selected dataset. The ECRG format is described in the MIL-PRF-32283 specification document.

Select a dataset and click Open Selected. All frames in the dataset load as a single RGB image layer. A shapefile describing each frame is loaded on top of the raster layer. When displayed at full extent, the image appears grey. Zoom in further to see the imagery.

Tip: From the ENVI menu bar, select File > Open World Data > Coastlines to view a world boundary map. This helps identify where the ECRG dataset is located.

The Status bar in the ENVI application displays the highest security level out of all displayed frames.

ECRG Legends

Datasets may have associated legends that describe the features of the maps:

  • Right-click on the image layer in the Layer Manager and select View Metadata. Then click the Legends node to view more information about the associated legends.
  • Right-click on the image layer in the Layer Manager and select Load Legend. Select the legends to load, and click OK. The legends are listed in the Data Manager. From here, you can load the legends to the display as needed.

GOES-16 Files

ENVI opens and displays the raw imagery and automatically applies gains and offsets to the data. It applies a geographic lookup table (GLT) to the imagery before displaying it. It also opens the data quality flag (DQF) metadata. You can use the Reproject GLT with Bowtie Correction tool to georeference the data.

GRIB Files

ENVI opens GRIB files with GRID_Simple and GRID_PNG packaging, in Regular_LL (Regular Geographic WGS-84 Latitude and Longitude Grids) only. If bands represent parameters with different acquisition times, the band names will include the times. Otherwise, the time for the entire dataset will be recorded in the acquisition time of the file metadata.

Himawari-8 Files

ENVI opens Himawari-8 files in NetCDF-3 format, distributed by the Japanese Meteorological Agency. From the ENVI menu, select File > Open As > Optical Sensors > Himawari-8. The data is distributed with each of the 16 bands in separate NetCDF-3 files, all in the same directory. When the Open dialog appears, select any of the 16 *.nc files. ENVI combines the bands into three rasters, all in the same geographic location but with different resolutions:

  • The 1 km resolution raster contains Albedo bands 1, 2, and 4.
  • The 500 m resolution raster contains Albedo band 3.
  • The 2 km resolution raster contains Albedo bands 5-6 and brightness temperature (TBB) bands 7-16.

These images already are calibrated to albedo and brightness temperatures in floating-point data, so you do not need to apply gains and offsets. ENVI locates the above bands within the same directory. If any bands are missing, ENVI attempts to open the images with the bands that are available, and the rasters above may be missing bands.

The images are georeferenced to a geographic lookup table (GLT) spatial reference. To reproject the image to a standard map projection, use the Reproject GLT with Bowtie Correction tool.

IKONOS Files

ENVI reads and displays IKONOS data in NITF and GeoTIFF formats. An individual GeoTIFF or NITF file may only contain one band of data, while another may contain a combination of multispectral bands.

  • If you select the metadata.txt file, ENVI reads it as an IKONOS product and opens all associated bands of data. ENVI reads the available calibration and time metadata so that you can calibrate images or use the metadata in the ENVI application programming interface (API).
  • If the metadata.txt file is not available and you select a GeoTIFF or NITF file, ENVI reads it as a generic GeoTIFF or NITF file.
  • If there is only one GeoTIFF or NITF file available (containing all bands of data) and you select it, ENVI reads it as an IKONOS product and opens all associated bands.
  • If there are multiple GeoTIFF or NITF files available (representing individual bands) and you select any file, ENVI reads it as a generic GeoTIFF or NITF file.

JPEG2000 Files

Select a .jp2 or .j2k file to open. ENVI reads map information from georeferenced JPEG2000 files in the following order of precedence:

  1. Map information in an ENVI header file (.hdr), if one is associated with the JPEG2000 file.
  2. GeoTIFF map information embedded in the UUID field of the JPEG2000 file.
  3. Geography Markup Language (GML) embedded in the gml.instance-data box of the JPEG2000 file.

MIE4NITF Files

A NITF/NSIF license is required in order to open MIE4NITF files. Use the File > Open As > Military Formats > MIE4NITF menu option to open a .ntf file. ENVI creates a raster series from the data and writes the .series files to the same directory as the NITF file. If this directory does not have write permissions, the .series files are written to the directory specified by the Temporary Directory preference.

Use the Series Manager to view a MIE4NITF dataset. To access the current image segment displayed in the view, click the Options drop-down list and select Load Current Raster. This loads the image segment as a new NITF file. Another way to open individual image segments is to use the File > Open As > Military Formats > NITF menu option and select a single .ntf file.

To view metadata for a MIE4NITF dataset, right-click on an individual NITF image layer (not the series layer) in the Layer Manager and select View Metadata. This will display the NITF metadata for all of the rasters that belong to the series, not just the selected raster.

MODIS Files

ENVI reads MODIS Level 1B, 2, 3, or 4 files, including products MOD02 through MOD44 and MYD02 through MYD44. It extracts gain and offset values from the HDF metadata and applies them when converting 16-bit data to calibrated floating-point data. The resulting emissive and reflectance data do not have units. The units of the radiance data are W/m2/μm/sr.

For Level 1B files, values greater than 32767 (which indicate invalid data) are replaced by -1 when applying the gains and offsets.

Use the File > Open option to open the following MODIS products: M*D08*, M*D27HV, M*D27W, M*D43B1, M*D43B1C, M*D43B2, M*D43B2C, M*D43B3, M*D43B3C, M*D43C2, and M*DATML2.

You can georeference and correct MODIS Level-1B data for bowtie artifacts by selecting Geometric Correction > Reproject GLT with Bowtie Correction from the Toolbox. The MODIS imagery must have separate Latitude and Longitude Scientific Data Sets (SDSs). You must open the MODIS data first before starting the tool.

OGC GeoPackage Files

ENVI reads OGC GeoPackage files and displays vector feature as shapefiles. Select the feature(s) you wish to open and click OK. Any features in the GeoPackage file that cannot be opened or displayed by ENVI (such as multipatch vectors) will be listed in the Unsupported Features field.

PeruSat

ENVI supports PeruSat-1 products. Use the File > Open or File > Open As > Optical Sensors > Airbus > PeruSat menu option and select a dim*.xml file to open.

PlanetScope

ENVI supports PlanetScope Level-1B and Level-3B products. Use the File > Open or File > Open As > Optical Sensors > Planet > PlanetScope menu option and select a *_metadata.xml file to open.

Proba-V Files

ENVI supports the following products:

  • S1 top-of-canopy (TOC) and top-of-atmosphere (TOA)
  • S10 TOC, including Normalized Difference Vegetation Index (NDVI)

From the menu bar, select File > Openand select an HDF5 file to open. Use the Data Manager to access the following rasters:

  • VNIR (Blue, Red, NIR), if present
  • SWIR, if present
  • NDVI
  • Quality, if present

Sentinel-2 Files

ENVI supports Sentinel-2 Level-1C and Level-2A products. Use File > Open or File > Open As > Optical Sensors > European Space Agency > Sentinel-2 and select an .xml file. Three rasters will be opened in the Data Manager, each covering the same geographic area but providing different resolution:

  • 10 meter resolution (490; 560; 665; and 842 nanometer bands)
  • 20 meter resolution (705; 740; 783; 865; 1,610; and 2,190 nanometer bands)
  • 60 meter resolution (443; 945; and 1,375 nanometer bands)

Only the 10 meter raster will be auto displayed.

Sentinel-3 Files

See the Sentinel-3 Marine Data Tutorial.

ENVI supports the following Sentinel-3 products:

Ocean Colour and Land Instrument (OLCI)

Label

Description

OL_1_EFR

Level-1 top-of-atmosphere (TOA) radiances for each view and each OLCI channel, 300 m resolution

OL_1_ERR

Level-1 TOA radiances for each view and each OLCI channel, 1.2 km resolution

OL_2_LFR

Level-2 land products at 300 m resolution. Land products include Global Vegetation Index (OGVI), Terrestrial Chlorophyll Index (OTCI), integrated water vapor (IWV) columns, and rectified reflectance for the 681 nm and 865 nm channels

OL_2_LRR

Level-2 land products at 1.2 km resolution

OL_2_WFR

Level-2 marine products at 300 m resolution. Marine products include reflectances in most channels, total backscattering coefficients, total absorption coefficients, algal pigment (chlorophyll) concentration from two different algorithms, total suspended matter (TSM) concentrations, diffuse attenuation coefficients, heated layer depth, water transparency, photosynthetically active radiation (PAR), aerosol Angström exponents, and IWV columns

OL_2_WRR

Level-2 marine products at 1.2 km resolution

Sea and Land Surface Temperature Radiometer (SLSTR)

Label

Description

SL_1_RBT

Level-1 top-of-atmosphere (TOA) radiances (0.5 km resolution) and brightness temperatures (1 km resolution)

SL_2_WCT

Level-2 sea surface temperatures (SSTs); single and dual view, 2 and 3 channels; 1 km resolution

SL_2_WST

Level-2P brightness temperatures, SSTs, sea ice fraction, and wind speed, 1 km resolution. SSTs are based on the Group for High Resolution Sea Surface Temperature (GHRSST) Level-2P specification.

SL_2_LST

Level-2 land surface temperatures and associated parameters, 1 km resolution

Use the following menu options to open Sentinel-3 data. In all cases, open the .xml manifest file.

  • File > Open
  • File > Open As > Optical Sensors > European Space Agency > Sentinel-3 OLCI
  • File > Open As > Optical Sensors > European Space Agency > Sentinel-3 SLSTR menu option and select a .xml file to open.

Use the Reproject GLT with Bowtie Correction tool to georeference the data.

SkySat Files

ENVI supports the following products:

  • Image Frames: High-resolution imagery with detailed metadata and minimal geometric processing. Each image represents a single frame; there can be tens or hundreds of frames that cover the extent of a collection area.
  • Geo Imagery: One image of the collection area for each product type: panchromatic, multispectral, and pan-sharpened. Each image has an associated RPC file. Use the RPC Orthorectification workflow to georeference these images. You must supply your own optional DEM and ground control points (GCPs).

Open the associated metadata file (*_metadata.txt). The Select SkySat File Parameters dialog provides the following options:

  • Select a DEM File to Use: Choose a DEM file, or accept the default file GMTED2010.jp2 that is provided with the ENVI installation. This DEM is from the Global Multi-resolution Terrain Elevation Data 2010.
  • Select a Geoid File To Use: Choose a geoid file, or accept the default file world_geoid_height_EGM96.img that is provided with the ENVI installation.
  • Select Product: Choose the product to open. The choices are Panchromatic, Multispectral, or Pan Sharpened.

After you click OK, ENVI reprojects the imagery to a Geographic Lat/Lon WGS-84 coordinate system, using the DEM and geoid that you specify to perform a quick orthorectification.

The individual frames are displayed in the Image window and added to the Layer Manager. To create a single image from the frames, you need to use the Seamless Mosaic tool.

SRTM Files

ENVI opens single SRTM DEM files (.hgt) as ENVI image files. When multiple DEMs are available, ENVI automatically mosaics them into one ENVI image file. If the file contains missing data points, you are prompted to correct the missing values. If you click Yes to replace missing values, the -32768 values (which indicate missing data) are replaced by values interpolated from valid neighboring pixels. Select a new output filename, or output to memory. ENVI retains the original input file and creates a new file containing the interpolated data points.

TIFF Files

ENVI reads GeoTIFF files, GeoTIFF world files (.tfw), and the following TIFF formats:

  • 1-bit
  • 4-bit
  • 8-bit (byte)
  • 12-bit
  • 16-bit signed integer
  • 16-bit unsigned integer
  • 32-bit signed long integer
  • 32-bit unsigned long integer
  • 32-bit floating point
  • 32-bit double-precision floating point

Use ENVI Classic to read the following formats:

  • 64-bit signed long integer
  • 64-bit unsigned long integer
  • Complex
  • Double-precision complex

TIMS Thermal Files

ENVI assumes the data has 6 bands, 638 pixels, plus a 60 byte offset at the beginning of each line, and is in band-interleaved-by-line (BIL) storage order. Default wavelengths are entered into the header, and you can edit them as needed.

TripleSat Files

ENVI supports TripleSat/DMC3 Level 1A and Level 2A products, both in XML and DIMAP formats. Use the File > Open menu option and select a .xml or .dim file to open.

UrtheCast Theia Files

ENVI supports UrtheCast Theia products. Use the File > Open or File > Open As > Optical Sensors > UrtheCast Theia menu option and select a .xml file to open.

Ziyuan-1-02C

Use the File > Open As > Optical Sensors > CRESDA > ZY-1-02C option from the menu bar to open the files as follows:

  • *.orientation.xml opens the MUX-PAN data product with metadata
  • *.xml opens the HRC data product (images with two parallel cameras) with metadata
  • *-MUX.xml opens multispectral data with metadata
  • *-PAN.xml opens panchromatic data with metadata

Ziyuan-3A

Use the File > Open As > Optical Sensors > CRESDA > ZY-3 option from the menu bar to open the files as follows:

  • *.orientation.xml opens the TLC data product (images with nadir, forward, backward view) with metadata
  • *.xml opens multispectral data with metadata
  • *-NAD.xml opens TLC nadir-view data with metadata



© 2019 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us