>  Docs Center  >  Using ENVI  >  Photogrammetry Module  >  Collect and Edit Ground Control Points

Collect and Edit Ground Control Points

Collect and Edit Ground Control Points

When you click Next in Step 1, the ENVI Orthorectification Wizard proceeds to the GCP Selection panel (Step 2 of 5). In this step, you associate image pixels to points on the ground whose locations are known through a horizontal coordinate system and vertical datum. These points are called ground control points (GCPs).

Note: Be sure that your GCPs are of a quality that is consistently better than the initial accuracy of the sensor model; this varies with data type and vendor. For example, mid-latitude QuickBird scenes of a relatively flat area may provide an accurate orthorectification without the use of GCPs.

GCP elevations should be expressed in meters above mean sea level (orthometric height), not as height above the ellipsoid.

The controls in this step of the Wizard allow you to optionally restore GCP files, to add new GCPs, and to edit existing GCPs. You may choose to bypass this step by clicking Next; the orthorectified solution will be computed without GCPs in this case.

See the following sections:

GCP File Format


Rigorous Orthorectification uses a specific GCP file format, which is an ASCII file that contains image file IDs, map X/Y coordinates, elevation in meters, and image X/Y coordinates. Fields are tab-delimited. You can either create a Rigorous Orthorectification GCP file from scratch using your map and elevation data (see example below), or you can enter map/image coordinates and elevations directly in the Wizard and save it to the Rigorous Orthorectification GCP file format.

A Rigorous Orthorectification GCP file requires a .pts file extension and begins with the words "ENVI Rigorous Orthorectification GCP File." The first several rows that begin with semicolons are header rows. Following is an example:

; ENVI Rigorous Orthorectification GCP File
; FileName0=image1.TIF; FileName1=image2.TIF
; projection info = {UTM, 12, North, WGS-84, units=Meters}
; ImageFile#, Map (x,y,elev), Image (x,y)
;
1  408620.653090  3698080.965069  314.977000  4366.000000  447.000000
1  406652.054304  3698011.485774  311.083000  3569.000000  479.000000
1  398163.369353  3694523.413367  309.603000  245.000000  1861.000000

The header rows that say "FileNamex" refer to the input image filenames, where x is an index number used to reference the filename throughout the rest of the GCP file. In the example above, a line that begins with “1” indicates GCP data for the file image2.TIF, as indicated in the header. If you ever change the mapped drive, you must remember to update the GCP file headers.

If you are creating your own GCP file in a text editor or other application, you do not need to include a full path to the image filenames (in the lines that begin with "FileNamex") as long as your filenames are unique. In cases where the filenames may be the same for all images (for example, Cartosat-1 and SPOT data), you need to include the full path to each image file in the "FileNamex" lines.

Note: Files in ENVI GCP format will not work with the ENVI Orthorectification Wizard; they must be in the Rigorous Orthorectification GCP file format.

Restore GCP Files


Follow these steps to restore an existing GCP file:

  1. Click the Load a new GCP file button. The Select GCP File dialog appears.
  2. Select an ASCII file with GCPs, and click Open. The GCP locations are displayed in the Layout View Area of the Layout Manager (if you enabled the GCP check box) and in the display group. You have two options to view the list of GCPs:
    • Click Show List in the ENVI Orthorectification Wizard. The Orthorectification Ground Control Points List appears. See Edit GCPs for instructions on working with this dialog.
  3. Evaluate the RMSE for the entire model and the error residuals for individual GCPs (as described in Evaluate Residual Errors in GCPs), and proceed with adding new GCPs or editing GCPs as needed.

Add GCPs


Follow these steps to add new GCPs to an existing set, or to create a new set of GCPs.

  1. A display group shows the image selected as the Active Image in the GCP Selection panel. To change the image that is displayed, select a different image from the Active Image list or Shift-click an image boundary in the Layout Manager to make that image active. The active image is shown with a red border in the Layout Manager, and ENVI will load the appropriate display group. (See Changing the Image Stack Order for more information about reordering images.)
  2. In the Image window, go to where you want to add a new GCP.
  3. In the Zoom window of the display group, click on a specific pixel to center the Zoom window over that pixel or portion of that pixel.
  4. The Image X/Y fields in the ENVI Orthorectification Wizard show the image coordinates of the selected pixel underlying the crosshairs in the Zoom window. Subpixel coordinates are supplied to provide higher accuracy in selecting GCPs. Whole-number pixel coordinates correspond to the upper-left corner of the pixel. The x,y values increase to the right and bottom of the pixel, respectively.

  5. If your image is not already georeferenced, you can enter known map coordinates for the GCP location into the E/N or Lat/Lon fields of the ENVI Orthorectification Wizard.
    • To enter map coordinates, select a map projection and datum. Click the toggle button next to the map projection name to switch between E/N and Lat/Lon fields.
    • Use negative (-) longitude for the western hemisphere and negative (-) latitude for the southern hemisphere.
    • To change the latitude and longitude values to decimal degrees, click DDEG. To use degrees, minutes, and seconds, click DMS.
  6. If your image is georeferenced, a recommended method is to use ENVI’s Pixel Locator dialog to enter coordinates into the ENVI Orthorectification Wizard. From the Display group menu bar, select Tools > Pixel Locator. The Pixel Locator dialog appears. The Sample and Line values reflect the pixel location where the Zoom window is centered.
  7. Set the correct map projection and datum (if needed) in the Pixel Locator dialog.
  8. Click Export in the Pixel Locator dialog. The map coordinates are transferred to the corresponding fields in the ENVI Orthorectification Wizard. (You do not need to perform this step with the Image X/Y fields.)
  9. Enter the elevation in meters above mean sea level for the point described by the Lat/Lon (or E/N) values, into the Elev field of the ENVI Orthorectification Wizard.
  10. Click Add Point in the ENVI Orthorectification Wizard to add the point to the GCP list.
  11. When you add a GCP, a marker is placed in the Layout View Area of the Layout Manager and in the display group. The marker consists of an ID next to a + symbol and indicates the selected pixel (or subpixel location). The center of the marker (located under the + symbol) indicates the GCP location.

  12. Add more GCPs as needed, using the same procedures.

When you enter at least three GCPs, the GCP list shows the residual errors for each GCP, along with the RMSE for the entire model. While ENVI accepts as few as one GCP, it is desirable to have four or more GCPs evenly distributed around each image. See Evaluate Residual Errors in GCPs.

Edit GCPs


You can edit the location of a GCP by changing the map and/or image coordinates in the ENVI Orthorectification Wizard.

To edit the location of a GCP in the ENVI Orthorectification Wizard, perform the following steps:

  1. Click Show List. The Orthorectification Ground Control Points List appears.
  2. Click a row number to select a given GCP, or click in a table cell corresponding to a GCP and click Goto. The display group centers over that GCP location, and the GCP is highlighted in the Layout Manager. If the image that corresponds to the GCP is not already displayed, ENVI loads the appropriate image into the display group.
  3. Edit the E/N (or Lat/Lon), Image X/Y, and Elev values in the Orthorectification Ground Control Points List. You can also use the Pixel Locator dialog to determine map coordinates, as described in Add GCPs.
  4. Click Update in the Orthorectification Ground Control Points List. The changes are reflected in the GCP list, display group, and the Layout Manager.

Remove GCPs


To remove any GCP from the table in the ENVI Orthorectification Wizard, select the row for that GCP and click Delete. To remove all GCPs, select Options > Clear All Points from the Orthorectification Ground Control Points List menu bar.

Turn GCPs On and Off


  1. In the Orthorectification Ground Control Points List, click on a row corresponding to a GCP you want to turn off.
  2. Click On/Off. The color of the GCP marker in the display group changes to green (by default) to indicate that it is off. You can change the default colors by clicking the Set GCP Color button . The Point Color dialog appears. Right-click on a color box and select the desired color.
  3. GCPs that you turn off are moved to the end of the Orthorectification Ground Control Points List if you have sorted the GCPs by error magnitude (see Evaluate Residual Errors in GCPs). Their ID values have a minus symbol to indicate they are turned off, and their Magnitude (m) values are 0. These GCPs are not used in the bundle adjustment model as long as they are off. The RMSE calculation is based only on GCPs that are turned on.

    When you click Next to proceed to the Tie Points panel, GCPs that were previously off are turned back on and used in the model. The purpose of the On/Off functionality is so that you can experiment with GCPs and decide whether or not to permanently delete any.

GCP Coordinate Projection


If you change the map projection in the Orthorectification Wizard, close the Orthorectification Ground Control Points List if it is currently open. Then re-open it to see the updated coordinate values.

Save GCP Files


To save edits to an existing GCP file, or to save new GCPs to a new file:

  1. Click the Save current GCP list button in the ENVI Orthorectification Wizard.
  2. The Select GCP File dialog appears.
  3. Specify an output location and filename, then click Save.

GCP files are saved in the current projection.

Evaluate Residual Errors in GCPs


For the best orthorectification results, try to minimize the RMSE for the entire model by refining the positions of the pixels with the largest errors or by removing them. The RMSE is calculated when three or more GCPs are available. You can reduce errors by adding more GCPs. If you only have a few GCPs, place them near the image corners or widely scatter them throughout the image.

To see which GCPs have the highest error magnitudes, within the GCP list:

  1. Click Show List in the ENVI Orthorectification Wizard. The Orthorectification Ground Control Points List appears.
  2. Scroll to the right until you see the Magnitude (m) column. From the Orthorectification Ground Control Points List menu bar, select Options > Order Points by Error. The GCPs are reordered so that those with the highest errors appear at the top of the list.
  3. Click on a row number for a given GCP to center the Layout View Area (in the Layout Manager) over that GCP.
  4. You can examine the impact of the model RMSE by turning GCPs on and off.

You can also enable the Residual Vectors option in the Layout Manager and increase the Residual Exaggeration slider to view the error magnitudes at each GCP location, as shown in the following figure. The Residual Vectors option is only available when you have at least three active GCPs.

Enable the Residual Image option in the Layout Manager to see a contour view of the residual error magnitudes across the entire model. Red areas represent the highest errors, and blue-to-white areas represent the lowest errors. This area is restricted to the minimum bounding rectangle of the GCPs. The Residual Image option is only available when you have at least three active GCPs.

Note: The accuracy of this plot is highly dependent on the distribution of GCPs. True errors may not follow a trend, but this contour plot provides an alternative to the residual vector display. Also, the Residual Image option is not a recommended choice for viewing the error magnitudes of GCPs that share the same map location or are very close to one another. Use the Residual Vectors option and Orthorectification Ground Control Points List instead.

Use the Residual Image option along with the Residual Vectors option, Residual Exaggeration slider, and RMSE field to evaluate which GCPs have the highest residual values. You can then correct or delete GCPs as needed to decrease the overall model error. The Residual Image option does not become available until you have selected at least three GCPs.



© 2019 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us