>  Docs Center  >  Using ENVI  >  Validate and Run Models
ENVI

Validate and Run Models

Validate and Run Models

After you have added the desired nodes and connectors, you are ready to run your model. Validation is necessary to ensure that the required input parameters are present, that all parameter values are valid, and that all connections and output parameters are configured properly. You can validate the model before running it by selecting Code > Validate Model from the ENVI Modeler menu bar. Or, run the model and ENVI will validate it before running it.

Validation problems include errors and warnings. If your model has errors, you will not be allowed to run the model. Warnings are recommendations that you should note, but you can still run the model.

To run a model, click the Run button or select Code > Run Model from the ENVI Modeler menu bar. Nodes are colored green when the model successfully completes those steps. If an error occurs, the model stops on the offending node (colored bright yellow) and issues an error message with the details of the problem.

Note: The ability to highlight nodes as you run a model to show progress requires an ENVI+IDL license.

An alternative way to run a model is to select Code > Run Model in Debug Mode from the ENVI Modeler menu bar. This feature requires an ENVI+IDL license. When the model runs, an Execution Report dialog reports the execution times for individual nodes and for the entire model. It also reports the values used for task parameters.

  • To save the report to a text file, click the Save button in the Execution Report.
  • To copy the report to the system clipboard, click the Copy button in the Execution Report.

See Also


Specify Input Datasets and Task Parameters, Generate and Run Code From Models, ENVI Modeler Examples



© 2019 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us