>  Docs Center  >  Using IDL  >  Hardware and Operating System Requirements
IDL

Hardware and Operating System Requirements

IDL Hardware and Operating System Requirements

Platform Hardware Operating System Supported Versions
Windows Intel/AMD 64-bit Windows

10

Macintosh Intel 64-bit OS X

10.14, 10.15*

Linux Intel/AMD 64-bit
Linux Kernel 3.10.0, glibc 2.17 or higher
  • * If you are installing ENVI on a Mac 10.15 operating system, or if you have ENVI installed on a previous Mac OS and are upgrading to 10.15, please refer to this Help Article before you begin the installation.
  • An X-Windows manager is required for Macintosh. IDL was tested using XQuartz 2.7.11.
  • Supported versions indicate that IDL was either built on the lowest version listed or tested on that version. You can install and run IDL on other versions that are binary-compatible.
  • The 64-bit Windows installer contains 32-bit binaries so that you can launch IDL in 32-bit mode on 64-bit Windows systems. You can find the 32-bit versions of IDL in the Windows Start menu under Programs > IDL x.x > 32-bit or Programs > ENVI x.x > IDL x.x > 32-bit.
  • IDL Help requires an HTML5-compatible browser.



© 2020 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us