Welcome to the Harris Geospatial product documentation center. Here you will find reference guides, help documents, and product libraries.


  >  Docs Center  >  Using ENVI  >  Spectral Analyst

ENVI

Spectral Analyst

Spectral Analyst

Use the Spectral Analyst to help identify materials based on their spectral characteristics. The Spectral Analyst uses ENVI techniques such as Binary Encoding, Spectral Angle Mapper, and Spectral Feature Fitting to rank the match of an unknown spectrum to the materials in a spectral library.

The output of the Spectral Analyst is a ranked or weighted score for each of the materials in the input spectral library. The highest score indicates the closest match and indicates higher confidence in the spectral similarity. Similar materials may have relatively high scores, but unrelated materials should have low scores. For more information, see Tips for Successful Use of the Spectral Analyst.

Note: This function does not identify spectra; it only recommends likely candidates for identification. The results may change when the similarity methods or weights are changed. You are still responsible for the actual identification.

See the following sections:

Open the Spectral Analyst


  1. You must display a spectral profile with at least one spectrum before running the Spectral Analyst.
  2. From the Toolbox, select Spectral > Spectral Analyst. The Spectral Analyst Input Spectral Library dialog appears.
  3. If a spectral library is not already open, click Open > Spectral Library and select the spectral library to use for the comparisons.
  4. Click OK. The Edit Identify Methods Weighting and Spectral Analyst dialogs appear.
  5. Enter a Weight for each similarity method. See Spectral Angle Mapper Classification, Spectral Feature Fitting, and Binary Encoding Classification for method descriptions. By default, Spectral Feature Fitting has a weight of 1.0. This is a recommended starting point.
  6. The Min and Max factors for each method indicate which values are considered a perfect match by scaling them from 0 to 1 (or from 1 to 0) scores.
    • For Spectral Angle Mapper, enter the Min and Max values in radians. (The similarity to the library spectra is measured in radians.)
    • For Spectral Feature Fitting, enter the Min and Max values in RMS error units. (The similarity is measured using the RMS fit error.)
  7. A SAM or SFF result less than or equal to Min indicates a perfect match and receives a score of 1. A SAM or SFF result greater than or equal to Max receives a score of 0.

    • For Binary Encoding, enter the Min and Max values as a percentage of bands correctly matched (0 to 1). A Binary Encoding result less than or equal to Min receives a score of 0, and a result greater than or equal to Max receives a score of 1.
  8. In the Edit Identify Methods Weighting dialog, click OK.
  9. In the Spectral Analyst dialog, click Apply to load a spectrum.
    • If one spectrum is plotted, it is automatically entered into the Spectral Analyst.
    • If more than one spectrum is plotted, select the desired spectrum name from the Spectral Profile. You can only select one spectrum at a time. Click OK.
    • Note: X/Y pixel coordinates in ENVI-displayed spectra are one less than those displayed in an ENVI Classic Z profile. For example, a pixel location of [X:165, Y:73] in ENVI yields the same spectrum as location [X:166, Y:74] in ENVI Classic.

  10. The Spectral Analyst dialog lists the results of the similarity measures. ENVI resamples the spectral library to match the spectral resolution of the input spectrum.

Spectral Analyst Options


Use the Spectral Analyst dialog to open a new spectral library; edit the weights, minimum, and maximum values; input x and y scale factors; and get input spectra from a Z Profile plot. The following is a description of the various options available from the are Spectral Analyst dialog:

  • To use a specific wavelength range, draw a box around the desired range in the spectral plot window, using the middle mouse button. Click Apply in the Spectral Analyst dialog.
  • To display the input spectrum and a selected library spectrum (with the continuum removed) in a plot together, double-click on a library spectrum name in the Spectral Analyst list.
  • To open a new spectral library file to use in the comparisons, select File > New Spectral Library File from the Spectral Analyst menu bar. Select the spectral library to use for the comparisons, and click OK.
  • To edit the weights, minimum values, and maximum values for each method, select Options > Edit Method Weights from the Spectral Analyst menu bar. Refer to steps 5-7 in Opening the Spectral Analyst for information about the Weight, Min, and Max fields in the Edit Identify Methods Weighting dialog.
  • To enter or edit x and y scale factors used to scale the input spectrum into the same space as the spectral library, select Options > Edit (x,y) Scale Factors from the Spectral Analyst menu bar. Enter values for X Data Multiplier and Y Data Multiplier in the Edit (x,y) Scale Factors dialog.
  • To enter spectra directly from a Z Profile plot, first open the Z Profile plot. In the Spectral Analyst window, select Options > Auto Input via Z-profile. In the Select Z Profiles dialog, select a spectral profile name and click OK. In the ENVI display, select a pixel to analyze. The spectral profile is updated, and the spectral comparison information appears in the Spectral Analyst dialog. As you move around the display, the information in the Spectral Analyst changes accordingly.

Tips for Successfully Using the Spectral Analyst


The Spectral Analyst is based on spectral matching techniques with specific requirements for successful operation. The items in this section summarize some of factors needed to effectively use the Spectral Analyst.

  • Many materials are similar in one wavelength range, yet they are very different in another range. For best results, use the wavelength range that contains the diagnostic absorption features. When a spectrum displays, the Spectral Analyst works over the range displayed in the corresponding plot being analyzed. To analyze a smaller range, use the middle mouse button in the plot to zoom to the desired wavelength range before clicking Apply in the Spectral Analyst.
  • Determine whether materials have absorption features. If so, Spectral Feature Fitting is probably the best method. Otherwise, Spectral Angle Mapper or Binary Encoding will yield better results.
  • The Spectral Analyst will not identify materials of interest in the input spectra that are not in the spectral library. If a material is not in the spectral library, materials similar to it may score relatively high.
  • High scores for multiple materials may indicate mixtures, particularly for minerals with absorption features in different parts of the spectrum. Because of this, you should run the Spectral Analyst on the results of an endmember determination, the pure endmember spectra.
  • Higher scores indicate higher confidence because more of the rules were satisfied. Greater separation between adjacent scores indicates higher confidence in the similarity. For example, a score of 0.98 for one material followed by a score of 0.96 for another material indicates that the unknown material is very similar to both sets of rules. A score of 0.98 for one material and a score of 0.50 for another material indicates a high probability that the spectrum represents the first material.
  • In many cases, the Spectral Analyst lists multiple identical scores for different materials in the rule base. This indicates that the Spectral Analyst cannot discriminate the two materials under the identification conditions. In this case, try a different wavelength range or use the different weighted methods to produce a unique result.
  • In some cases, the Spectral Analyst may list a score of 0.000 (no match) for all materials in the spectral library. This is a good indication that the material is not in the spectral library, or the material is not similar to other materials in the spectral library.
  • Examine the spectral ranking in the context of the image setting and known information. If a suggested identification seems invalid with respect to the known information, it is probably not the correct identification.

  • The Spectral Analyst tool is not foolproof. It should be used as a starting point to identify the materials in an image scene. If you use it properly with a good spectral library, it can provide excellent suggestions for identification. Used blindly, it can produce erroneous results.



© 2018 Harris Geospatial Solutions, Inc. |  Legal
My Account    |    Store    |    Contact Us